Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-09
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER REGISTERED OR NOT.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 11430 | tcp | Reserved | |||||||||
| 11431-11433 | Unassigned | ||||||||||
| ollama | 11434 | tcp | Ollama | Jesse Gross | Jesse Gross | 2025-09-26 | |||||
| 11434 | udp | Reserved | |||||||||
| 11435-11488 | Unassigned | Known UNAUTHORIZED USE: port 11488 | |||||||||
| asgcypresstcps | 11489 | tcp | ASG Cypress Secure Only | David Luxford | David Luxford | 2010-07-01 | |||||
| 11489 | udp | Reserved | |||||||||
| 11490-11599 | Unassigned | ||||||||||
| 12014-12108 | Unassigned | ||||||||||
| scotty-ft | 14000 | tcp | SCOTTY High-Speed Filetransfer | Patrick Verbeek | Patrick Verbeek | 2007-05 | |||||
| scotty-ft | 14000 | udp | SCOTTY High-Speed Filetransfer | Patrick Verbeek | Patrick Verbeek | 2007-05 | |||||
| sua | 14001 | tcp | SUA | Miguel Angel Garcia | Miguel Angel Garcia | ||||||
| sua | 14001 | udp | De-Registered | Miguel Angel Garcia | Miguel Angel Garcia | 2001-06-06 | |||||
| sua | 14001 | sctp | SUA | Miguel Angel Garcia | Miguel Angel Garcia | ||||||
| scotty-disc | 14002 | udp | Discovery of a SCOTTY hardware codec board | SCOTTY Group SE | Patrick Verbeek | 2013-01-14 | |||||
| 14002 | tcp | Reserved | |||||||||
| 14003-14032 | Unassigned | ||||||||||
| sage-best-com1 | 14033 | tcp | sage Best! Config Server 1 | Christian Rubach | Christian Rubach | ||||||
| sage-best-com1 | 14033 | udp | sage Best! Config Server 1 | Christian Rubach | Christian Rubach | ||||||
| sage-best-com2 | 14034 | tcp | sage Best! Config Server 2 | Christian Rubach | Christian Rubach | ||||||
| sage-best-com2 | 14034 | udp | sage Best! Config Server 2 | Christian Rubach | Christian Rubach | ||||||
| 14035-14140 | Unassigned | ||||||||||
| vcs-app | 14141 | tcp | VCS Application | Ming Xu | Ming Xu | ||||||
| vcs-app | 14141 | udp | VCS Application | Ming Xu | Ming Xu | ||||||
| icpp | 14142 | tcp | IceWall Cert Protocol | Tsutomu Fujinami | Tsutomu Fujinami | 2005-08 | |||||
| icpp | 14142 | udp | IceWall Cert Protocol | Tsutomu Fujinami | Tsutomu Fujinami | 2005-08 | |||||
| icpps | 14143 | tcp | IceWall Cert Protocol over TLS | Kenta Kambara | Kenta Kambara | 2016-05-24 | |||||
| 14143 | udp | Reserved | |||||||||
| 14144 | Unassigned | ||||||||||
| gcm-app | 14145 | tcp | GCM Application | Ming Xu | Ming Xu | ||||||
| gcm-app | 14145 | udp | GCM Application | Ming Xu | Ming Xu | ||||||
| 14146-14148 | Unassigned | ||||||||||
| vrts-tdd | 14149 | tcp | Veritas Traffic Director | Sameer Deokule | Sameer Deokule | 2002-03 | |||||
| vrts-tdd | 14149 | udp | Veritas Traffic Director | Sameer Deokule | Sameer Deokule | 2002-03 | |||||
| vcscmd | 14150 | tcp | Veritas Cluster Server Command Server | Anand Bhalerao | Anand Bhalerao | 2008-10-02 | |||||
| 14150 | udp | Reserved | |||||||||
| 14151-14153 | Unassigned | ||||||||||
| vad | 14154 | tcp | Veritas Application Director | Rajeev Verma | Rajeev Verma | 2006-02 | |||||
| vad | 14154 | udp | Veritas Application Director | Rajeev Verma | Rajeev Verma | 2006-02 | |||||
| 14155-14249 | Unassigned | ||||||||||
| cps | 14250 | tcp | Fencing Server | Mayank Vasa | Mayank Vasa | 2008-04-03 | |||||
| cps | 14250 | udp | Fencing Server | Mayank Vasa | Mayank Vasa | 2008-04-03 | |||||
| 14251-14413 | Unassigned | ||||||||||
| ca-web-update | 14414 | tcp | CA eTrust Web Update Service | Robert Ciochon | Robert Ciochon | 2006-08 | |||||
| ca-web-update | 14414 | udp | CA eTrust Web Update Service | Robert Ciochon | Robert Ciochon | 2006-08 | |||||
| 14415-14499 | Unassigned | ||||||||||
| xpra | 14500 | tcp | xpra network protocol | Xpra | Antoine Martin | 2016-10-05 | |||||
| 14500 | udp | Reserved | |||||||||
| 14501-14935 | Unassigned | ||||||||||
| hde-lcesrvr-1 | 14936 | tcp | hde-lcesrvr-1 | Horizon Digital Enterprise Inc. | Horizon Digital Enterprise Inc. | ||||||
| hde-lcesrvr-1 | 14936 | udp | hde-lcesrvr-1 | Horizon Digital Enterprise Inc. | Horizon Digital Enterprise Inc. | ||||||
| hde-lcesrvr-2 | 14937 | tcp | hde-lcesrvr-2 | Horizon Digital Enterprise Inc. | Horizon Digital Enterprise Inc. | ||||||
| hde-lcesrvr-2 | 14937 | udp | hde-lcesrvr-2 | Horizon Digital Enterprise Inc. | Horizon Digital Enterprise Inc. | ||||||
| 14938-14999 | Unassigned | ||||||||||
| 19284-19314 | Unassigned | ||||||||||
| opendeploy | 20014 | tcp | OpenDeploy Listener | Todd Scallan | Todd Scallan | 2005-08 | |||||
| opendeploy | 20014 | udp | OpenDeploy Listener | Todd Scallan | Todd Scallan | 2005-08 | |||||
| 21214-21220 | Unassigned | ||||||||||
| pace-licensed | 31400 | tcp | PACE license server | PACE Anti-Piracy | Allen Cronce | 2014-04-28 | |||||
| 31400 | udp | Reserved | |||||||||
| 31401-31415 | Unassigned | ||||||||||
| xqosd | 31416 | tcp | XQoS network monitor | Joe Elliott | Joe Elliott | 2002-06 | |||||
| xqosd | 31416 | udp | XQoS network monitor | Joe Elliott | Joe Elliott | 2002-06 | |||||
| 31417-31456 | Unassigned | ||||||||||
| tetrinet | 31457 | tcp | TetriNET Protocol | Emmanuel Bourg | Emmanuel Bourg | 2004-11 | |||||
| tetrinet | 31457 | udp | TetriNET Protocol | Emmanuel Bourg | Emmanuel Bourg | 2004-11 | |||||
| 31458-31619 | Unassigned | ||||||||||
| cloudcheck | 45514 | tcp | ASSIA CloudCheck WiFi Management System | ASSIA Inc. | Leonardo Dagum | 2016-08-29 | |||||
| cloudcheck-ping | 45514 | udp | ASSIA CloudCheck WiFi Management keepalive | ASSIA Inc. | Leonardo Dagum | 2016-08-29 | |||||
| 49002-49149 | Unassigned | ||||||||||
| est-coaps | udp | EST over secure CoAP (EST-coaps) | Toerless Eckert | Toerless Eckert | 2022-05-03 | 2022-05-04 | RFC 9148. Defined TXT keys: None | ||||
| jnx-kcsync | tcp | jollys keychain cloud sync protocol | Patrick Stein | Patrick Stein | 2011-10-24 | Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa | |||||
| robustirc | tcp | Like ircu (RFC 1459), but failure tolerant due to strong consistency among n>=3 servers | Michael Stapelberg | Michael Stapelberg | 2015-01-07 | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Allen Cronce | PACE Anti-Piracy | allen&paceap.com | 2014-04-28 |
| Anand Bhalerao | anand_bhalerao&symantec.com | 2008-10-02 | |
| Antoine Martin | antoine&nagafix.co.uk | 2016-10-05 | |
| ASSIA Inc. | info&assia-inc.com | 2016-08-29 | |
| Christian Rubach | Christian_Rubach&bestsoftware.com | ||
| David Luxford | david.luxford&asg.com | 2010-07-01 | |
| Emmanuel Bourg | smanux&lfjr.net | 2004-11 | |
| Horizon Digital Enterprise Inc. | info&hde.co.jp | ||
| Jesse Gross | jesse&ollama.com | 2026-02-02 | |
| Joe Elliott | joe&inetd.com | 2002-06 | |
| Kenta Kambara | kenta.kambara&hpe.com | 2016-05-24 | |
| Leonardo Dagum | ldagum&assia-inc.com | 2016-08-29 | |
| Mayank Vasa | mayank_vasa&symantec.com | 2008-04-03 | |
| Michael Stapelberg | michael+iana&stapelberg.ch | 2015-01-07 | |
| Miguel Angel Garcia | Miguel.A.Garcia&ericsson.com | ||
| Ming Xu | ming&veritas.com | ||
| PACE Anti-Piracy | allen&paceap.com | 2014-04-28 | |
| Patrick Stein | Patrick.Stein&jinx.eu | 2011-10-24 | |
| Patrick Verbeek | p.verbeek&scottygroup.com | 2007-05 | |
| Patrick Verbeek | SCOTTY Group SE | p.verbeek&scottygroup.com | 2013-01-14 |
| Rajeev Verma | rajeev_verma&symantec.com | 2006-02 | |
| Robert Ciochon | robert.ciochon&ca.com | 2006-08 | |
| Sameer Deokule | sameer.deokule&veritas.com | 2002-03 | |
| SCOTTY Group SE | p.verbeek&scottygroup.com | 2013-01-14 | |
| Todd Scallan | tscallan&interwoven.com | 2005-08 | |
| Toerless Eckert | tte&cs.fau.de | 2022-05-03 | |
| Tsutomu Fujinami | tsutomu.fujinami&hp.com | 2005-08 | |
| Xpra | xpra&xpra.org | 2016-10-05 |