Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
apani5 9164 tcp apani5 Neal Taylor Neal Taylor
apani5 9164 udp apani5 Neal Taylor Neal Taylor
9165-9182 Unassigned
acme 9216 tcp Aionex Communication Management Engine Mark Sapp Mark Sapp 2006-04
acme 9216 udp Aionex Communication Management Engine Mark Sapp Mark Sapp 2006-04
erunbook-agent 9616 tcp eRunbook Agent

IANA assigned this well-formed service name as a replacement for "erunbook_agent".
Gerhard Wagner Gerhard Wagner 2009-03-10
erunbook_agent 9616 tcp eRunbook Agent Gerhard Wagner Gerhard Wagner 2009-03-10 This entry is an alias to "erunbook-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
9616 udp Reserved
netiq-voipa 10116 tcp NetIQ VoIP Assessor Gary Weichinger Gary Weichinger
netiq-voipa 10116 udp NetIQ VoIP Assessor Gary Weichinger Gary Weichinger
qb-db-server 10160 tcp QB Database Server Wei Wang Wei Wang 2005-11
qb-db-server 10160 udp QB Database Server Wei Wang Wei Wang 2005-11
snmptls 10161 tcp SNMP-TLS RFC 6353
snmpdtls 10161 udp SNMP-DTLS RFC 6353
snmptls-trap 10162 tcp SNMP-Trap-TLS RFC 6353
snmpdtls-trap 10162 udp SNMP-Trap-DTLS RFC 6353
10163-10199 Unassigned
11113-11160 Unassigned
suncacao-snmp 11161 tcp sun cacao snmp access point Nick Stephen Nick Stephen 2005-08
suncacao-snmp 11161 udp sun cacao snmp access point Nick Stephen Nick Stephen 2005-08
suncacao-jmxmp 11162 tcp sun cacao JMX-remoting access point Nick Stephen Nick Stephen 2005-08
suncacao-jmxmp 11162 udp sun cacao JMX-remoting access point Nick Stephen Nick Stephen 2005-08
suncacao-rmi 11163 tcp sun cacao rmi registry access point Nick Stephen Nick Stephen 2005-08
suncacao-rmi 11163 udp sun cacao rmi registry access point Nick Stephen Nick Stephen 2005-08
suncacao-csa 11164 tcp sun cacao command-streaming access point Nick Stephen Nick Stephen 2005-08
suncacao-csa 11164 udp sun cacao command-streaming access point Nick Stephen Nick Stephen 2005-08
suncacao-websvc 11165 tcp sun cacao web service access point Nick Stephen Nick Stephen 2005-08
suncacao-websvc 11165 udp sun cacao web service access point Nick Stephen Nick Stephen 2005-08
11166-11170 Unassigned
tempest-port 11600 tcp Tempest Protocol Port Francis Cianfrocca Francis Cianfrocca
tempest-port 11600 udp Tempest Protocol Port Francis Cianfrocca Francis Cianfrocca
11601-11622 Unassigned
emc-xsw-dconfig 11623 tcp EMC XtremSW distributed config EMC David Erel 2013-09-18
11623 udp Reserved
11624-11719 Unassigned Unauthorized Use Known on port 11711
12122-12167 Unassigned
cawas 12168 tcp CA Web Access Service Jon Press Jon Press 2005-08
cawas 12168 udp CA Web Access Service Jon Press Jon Press 2005-08
12169-12171 Unassigned
i-zipqd 13160 tcp I-ZIPQD Chuck Runquist Chuck Runquist
i-zipqd 13160 udp I-ZIPQD Chuck Runquist Chuck Runquist
13161-13215 Unassigned
bcslogc 13216 tcp Black Crow Software application logging Ramindur Singh Ramindur Singh 2008-12-04
bcslogc 13216 udp Black Crow Software application logging Ramindur Singh Ramindur Singh 2008-12-04
fmsas 16000 tcp Administration Server Access Mark Davidson Mark Davidson 2010-10-06 Known Unauthorized Use on port 16000
16000 udp Reserved Known Unauthorized Use on port 16000
fmsascon 16001 tcp Administration Server Connector Mark Davidson Mark Davidson 2010-10-06
16001 udp Reserved
gsms 16002 tcp GoodSync Mediation Service Vadim Maslov Vadim Maslov 2010-10-06
16002 udp Reserved
16003 tcp Reserved
alfin 16003 udp Automation and Control by REGULACE.ORG Ing. Tomas Halabala Ing. Tomas Halabala 2010-10-06
16004-16019 Unassigned
jwpc 16020 tcp Filemaker Java Web Publishing Core Robert Parks Robert Parks 2010-05-12
16020 udp Reserved
jwpc-bin 16021 tcp Filemaker Java Web Publishing Core Binary Robert Parks Robert Parks 2010-05-12
16021 udp Reserved
16022-16160 Unassigned
sun-sea-port 16161 tcp Solaris SEA Port Dana Porter Dana Porter 2003-10
sun-sea-port 16161 udp Solaris SEA Port Dana Porter Dana Porter 2003-10
solaris-audit 16162 tcp Solaris Audit - secure remote audit log Jan Friedel Jan Friedel 2009-05-07
16162 udp Reserved
16163-16308 Unassigned
etb4j 16309 tcp etb4j Christopher R. Smith Christopher R. Smith 2004-11
etb4j 16309 udp etb4j Christopher R. Smith Christopher R. Smith 2004-11
pduncs 16310 tcp Policy Distribute, Update Notification Diane I. Shannon Diane I. Shannon 2006-08
pduncs 16310 udp Policy Distribute, Update Notification Diane I. Shannon Diane I. Shannon 2006-08
pdefmns 16311 tcp Policy definition and update management Diane I. Shannon Diane I. Shannon 2007-04
pdefmns 16311 udp Policy definition and update management Diane I. Shannon Diane I. Shannon 2007-04
16312-16359 Unassigned
netserialext1 16360 tcp Network Serial Extension Ports One Michael J Hoy Michael J Hoy
netserialext1 16360 udp Network Serial Extension Ports One Michael J Hoy Michael J Hoy
netserialext2 16361 tcp Network Serial Extension Ports Two Michael J Hoy Michael J Hoy
netserialext2 16361 udp Network Serial Extension Ports Two Michael J Hoy Michael J Hoy
16362-16366 Unassigned
netserialext3 16367 tcp Network Serial Extension Ports Three Michael J Hoy Michael J Hoy
netserialext3 16367 udp Network Serial Extension Ports Three Michael J Hoy Michael J Hoy
netserialext4 16368 tcp Network Serial Extension Ports Four Michael J Hoy Michael J Hoy
netserialext4 16368 udp Network Serial Extension Ports Four Michael J Hoy Michael J Hoy
16369-16383 Unassigned
connected 16384 tcp Connected Corp Nicole C. Ouellette Nicole C. Ouellette 2004-02
connected 16384 udp Connected Corp Nicole C. Ouellette Nicole C. Ouellette 2004-02
rdgs 16385 tcp Reliable Datagram Sockets Oracle Corp Sowmini Varadhan 2015-04-30
16385 udp Reserved
16386-16618 Unassigned
xoms 16619 tcp X509 Objects Management Service Francis GASCHET Francis GASCHET 2008-09-08
16619 udp Reserved
16620-16664 Unassigned
axon-tunnel 16665 tcp Reliable multipath data transport for high latencies Bridgeworks Mihai Popa 2014-09-26 2026-09-11
16665 udp Reserved
16666 tcp Reserved
vtp 16666 udp Vidder Tunnel Protocol Vidder, Inc. Ted Schroeder 2011-10-24
16667-16788 Unassigned
cadsisvr 16789 tcp This server provides callable services to mainframe External Security Managers from any TCP/IP platform Broadcom Thomas Sakowski 2015-06-02 2023-03-29
16789 udp Reserved
16790-16899 Unassigned
newbay-snc-mc 16900 tcp Newbay Mobile Client Update Service Srinivasa Nayudu Srinivasa Nayudu 2009-07-06
newbay-snc-mc 16900 udp Newbay Mobile Client Update Service Srinivasa Nayudu Srinivasa Nayudu 2009-07-06
16901-16949 Unassigned
sgcip 16950 tcp Simple Generic Client Interface Protocol John Aquilino John Aquilino
sgcip 16950 udp Simple Generic Client Interface Protocol John Aquilino John Aquilino

Contact Information

Name Organization Contact URI Last Updated
Bridgeworks mihai.popa&4bridgeworks.com 2026-09-11
Broadcom thomas.sakowski&broadcom.com 2023-03-29
Christopher R. Smith csmith4&us.ibm.com 2004-11
Chuck Runquist crunquist&quarterdeck.com
Dana Porter dana.porter&sun.com 2003-10
David Erel EMC david.erel&emc.com 2013-09-18
Diane I. Shannon shannond&us.ibm.com 2007-04
EMC david.erel&emc.com 2013-09-18
Francis Cianfrocca francis&tempest.com
Francis GASCHET NUMLOG fg&numlog.fr 2008-09-08
Gary Weichinger gary.weichinger&netiq.com
Gerhard Wagner gw&nova-ratio.de 2009-03-10
Ing. Tomas Halabala tomas.halabala&regulace.org 2010-10-06
Jan Friedel Jan.Friedel&sun.com 2009-05-07
John Aquilino john.aquilino&maryville.com
Jon Press IANA.Registions&ca.com 2005-09
Mark Davidson mark_davidson&filemaker.com 2010-10-06
Mark Sapp mark.sapp&aionex.com 2006-04
Michael J Hoy mhoy&canberra-abq.com
Mihai Popa mihai.popa&4bridgeworks.com 2026-09-11
Neal Taylor ianareg&apani.com
Nick Stephen nick.stephen&sun.com 2005-08
Nicole C. Ouellette nouellette&connected.com 2004-02
Oracle Corp sowmini.varadhan&oracle.com 2015-04-30
Ramindur Singh Ramindur.Singh&blackcrowsoftware.com 2008-12-04
Robert Parks robert_parks&filemaker.com 2010-05-12
Sowmini Varadhan Oracle Corp sowmini.varadhan&oracle.com 2015-04-30
Srinivasa Nayudu sn156n&att.com 2009-07-06
Ted Schroeder Vidder, Inc. ted&vidder.com 2011-10-24
Thomas Sakowski Broadcom thomas.sakowski&broadcom.com 2023-03-29
Vadim Maslov vm&siber.com 2010-10-06
Vidder, Inc. ted&vidder.com 2011-10-24
Wei Wang Wei_Wang&intuit.com 2005-11