Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
17011-17183 Unassigned
vestasdlp 17184 tcp Vestas Data Layer Protocol Vestas Wind Systems Teunis de Wit 2013-10-30
17184 udp Reserved
soundsvirtual 17185 tcp Sounds Virtual Richard Snider Richard Snider
soundsvirtual 17185 udp Sounds Virtual Richard Snider Richard Snider
17186-17218 Unassigned
chipper 17219 tcp Chipper Ronald Jimmink Ronald Jimmink
chipper 17219 udp Chipper Ronald Jimmink Ronald Jimmink
avtp 17220 tcp IEEE 1722 Transport Protocol for Time Sensitive Applications Transport Protocol for Time-Sensitive Networking TG Ashley Butterworth 2014-03-07
avtp 17220 udp IEEE 1722 Transport Protocol for Time Sensitive Applications Transport Protocol for Time-Sensitive Networking TG Ashley Butterworth 2014-03-07
avdecc 17221 tcp IEEE 1722.1 AVB Discovery, Enumeration, Connection management, and Control IEEE-1722.1 Jeffrey Daniel Koftinoff 2011-11-01
avdecc 17221 udp IEEE 1722.1 AVB Discovery, Enumeration, Connection management, and Control IEEE-1722.1 Jeffrey Daniel Koftinoff 2011-11-01
17222 tcp Reserved
cpsp 17222 udp Control Plane Synchronization Protocol (SPSP) Randall Stewart Randall Stewart 2011-11-10
isa100-gci 17223 tcp ISA100 GCI is a service utilizing a common interface between an ISA100 Wireless gateway and a client application ISA100 Wireless Compliance Institute Jay Werb 2015-07-24
17223 udp Reserved
trdp-pd 17224 udp Train Realtime Data Protocol (TRDP) Process Data IEC Central Office Gianosvaldo Fadin 2015-07-24
17224 tcp Reserved
trdp-md 17225 tcp Train Realtime Data Protocol (TRDP) Message Data IEC Central Office Gianosvaldo Fadin 2015-07-24
trdp-md 17225 udp Train Realtime Data Protocol (TRDP) Message Data IEC Central Office Gianosvaldo Fadin 2015-07-24
17226-17233 Unassigned
integrius-stp 17234 tcp Integrius Secure Tunnel Protocol Christian Klemetsson Christian Klemetsson 2010-03-04
integrius-stp 17234 udp Integrius Secure Tunnel Protocol Christian Klemetsson Christian Klemetsson 2010-03-04
ssh-mgmt 17235 tcp SSH Tectia Manager Ville Laurikari Ville Laurikari 2005-08
ssh-mgmt 17235 udp SSH Tectia Manager Ville Laurikari Ville Laurikari 2005-08
17236-17499 Unassigned
db-lsp 17500 tcp Dropbox LanSync Protocol Paul Bohm Paul Bohm 2010-01-21
db-lsp-disc 17500 udp Dropbox LanSync Discovery Paul Bohm Paul Bohm 2010-01-21
17501-17554 Unassigned
ailith 17555 tcp Ailith management of routers Thomas Boje Thomas Boje 2014-03-27
17555 udp Reserved
17556-17728 Unassigned
ea 17729 tcp Eclipse Aviation William Schmidt William Schmidt 2006-03
ea 17729 udp Eclipse Aviation William Schmidt William Schmidt 2006-03
17730-17753 Unassigned
zep 17754 tcp Encap. ZigBee Packets Fred Fierling Fred Fierling 2006-02
zep 17754 udp Encap. ZigBee Packets Fred Fierling Fred Fierling 2006-02
zigbee-ip 17755 tcp ZigBee IP Transport Service Chris Herzog Chris Herzog 2006-05
zigbee-ip 17755 udp ZigBee IP Transport Service Chris Herzog Chris Herzog 2006-05
zigbee-ips 17756 tcp ZigBee IP Transport Secure Service Chris Herzog Chris Herzog 2006-05
zigbee-ips 17756 udp ZigBee IP Transport Secure Service Chris Herzog Chris Herzog 2006-05
17757-17776 Unassigned
sw-orion 17777 tcp SolarWinds Orion Joel Dolisy Joel Dolisy 2008-09-10
17777 udp Reserved
17778-17999 Unassigned
18517-18633 Unassigned
21591-21799 Unassigned
mongodb 27017 tcp Mongo database system MongoDB, Inc. Akshay Kumar 2019-02-21
27017 udp Reserved
28011-28079 Unassigned Unauthorized Use Known on ports 28017, 28018 and 28019
29001-29117 Unassigned
29170-29998 Unassigned
31017-31019 Unassigned
31417-31456 Unassigned
31686-31764 Unassigned
gamesmith-port 31765 tcp GameSmith Port Randy Thompson Randy Thompson 2002-08
gamesmith-port 31765 udp GameSmith Port Randy Thompson Randy Thompson 2002-08
31766-31947 Unassigned
41231-41793 Unassigned
crestron-cip 41794 tcp Crestron Control Port Crestron Electronics, Inc. John Pavlik 2003-01 2019-10-17
crestron-cip 41794 udp Crestron Control Port Crestron Electronics, Inc. John Pavlik 2003-01 2019-10-17
crestron-ctp 41795 tcp Crestron Terminal Port Crestron Electronics, Inc. John Pavlik 2003-01 2019-10-17
crestron-ctp 41795 udp Crestron Terminal Port Crestron Electronics, Inc. John Pavlik 2003-01 2019-10-17
crestron-cips 41796 tcp Crestron Secure Control Port Crestron Electronics, Inc. John Pavlik 2012-06-27 2019-10-17
41796 udp Reserved
crestron-ctps 41797 tcp Crestron Secure Terminal Port Crestron Electronics, Inc. John Pavlik 2012-06-27 2019-10-17
41797 udp Reserved
41798-42507 Unassigned Unauthorized Use Known on port 42000
44601-44817 Unassigned
core-rd tcp Resource Directory accessed using CoAP over TCP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd udp Resource Directory accessed using CoAP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd-tls tcp Resource Directory accessed using CoAP over TLS IESG IETF Chair 2021-03-16 2022-04-14 RFC 9176 Defined TXT keys: None
core-rd-dtls udp Resource Directory accessed using CoAP over DTLS IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
x510 tcp Security service to protocols ITU-T Study Group 17 Erik Andersen 2019-08-13 Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Akshay Kumar MongoDB, Inc. akshay&mongodb.com 2019-02-21
Ashley Butterworth abutterworth&apple.com 2014-03-07
Chris Herzog zog&stg.com 2006-05
Christian Klemetsson Integrius AB christian.klemetsson&integrius.se 2010-03-04
Crestron Electronics, Inc. jpavlik&crestron.com 2019-10-17
Erik Andersen era&x500.eu 2019-08-13
Fred Fierling fff&exegin.com 2006-02
Gianosvaldo Fadin IEC Central Office gianosvaldo.fadin&anie.it 2015-07-24
IEEE-1722.1 jeff.koftinoff&ieee.com 2011-11-01
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
IEC Central Office cj&iec.ch 2015-07-24
ISA100 Wireless Compliance Institute jay&jwerb.com 2015-07-24
ITU-T Study Group 17 era&x500.eu 2019-08-13
Jay Werb ISA100 Wireless Compliance Institute jay&jwerb.com 2015-07-24
Jeffrey Daniel Koftinoff IEEE-1722.1 jeff.koftinoff&ieee.com 2011-11-01
Joel Dolisy joel.dolisy&solarwinds.com 2008-09-10
John Pavlik jpavlik&crestron.com 2019-10-17
MongoDB, Inc. akshay&mongodb.com 2019-02-21
Paul Bohm paul&dropbox.com 2010-01-21
Randall Stewart rrs&lakerest.net 2011-10-24
Randy Thompson thompr&earthlink.net 2002-08
Richard Snider rsnider&sounds.com
Ronald Jimmink Ronald.Jimmink&chipper.nl
Teunis de Wit Vestas Wind Systems tdwi&vestas.com 2013-10-30
Thomas Boje thomas.boje&gmx.de 2014-03-27
Transport Protocol for Time-Sensitive Networking TG AVBTP&ieee.org 2014-03-07
Vestas Wind Systems tdwi&vestas.com 2013-10-30
Ville Laurikari vlaurika&ssh.com 2005-08
William Schmidt info&eclipseaviation.com 2006-03