Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| intel_rci | 24386 | udp | Intel RCI | Mark Lewis | Mark Lewis | This entry is an alias to "intel-rci". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 24387-24464 | Unassigned | ||||||||||
| tonidods | 24465 | tcp | Tonido Domain Server | Madhan Kanagavel | Madhan Kanagavel | 2008-07-18 | |||||
| tonidods | 24465 | udp | Tonido Domain Server | Madhan Kanagavel | Madhan Kanagavel | 2008-07-18 | |||||
| 24466-24553 | Unassigned | ||||||||||
| binkp | 24554 | tcp | BINKP | Maxim Masiutin | Maxim Masiutin | 2020-06-02 | |||||
| binkp | 24554 | udp | BINKP | Maxim Masiutin | Maxim Masiutin | 2020-06-02 | |||||
| 24555-24576 | Unassigned | ||||||||||
| bilobit | 24577 | tcp | bilobit Service | bilobit GmbH | Martin Schmuker | 2014-08-15 | |||||
| bilobit-update | 24577 | udp | bilobit Service Update | bilobit GmbH | Martin Schmuker | 2014-08-15 | |||||
| 24578-24600 | Unassigned | ||||||||||
| udpstp | 24601 | udp | UDP-based IP-Layer Capacity and Performance Measurement protocol | IESG | IETF Chair | 2025-09-26 | RFC 9946 | ||||
| 24601 | tcp | Reserved | |||||||||
| 24602-24665 | Unassigned | ||||||||||
| sdtvwcam | 24666 | tcp | Service used by SmarDTV to communicate between a CAM and a second screen application | SmarDTV | Vincent Demortier | 2015-03-04 | |||||
| 24666 | udp | Reserved | |||||||||
| 24667-24675 | Unassigned | ||||||||||
| canditv | 24676 | tcp | Canditv Message Service | Gary Aston | Gary Aston | 2009-03-10 | |||||
| canditv | 24676 | udp | Canditv Message Service | Gary Aston | Gary Aston | 2009-03-10 | |||||
| flashfiler | 24677 | tcp | FlashFiler | Ben Oram | Ben Oram | ||||||
| flashfiler | 24677 | udp | FlashFiler | Ben Oram | Ben Oram | ||||||
| proactivate | 24678 | tcp | Turbopower Proactivate | Ben Oram | Ben Oram | ||||||
| proactivate | 24678 | udp | Turbopower Proactivate | Ben Oram | Ben Oram | ||||||
| 24679 | Unassigned | ||||||||||
| tcc-http | 24680 | tcp | TCC User HTTP Service | Brian Kennedy | Brian Kennedy | 2006-08 | |||||
| tcc-http | 24680 | udp | TCC User HTTP Service | Brian Kennedy | Brian Kennedy | 2006-08 | |||||
| 24681-24726 | Unassigned | ||||||||||
| 24727 | Unassigned | Unauthorized Use Known on port 24727 | |||||||||
| 24728-24753 | Unassigned | ||||||||||
| cslg | 24754 | tcp | Citrix StorageLink Gateway | Mark Nijmeijer | Mark Nijmeijer | 2009-04-17 | |||||
| 24754 | udp | Reserved | |||||||||
| 24755-24849 | Unassigned | ||||||||||
| 24850 | tcp | Reserved | |||||||||
| assoc-disc | 24850 | udp | Device Association Discovery | Microsoft Corporation | Sachin Sheth | 2012-06-27 | |||||
| 24851-24921 | Unassigned | ||||||||||
| find | 24922 | tcp | Find Identification of Network Devices | Jean-Paul Moreaux | Jean-Paul Moreaux | ||||||
| find | 24922 | udp | Find Identification of Network Devices | Jean-Paul Moreaux | Jean-Paul Moreaux | ||||||
| 24923-24999 | Unassigned | ||||||||||
| siemensgsm | 28240 | tcp | Siemens GSM | David Anuszewski | David Anuszewski | 2004-11 | |||||
| siemensgsm | 28240 | udp | Siemens GSM | David Anuszewski | David Anuszewski | 2004-11 | |||||
| 28241-28588 | Unassigned | ||||||||||
| autotrac-acp | 31020 | tcp | Autotrac ACP 245 | Roberto Jorge Dino | Roberto Jorge Dino | ||||||
| 32035-32248 | Unassigned | ||||||||||
| t1distproc60 | 32249 | tcp | T1 Distributed Processor | Peter Beahan | Peter Beahan | 2004-11 | |||||
| t1distproc60 | 32249 | udp | T1 Distributed Processor | Peter Beahan | Peter Beahan | 2004-11 | |||||
| plex | 32400 | tcp | Plex multimedia | Plex Inc. | Sasha Hilton | 2016-06-02 | |||||
| 32400 | udp | Reserved | |||||||||
| 32401-32482 | Unassigned | ||||||||||
| apm-link | 32483 | tcp | Access Point Manager Link | Tony Diodato | Tony Diodato | 2005-08 | |||||
| apm-link | 32483 | udp | Access Point Manager Link | Tony Diodato | Tony Diodato | 2005-08 | |||||
| 32484-32634 | Unassigned | ||||||||||
| 33124-33330 | Unassigned | ||||||||||
| 33891-34248 | Unassigned | ||||||||||
| turbonote-2 | 34249 | tcp | TurboNote Relay Server Default Port | Peter Hyde | Peter Hyde | ||||||
| turbonote-2 | 34249 | udp | TurboNote Relay Server Default Port | Peter Hyde | Peter Hyde | ||||||
| nq-ap | 36424 | sctp | Nq and Nq' Application Protocol | 3GPP | Kimmo Kymalainen | 2015-06-18 | |||||
| febooti-aw | 36524 | tcp | Febooti Automation Workshop | Maris Bormanis | Maris Bormanis | 2011-06-10 | |||||
| 36524 | udp | Reserved | |||||||||
| 40024-40403 | Unassigned | ||||||||||
| 44124-44320 | Unassigned | ||||||||||
| 44324-44443 | Unassigned | ||||||||||
| dai-shell | 45824 | tcp | Server for the DAI family of client-server products | Data Access, Inc. | Adam Robinson | 2012-04-30 | |||||
| 45824 | udp | Reserved | |||||||||
| directplaysrvr | 47624 | tcp | Direct Play Server | Ajay Jindal | Ajay Jindal | ||||||
| directplaysrvr | 47624 | udp | Direct Play Server | Ajay Jindal | Ajay Jindal |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | kimmo.kymalainen&etsi.org | 2015-06-18 | |
| Adam Robinson | Data Access, Inc. | adam&dataaccessinc.com | 2012-04-30 |
| Ajay Jindal | ajayjµsoft.com | ||
| Ben Oram | beno&turbopower.com | ||
| bilobit GmbH | ms&bilobit.com | 2014-08-15 | |
| Brian Kennedy | BrianK&targetedconvergence.com | 2006-08 | |
| Data Access, Inc. | development&dataaccessinc.com | 2012-04-30 | |
| David Anuszewski | david.anuszewski&siemens.com | 2004-11 | |
| Gary Aston | Gary.Aston&datadrivenlogistics.com | 2009-03-10 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jean-Paul Moreaux | jean-paul.moreaux&airbus.com | ||
| Kimmo Kymalainen | kimmo.kymalainen&etsi.org | 2017-05-08 | |
| Madhan Kanagavel | madhan&codelathe.com | 2008-07-18 | |
| Maris Bormanis | info&febooti.com | 2011-06-10 | |
| Mark Lewis | mark.h.lewis&intel.com | ||
| Mark Nijmeijer | Mark.Nijmeijer&citrix.com | 2009-04-17 | |
| Martin Schmuker | bilobit GmbH | ms&bilobit.com | 2014-08-15 |
| Maxim Masiutin | maxim.masiutin&gmail.com | 2020-06-02 | |
| Microsoft Corporation | sachinsµsoft.com | 2012-06-27 | |
| Peter Beahan | peter_beahan&technologyonecorp.com | 2004-11 | |
| Peter Hyde | peter&spis.co.nz | ||
| Plex Inc. | sashahilton00&gmail.com | 2016-06-02 | |
| Roberto Jorge Dino | roberto.dino&autotrac.com.br | ||
| Sachin Sheth | Microsoft Corporation | sachinsµsoft.com | 2012-06-27 |
| Sasha Hilton | sashahilton00&gmail.com | 2016-06-02 | |
| SmarDTV | vincent.demortier&smardtv.com | 2015-03-04 | |
| Tony Diodato | tdiodato&cyprx.com | 2005-08 | |
| Vincent Demortier | SmarDTV | vincent.demortier&smardtv.com | 2015-03-04 |