Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
imagepump 27345 udp ImagePump Richard Minner Richard Minner
27346-27441 Unassigned
iracinghelper 32034 tcp iRacing helper service Randy Cassidy Randy Cassidy 2007-08-30
iracinghelper 32034 udp iRacing helper service Randy Cassidy Randy Cassidy 2007-08-30
32484-32634 Unassigned
speedtrace 33334 tcp SpeedTrace TraceAgent Holger Heinrich Holger Heinrich 2012-02-01
speedtrace-disc 33334 udp SpeedTrace TraceAgent Discovery Holger Heinrich Holger Heinrich 2012-02-01
33335-33433 Unassigned
traceroute 33434 tcp traceroute use IANA IANA
traceroute 33434 udp traceroute use IANA IANA
33435 tcp Reserved
mtrace 33435 udp IP Multicast Traceroute IESG IETF Chair 2017-12-13 2019-08-09 RFC 8487 Known Unauthorized Use on port 33435
33436-33655 Unassigned Known Unauthorized Use on ports 33436-33534
33891-34248 Unassigned
turbonote-2 34249 tcp TurboNote Relay Server Default Port Peter Hyde Peter Hyde
turbonote-2 34249 udp TurboNote Relay Server Default Port Peter Hyde Peter Hyde
34250-34377 Unassigned
p-net-local 34378 tcp P-Net on IP local Kurt Nissen Kurt Nissen 2004-02
p-net-local 34378 udp P-Net on IP local Kurt Nissen Kurt Nissen 2004-02
p-net-remote 34379 tcp P-Net on IP remote Kurt Nissen Kurt Nissen 2004-02
p-net-remote 34379 udp P-Net on IP remote Kurt Nissen Kurt Nissen 2004-02
34380-34566 Unassigned
dhanalakshmi 34567 tcp dhanalakshmi.org EDI Service Girish Gopalakrishnan Girish Gopalakrishnan 2010-04-20
edi_service 34567 udp dhanalakshmi.org EDI Service Girish Gopalakrishnan Girish Gopalakrishnan 2016-10-26
34568-34961 Unassigned
profinet-rt 34962 tcp PROFInet RT Unicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-rt 34962 udp PROFInet RT Unicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-rtm 34963 tcp PROFInet RT Multicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-rtm 34963 udp PROFInet RT Multicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-cm 34964 tcp PROFInet Context Manager PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-cm 34964 udp PROFInet Context Manager PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-cm-sec 34965 tcp PROFINET secure connection management and key provisioning PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2026-03-10
profinet-cm-sec 34965 udp PROFINET secure connection management and key provisioning PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2026-03-10
34966 tcp Reserved
profinet-rt-sec 34966 udp PROFINET secure real-time data transfer over UDP (unicast and multicast) PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2026-03-10
34967-34979 Unassigned
ethercat 34980 tcp EtherCAT Port Martin Rostan Martin Rostan 2003-11
ethercat 34980 udp EtherCAT Port Martin Rostan Martin Rostan 2003-11
34981-34999 Unassigned
43211-43437 Unassigned
43438 tcp Reserved
hmip-routing 43438 udp HmIP LAN Routing eQ-3 Entwicklung GmbH Tido de Vries 2018-02-28
eq3-update 43439 tcp EQ3 firmware update eQ-3 Entwicklung GmbH Tido de Vries 2012-02-10 2014-05-09
eq3-config 43439 udp EQ3 discovery and configuration eQ-3 Entwicklung GmbH Tido de Vries 2012-02-10 2014-05-09
ew-mgmt 43440 tcp Cisco EnergyWise Management
ew-disc-cmd 43440 udp Cisco EnergyWise Discovery and Command Flooding John Parello John Parello 2009-05-19
ciscocsdb 43441 tcp Cisco NetMgmt DB Ports Cisco Systems Cisco Systems 2005-11
ciscocsdb 43441 udp Cisco NetMgmt DB Ports Cisco Systems Cisco Systems 2005-11
43442-44122 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Cisco Systems nmtg-port-numbers&cisco.com 2005-11
Dietmar Bohn standards.central-office&profibus.com 2026-03-10
eQ-3 Entwicklung GmbH ports&entwicklung.eq-3.de 2018-02-28
Girish Gopalakrishnan girish&shankar-software.org 2016-10-26
Holger Heinrich holger2222&googlemail.com 2012-02-01
IANA iana&iana.org
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
John Parello jparello&cisco.com 2009-05-19
Kurt Nissen kn&proces-data.com 2004-02
Martin Rostan m.rostan&beckhoff.com 2003-11
Peter Hyde peter&spis.co.nz
PNO – PROFIBUS Nutzerorganisation e.V. standards.central-office&profibus.com 2026-03-10
Randy Cassidy randy.cassidy&iracing.com 2007-08-30
Richard Minner http://xippix.com
Tido de Vries eQ-3 Entwicklung GmbH tido.devries&entwicklung.eq-3.de 2018-02-28