Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 23546 | udp | Reserved | |||||||||
| 23547-23999 | Unassigned | ||||||||||
| 32035-32248 | Unassigned | ||||||||||
| sec-ntb-clnt | 32635 | tcp | SecureNotebook-CLNT | Eric Cantineau | Eric Cantineau | 2004-11 | |||||
| sec-ntb-clnt | 32635 | udp | SecureNotebook-CLNT | Eric Cantineau | Eric Cantineau | 2004-11 | |||||
| 33335-33433 | Unassigned | ||||||||||
| 33435 | tcp | Reserved | |||||||||
| mtrace | 33435 | udp | IP Multicast Traceroute | IESG | IETF Chair | 2017-12-13 | 2019-08-09 | RFC 8487 | Known Unauthorized Use on port 33435 | ||
| 33436-33655 | Unassigned | Known Unauthorized Use on ports 33436-33534 | |||||||||
| heathview | 35000 | tcp | HeathView | Heathwest Systems Limited | Andrew Porrer | 2013-03-21 | |||||
| 35000 | udp | Reserved | |||||||||
| rt-viewer | 35001 | tcp | ReadyTech Viewer | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-viewer | 35001 | udp | ReadyTech Viewer | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-sound | 35002 | tcp | ReadyTech Sound Server | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35002 | udp | Reserved | |||||||||
| rt-devicemapper | 35003 | tcp | ReadyTech DeviceMapper Server | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35003 | udp | Reserved | |||||||||
| rt-classmanager | 35004 | tcp | ReadyTech ClassManager | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-classmanager | 35004 | udp | ReadyTech ClassManager | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-labtracker | 35005 | tcp | ReadyTech LabTracker | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35005 | udp | Reserved | |||||||||
| rt-helper | 35006 | tcp | ReadyTech Helper Service | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35006 | udp | Reserved | |||||||||
| 35007-35099 | Unassigned | ||||||||||
| axio-disc | 35100 | tcp | Axiomatic discovery protocol | Axiomatic Technologies Corporation | Oleksandr_Bogush | 2016-12-09 | |||||
| axio-disc | 35100 | udp | Axiomatic discovery protocol | Axiomatic Technologies Corporation | Oleksandr_Bogush | 2016-12-09 | |||||
| 35101-35353 | Unassigned | ||||||||||
| kitim | 35354 | tcp | KIT Messenger | Rudi Visser | Rudi Visser | 2011-07-07 | |||||
| 35354 | udp | Reserved | |||||||||
| altova-lm | 35355 | tcp | Altova License Management | Alexander Falk | Alexander Falk | 2011-07-07 | |||||
| altova-lm-disc | 35355 | udp | Altova License Management Discovery | Alexander Falk | Alexander Falk | 2011-07-07 | |||||
| guttersnex | 35356 | tcp | Gutters Note Exchange | Squee! Application Development | Tristan Seifert | 2011-07-19 | |||||
| 35356 | udp | Reserved | |||||||||
| openstack-id | 35357 | tcp | OpenStack ID Service | Rackspace Hosting | Ziad Sawalha | 2011-08-15 | |||||
| 35357 | udp | Reserved | |||||||||
| 35358-36000 | Unassigned | ||||||||||
| 44323 | udp | Unassigned | "pcp" assignment withdrawn, moved to port 5351 per RFC 6887 | ||||||||
| 45967-46335 | Unassigned | ||||||||||
| 49151 | Reserved | 2024-12-20 | RFC 6335 | ||||||||
| carddav | tcp | vCard Extensions to WebDAV (CardDAV) - non-TLS | IESG | IETF Chair | 2012-02-17 | RFC 6352 | This is an extension of the http service. Defined TXT keys: path=<context path> | ||||
| carddavs | tcp | vCard Extensions to WebDAV (CardDAV) - over TLS | IESG | IETF Chair | 2012-02-17 | RFC 6352 | This is an extension of the https service. Defined TXT keys: path=<context path> | ||||
| dccp-ping | dccp | ping/traceroute using DCCP | Samuel Jero | Samuel Jero | 2012-11-14 | 1885957735 | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alexander Falk | Altova, Inc. | al&altova.com | 2011-07-07 |
| Andrew Porrer | Heathwest Systems Limited | Andrew.Porrer&heathwest.com | 2013-03-21 |
| Axiomatic Technologies Corporation | obogush&axiomatic.com | 2016-12-09 | |
| Eric Cantineau | eric&securenotebook.com | 2004-11 | |
| Heathwest Systems Limited | info&heathwest.com | 2013-03-21 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Kevin Woodward | ReadyTech Corporation | kwoodward&readytech.com | 2013-09-13 |
| Oleksandr_Bogush | obogush&axiomatic.com | 2016-12-09 | |
| Rackspace Hosting | ziad.sawalha&rackspace.com | 2011-08-15 | |
| ReadyTech Corporation | kwoodward&readytech.com | 2013-09-13 | |
| Rudi Visser | rudi.visser&ljund.eu | 2011-07-07 | |
| Samuel Jero | sj323707&ohio.edu | 2012-11-14 | |
| Squee! Application Development | tristan&squee.co | 2011-07-19 | |
| Tristan Seifert | Squee! Application Development | tristan&squee.co | 2011-07-19 |
| Ziad Sawalha | Rackspace Hosting | ziad.sawalha&rackspace.com | 2011-08-15 |