Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 14150 | udp | Reserved | |||||||||
| 14151-14153 | Unassigned | ||||||||||
| vad | 14154 | tcp | Veritas Application Director | Rajeev Verma | Rajeev Verma | 2006-02 | |||||
| vad | 14154 | udp | Veritas Application Director | Rajeev Verma | Rajeev Verma | 2006-02 | |||||
| 14155-14249 | Unassigned | ||||||||||
| 14251-14413 | Unassigned | ||||||||||
| ca-web-update | 14414 | tcp | CA eTrust Web Update Service | Robert Ciochon | Robert Ciochon | 2006-08 | |||||
| ca-web-update | 14414 | udp | CA eTrust Web Update Service | Robert Ciochon | Robert Ciochon | 2006-08 | |||||
| 14415-14499 | Unassigned | ||||||||||
| 15741-15997 | Unassigned | ||||||||||
| checkpoint-rtm | 18241 | tcp | Check Point RTM | Dudi Hazan | Dudi Hazan | ||||||
| checkpoint-rtm | 18241 | udp | Check Point RTM | Dudi Hazan | Dudi Hazan | ||||||
| hp-sco | 19410 | tcp | hp-sco | Larry Schwartz | Larry Schwartz | ||||||
| hp-sco | 19410 | udp | hp-sco | Larry Schwartz | Larry Schwartz | ||||||
| hp-sca | 19411 | tcp | hp-sca | Larry Schwartz | Larry Schwartz | ||||||
| hp-sca | 19411 | udp | hp-sca | Larry Schwartz | Larry Schwartz | ||||||
| hp-sessmon | 19412 | tcp | HP-SESSMON | Gita Murthy | Gita Murthy | ||||||
| hp-sessmon | 19412 | udp | HP-SESSMON | Gita Murthy | Gita Murthy | ||||||
| 19413-19538 | Unassigned | ||||||||||
| jcp | 19541 | tcp | JCP Client | Yuji Sasaki | Yuji Sasaki | ||||||
| jcp | 19541 | udp | JCP Client | Yuji Sasaki | Yuji Sasaki | ||||||
| 24007-24241 | Unassigned | ||||||||||
| 27346-27441 | Unassigned | ||||||||||
| 28241-28588 | Unassigned | ||||||||||
| 31401-31415 | Unassigned | ||||||||||
| xqosd | 31416 | tcp | XQoS network monitor | Joe Elliott | Joe Elliott | 2002-06 | |||||
| xqosd | 31416 | udp | XQoS network monitor | Joe Elliott | Joe Elliott | 2002-06 | |||||
| 31417-31456 | Unassigned | ||||||||||
| 36002-36410 | Unassigned | ||||||||||
| wlcp | 36411 | udp | Wireless LAN Control plane Protocol (WLCP) | 3GPP | Dongwook Kim | 2014-11-14 | 2026-01-23 | ||||
| 36411 | tcp | Reserved | |||||||||
| 36412 | tcp | Reserved | |||||||||
| 36412 | udp | Reserved | |||||||||
| s1-control | 36412 | sctp | S1-Control Plane (3GPP) | Kimmo Kymalainen | Kimmo Kymalainen | 2009-09-01 | |||||
| 36413-36421 | Unassigned | ||||||||||
| 38204-38411 | Unassigned | ||||||||||
| 38412 | tcp | Reserved | |||||||||
| 38412 | udp | Reserved | |||||||||
| ng-control | 38412 | sctp | NG Control Plane (3GPP) | Luis Lopes | Luis Lopes | 2017-05-18 | 2017-05-19 | ||||
| 38413-38421 | Unassigned | ||||||||||
| cscp | 40841 | tcp | CSCP | Michael Dodge | Michael Dodge | ||||||
| cscp | 40841 | udp | CSCP | Michael Dodge | Michael Dodge | ||||||
| 40854-41110 | Unassigned | ||||||||||
| fs-qos | 41111 | tcp | Foursticks QoS Protocol | Chee Kent Lam | Chee Kent Lam | 2002-04 | |||||
| fs-qos | 41111 | udp | Foursticks QoS Protocol | Chee Kent Lam | Chee Kent Lam | 2002-04 | |||||
| 41112-41120 | Unassigned | ||||||||||
| tentacle | 41121 | tcp | Tentacle Server | Sancho Lerena | Sancho Lerena | 2009-06-02 | |||||
| 41121 | udp | Reserved | |||||||||
| 41122-41229 | Unassigned | ||||||||||
| z-wave-s | 41230 | tcp | Z-Wave Protocol over SSL/TLS | Sigma Designs | Anders Brandt | 2015-06-26 | |||||
| z-wave-s | 41230 | udp | Z-Wave Protocol over DTLS | Sigma Designs | Anders Brandt | 2015-06-26 | |||||
| 41231-41793 | Unassigned | ||||||||||
| crestron-cip | 41794 | tcp | Crestron Control Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-cip | 41794 | udp | Crestron Control Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-ctp | 41795 | tcp | Crestron Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-ctp | 41795 | udp | Crestron Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-cips | 41796 | tcp | Crestron Secure Control Port | Crestron Electronics, Inc. | John Pavlik | 2012-06-27 | 2019-10-17 | ||||
| 41796 | udp | Reserved | |||||||||
| crestron-ctps | 41797 | tcp | Crestron Secure Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2012-06-27 | 2019-10-17 | ||||
| 41797 | udp | Reserved | |||||||||
| 41798-42507 | Unassigned | Unauthorized Use Known on port 42000 | |||||||||
| ciscocsdb | 43441 | tcp | Cisco NetMgmt DB Ports | Cisco Systems | Cisco Systems | 2005-11 | |||||
| ciscocsdb | 43441 | udp | Cisco NetMgmt DB Ports | Cisco Systems | Cisco Systems | 2005-11 | |||||
| 43442-44122 | Unassigned | ||||||||||
| z-wave-tunnel | 44123 | tcp | Z-Wave Secure Tunnel | Sigma Designs, Inc. | Anders Brandt | 2012-10-12 | 2015-06-26 | ||||
| 44123 | udp | Reserved | |||||||||
| 44124-44320 | Unassigned | ||||||||||
| nfs-domainroot | tcp | NFS service for the domain root, the root of an organization's published file namespace. | IESG | IETF Chair | 2012-04-24 | RFC 6641 | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | dongwook.kim&etsi.org | 2026-01-23 | |
| Anders Brandt | Sigma Designs | anders_brandt&sigmadesigns.com | 2012-10-12 |
| Anders Brandt | Sigma Designs | anders_brandt&sigmadesigns.com | 2015-06-26 |
| Chee Kent Lam | cklam&foursticks.com | 2002-04 | |
| Cisco Systems | nmtg-port-numbers&cisco.com | 2005-11 | |
| Crestron Electronics, Inc. | jpavlik&crestron.com | 2019-10-17 | |
| Dongwook Kim | 3GPP | dongwook.kim&etsi.org | 2026-01-23 |
| Dudi Hazan | dudi&checkpoint.com | ||
| Gita Murthy | gita&cup.hp.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Joe Elliott | joe&inetd.com | 2002-06 | |
| John Pavlik | jpavlik&crestron.com | 2019-10-17 | |
| Kimmo Kymalainen | kimmo.kymalainen&etsi.org | 2017-05-08 | |
| Larry Schwartz | lrs&cup.hp.com | ||
| Luis Lopes | llopes&qti.qualcomm.com | 2017-06-23 | |
| Michael Dodge | sarge¢erspan.com | ||
| Rajeev Verma | rajeev_verma&symantec.com | 2006-02 | |
| Robert Ciochon | robert.ciochon&ca.com | 2006-08 | |
| Sancho Lerena | slerena&artica.es | 2009-06-02 | |
| Sigma Designs, Inc. | anders_brandt&sigmadesigns.com | 2011-10-03 | |
| Sigma Designs | anders_brandt&sigmadesigns.com | 2015-06-26 | |
| Yuji Sasaki | sasaki&silex.jp |