Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
imaps 993 tcp IMAP over TLS protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 8314; RFC 9051
993 udp Reserved 2021-02-22 RFC 9051
pop3s 995 tcp POP3 over TLS protocol IESG IETF Chair 2017-12-12 RFC 8314
pop3s 995 udp pop3 protocol over TLS/SSL (was spop3) Gordon Mangione Gordon Mangione
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
1023 tcp Reserved 2024-12-20 RFC 6335
1023 udp Reserved 2024-12-20 RFC 6335
1024 tcp Reserved 2024-12-20 RFC 6335
1024 udp Reserved 2024-12-20 RFC 6335
blackjack 1025 tcp network blackjack
blackjack 1025 udp network blackjack
6a44 1027 udp IPv6 Behind NAT44 CPEs IESG IETF Chair 2012-08-02 RFC 6751
1030 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
1031 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
1032 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
mxxrlogin 1035 tcp MX-XR RPC Valassis John Eckert 2003-04 2015-05-05
mxxrlogin 1035 udp MX-XR RPC Valassis John Eckert 2003-04 2015-05-05
fpitp 1045 tcp Fingerprint Image Transfer Protocol Steven Fields Steven Fields 2002-02
fpitp 1045 udp Fingerprint Image Transfer Protocol Steven Fields Steven Fields 2002-02
cma 1050 tcp CORBA Management Agent Ramy Zaarour Ramy Zaarour
cma 1050 udp CORBA Management Agent Ramy Zaarour Ramy Zaarour
optima-vnet 1051 tcp Optima VNET Ralf Doewich Ralf Doewich
optima-vnet 1051 udp Optima VNET Ralf Doewich Ralf Doewich
ddt 1052 tcp Dynamic DNS Tools Remi Lefebvre Remi Lefebvre
ddt 1052 udp Dynamic DNS Tools Remi Lefebvre Remi Lefebvre
remote-as 1053 tcp Remote Assistant (RA) Roman Kriis Roman Kriis Unauthorized Use Known on port 1053
remote-as 1053 udp Remote Assistant (RA) Roman Kriis Roman Kriis
brvread 1054 tcp BRVREAD A. Boninn A. Boninn
brvread 1054 udp BRVREAD A. Boninn A. Boninn
ansyslmd 1055 tcp ANSYS - License Manager Suzanne Lorrin Suzanne Lorrin
ansyslmd 1055 udp ANSYS - License Manager Suzanne Lorrin Suzanne Lorrin
vfo 1056 tcp VFO Anthony Gonzalez Anthony Gonzalez
vfo 1056 udp VFO Anthony Gonzalez Anthony Gonzalez
startron 1057 tcp STARTRON Markus Sabadello Markus Sabadello
startron 1057 udp STARTRON Markus Sabadello Markus Sabadello
nim 1058 tcp nim
nim 1058 udp nim
nimreg 1059 tcp nimreg Robert Gordon Robert Gordon
nimreg 1059 udp nimreg Robert Gordon Robert Gordon
syscomlan 1065 tcp SYSCOMLAN Alexandre Lechenne Alexandre Lechenne 2008-12-10
syscomlan 1065 udp SYSCOMLAN Alexandre Lechenne Alexandre Lechenne 2008-12-10
rdrmshc 1075 tcp RDRMSHC Ericko Shimada Ericko Shimada
rdrmshc 1075 udp RDRMSHC Ericko Shimada Ericko Shimada
webobjects 1085 tcp Web Objects Andy Belk Andy Belk
webobjects 1085 udp Web Objects Andy Belk Andy Belk
nicelink 1095 tcp NICELink Jordi Lisbona Jordi Lisbona
nicelink 1095 udp NICELink Jordi Lisbona Jordi Lisbona
ftranhc 1105 tcp FTRANHC Eriko Shimada Eriko Shimada
ftranhc 1105 udp FTRANHC Eriko Shimada Eriko Shimada
ltp-deepspace 1113 tcp Licklider Transmission Protocol RFC 5326
ltp-deepspace 1113 udp Licklider Transmission Protocol 2014-02-21 RFC 5326; RFC 7122
ardus-trns 1115 tcp ARDUS Transfer
ardus-trns 1115 udp ARDUS Transfer
hpvmmagent 1125 tcp HP VMM Agent
hpvmmagent 1125 udp HP VMM Agent
omnivision 1135 tcp OmniVision Communication Service Serge Vacquier Serge Vacquier 2006-02
omnivision 1135 udp OmniVision Communication Service Serge Vacquier Serge Vacquier 2006-02
x9-icue 1145 tcp X9 iCue Show Control Brandon Potter Brandon Potter 2006-01
x9-icue 1145 udp X9 iCue Show Control Brandon Potter Brandon Potter 2006-01
blaze 1150 tcp Blaze File Server Curt Schimmel Curt Schimmel 2005-11
blaze 1150 udp Blaze File Server Curt Schimmel Curt Schimmel 2005-11
unizensus 1151 tcp Unizensus Login Server Dirk Materlik Dirk Materlik 2005-11
unizensus 1151 udp Unizensus Login Server Dirk Materlik Dirk Materlik 2005-11
winpoplanmess 1152 tcp Winpopup LAN Messenger Vitali Fomine Vitali Fomine 2005-11
winpoplanmess 1152 udp Winpopup LAN Messenger Vitali Fomine Vitali Fomine 2005-11
c1222-acse 1153 tcp ANSI C12.22 Port RFC 6142
c1222-acse 1153 udp ANSI C12.22 Port RFC 6142
resacommunity 1154 tcp Community Service Stéphane MONS Stéphane MONS 2005-09
resacommunity 1154 udp Community Service Stéphane MONS Stéphane MONS 2005-09
nfa 1155 tcp Network File Access James Powell James Powell
nfa 1155 udp Network File Access James Powell James Powell
iascontrol-oms 1156 tcp iasControl OMS Todd Guay Todd Guay 2004-11
iascontrol-oms 1156 udp iasControl OMS Todd Guay Todd Guay 2004-11
iascontrol 1157 tcp Oracle iASControl Todd Guay Todd Guay 2004-11
iascontrol 1157 udp Oracle iASControl Todd Guay Todd Guay 2004-11
dbcontrol-oms 1158 tcp dbControl OMS Todd Guay Todd Guay 2004-11
dbcontrol-oms 1158 udp dbControl OMS Todd Guay Todd Guay 2004-11
oracle-oms 1159 tcp Oracle OMS Todd Guay Todd Guay 2004-11
oracle-oms 1159 udp Oracle OMS Todd Guay Todd Guay 2004-11
qsm-gui 1165 tcp QSM GUI Service Norm Lunde Norm Lunde 2004-11
qsm-gui 1165 udp QSM GUI Service Norm Lunde Norm Lunde 2004-11
dossier 1175 tcp Dossier Server Rob Minerick Rob Minerick 2004-11
dossier 1175 udp Dossier Server Rob Minerick Rob Minerick 2004-11
catchpole 1185 tcp Catchpole port Christian Catchpole Christian Catchpole 2002-03
catchpole 1185 udp Catchpole port Christian Catchpole Christian Catchpole 2002-03
rsf-1 1195 tcp RSF-1 clustering Dave Hines Dave Hines 2004-11
rsf-1 1195 udp RSF-1 clustering Dave Hines Dave Hines 2004-11
accord-mgc 1205 tcp Accord-MGC Roni Even Roni Even
accord-mgc 1205 udp Accord-MGC Roni Even Roni Even
scanstat-1 1215 tcp scanSTAT 1.0 William Scheding William Scheding
scanstat-1 1215 udp scanSTAT 1.0 William Scheding William Scheding
etebac5 1216 tcp ETEBAC 5 Jean-Louis Barbut Jean-Louis Barbut
etebac5 1216 udp ETEBAC 5 Jean-Louis Barbut Jean-Louis Barbut
slinkysearch 1225 tcp SLINKYSEARCH Desmond Chan Desmond Chan

Contact Information

Name Organization Contact URI Last Updated
A. Boninn aboninn&hotmail.com
Alexandre Lechenne alexandre.lechenne&selectron.ch 2008-12-10
Andy Belk abelk&apple.com
Anthony Gonzalez agonzal1&telcordia.com
Brandon Potter iana&brandonpotter.com 2006-01
Christian Catchpole christian&catchpole.net 2002-03
Curt Schimmel curt&small-tree.com 2005-11
Dave Hines d.hines&high-availability.com 2004-11
Desmond Chan deschan&prismedia.com
Dirk Materlik materlik&blubbsoft.de 2005-11
Ericko Shimada eriko&kel.fujitsu.co.jp
Eriko Shimada eriko&kel.fujitsu.co.jp
Gordon Mangione gordm&microsoft.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James Powell james&mailhost.unidata.com
Jean-Louis Barbut etebac5&gsit.fr
John Eckert Valassis eckertj&valassis.com 2015-05-05
Jordi Lisbona jlisbona&tango04.net
Markus Sabadello sabadello&startron.org
Norm Lunde norm&commvault.com 2004-11
Ralf Doewich ralf.doewich&optimatele.com
Ramy Zaarour ramy&lumos.com
Remi Lefebvre remi&debian.org
Rob Minerick rob&vortimac.com 2004-11
Robert Gordon rbg&austin.ibm.com
Roman Kriis roman&previo.ee
Roni Even roni_e&accord.co.il
Serge Vacquier svacquier&axway.com 2019-03-29
Stéphane MONS stephane.mons&free.fr 2005-09
Steven Fields sfields&identix.com 2002-02
Suzanne Lorrin suzanne.lorrin&ansys.com
Todd Guay todd.guay&oracle.com 2005-08
Valassis eckertj&valassis.com 2015-05-05
Vitali Fomine info&winpopup-lan-messenger.com 2005-11
William Scheding wls&wls.org