Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
twamp-test 862 udp TWAMP-Test Receiver Port IESG IETF Chair 2018-12-21 RFC 8545
863-872 Unassigned
iclcnet-locate 886 tcp ICL coNETion locate server Bob Lyon Bob Lyon
iclcnet-locate 886 udp ICL coNETion locate server Bob Lyon Bob Lyon
rift-lies 914 udp Routing in Fat Trees Link Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
rift-ties 915 udp Routing in Fat Trees Topology Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
916-952 Unassigned
vsinet 996 tcp vsinet Rob Juergens Rob Juergens
vsinet 996 udp vsinet Rob Juergens Rob Juergens
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
1023 tcp Reserved 2024-12-20 RFC 6335
1023 udp Reserved 2024-12-20 RFC 6335
1024 tcp Reserved 2024-12-20 RFC 6335
1024 udp Reserved 2024-12-20 RFC 6335
cap 1026 tcp Calendar Access Protocol Doug Royer Doug Royer 2010-12-09
cap 1026 udp Calendar Access Protocol Doug Royer Doug Royer 2010-12-09
6a44 1027 udp IPv6 Behind NAT44 CPEs IESG IETF Chair 2012-08-02 RFC 6751
nsstp 1036 tcp Nebula Secure Segment Transfer Protocol Steve Ravida Steve Ravida
nsstp 1036 udp Nebula Secure Segment Transfer Protocol Steve Ravida Steve Ravida
wfremotertm 1046 tcp WebFilter Remote Monitor Tim Morgan Tim Morgan 2004-11
wfremotertm 1046 udp WebFilter Remote Monitor Tim Morgan Tim Morgan 2004-11
vfo 1056 tcp VFO Anthony Gonzalez Anthony Gonzalez
vfo 1056 udp VFO Anthony Gonzalez Anthony Gonzalez
polestar 1060 tcp POLESTAR Masakuni Okada Masakuni Okada
polestar 1060 udp POLESTAR Masakuni Okada Masakuni Okada
kiosk 1061 tcp KIOSK Ken Ksiazek Ken Ksiazek
kiosk 1061 udp KIOSK Ken Ksiazek Ken Ksiazek
veracity 1062 tcp Veracity Ross Williams Ross Williams
veracity 1062 udp Veracity Ross Williams Ross Williams
kyoceranetdev 1063 tcp KyoceraNetDev Shigenaka Kanemitsu Shigenaka Kanemitsu
kyoceranetdev 1063 udp KyoceraNetDev Shigenaka Kanemitsu Shigenaka Kanemitsu
jstel 1064 tcp JSTEL Duane Kiser Duane Kiser
jstel 1064 udp JSTEL Duane Kiser Duane Kiser
syscomlan 1065 tcp SYSCOMLAN Alexandre Lechenne Alexandre Lechenne 2008-12-10
syscomlan 1065 udp SYSCOMLAN Alexandre Lechenne Alexandre Lechenne 2008-12-10
fpo-fns 1066 tcp FPO-FNS Jens Klose Jens Klose
fpo-fns 1066 udp FPO-FNS Jens Klose Jens Klose
instl-boots 1067 tcp Installation Bootstrap Proto. Serv.

IANA assigned this well-formed service name as a replacement for "instl_boots".
instl_boots 1067 tcp Installation Bootstrap Proto. Serv. This entry is an alias to "instl-boots". This entry is now historic, not usable for use with many common service discovery mechanisms.
instl-boots 1067 udp Installation Bootstrap Proto. Serv.

IANA assigned this well-formed service name as a replacement for "instl_boots".
instl_boots 1067 udp Installation Bootstrap Proto. Serv. This entry is an alias to "instl-boots". This entry is now historic, not usable for use with many common service discovery mechanisms.
instl-bootc 1068 tcp Installation Bootstrap Proto. Cli.

IANA assigned this well-formed service name as a replacement for "instl_bootc".
David Arko David Arko
instl_bootc 1068 tcp Installation Bootstrap Proto. Cli. David Arko David Arko This entry is an alias to "instl-bootc". This entry is now historic, not usable for use with many common service discovery mechanisms.
instl-bootc 1068 udp Installation Bootstrap Proto. Cli.

IANA assigned this well-formed service name as a replacement for "instl_bootc".
David Arko David Arko
instl_bootc 1068 udp Installation Bootstrap Proto. Cli. David Arko David Arko This entry is an alias to "instl-bootc". This entry is now historic, not usable for use with many common service discovery mechanisms.
cognex-insight 1069 tcp COGNEX-INSIGHT Steve Olson Steve Olson
cognex-insight 1069 udp COGNEX-INSIGHT Steve Olson Steve Olson
dab-sti-c 1076 tcp DAB STI-C World DAB World DAB
dab-sti-c 1076 udp DAB STI-C World DAB World DAB
cplscrambler-lg 1086 tcp CPL Scrambler Logging
cplscrambler-lg 1086 udp CPL Scrambler Logging
cnrprotocol 1096 tcp Common Name Resolution Protocol Michael Mealling Michael Mealling
cnrprotocol 1096 udp Common Name Resolution Protocol Michael Mealling Michael Mealling
isoipsigport-1 1106 tcp ISOIPSIGPORT-1
isoipsigport-1 1106 udp ISOIPSIGPORT-1
ltp-deepspace 1113 tcp Licklider Transmission Protocol RFC 5326
ltp-deepspace 1113 udp Licklider Transmission Protocol 2014-02-21 RFC 5326; RFC 7122
ltp-deepspace 1113 dccp Licklider Transmission Protocol 2013-11-12 2014-02-21 RFC 7122 7107696
ardus-cntl 1116 tcp ARDUS Control
ardus-cntl 1116 udp ARDUS Control
sacred 1118 tcp SACRED RFC 3767
sacred 1118 udp SACRED RFC 3767
hpvmmdata 1126 tcp HP VMM Agent John Morton John Morton 2004-11
hpvmmdata 1126 udp HP VMM Agent John Morton John Morton 2004-11
hhb-gateway 1136 tcp HHB Gateway Control Richard Harwell Richard Harwell 2006-02
hhb-gateway 1136 udp HHB Gateway Control Richard Harwell Richard Harwell 2006-02
audit-transfer 1146 tcp audit transfer Mark Wahl Mark Wahl 2005-11
audit-transfer 1146 udp audit transfer Mark Wahl Mark Wahl 2005-11
c1222-acse 1153 tcp ANSI C12.22 Port RFC 6142
c1222-acse 1153 udp ANSI C12.22 Port RFC 6142
iascontrol-oms 1156 tcp iasControl OMS Todd Guay Todd Guay 2004-11
iascontrol-oms 1156 udp iasControl OMS Todd Guay Todd Guay 2004-11
olsv 1160 tcp DB Lite Mult-User Server Philip Stephenson Philip Stephenson 2005-08
olsv 1160 udp DB Lite Mult-User Server Philip Stephenson Philip Stephenson 2005-08
health-polling 1161 tcp Health Polling
health-polling 1161 udp Health Polling
health-trap 1162 tcp Health Trap
health-trap 1162 udp Health Trap
sddp 1163 tcp SmartDialer Data Protocol Lee Griffiths Lee Griffiths 2004-11
sddp 1163 udp SmartDialer Data Protocol Lee Griffiths Lee Griffiths 2004-11
qsm-proxy 1164 tcp QSM Proxy Service Norm Lunde Norm Lunde 2004-11
qsm-proxy 1164 udp QSM Proxy Service Norm Lunde Norm Lunde 2004-11
qsm-gui 1165 tcp QSM GUI Service Norm Lunde Norm Lunde 2004-11
qsm-gui 1165 udp QSM GUI Service Norm Lunde Norm Lunde 2004-11
qsm-remote 1166 tcp QSM RemoteExec Norm Lunde Norm Lunde 2004-11
qsm-remote 1166 udp QSM RemoteExec Norm Lunde Norm Lunde 2004-11
cisco-ipsla 1167 tcp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
cisco-ipsla 1167 udp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
cisco-ipsla 1167 sctp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
vchat 1168 tcp VChat Conference Service Andreas Wetzel Andreas Wetzel 2002-09
vchat 1168 udp VChat Conference Service Andreas Wetzel Andreas Wetzel 2002-09
tripwire 1169 tcp TRIPWIRE Ed Metcalf; Albert Holt Ed Metcalf; Albert Holt
tripwire 1169 udp TRIPWIRE Ed Metcalf; Albert Holt Ed Metcalf; Albert Holt
indigo-server 1176 tcp Indigo Home Server Matt Bendiksen Matt Bendiksen 2004-11

Contact Information

Name Organization Contact URI Last Updated
Albert Holt alberth&triosoftware.com
Alexandre Lechenne alexandre.lechenne&selectron.ch 2008-12-10
Andreas Wetzel mickey&enforcer.cc 2002-09
Anthony Gonzalez agonzal1&telcordia.com
Bob Lyon bl&oasis.icl.co.uk
David Arko darko&hpfcrn.fc.hp.com
Doug Royer DouglasRoyer&gmail.com 2010-12-09
Duane Kiser dkiser&jsexpress.com
Ed Metcalf emetcalf&tripwiresecurity.com
Emmanuel Tychon etychon&cisco.com 2006-03
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jens Klose jklose&intercope.com
John Morton j.morton&hp.com 2004-11
Ken Ksiazek kksiazek&maytag.com
Lee Griffiths lg&dataconnection.com 2004-11
Mark Wahl mark.wahl&informed-control.com 2005-11
Masakuni Okada masakuni&jp.ibm.com
Matt Bendiksen matt&perceptiveautomation.com 2004-11
Michael Mealling michaelm&netsol.com
Norm Lunde norm&commvault.com 2004-11
Philip Stephenson Philip.stephenson&oracle.com 2005-08
Richard Harwell richardcharwell&eaton.com 2006-02
Rob Juergens robj&vsi.com
Ross Williams ross&rocksoft.com
Shigenaka Kanemitsu Shigenaka_Kanemitsu&ypd.kyocera.co.jp
Steve Olson solson&cognex.com
Steve Ravida steve.ravida&nebulaholdings.com
Tim Morgan timm&surfcontrol.com 2004-11
Todd Guay todd.guay&oracle.com 2005-08
World DAB worlddab_irc&worlddab.org