Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| webphone | 21845 | tcp | webphone | Toby Hosterman | Toby Hosterman | ||||||
| webphone | 21845 | udp | webphone | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-is | 21846 | tcp | NetSpeak Corp. Directory Services | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-is | 21846 | udp | NetSpeak Corp. Directory Services | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-cs | 21847 | tcp | NetSpeak Corp. Connection Services | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-cs | 21847 | udp | NetSpeak Corp. Connection Services | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-acd | 21848 | tcp | NetSpeak Corp. Automatic Call Distribution | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-acd | 21848 | udp | NetSpeak Corp. Automatic Call Distribution | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-cps | 21849 | tcp | NetSpeak Corp. Credit Processing System | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-cps | 21849 | udp | NetSpeak Corp. Credit Processing System | Toby Hosterman | Toby Hosterman | ||||||
| 21850-21999 | Unassigned | ||||||||||
| optocontrol | 22001 | tcp | OptoControl | Kevin Kuhns | Kevin Kuhns | ||||||
| optocontrol | 22001 | udp | OptoControl | Kevin Kuhns | Kevin Kuhns | ||||||
| 22006-22124 | Unassigned | ||||||||||
| dcap | 22125 | tcp | dCache Access Protocol | Christoph Anton Mitterer | Christoph Anton Mitterer | 2009-03-10 | |||||
| 22125 | udp | Reserved | |||||||||
| 22126-22127 | Unassigned | ||||||||||
| gsidcap | 22128 | tcp | GSI dCache Access Protocol | Christoph Anton Mitterer | Christoph Anton Mitterer | 2009-03-10 | |||||
| 22128 | udp | Reserved | |||||||||
| 22129-22221 | Unassigned | ||||||||||
| codemeter-cmwan | 22351 | tcp | TPC/IP requests of copy protection software to a server | WIBU-SYSTEMS AG | Wolfgang Völker | 2013-06-25 | |||||
| 22351 | udp | Reserved | |||||||||
| 22801-22950 | Unassigned | ||||||||||
| brf-gw | 22951 | tcp | Telerate Information Platform WAN | Timo Sivonen | Timo Sivonen | ||||||
| brf-gw | 22951 | udp | Telerate Information Platform WAN | Timo Sivonen | Timo Sivonen | ||||||
| inovaport1 | 23000 | tcp | Inova LightLink Server Type 1 | Chris Koeritz | Chris Koeritz | 2006-10 | |||||
| inovaport1 | 23000 | udp | Inova LightLink Server Type 1 | Chris Koeritz | Chris Koeritz | 2006-10 | |||||
| inovaport2 | 23001 | tcp | Inova LightLink Server Type 2 | Chris Koeritz | Chris Koeritz | 2006-10 | |||||
| inovaport2 | 23001 | udp | Inova LightLink Server Type 2 | Chris Koeritz | Chris Koeritz | 2006-10 | |||||
| 23054-23271 | Unassigned | ||||||||||
| s102 | 23272 | udp | S102 application | Kimmo Kymalainen | Kimmo Kymalainen | 2009-08-26 | |||||
| novar-alarm | 23401 | tcp | Novar Alarm | Keith Kilroy | Keith Kilroy | 2006-02 | |||||
| novar-alarm | 23401 | udp | Novar Alarm | Keith Kilroy | Keith Kilroy | 2006-02 | |||||
| med-fsp-rx | 24001 | tcp | med-fsp-rx | Juergen Fischbach | Juergen Fischbach | ||||||
| med-fsp-rx | 24001 | udp | med-fsp-rx | Juergen Fischbach | Juergen Fischbach | ||||||
| 24007-24241 | Unassigned | ||||||||||
| ild | 24321 | tcp | Isolv Local Directory | Mitchell Bass | Mitchell Bass | 2005-08 | |||||
| ild | 24321 | udp | Isolv Local Directory | Mitchell Bass | Mitchell Bass | 2005-08 | |||||
| udpstp | 24601 | udp | UDP-based IP-Layer Capacity and Performance Measurement protocol | IESG | IETF Chair | 2025-09-26 | RFC 9946 | ||||
| 24601 | tcp | Reserved | |||||||||
| 24681-24726 | Unassigned | ||||||||||
| 24851-24921 | Unassigned | ||||||||||
| icl-twobase1 | 25000 | tcp | icl-twobase1 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase1 | 25000 | udp | icl-twobase1 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase2 | 25001 | tcp | icl-twobase2 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase2 | 25001 | udp | icl-twobase2 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase10 | 25009 | tcp | icl-twobase10 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase10 | 25009 | udp | icl-twobase10 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| 25010-25099 | Unassigned | ||||||||||
| db2c-tls | 25100 | tcp | IBM Db2 Client Interface - Encrypted | IBM | Matthew Emmerton | 2024-03-05 | |||||
| 25100 | udp | Reserved | |||||||||
| 25101-25470 | Unassigned | ||||||||||
| rna | 25471 | sctp | RNSAP User Adaptation for Iurh | Dario S. Tonesi | Dario S. Tonesi | 2011-02-07 | |||||
| niobserver | 25901 | tcp | NIObserver | Roman Oliynyk | Roman Oliynyk | ||||||
| niobserver | 25901 | udp | NIObserver | Roman Oliynyk | Roman Oliynyk | ||||||
| 26001-26132 | Unassigned | ||||||||||
| scscp | 26133 | tcp | Symbolic Computation Software Composability Protocol | Alexander Konovalov | Alexander Konovalov | 2007-11-27 | |||||
| scscp | 26133 | udp | Symbolic Computation Software Composability Protocol | Alexander Konovalov | Alexander Konovalov | 2007-11-27 | |||||
| 26134-26207 | Unassigned | ||||||||||
| ezmeeting | 26261 | tcp | eZmeeting | Albert C. Yang | Albert C. Yang | ||||||
| ezmeeting | 26261 | udp | eZmeeting | Albert C. Yang | Albert C. Yang | ||||||
| flex-lm | 27000-27009 | FLEX LM (1-10) | Flexera Software | Paul Bland | 2018-02-15 | ||||||
| flex-lmadmin | 27010 | tcp | A protocol for managing license services | Flexera | Paul Bland | 2018-08-22 | |||||
| 27010 | udp | Reserved | |||||||||
| 27011-27015 | Unassigned | ||||||||||
| chlenix | 27016 | tcp | Cloud hosting environment network | Vlad Bondarenko | Vlad Bondarenko | 2024-09-23 | |||||
| 27016 | udp | Reserved | |||||||||
| mongodb | 27017 | tcp | Mongo database system | MongoDB, Inc. | Akshay Kumar | 2019-02-21 | |||||
| 27017 | udp | Reserved | |||||||||
| 27018-27344 | Unassigned | Unauthorized Use Known on ports 27018 and 27019 | |||||||||
| 27346-27441 | Unassigned | ||||||||||
| 27505-27781 | Unassigned | ||||||||||
| pqsp | 28001 | tcp | PQ Service | Peter Laschtowitz | Peter Laschtowitz | 2009-09-15 | |||||
| 28001 | udp | Reserved | |||||||||
| gruber-cashreg | 28010 | tcp | Gruber cash registry protocol | Gruber Schanksysteme | Clemens Gruber | 2019-12-31 | |||||
| 28010 | udp | Reserved | |||||||||
| 28011-28079 | Unassigned | Unauthorized Use Known on ports 28017, 28018 and 28019 | |||||||||
| 28081-28118 | Unassigned | ||||||||||
| 28119 | tcp | Reserved | |||||||||
| a27-ran-ran | 28119 | udp | A27 cdma2000 RAN Management | 3GPP2 | Zhiming Li | 2012-04-13 | |||||
| 28120-28199 | Unassigned | ||||||||||
| 28201-28239 | Unassigned | ||||||||||
| 28241-28588 | Unassigned | ||||||||||
| 29001-29117 | Unassigned | ||||||||||
| 29118 | tcp | Reserved | |||||||||
| 29118 | udp | Reserved | |||||||||
| sgsap | 29118 | sctp | SGsAP in 3GPP | Dongwook Kim | Dongwook Kim | 2009-06-11 | |||||
| 29119-29166 | Unassigned | ||||||||||
| otmp | 29167 | tcp | ObTools Message Protocol | Paul Clark | Paul Clark | 2006-02 | |||||
| otmp | 29167 | udp | ObTools Message Protocol | Paul Clark | Paul Clark | 2006-02 | |||||
| 29168 | tcp | Reserved | |||||||||
| 29168 | udp | Reserved | |||||||||
| sbcap | 29168 | sctp | SBcAP in 3GPP | Dongwook Kim | Dongwook Kim | 2009-06-11 | |||||
| iuhsctpassoc | 29169 | sctp | HNBAP and RUA Common Association | Dongwook Kim | Dongwook Kim | 2009-09-08 | 2026-01-23 | ||||
| 29170-29998 | Unassigned | ||||||||||
| bingbang | 29999 | tcp | data exchange protocol for IEC61850 in wind power plants | DEIF A/S | Armin Solies | 2012-10-15 | |||||
| pago-services1 | 30001 | tcp | Pago Services 1 | Balduin Mueller-Platz | Balduin Mueller-Platz | 2002-03 | |||||
| pago-services1 | 30001 | udp | Pago Services 1 | Balduin Mueller-Platz | Balduin Mueller-Platz | 2002-03 | |||||
| rwp | 30100 | tcp | Remote Window Protocol | Maxim Baklanovsky | Maxim Baklanovsky | 2015-05-20 | |||||
| 30100 | udp | Reserved | |||||||||
| rwp | 30100 | sctp | Remote Window Protocol | Maxim Baklanovsky | Maxim Baklanovsky | 2015-05-20 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP2 | lizhiming&huawei.com | 2012-01-11 | |
| Akshay Kumar | MongoDB, Inc. | akshay&mongodb.com | 2019-02-21 |
| Albert C. Yang | albert.yang&ezmeeting.com | 2002-03 | |
| Alexander Konovalov | konovalov&member.ams.org | 2007-11-27 | |
| Armin Solies | DEIF A/S | aes&deif.com | 2012-10-15 |
| Balduin Mueller-Platz | balduin.mueller-platz&pago.de | 2002-03 | |
| Chris Koeritz | portmanager&inovasolutions.com | 2006-10 | |
| Christoph Anton Mitterer | calestyo&scientia.net | 2009-03-10 | |
| Clemens Gruber | iana&pqgruber.com | 2019-12-31 | |
| Dario S. Tonesi | dario.tonesi&nsn.com | 2011-02-07 | |
| DEIF A/S | aes&deif.com | 2012-10-15 | |
| Dongwook Kim | 3GPP | dongwook.kim&etsi.org | 2026-01-23 |
| Flexera | pbland&flexera.com | 2018-08-22 | |
| Flexera Software | security&flexerasoftware.com | 2016-07-19 | |
| Dongwook Kim | 3GPP Specifications Manager | dongwook.kim&etsi.org | 2026-01-23 |
| Gruber Schanksysteme | iana&pqgruber.com | 2019-12-31 | |
| IBM | memmerto&ca.ibm.com | 2024-03-05 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| J. A. (Tony) Sever | J.A.Sever&bra0119.wins.icl.co.uk | ||
| Juergen Fischbach | juergen.fischbach&philips.com | ||
| Keith Kilroy | Keith.Kilroy&novarcontrols.com | 2006-02 | |
| Kevin Kuhns | kkuhns&opto22.com | ||
| Kimmo Kymalainen | kimmo.kymalainen&etsi.org | 2017-05-08 | |
| Matthew Emmerton | IBM | memmerto&ca.ibm.com | 2024-03-05 |
| Maxim Baklanovsky | m.baklanovsky&spbu.ru | 2015-05-20 | |
| Mitchell Bass | mitch&integrasolv.com | 2005-08 | |
| MongoDB, Inc. | akshay&mongodb.com | 2019-02-21 | |
| Paul Bland | pbland&flexera.com | 2018-08-22 | |
| Paul Clark | paul&xmill.com | 2006-02 | |
| Peter Laschtowitz | pl&pq-computers.de | 2009-09-15 | |
| Roman Oliynyk | romano&netinst.com | ||
| Timo Sivonen | timo.sivonen&ccmail.dowjones.com | ||
| Toby Hosterman | root&netspeak.com | ||
| Vlad Bondarenko | bondarenko.vlad.univ&gmail.com | 2024-09-23 | |
| WIBU-SYSTEMS AG | oliver.winzenried&wibu.com | 2013-06-25 | |
| Wolfgang Völker | WIBU-SYSTEMS AG | wolfgang.voelker&wibu.com | 2013-06-25 |
| Zhiming Li | 3GPP2 | lizhiming&huawei.com | 2012-01-11 |