Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 38801-38864 | Unassigned | ||||||||||
| turbonote-1 | 39681 | tcp | TurboNote Default Port | Peter Hyde | Peter Hyde | ||||||
| turbonote-1 | 39681 | udp | TurboNote Default Port | Peter Hyde | Peter Hyde | ||||||
| 40001-40022 | Unassigned | ||||||||||
| cscp | 40841 | tcp | CSCP | Michael Dodge | Michael Dodge | ||||||
| cscp | 40841 | udp | CSCP | Michael Dodge | Michael Dodge | ||||||
| 40854-41110 | Unassigned | ||||||||||
| fs-qos | 41111 | tcp | Foursticks QoS Protocol | Chee Kent Lam | Chee Kent Lam | 2002-04 | |||||
| fs-qos | 41111 | udp | Foursticks QoS Protocol | Chee Kent Lam | Chee Kent Lam | 2002-04 | |||||
| 41112-41120 | Unassigned | ||||||||||
| tentacle | 41121 | tcp | Tentacle Server | Sancho Lerena | Sancho Lerena | 2009-06-02 | |||||
| 41121 | udp | Reserved | |||||||||
| 41122-41229 | Unassigned | ||||||||||
| z-wave-s | 41230 | tcp | Z-Wave Protocol over SSL/TLS | Sigma Designs | Anders Brandt | 2015-06-26 | |||||
| z-wave-s | 41230 | udp | Z-Wave Protocol over DTLS | Sigma Designs | Anders Brandt | 2015-06-26 | |||||
| 41231-41793 | Unassigned | ||||||||||
| crestron-cip | 41794 | tcp | Crestron Control Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-cip | 41794 | udp | Crestron Control Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-ctp | 41795 | tcp | Crestron Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-ctp | 41795 | udp | Crestron Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-cips | 41796 | tcp | Crestron Secure Control Port | Crestron Electronics, Inc. | John Pavlik | 2012-06-27 | 2019-10-17 | ||||
| 41796 | udp | Reserved | |||||||||
| crestron-ctps | 41797 | tcp | Crestron Secure Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2012-06-27 | 2019-10-17 | ||||
| 41797 | udp | Reserved | |||||||||
| 41798-42507 | Unassigned | Unauthorized Use Known on port 42000 | |||||||||
| caerpc | 42510 | tcp | CA eTrust RPC | Jon Press | Jon Press | 2005-08 | |||||
| caerpc | 42510 | udp | CA eTrust RPC | Jon Press | Jon Press | 2005-08 | |||||
| 42511-42998 | Unassigned | ||||||||||
| 43001-43187 | Unassigned | ||||||||||
| reachout | 43188 | tcp | REACHOUT | Roman Kriis | Roman Kriis | ||||||
| reachout | 43188 | udp | REACHOUT | Roman Kriis | Roman Kriis | ||||||
| ndm-agent-port | 43189 | tcp | NDM-AGENT-PORT | Roman Kriis | Roman Kriis | ||||||
| ndm-agent-port | 43189 | udp | NDM-AGENT-PORT | Roman Kriis | Roman Kriis | ||||||
| ip-provision | 43190 | tcp | IP-PROVISION | Roman Kriis | Roman Kriis | ||||||
| ip-provision | 43190 | udp | IP-PROVISION | Roman Kriis | Roman Kriis | ||||||
| noit-transport | 43191 | tcp | Reconnoiter Agent Data Transport | Theo Schlossnagle | Theo Schlossnagle | 2009-05-19 | |||||
| 43191 | udp | Reserved | |||||||||
| 43192-43209 | Unassigned | ||||||||||
| shaperai | 43210 | tcp | Shaper Automation Server Management | Shaper Automation Inc. | Yohann Sulaiman | 2012-06-22 | |||||
| shaperai-disc | 43210 | udp | Shaper Automation Server Management Discovery | Shaper Automation Inc. | Yohann Sulaiman | 2012-06-22 | |||||
| 43211-43437 | Unassigned | ||||||||||
| ciscocsdb | 43441 | tcp | Cisco NetMgmt DB Ports | Cisco Systems | Cisco Systems | 2005-11 | |||||
| ciscocsdb | 43441 | udp | Cisco NetMgmt DB Ports | Cisco Systems | Cisco Systems | 2005-11 | |||||
| 43442-44122 | Unassigned | ||||||||||
| z-wave-tunnel | 44123 | tcp | Z-Wave Secure Tunnel | Sigma Designs, Inc. | Anders Brandt | 2012-10-12 | 2015-06-26 | ||||
| 44123 | udp | Reserved | |||||||||
| 44124-44320 | Unassigned | ||||||||||
| pmcd | 44321 | tcp | PCP server (pmcd) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2010-12-20 | 2025-09-29 | ||||
| pmcd | 44321 | udp | PCP server (pmcd) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2010-12-20 | 2025-09-29 | ||||
| 44323 | udp | Unassigned | "pcp" assignment withdrawn, moved to port 5351 per RFC 6887 | ||||||||
| 44446-44543 | Unassigned | Known UNAUTHORIZED USE: Ports 44515 & 44516 | |||||||||
| 44601-44817 | Unassigned | ||||||||||
| EtherNet-IP-2 | 44818 | tcp | EtherNet/IP messaging IANA assigned this well-formed service name as a replacement for "EtherNet/IP-2". |
Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 | |||||
| EtherNet/IP-2 | 44818 | tcp | EtherNet/IP messaging | Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 This entry is an alias to "EtherNet-IP-2". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| EtherNet-IP-2 | 44818 | udp | EtherNet/IP messaging IANA assigned this well-formed service name as a replacement for "EtherNet/IP-2". |
Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 | |||||
| EtherNet/IP-2 | 44818 | udp | EtherNet/IP messaging | Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 This entry is an alias to "EtherNet-IP-2". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 44819-44899 | Unassigned | ||||||||||
| 44901-44999 | Unassigned | ||||||||||
| asmps | 45001 | tcp | Nuance AutoStore Status Monitoring Protocol (secure data transfer) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| 45001 | udp | Reserved | |||||||||
| 45055-45184 | Unassigned | ||||||||||
| witsnet | 45185 | tcp | Wire and Wireless transfer on synchroniz | Shenzhen Inovance Technology Co., Ltd | Yan Yi | 2025-03-11 | |||||
| witsnet | 45185 | udp | Wire and Wireless transfer on synchroniz | Shenzhen Inovance Technology Co., Ltd | Yan Yi | 2025-03-11 | |||||
| 45186-45513 | Unassigned | ||||||||||
| cloudcheck | 45514 | tcp | ASSIA CloudCheck WiFi Management System | ASSIA Inc. | Leonardo Dagum | 2016-08-29 | |||||
| cloudcheck-ping | 45514 | udp | ASSIA CloudCheck WiFi Management keepalive | ASSIA Inc. | Leonardo Dagum | 2016-08-29 | |||||
| 45515-45677 | Unassigned | ||||||||||
| winrm | 47001 | tcp | Windows Remote Management Service | Ryan Mack | Ryan Mack | 2009-04-29 | |||||
| 47001 | udp | Reserved | |||||||||
| jvl-mactalk | 47100 | udp | Configuration of motors connected to Industrial Ethernet | JVL Industri Elektronik | Kim Berthelsen | 2012-12-21 | |||||
| 47100 | tcp | Reserved | |||||||||
| 47101-47556 | Unassigned | ||||||||||
| 47810-47999 | Unassigned | ||||||||||
| nimspooler | 48001 | tcp | Nimbus Spooler | Carstein Seeberg | Carstein Seeberg | ||||||
| nimspooler | 48001 | udp | Nimbus Spooler | Carstein Seeberg | Carstein Seeberg | ||||||
| 48051-48127 | Unassigned | ||||||||||
| isnetserv | 48128 | tcp | Image Systems Network Services | Bengt Gustafsson | Bengt Gustafsson | 2006-05 | |||||
| isnetserv | 48128 | udp | Image Systems Network Services | Bengt Gustafsson | Bengt Gustafsson | 2006-05 | |||||
| blp5 | 48129 | tcp | Bloomberg locator | Albert Hou | Albert Hou | 2006-05 | |||||
| blp5 | 48129 | udp | Bloomberg locator | Albert Hou | Albert Hou | 2006-05 | |||||
| 48130-48555 | Unassigned | ||||||||||
| 48557-48618 | Unassigned | ||||||||||
| iqobject | 48619 | tcp | iqobject | Bjorn de Bonnenfant | Bjorn de Bonnenfant | 2003-11 | |||||
| iqobject | 48619 | udp | iqobject | Bjorn de Bonnenfant | Bjorn de Bonnenfant | 2003-11 | |||||
| nusrp | 49001 | tcp | Nuance Unity Service Request Protocol | Nuance Communications, Inc. | Andrew Andrews | 2017-04-20 | |||||
| nusdp-disc | 49001 | udp | Nuance Unity Service Discovery Protocol | Nuance Communications, Inc. | Andrew Andrews | 2017-04-20 | |||||
| 49002-49149 | Unassigned | ||||||||||
| inspider | 49150 | tcp | InSpider System | AnRobot | Zhang Xinnan | 2017-11-06 | |||||
| 49150 | udp | Reserved | |||||||||
| 49151 | Reserved | 2024-12-20 | RFC 6335 | ||||||||
| leaf-1 | Leaf-1 Protocol | ||||||||||
| trunk-1 | Trunk-1 Protocol | ||||||||||
| 1password | 1Password Password Manager data sharing and synchronization protocol | Roustem Karimov | Roustem Karimov | Defined TXT keys: None | |||||||
| adobe-vc | Adobe Version Cue | Defined TXT keys: txtvers=1, name, version, build | |||||||||
| affinity-docs1 | tcp | Affinity Photo document sharing | Serif (Europe) Ltd. | Tom Lachecki | 2023-03-30 | Defined TXT keys: Proprietary | |||||
| av-chat-ring-01 | tcp | TCP SpyChat Stream Message Exchange | Alexios Vasileiadis | Alexios Vasileiadis | 2018-05-03 | Defined TXT keys: There are two TXT record keys: 1st key: "txt-vers" associated with an 'int' entry. 2nd key: "conn-stat" associated with an 'int' entry. | |||||
| autotunnel | udp | IPSEC VPN tunnel over UDP | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | RFC 6281 | Defined TXT Keys: None | ||||
| b3d-convince | 3M Unitek Digital Orthodontic System | Rajiv Aaron Manglani | Rajiv Aaron Manglani | Defined TXT keys: txtvers=1, protovers=<api version>, guid=<32 hex digits> | |||||||
| certificates | tcp | Server for S/MIME and PGP certificates | IESG | John Levine | 2016-07-26 | draft-bhjl-x509-srv-01 | Defined TXT keys: None | ||||
| core-rd | tcp | Resource Directory accessed using CoAP over TCP | IESG | IETF Chair | 2021-03-16 | RFC 9176 | Defined TXT keys: None | ||||
| core-rd | udp | Resource Directory accessed using CoAP | IESG | IETF Chair | 2021-03-16 | RFC 9176 | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Albert Hou | ahou1&bloomberg.com | 2006-05 | |
| Alexios Vasileiadis | alexvas100&gmail.com | 2018-05-03 | |
| Anders Brandt | Sigma Designs | anders_brandt&sigmadesigns.com | 2012-10-12 |
| Anders Brandt | Sigma Designs | anders_brandt&sigmadesigns.com | 2015-06-26 |
| Andrew Andrews | Andrew.Andrews&Nuance.com | 2017-04-26 | |
| AnRobot | webmaster&anrobot.org | 2017-11-06 | |
| ASSIA Inc. | info&assia-inc.com | 2016-08-29 | |
| Bengt Gustafsson | bengt.gustafsson&imagesystems.se | 2006-05 | |
| Bjorn de Bonnenfant | bdeb&iqobject.com | 2003-11 | |
| Brian Batke | eip.jsig&gmail.com | ||
| Carstein Seeberg | case&nimsoft.no | ||
| Chee Kent Lam | cklam&foursticks.com | 2002-04 | |
| Cisco Systems | nmtg-port-numbers&cisco.com | 2005-11 | |
| Crestron Electronics, Inc. | jpavlik&crestron.com | 2019-10-17 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| John Levine | standards&taugh.com | 2016-07-26 | |
| John Pavlik | jpavlik&crestron.com | 2019-10-17 | |
| Jon Press | IANA.Registions&ca.com | 2005-09 | |
| JVL Industri Elektronik | jvl&jvl.dk | 2012-12-21 | |
| Ken McDonell | kenj&kenj.id.au | 2025-09-26 | |
| Kim Berthelsen | JVL Industri Elektronik | kb&jvl.dk | 2012-12-21 |
| Leonardo Dagum | ldagum&assia-inc.com | 2016-08-29 | |
| Michael Dodge | sarge¢erspan.com | ||
| Nuance Communications, Inc. | Andrew.Andrews&Nuance.com | 2017-04-20 | |
| Nuance Communications, Inc. | dev&nsius.com | 2017-04-26 | |
| Performance Co-Pilot (PCP) Project | pcp-maintainers&groups.io | 2025-09-26 | |
| Peter Hyde | peter&spis.co.nz | ||
| Rajiv Aaron Manglani | rajivmanglani&mmm.com | ||
| Roman Kriis | roman&previo.ee | ||
| Roustem Karimov | roustem&agilewebsolutions.com | ||
| Ryan Mack | rmackµsoft.com | 2009-04-29 | |
| Sancho Lerena | slerena&artica.es | 2009-06-02 | |
| Serif (Europe) Ltd. | affinity&serif.com | 2023-03-30 | |
| Shaper Automation Inc. | ports&shaperai.com | 2012-06-22 | |
| Shenzhen Inovance Technology Co., Ltd | yanyi&inovance.com | 2025-03-11 | |
| Sigma Designs, Inc. | anders_brandt&sigmadesigns.com | 2011-10-03 | |
| Sigma Designs | anders_brandt&sigmadesigns.com | 2015-06-26 | |
| Stuart Cheshire | cheshire&apple.com | 2022-07-11 | |
| Theo Schlossnagle | jesus&omniti.com | 2009-05-19 | |
| Tom Lachecki | Serif (Europe) Ltd. | tlachecki&serif.com | 2023-03-30 |
| Yan Yi | yanyi&inovance.com | 2025-03-11 | |
| Yohann Sulaiman | ports&shaperai.com | 2012-06-22 | |
| Zhang Xinnan | 70331471&qq.com | 2017-11-06 |