Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
core-rd udp Resource Directory accessed using CoAP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd-tls tcp Resource Directory accessed using CoAP over TLS IESG IETF Chair 2021-03-16 2022-04-14 RFC 9176 Defined TXT keys: None
core-rd-dtls udp Resource Directory accessed using CoAP over DTLS IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
dccp-ping dccp ping/traceroute using DCCP Samuel Jero Samuel Jero 2012-11-14 1885957735 Defined TXT keys: None
dns-llq-tls tcp DNS Long-Lived Queries over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 Defined TXT Keys: None
dns-update-tls tcp DNS Dynamic Update Service over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain.
edge1 tcp Edge1 Base Station Skycatch, Inc. Ruben Beltran del Rio 2018-02-09 Defined TXT keys: None
est-coaps udp EST over secure CoAP (EST-coaps) Toerless Eckert Toerless Eckert 2022-05-03 2022-05-04 RFC 9148. Defined TXT keys: None
ewelink tcp eWeLink devices supporting LAN Control Shenzhen CoolKit Technology Co., Ltd. Michael Hu 2019-01-17 Defined TXT keys: txtvers, id, type, apivers, encrypt, data1, data2, data3, data4, iv
eyetvsn EyeTV Sharing Elgato Elgato Defined TXT keys: txtvers=1, keyhash=<4 bytes>
fix Financial Information Exchange (FIX) Protocol Joakim Johansson Joakim Johansson Defined TXT keys: Currently valid enumerated values: FIX Session Protocol Versions (SESSIONVERSION): 1.1 FIX Application Protocol Versions (APPLICATIONVERSION): 2.7, 3.0, 4.0, 4.1, 4.2, 4.3, 4.4, 5.0 Possible TXT records defined and their values (replace uppercase text with enumerations from the list above): txtvers=1 fix=APPLICATIONVERSION fix supported=APPLICATIONVERSION[,APPLICATIONVERSION, ... ,APPLICATIONVERSION] fixt=SESSIONVERSION
help HELP command RFC 1078 TCP Port Service Multiplexer (TCPMUX)
hpr-bldlnx HP Remote Build System for Linux-based Systems Jeffrey J. Walls Jeffrey J. Walls Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102
hpr-toollnx HP Remote System that houses compilers and tools for Linux-based Systems Jeffrey J. Walls Jeffrey J. Walls Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102
hpr-tstlnx HP Remote Test System for Linux-based Systems Jeffrey J. Walls Jeffrey J. Walls Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102
iad1 BBN IAD 2013-05-24 This service name is no longer in use.
ichat iChat 1.0 Jens Alfke Jens Alfke Defined TXT keys: Proprietary
im tcp Instant Messaging RFC 3861
im udp Instant Messaging RFC 3861
jnx-kcsync tcp jollys keychain cloud sync protocol Patrick Stein Patrick Stein 2011-10-24 Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa
lsys-ezcfg LinkSys EZ Configuration Frank Zerangue Frank Zerangue Defined TXT keys: model=value (string) serial=value (sring) hwversion=value (string) swversion=value (string) ifversion=value (string) type=value (string) mac=value (12 hex digits)
lsys-oamp LinkSys Operations, Administration, Management, and Provisioning Frank Zerangue Frank Zerangue Defined TXT keys: model=value (string) serial=value (sring) hwversion=value (string) swversion=value (string) ifversion=value (string) type=value (string) mac=value (12 hex digits)
lumiere tcp A protocol to remotely control DMX512 devices over the network Gangsta Ltd. Jean-Charles Boude 2011-10-13 Defined TXT keys: None
M30S1PT tcp Moritz30-Project Standard protocol 1 Plain Text Moritz30 Matthias Merkel 2015-12-07 Defined TXT keys: None
M30S1PT udp Moritz30-Project Standard protocol 1 Plain Text Moritz30 Matthias Merkel 2015-12-07 Defined TXT keys: None
mazepseudo-game udp Peer to peer communication between instances of the Maze Pseudo game. Mad Elf Software, Inc. Kenneth Suda 2016-02-02 2016-03-30 Defined TXT keys: 1 TXT record key for the RSA public key used by the server instance.
mediaboard1 MediaBoardONE Asset and Information Manager data sharing and synchronization protocol Thomas K. Fischer Thomas K. Fischer Defined TXT keys: None
meshcop udp Thread Mesh Commissioning Thread Group, Inc. Esko Dijk 2020-11-20 Defined TXT keys: Thread 1.1 Specification, Section 8.4.1.1.2. https://www.threadgroup.org/ThreadSpec
meshcop-e udp Thread Mesh Commissioning Ephemeral-key Thread Group, Inc. Esko Dijk 2024-01-22 Defined TXT keys: TXT records keys, if any, will be defined in Section 8.12 of the Thread Specification. https://www.threadgroup.org/ThreadSpec
moodring Bonjour Mood Ring tutorial program Daniel Steinberg Daniel Steinberg Defined TXT keys: txtvers=1 mood=<ascii digit from 0-4>
nfs-domainroot tcp NFS service for the domain root, the root of an organization's published file namespace. IESG IETF Chair 2012-04-24 RFC 6641 Defined TXT keys: None
objective Means for clients to locate servers in an Objective (http://www.objective.com) instance. Marc Bailey Marc Bailey Defined TXT keys: txtvers='1' type={'production'|'standby'|'test'|'demo'} protocol={['SOAP'],['CORBA']} transport=['iiop']|['http']
oca tcp Insecure OCP.1 protocol, which is the insecure TCP/IP implementation of the Object Control Architecture OCA Alliance Stephan van Tienen 2012-10-11 Defined TXT keys: txtvers=1 protovers=x
oca udp Insecure OCP.1 protocol, which is the insecure TCP/IP implementation of the Object Control Architecture OCA Alliance Stephan van Tienen 2012-10-11 Defined TXT keys: txtvers=1 protovers=x
ocasec tcp Secure OCP.1 protocol, which is the secure TCP/IP implementation of the Object Control Architecture OCA Alliance Stephan van Tienen 2012-10-11 Defined TXT keys: txtvers=1 protovers=x
ocasec udp Secure OCP.1 protocol, which is the secure TCP/IP implementation of the Object Control Architecture OCA Alliance Stephan van Tienen 2012-10-11 Defined TXT keys: txtvers=1 protovers=x
ocaws tcp Insecure OCP.1 hosted on a WebSocket OCA Alliance Stephan van Tienen 2017-05-19 Defined TXT keys: txtvers protovers path
olpc-activity1 udp One Laptop per Child activity One Laptop per Child/Collabora Ltd. One Laptop per Child/Collabora Ltd. Defined TXT keys: Shared_Activity_Protocol_1.0
owhttpd OWFS (1-wire file system) web server Paul H Alfille Paul H Alfille Defined TXT keys: txtvers
pgpkey-http PGP Keyserver using HTTP/1.1 Jeroen Massar Jeroen Massar Defined TXT keys: path=<path on the server where the HKP applications reside> normally: "path=/pks/"
pres tcp Presence RFC 3861
pres udp Presence RFC 3861
presence Peer-to-peer messaging / Link-Local Messaging XMPP Registrar XMPP Registrar Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html Note: Registration updated May 2007. Was formerly listed as "iChat AV" (Apple's IM client for Mac OS X) with TXT keys: txtvers, port.p2pj, phsh, vc, 1st, AIM, msg, status, last When first shipped in Mac OS X 10.2, iChat's peer-to-peer messaging protocol was created to solve the problem of serverless messaging between peers on the same link. However, there is nothing inherent in the protocol that limits it to being only link-local; it was simply an artifact of iChat in Mac OS X 10.2 using link-local Multicast DNS to discover peers. With the advent of Wide-Area DNS-SD, it is also possible to use iChat's peer-to-peer messaging between machines on different links.
psap udp Progal Service Advertising Protocol Soren Weber Soren Weber Defined TXT keys: c0, c1, ..., cn
ptp-req PTP Initiation Request Protocol Mark Wood Mark Wood Defined TXT keys: txtvers, guid, c0, c1, c2, ..., where the number of c_n attributes is variable
recipe-sharing tcp Recipe Sharing Protocol Daniel G. Taylor Daniel G. Taylor 2007-11 Defined TXT keys: http://www.recipemanager.org/rsp/rsp10draft.html#dnssd
rfid RFID Reader Mach1(tm) Protocol Paul Dietrich Paul Dietrich Defined TXT keys: None
rgb tcp RGB Spectrum Device Discovery RGB Spectrum Steve Hershey 2011-10-10 Defined TXT keys: Keyboard, Mouse, Option1, Option2, Option3, Option4, ModelName
robustirc tcp Like ircu (RFC 1459), but failure tolerant due to strong consistency among n>=3 servers Michael Stapelberg Michael Stapelberg 2015-01-07 Defined TXT keys: None
roku-rcp Roku Control Protocol Don Woodward Don Woodward Defined TXT keys: txtvers=1
see SubEthaEdit 2 TheCodingMonkeys TheCodingMonkeys Defined TXT keys: txtvers=1, name=<Full Name>, userid=<User ID>, version=2
smimeca tcp Domain signing certificate for S/MIME keys IESG John Levine 2016-07-26 draft-bhjl-x509-srv-01 Defined TXT keys: None
sparql SPARQL Protocol and RDF Query Language Alex Tucker Alex Tucker Defined TXT keys: txtvers=1 path=<relative or absolute URL of endpoint> protovers=<number> [if not specified then default is 1.0, corresponding to SPARQL version] binding=<HTTP | SOAP> [if not specified then default is HTTP] vocabs=<space separated list of URIs> [RDF vocabularies or OWL ontologies used by the endpoint] metadata=<URL> [to fetch RDF/XML description of SPARQL service]
spx-hmp tcp SpinetiX HMP SpinetiX S.A. Diego Santa Cruz 2011-10-18 Defined TXT keys: txtvers=1 cport= the port for the content HTTP server (secondary HTTP server used for content publishing) mode= the mode in which the HMP device is currently operating, one of "normal", "safe" or "recovery" serial= serial number of the HMP device firmware= firmware version string (e.g., 2.1.0-0.1.7844) model= model string (e.g., HMP100)
strobe-sync tcp Strobe Synchronization Jasper Morgal Richard Morgal 2019-06-13 Defined TXT keys: Application will rely upon Bonjour version 3.1.0.1
sugarlock-rcp tcp Remote control protocol for Sugarlock consumer electronics devices Sugarlock, LLC Don Woodward 2016-01-22 Defined TXT keys: txtvers=1
sugarlock-rcp udp Remote control protocol for Sugarlock consumer electronics devices Sugarlock, LLC Don Woodward 2016-01-22 Defined TXT keys: txtvers=1
tbricks tbricks internal protocol Joakim Johansson Joakim Johansson Defined TXT keys: txtvers=1, sesna, seid, setype, cosna, coid, cotype, sysna, syna, syid, subsyid, venid, protocols, pid
tinavigator TI Navigator Hub 1.0 Discovery Service Stephen Reid Stephen Reid Defined TXT keys: None
vedabase tcp Application specific synchronization protocol Peter Kollath Peter Kollath 2014-05-27 Defined TXT keys: txtvers=1
visel visel Q-System services Lehpaner Sasa Lehpaner Sasa Defined TXT keys: Version=<service version> Type=<service type> Name=<service Name> Zone=<service zone> ID=<serviceID> SString=<serviceString> SString1=<serviceString>
vxi-11 VXI-11 TCP/IP Instrument Protocol Nick Barendt Nick Barendt Defined TXT keys: None
wormhole Roku Cascade Wormhole Protocol Don Woodward Don Woodward Defined TXT keys: txtvers=1
x510 tcp Security service to protocols ITU-T Study Group 17 Erik Andersen 2019-08-13 Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Alex Tucker alex&floop.org.uk
Daniel G. Taylor dan&programmer-art.org 2007-11
Daniel Steinberg daniel&oreilly.com
Diego Santa Cruz SpinetiX S.A. Diego.SantaCruz&spinetix.com 2011-10-18
Don Woodward dwoodward&rokulabs.com
Don Woodward don&sugarlock.comm 2016-01-22
Elgato support&elgato.com
Erik Andersen era&x500.eu 2019-08-13
Esko Dijk Thread Group, Inc. esko.dijk&iotconsultancy.nl 2024-01-22
Frank Zerangue fzerang&cisco.com
Gangsta Ltd. jc&gangstamedia.com 2011-10-13
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU-T Study Group 17 era&x500.eu 2019-08-13
Jasper Morgal jpmorgal8&gmail.com 2019-06-13
Jean-Charles Boude Gangsta Ltd. jc&gangstamedia.com 2011-10-17
Jeffrey J. Walls jeff.walls&hp.com
Jens Alfke jens&apple.com
Jeroen Massar jeroen&unfix.org
Joakim Johansson joakim.johansson&tbricks.com
John Levine standards&taugh.com 2016-07-26
Kenneth Suda Mad Elf Software, Inc. help&madelfsoftware.com 2016-03-30
Lehpaner Sasa lsasa&visel.it
Mad Elf Software, Inc. help&madelfsoftware.com 2016-03-30
Marc Bailey marc&objective.com
Mark Wood mark.d.wood&kodak.com
Matthias Merkel moritz30&moritz30.de 2015-12-07
Michael Hu Shenzhen CoolKit Technology Co., Ltd. michael.hu&coolkit.cn 2019-01-17
Michael Stapelberg michael+iana&stapelberg.ch 2015-01-07
Moritz30 moritz30&moritz30.de 2015-12-07
Nick Barendt nbarendt&vxitech.com
OCA Alliance tina.lipscomb&oca-alliance.com 2017-05-19
One Laptop per Child/Collabora Ltd. devel&lists.laptop.org
Patrick Stein Patrick.Stein&jinx.eu 2011-10-24
Paul Dietrich registrar&impinj.com
Paul H Alfille paul.alfille&gmail.com
Peter Kollath root&gopal.home.sk 2014-05-27
RGB Spectrum shershey&rgb.com 2011-10-10
Richard Morgal rmorgal&wildblue.net 2019-06-13
Ruben Beltran del Rio benb&skycatch.com 2018-02-09
Samuel Jero sj323707&ohio.edu 2012-11-14
Shenzhen CoolKit Technology Co., Ltd. admin&coolkit.cn 2019-01-17
Skycatch, Inc. dev&skycatch.com 2018-02-09
Soren Weber sw&ditec-gmbh.de
SpinetiX S.A. Diego.SantaCruz&spinetix.com 2011-10-18
Stephen Reid sreid&ti.com
Stephan van Tienen OCA Alliance stephan.vantienen&bosch.com 2017-05-19
Steve Hershey RGB Spectrum shershey&rgb.com 2011-10-10
Stuart Cheshire cheshire&apple.com 2022-07-11
Sugarlock, LLC don&sugarlock.com 2016-01-22
TheCodingMonkeys monkeys&codingmonkeys.de
Thomas K. Fischer thomas.fischer&interservices.de
Thread Group, Inc. help&threadgroup.org 2024-01-22
Toerless Eckert tte&cs.fau.de 2022-05-03
XMPP Registrar registrar&xmpp.org