Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
med-ci 24005 tcp med-ci [Juergen_Fischbach] [Juergen_Fischbach]
med-ci 24005 udp med-ci [Juergen_Fischbach] [Juergen_Fischbach]
med-net-svc 24006 tcp med-net-svc [Juergen_Fischbach] [Juergen_Fischbach]
med-net-svc 24006 udp med-net-svc [Juergen_Fischbach] [Juergen_Fischbach]
24007-24241 Unassigned
24243-24248 Unassigned
vista-4gl 24249 tcp Vista 4GL [Ingenta_plc] [Mark_Itzcovitz] 2020-01-06
vista-4gl 24249 udp Vista 4GL [Ingenta_plc] [Mark_Itzcovitz] 2020-01-06
24250-24320 Unassigned
vrmg-ip 24323 tcp Verimag mobile class protocol over TCP [Verimag_OOO] [Denis_Ionov] 2018-08-15
24324-24385 Unassigned
intel-rci 24386 tcp Intel RCI

IANA assigned this well-formed service name as a replacement for "intel_rci".
[Mark_Lewis_2] [Mark_Lewis_2]
intel_rci 24386 tcp Intel RCI [Mark_Lewis_2] [Mark_Lewis_2] This entry is an alias to "intel-rci". This entry is now historic, not usable for use with many common service discovery mechanisms.
intel-rci 24386 udp Intel RCI

IANA assigned this well-formed service name as a replacement for "intel_rci".
[Mark_Lewis_2] [Mark_Lewis_2]
intel_rci 24386 udp Intel RCI [Mark_Lewis_2] [Mark_Lewis_2] This entry is an alias to "intel-rci". This entry is now historic, not usable for use with many common service discovery mechanisms.
24387-24464 Unassigned
24466-24553 Unassigned
24555-24576 Unassigned
bilobit-update 24577 udp bilobit Service Update [bilobit_GmbH] [Martin_Schmuker] 2014-08-15
24578-24600 Unassigned
udpstp 24601 udp UDP-based IP-Layer Capacity and Performance Measurement protocol [IESG] [IETF_Chair] 2025-09-26 [RFC 9946]
24602-24665 Unassigned
24667-24675 Unassigned
tcc-http 24680 tcp TCC User HTTP Service [Brian_Kennedy] [Brian_Kennedy] 2006-08
tcc-http 24680 udp TCC User HTTP Service [Brian_Kennedy] [Brian_Kennedy] 2006-08
24681-24726 Unassigned
24728-24753 Unassigned
24755-24849 Unassigned
assoc-disc 24850 udp Device Association Discovery [Microsoft_Corporation_3] [Sachin_Sheth] 2012-06-27
24851-24921 Unassigned
24923-24999 Unassigned
icl-twobase1 25000 tcp icl-twobase1 [J_A_Sever] [J_A_Sever]
icl-twobase1 25000 udp icl-twobase1 [J_A_Sever] [J_A_Sever]
icl-twobase2 25001 tcp icl-twobase2 [J_A_Sever] [J_A_Sever]
icl-twobase2 25001 udp icl-twobase2 [J_A_Sever] [J_A_Sever]
icl-twobase3 25002 tcp icl-twobase3 [J_A_Sever] [J_A_Sever]
icl-twobase3 25002 udp icl-twobase3 [J_A_Sever] [J_A_Sever]
icl-twobase4 25003 tcp icl-twobase4 [J_A_Sever] [J_A_Sever]
icl-twobase4 25003 udp icl-twobase4 [J_A_Sever] [J_A_Sever]
icl-twobase5 25004 tcp icl-twobase5 [J_A_Sever] [J_A_Sever]
icl-twobase5 25004 udp icl-twobase5 [J_A_Sever] [J_A_Sever]
icl-twobase6 25005 tcp icl-twobase6 [J_A_Sever] [J_A_Sever]
icl-twobase6 25005 udp icl-twobase6 [J_A_Sever] [J_A_Sever]
icl-twobase7 25006 tcp icl-twobase7 [J_A_Sever] [J_A_Sever]
icl-twobase7 25006 udp icl-twobase7 [J_A_Sever] [J_A_Sever]
icl-twobase8 25007 tcp icl-twobase8 [J_A_Sever] [J_A_Sever]
icl-twobase8 25007 udp icl-twobase8 [J_A_Sever] [J_A_Sever]
icl-twobase9 25008 tcp icl-twobase9 [J_A_Sever] [J_A_Sever]
icl-twobase9 25008 udp icl-twobase9 [J_A_Sever] [J_A_Sever]
icl-twobase10 25009 tcp icl-twobase10 [J_A_Sever] [J_A_Sever]
icl-twobase10 25009 udp icl-twobase10 [J_A_Sever] [J_A_Sever]
25010-25099 Unassigned
db2c-tls 25100 tcp IBM Db2 Client Interface - Encrypted [IBM] [Matthew_Emmerton] 2024-03-05
25101-25470 Unassigned
25472-25575 Unassigned
25577-25603 Unassigned
idtp 25604 tcp Identifier Tracing Protocol [Huang_Neng-geng] [Huang_Neng-geng] 2011-08-09
25605-25792 Unassigned
vocaltec-hos 25793 tcp Vocaltec Address Server [Scott_Petrack] [Scott_Petrack]
vocaltec-hos 25793 udp Vocaltec Address Server [Scott_Petrack] [Scott_Petrack]
25794-25899 Unassigned
tasp-net 25900 tcp TASP Network Comm [Martin_Ellis] [Martin_Ellis] 2004-11
tasp-net 25900 udp TASP Network Comm [Martin_Ellis] [Martin_Ellis] 2004-11
25904-25953 Unassigned
bf-game 25954 udp Bitfighter game server [Christopher_Eykamp] [Christopher_Eykamp] 2012-08-16
bf-master 25955 udp Bitfighter master server [Christopher_Eykamp] [Christopher_Eykamp] 2012-08-16
25956-25999 Unassigned
26001-26132 Unassigned
26134-26207 Unassigned
wnn6-ds 26208 tcp wnn6-ds [Yasunari_Gon_Yamasit] [Yasunari_Gon_Yamasit]
wnn6-ds 26208 udp wnn6-ds [Yasunari_Gon_Yamasit] [Yasunari_Gon_Yamasit]
26209-26256 Unassigned
26258-26259 Unassigned
k3software-svr 26262 tcp K3 Software-Server [Jim_Baldridge] [Jim_Baldridge]
k3software-svr 26262 udp K3 Software-Server [Jim_Baldridge] [Jim_Baldridge]
k3software-cli 26263 tcp K3 Software-Client [Jim_Baldridge] [Jim_Baldridge]
k3software-cli 26263 udp K3 Software-Client [Jim_Baldridge] [Jim_Baldridge]
26264 De-registered 2006-04-06
26265-26485 Unassigned
exoline-tcp 26486 tcp EXOline-TCP [AB_Regin] [Simon_Jonsson] 2008-12-24 2018-09-13
exoline-udp 26486 udp EXOline-UDP [AB_Regin] [Simon_Jonsson] 2008-12-24 2018-09-13
26490-26999 Unassigned
flex-lm 27000-27009 FLEX LM (1-10) [Flexera_Software] [Paul_Bland] 2018-02-15
flex-lmadmin 27010 tcp A protocol for managing license services [Flexera] [Paul_Bland] 2018-08-22
27011-27015 Unassigned
27018-27344 Unassigned Unauthorized Use Known on ports 27018 and 27019
27346-27441 Unassigned
27443-27503 Unassigned
kopek-httphead 27504 tcp Kopek HTTP Head Port [Sten_H_Danielsen] [Sten_H_Danielsen] 2002-07
kopek-httphead 27504 udp Kopek HTTP Head Port [Sten_H_Danielsen] [Sten_H_Danielsen] 2002-07
27505-27781 Unassigned
ars-vista 27782 tcp ARS VISTA Application [Spencer_Teran_2] [Spencer_Teran_2] 2004-11
ars-vista 27782 udp ARS VISTA Application [Spencer_Teran_2] [Spencer_Teran_2] 2004-11
27783-27875 Unassigned
27877-27998 Unassigned
tw-auth-key 27999 tcp TW Authentication/Key Distribution and [Alex_Duncan_2] [Alex_Duncan_2]
tw-auth-key 27999 udp Attribute Certificate Services [Alex_Duncan_2] [Alex_Duncan_2]
28002-28009 Unassigned
gruber-cashreg 28010 tcp Gruber cash registry protocol [Gruber_Schanksysteme] [Clemens_Gruber] 2019-12-31
28011-28079 Unassigned Unauthorized Use Known on ports 28017, 28018 and 28019
thor-engine 28080 tcp thor/server - ML engine [Aronetics_LLC] [John_Aron] 2021-09-29 2021-10-01

Contact Information

ID Name Organization Contact URI Last Updated
[AB_Regin] AB Regin mailto:urban.fosseus&regin.se 2018-09-13
[Alex_Duncan_2] Alex Duncan mailto:Alex.Duncan&sse.ie
[Aronetics_LLC] Aronetics LLC mailto:john&aronetics.com 2021-09-29
[bilobit_GmbH] bilobit GmbH mailto:ms&bilobit.com 2014-08-15
[Brian_Kennedy] Brian Kennedy mailto:BrianK&targetedconvergence.com 2006-08
[Christopher_Eykamp] Christopher Eykamp mailto:chris&eykamp.com 2012-08-16
[Clemens_Gruber] Clemens Gruber mailto:iana&pqgruber.com 2019-12-31
[Denis_Ionov] Denis Ionov Verimag, OOO mailto:iddi&verimag.ru 2018-07-20
[Flexera] Flexera mailto:pbland&flexera.com 2018-08-22
[Flexera_Software] Flexera Software mailto:security&flexerasoftware.com 2016-07-19
[Gruber_Schanksysteme] Gruber Schanksysteme mailto:iana&pqgruber.com 2019-12-31
[Huang_Neng-geng] Huang Neng-geng mailto:huangng&ngweb.org
mailto:nghuang&ieee.org
2011-08-09
[IBM] IBM mailto:memmerto&ca.ibm.com 2024-03-05
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Ingenta_plc] Ingenta plc mailto:mark.itzcovitz&ingenta.com 2020-01-06
[J_A_Sever] J. A. (Tony) Sever mailto:J.A.Sever&bra0119.wins.icl.co.uk
[Jim_Baldridge] Jim Baldridge mailto:jimb&rpower.com
[John_Aron] John Aron Aronetics LLC mailto:john&aronetics.com 2021-09-29
[Juergen_Fischbach] Juergen Fischbach mailto:juergen.fischbach&philips.com
[Mark_Itzcovitz] Mark Itzcovitz mailto:mark.itzcovitz&ingenta.com 2020-01-06
[Mark_Lewis_2] Mark Lewis mailto:mark.h.lewis&intel.com
[Martin_Ellis] Martin Ellis mailto:martin&clanleagues.net 2004-11
[Martin_Schmuker] Martin Schmuker bilobit GmbH mailto:ms&bilobit.com 2014-08-15
[Matthew_Emmerton] Matthew Emmerton IBM mailto:memmerto&ca.ibm.com 2024-03-05
[Microsoft_Corporation_3] Microsoft Corporation mailto:sachins&microsoft.com 2012-06-27
[Paul_Bland] Paul Bland mailto:pbland&flexera.com 2018-08-22
[Sachin_Sheth] Sachin Sheth Microsoft Corporation mailto:sachins&microsoft.com 2012-06-27
[Scott_Petrack] Scott Petrack mailto:Scott_Petrack&vocaltec.com
[Simon_Jonsson] Simon Jönsson AB Regin mailto:simon.jonsson&regin.se 2018-09-13
[Spencer_Teran_2] Spencer Teran mailto:steran&ars.com 2004-11
[Sten_H_Danielsen] Sten H. Danielsen mailto:shd&kopek.net 2002-07
[Verimag_OOO] Verimag, OOO mailto:support&verimag.ru 2018-07-20
[Yasunari_Gon_Yamasit] Yasunari Gon Yamasita mailto:yamasita&omronsoft.co.jp