Service Name and Transport Protocol Port Number Registry

Last Updated
2026-09-11
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
sugarlock-rcp tcp Remote control protocol for Sugarlock consumer electronics devices [Sugarlock_LLC] [Don_Woodward-Sugarlock] 2016-01-22 Defined TXT keys: txtvers=1
synclavier tcp Remote control of Synclavier Digital Audio Workstation over local area network. [Synclavier_Digital] [Cameron_Jones] 2016-01-27 Defined TXT keys: None
sztp tcp This service name is used to construct the SRV service label "_sztp" for discovering SZTP bootstrap servers. [IESG] [IETF_Chair] 2019-01-17 [RFC 8572] This protocol uses HTTPS as a substrate.
tenir-rc tcp Proprietary [Tenir_Software] [Steve_Gums] 2011-10-27 Defined TXT keys: Proprietary
test-ok tcp Test Controller Card [TEST-OK_BV] [Jeroen_Ommering] 2012-09-05 Defined TXT keys: TEST-OK Test Controller Card TCCxxxx
thing tcp Internet of things service discovery [Aaltronav] [ICT_Manager] 2019-10-02 Defined TXT keys: version, url, location, privacy, support, vendor, about
tic-tac-toe tcp Tic Tac Toe game [Stuart_Cheshire] [Stuart_Cheshire] 2019-05-31 Defined TXT keys: None
timezone tcp Time Zone Data Distribution Service - non-TLS [IESG] [IETF_Chair] 2015-08-03 [RFC 7808] This is an extension of the http service. Defined TXT keys: path=<context path> (as per Section 6 of [RFC 6763]).
timezones tcp Time Zone Data Distribution Service - over TLS [IESG] [IETF_Chair] 2015-08-03 [RFC 7808] This is an extension of the https service. Defined TXT keys: path=<context path> (as per Section 6 of [RFC 6763]).
tivo-device tcp TiVo Device Protocol [TiVo_Inc] [Developer_Support_2] 2011-10-18 Defined TXT keys: None
tivo-mindrpc tcp TiVo RPC Protocol [TiVo_Inc] [Developer_Support_2] 2011-10-18 Defined TXT keys: None
tmsensor tcp Teledyne Marine Sensor [Teledyne_Marine] [Anders_Brandt_5] 2023-10-03 Defined TXT keys: None
tokenlens tcp AI token usage and billing metering [KuoChun_Fang] [KuoChun_Fang] 2026-07-19 Defined TXT keys: None
tptx-console tcp Coordination service for client users of the TotalPraisTrax iPad application [Randy_Davenport] [Chris_Watson] 2014-03-04 Defined TXT keys: None
transmitr tcp Service discovery and media transfer for peer to peer mobile media transfer app [Windward_Code_LLC] [Alex_Belliotti] 2013-11-27 Defined TXT keys: None
tsbiis tcp The Social Broadband Interference Information Sharing [Sergio_Luis] [Sergio_Luis] 2012-02-27 Defined TXT keys: there is no TXT keys defined for this protocol
tvm tcp Vogel's TV mount control [Vogels_Products] [Remco_Poelstra] 2022-03-29 Defined TXT keys: txtvers, model
twiline-disc tcp Discovery for Twiline systems [W._Wahli_AG] [Michael_Voser] 2023-12-04 Defined TXT keys: txtvers, protovers, caddr, xbusid
twinlevel tcp detect sanitary product [Oblamatik_AG] [Simon_Ensslen] 2012-09-05 Defined TXT keys: None
twosnakes tcp Service to enable multiplayer game called two snakes. [Narendra_Kumar_Reddy_Thummaluru] [Narendra_Kumar_Reddy_Thummaluru] 2016-06-01 Defined TXT keys: None
tyba tcp Tyba control [Tyba_Design_Limited] [Oz_Andrews] 2018-08-24 Defined TXT keys: PRID, HWSN, VERS
tzrpc tcp TZ-Software remote procedure call based synchronization protocol [Thomas_Zwick] [Thomas_Zwick] 2011-10-12 Defined TXT keys: Proprietary
usp-agt-http tcp USP discovery [Broadband_Forum] [Broadband_Forum] 2017-01-12 [http://www.broadband-forum.org/assignments] Defined TXT keys: see www.broadband-forum.org/assignments
usp-agt-mqtt tcp USP discovery [Broadband_Forum] [Broadband_Forum] 2020-03-17 [http://www.broadband-forum.org/assignments] Defined TXT keys: see www.broadband-forum.org/assignments
usp-agt-stomp tcp USP discovery [Broadband_Forum] [Broadband_Forum] 2017-01-12 [http://www.broadband-forum.org/assignments] Defined TXT keys: see www.broadband-forum.org/assignments
usp-agt-ws tcp USP discovery [Broadband_Forum] [Broadband_Forum] 2017-09-28 [http://www.broadband-forum.org/assignments] Defined TXT keys: see www.broadband-forum.org/assignments
usp-ctr-http tcp USP discovery [Broadband_Forum] [Broadband_Forum] 2017-01-12 [http://www.broadband-forum.org/assignments] Defined TXT keys: see www.broadband-forum.org/assignments
usp-ctr-mqtt tcp USP discovery [Broadband_Forum] [Broadband_Forum] 2020-03-17 [http://www.broadband-forum.org/assignments] Defined TXT keys: see www.broadband-forum.org/assignments
usp-ctr-stomp tcp USP discovery [Broadband_Forum] [Broadband_Forum] 2017-01-12 [http://www.broadband-forum.org/assignments] Defined TXT keys: see www.broadband-forum.org/assignments
usp-ctr-ws tcp USP discovery [Broadband_Forum] [Broadband_Forum] 2017-09-28 [http://www.broadband-forum.org/assignments] Defined TXT keys: see www.broadband-forum.org/assignments
vapix-http tcp Indicator for VAPIX support over HTTP [Axis_Communications] [Christian_Storm] 2023-04-18 Defined TXT keys: https://help.axis.com/en-us/axis-os#axis-bonjour-implementation
vapix-https tcp Indicator for VAPIX support over HTTPS [Axis_Communications] [Christian_Storm] 2023-04-18 Defined TXT keys: https://help.axis.com/en-us/axis-os#axis-bonjour-implementation
vedabase tcp Application specific synchronization protocol [Peter_Kollath_2] [Peter_Kollath_2] 2014-05-27 Defined TXT keys: txtvers=1
vhusb tcp USB over IP Sharing System [VirtualHere_Pty_Ltd] [Michael_Broadfoot] 2015-04-02 Defined TXT keys: <serial number of server>
voalte2 tcp Server location via DNS-SD [Voalte_Inc] [John_Simpson] 2019-01-22 Defined TXT keys: txtvers, name, (others not publicly documented)
voalte3 tcp Server location via DNS-SD [Voalte_Inc] [John_Simpson] 2019-01-22 Defined TXT keys: txtvers, name, (others not publicly documented)
volterio tcp Internal Communication Service [Volterio] [Johannes_Ofner] 2021-07-23 Defined TXT keys: None
vos Virtual Object System (using VOP/TCP) [Reed_Hedges][Peter_Amstutz] [Reed_Hedges][Peter_Amstutz] Defined TXT keys: url=<Object URL with full path> type=<Comma-seperated list of object types> title=<Short title of service> descr=<Short description of service>
voxidahmp tcp RTP Mixer/Summation Resource [Accurate_Always_Inc] [Yousef_Shemisa] 2018-12-03 Defined TXT keys: None
vrmg-p2p tcp Verimag mobile class protocol over P2P [Verimag_OOO] [Denis_Ionov] 2018-07-20 Defined TXT keys: d=<discovery key>, t=<mobile class ID>
vxi-11 VXI-11 TCP/IP Instrument Protocol [Nick_Barendt_2] [Nick_Barendt_2] Defined TXT keys: None
wakeywakey tcp Proprietary [gerry_Brown_associates] [Gerry_Brown] 2012-11-29 Defined TXT keys: None
wd-2go tcp NAS Service Protocol [Western_Digital] [Rajesh_Batra] 2012-07-11 Defined TXT keys: None
wdp tcp Windows Device Portal [Microsoft_Corporation_5] [Hirsch_Singhal] 2016-03-03 Defined TXT keys: D (device type), S (https port), A (architecture), T (tags)
web-xi tcp HTTP-based protocol for DAQ devices [Spectris_plc] [Carsten_Hansen] 2019-02-13 Defined TXT keys: name, version
webex tcp Cisco WebEx serials products will release Bonjour based service [Mobile_Team] [Aulion_Huang] 2018-02-09 Defined TXT keys: None
wico tcp Session-based protocol for embedded unit [WISI_Group] [Patrik_Lantto] 2026-08-11 Defined TXT keys: None
wifile tcp System for transferring files between mobile device and computer in a local network [Artyom_Nikolaev] [Artyom_Nikolaev] 2016-12-23 Defined TXT keys: None
wot tcp W3C WoT Thing Description or Directory [W3C_Web_of_Things_Working_Group] [Kazuyuki_Ashimura] 2022-11-22 2022-12-15

Defined TXT keys:

td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory.

type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing.

scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations [RFC7595]: http (HTTP over TCP),https (HTTP over TLS/TCP), coap+tcp (CoAP over TCP), or coaps+tcp (CoAP over TLS/TCP). If omitted, the scheme is assumed to be http.

wpl-ers-http tcp World Programming repository server [World_Programming_Limited] [Thomas_Quarendon] 2017-03-17 Defined TXT keys: None
wpl-ers-zmq tcp World Programming repository server [World_Programming_Limited] [Thomas_Quarendon] 2017-03-17 Defined TXT keys: None
x510 tcp Security service to protocols [ITU-T_Study_Group_17] [Erik_Andersen] 2019-08-13 Defined TXT keys: None
xential tcp xential document creation services [Xential] [Michiel_Terpstra] 2013-11-13 Defined TXT keys: None
xmiserver tcp XMI Systems home terminal local connection [XMI_Systems_SA] [CLAUDE_MALLY] 2013-01-18 Defined TXT keys: coucou
xul-http XUL (XML User Interface Language) transported over HTTP [Eran_Gampel] [Eran_Gampel] Defined TXT keys: u=<username> p=<password> path=<path to document> (Same as for _http._tcp)
z-wave tcp Z-Wave Service Discovery [Sigma_Designs_Inc] [Anders_Brandt_2] 2011-10-03 Defined TXT keys: NIF, EP, LM
zeromq tcp High performance brokerless messaging [Daniel_Holth] [Daniel_Holth] 2012-04-24 Defined TXT keys: type, app, label, note
zigbee-bridge tcp ZigBee Bridge device [ZigBee_Alliances_Network_Device_working_group] [Leslie_Mulder] 2013-05-28 Defined TXT keys: see: http://www.zigbee.org/Standards/ZigBeeNetworkDevices
zigbee-gateway tcp ZigBee IP Gateway [ZigBee_Alliances_Network_Device_working_group] [Leslie_Mulder] 2013-05-28 Defined TXT keys: see: http://www.zigbee.org/Standards/ZigBeeNetworkDevices

Contact Information

ID Name Organization Contact URI Last Updated
[Accurate_Always_Inc] Accurate Always Inc. mailto:legal&accuratealways.com 2018-11-03
[Aaltronav] Aaltronav mailto:hostmaster&aaltronav.eu 2019-10-02
[Alex_Belliotti] Alex Belliotti Windward Code LLC mailto:alex&windwardcode.com 2013-11-27
[Anders_Brandt_2] Anders Brandt Sigma Designs, Inc. mailto:anders_brandt&sigmadesigns.com 2011-10-03
[Anders_Brandt_5] Anders Brandt Teledyne Marine mailto:Anders.Brandt&Teledyne.com 2023-10-03
[Artyom_Nikolaev] Artyom Nikolaev mailto:support&wifile.info 2016-12-23
[Aulion_Huang] Aulion Huang mailto:aulionh&cisco.com 2018-02-09
[Axis_Communications] Axis Communications mailto:christnn&axis.com 2023-04-18
[Broadband_Forum] Broadband Forum mailto:help&broadband-forum.org 2020-03-17
[Cameron_Jones] Cameron Jones Synclavier Digital mailto:cjones&synclavier.com 2016-01-27
[Carsten_Hansen] Carsten Hansen Spectris plc mailto:Carsten.Hansen&bksv.com 2019-02-13
[Chris_Watson] Chris Watson mailto:chrisf16&mac.com 2014-03-04
[Christian_Storm] Christian Storm Axis Communications mailto:christnn&axis.com 2023-04-18
[CLAUDE_MALLY] CLAUDE MALLY XMI Systems SA mailto:cma&xmisystems.com 2013-01-18
[Daniel_Holth] Daniel Holth mailto:dholth&fastmail.fm 2012-04-24
[Denis_Ionov] Denis Ionov Verimag, OOO mailto:iddi&verimag.ru 2018-07-20
[Developer_Support_2] Developer Support TiVo Inc. mailto:devsupport&tivo.com 2011-10-18
[Don_Woodward-Sugarlock] Don Woodward mailto:don&sugarlock.comm 2016-01-22
[Eran_Gampel] Eran Gampel mailto:eran&aoe6.net
[Erik_Andersen] Erik Andersen mailto:era&x500.eu 2019-08-13
[Gerry_Brown] Gerry Brown gerry Brown associates mailto:gerry&gbrown.com 2012-11-29
[gerry_Brown_associates] gerry Brown associates mailto:gerry&gbrown.com 2012-11-29
[Hirsch_Singhal] Hirsch Singhal Microsoft Corporation mailto:hirsin&microsoft.com 2016-03-03
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[ICT_Manager] ICT Manager Aaltronav mailto:hostmaster&aaltronav.eu 2019-10-02
[ITU-T_Study_Group_17] ITU-T Study Group 17 mailto:era&x500.eu 2019-08-13
[Jeroen_Ommering] Jeroen Ommering TEST-OK B.V. mailto:jeroen.ommering&test-ok.nl 2012-09-05
[Johannes_Ofner] Johannes Ofner Volterio mailto:johannes.ofner&volterio.com 2021-07-23
[John_Simpson] John Simpson Voalte, Inc. mailto:jms1&voalte.com 2019-01-22
[Kazuyuki_Ashimura] Kazuyuki Ashimura mailto:ashimura&w3.org 2022-11-22
[KuoChun_Fang] KuoChun Fang mailto:RoyFang53&gmail.com 2026-07-19
[Leslie_Mulder] Leslie Mulder ZigBee Alliance's Network Device working group mailto:ljm&exegin.com 2013-05-28
[Michael_Broadfoot] Michael Broadfoot VirtualHere Pty. Ltd. mailto:mail&virtualhere.com 2015-04-02
[Michael_Voser] Michael Voser mailto:support&twiline.com 2023-12-04
[Michiel_Terpstra] Michiel Terpstra mailto:terpstra.m&interactionnext.nl 2013-11-13
[Microsoft_Corporation_5] Microsoft Corporation mailto:hirsin&microsoft.com 2016-03-03
[Mobile_Team] Mobile Team mailto:group.felix&cisco.com 2018-02-09
[Narendra_Kumar_Reddy_Thummaluru] Narendra Kumar Reddy Thummaluru mailto:narendrakumar.narribits&gmail.com 2016-06-01
[Nick_Barendt_2] Nick Barendt mailto:nbarendt&vxitech.com
[Oblamatik_AG] Oblamatik AG mailto:info&oblamatik.ch 2012-09-05
[Oz_Andrews] Oz Andrews Tyba Design Limited mailto:oz&tyba.co.uk 2018-08-24
[Patrik_Lantto] Patrik Lantto WISI Group mailto:patrik.lantto&wisi.se 2026-08-11
[Peter_Amstutz] Peter Amstutz mailto:tetron&interreality.org
[Peter_Kollath_2] Peter Kollath mailto:root&gopal.home.sk 2014-05-27
[Rajesh_Batra] Rajesh Batra Western Digital Inc. mailto:rajesh.batra&wdc.com 2012-07-11
[Randy_Davenport] Randy Davenport mailto:rdaven69&gmail.com 2014-03-04
[Reed_Hedges] Reed Hedges mailto:reed&interreality.org
[Remco_Poelstra] Remco Poelstra Vogel's Products mailto:r.poelstra&vogels.com 2022-03-29
[Sergio_Luis] Sérgio Luís Dias Lima Gramacho mailto:slgramacho&gmail.com 2012-02-27
[Sigma_Designs_Inc] Sigma Designs, Inc. mailto:anders_brandt&sigmadesigns.com 2011-10-03
[Simon_Ensslen] Simon Ensslen Oblamatik AG mailto:s.ensslen&oblamatik.ch 2012-09-05
[Spectris_plc] Spectris plc mailto:Carsten.Hansen&bksv.com 2019-02-13
[Steve_Gums] Steve Gums Tenir Software mailto:sgums&tenirsoftware.com 2011-10-27
[Stuart_Cheshire] Stuart Cheshire mailto:cheshire&apple.com 2022-07-11
[Sugarlock_LLC] Sugarlock, LLC mailto:don&sugarlock.com 2016-01-22
[Synclavier_Digital] Synclavier Digital mailto:admin&synclavier.com 2016-01-27
[Teledyne_Marine] Teledyne Marine mailto:info&teledynemarine.com 2023-10-03
[Tenir_Software] Tenir Software mailto:sgums&tenirsoftware.com 2011-10-27
[TEST-OK_BV] TEST-OK B.V. mailto:jeroen.ommering&test-ok.nl 2012-09-05
[Thomas_Quarendon] Thomas Quarendon World Programming Limited mailto:tom.quarendon&worldprogramming.com 2017-04-04
[Thomas_Zwick] Thomas Zwick mailto:thomas.zwick&tz-software.de 2011-10-12
[TiVo_Inc] TiVo Inc. mailto:devsupport&tivo.com 2011-10-18
[Tyba_Design_Limited] Tyba Design Limited mailto:info&tyba.co.ik 2018-08-24
[Verimag_OOO] Verimag, OOO mailto:support&verimag.ru 2018-07-20
[VirtualHere_Pty_Ltd] VirtualHere Pty. Ltd. mailto:mail&virtualhere.com 2015-04-02
[Voalte_Inc] Voalte, Inc. mailto:engops&voalte.com 2019-01-22
[Vogels_Products] Vogel's Products mailto:r.poelstra&vogels.com 2022-03-29
[Volterio] Volterio mailto:office&volterio.com 2021-07-23
[W._Wahli_AG] W. Wahli AG mailto:support&twiline.com 2023-12-04
[W3C_Web_of_Things_Working_Group] W3C Web of Things Working Group mailto:team-wot&w3.org 2022-11-22
[Western_Digital] Western Digital Inc. mailto:rajesh.batra&wdc.com 2012-07-11
[Windward_Code_LLC] Windward Code LLC mailto:alex&windwardcode.com 2013-11-27
[WISI_Group] WISI Group mailto:patrik.lantto&wisi.se 2026-08-11
[World_Programming_Limited] World Programming Limited mailto:support&worldprogramming.com 2017-04-04
[Xential] Xential mailto:info&xential.nl 2013-11-13
[XMI_Systems_SA] XMI Systems SA mailto:cma&xmisystems.com 2013-01-18
[Yousef_Shemisa] Yousef Shemisa Accurate Always Inc. mailto:yshemisa&accuratealways.com 2018-12-03
[ZigBee_Alliances_Network_Device_working_group] ZigBee Alliance's Network Device working group mailto:ljm&exegin.com 2013-05-28