Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ip-dc Internet Protocol on DC Networks
ip-dvmrp Distance Vector Multicast Routing Protocol
ip-e Internet Protocol on Ethernet Networks
ip-ee Internet Protocol on Exp. Ethernet Nets
ip-fddi Transmission of IP over FDDI
ip-hc Internet Protocol on Hyperchannnel
ip-ieee Internet Protocol on IEEE 802
ip-ipx Transmission of 802.2 over IPX Networks
ip-mtu IP MTU Discovery Options
ip-netbios Internet Protocol over NetBIOS Networks
ip-slip Transmission of IP over Serial Lines
ip-wb Internet Protocol on Wideband Network
ip-x25 Internet Protocol on X.25 Networks
iso-tp4 ISO Transport Protocol Class 4
leaf-1 Leaf-1 Protocol
leaf-2 Leaf-2 Protocol
loc-srv Location Service
merit-inp MERIT Internodal Protocol
mfe-nsp MFE Network Services Protocol
mit-subnet MIT Subnet Support
netconf-beep NETCONF over BEEP [RFC 4744][RFC 9900]
nvp-ii Network Voice Protocol
ppp Point-to-Point Protocol
sat-expak Satnet and Backroom EXPAK
sat-mon SATNET Monitoring
sun-rpc SUN Remote Procedure Call
tcp-aco TCP Alternate Checksum Option
tp-tcp ISO Transport Service on top of the TCP
trunk-1 Trunk-1 Protocol
trunk-2 Trunk-2 Protocol
via-ftp VIA Systems-File Transfer Protocol
wb-expak Wideband EXPAK
wb-mon Wideband Monitoring
xns-idp Xerox NS IDP
a-d-sync Altos Design Synchronization protocol [David_Lasker] [David_Lasker] Defined TXT keys: None
abi-instrument Applied Biosystems Universal Instrument Framework [ThermoFisher_Scientific] [Carlo_Quiñónez] 2021-07-27 Defined TXT keys: product=<short product name/model> description=<readable name> version=<firmware/instrument controller version>
ab-secure tcp AB Secure Protocol [Saso_Ahmed] [Saso_Ahmed] 2026-05-29 Defined TXT keys: None
ab-secure udp AB Secure Protocol [Saso_Ahmed] [Saso_Ahmed] 2026-05-29 Defined TXT keys: None
accessdata-f2d FTK2 Database Discovery Service [Rick_Russell] [Rick_Russell] Defined TXT keys: Proprietary
accessdata-f2w FTK2 Backend Processing Agent Service [Rick_Russell] [Rick_Russell] Defined TXT keys: Proprietary
acs-ctl-ds tcp Access Control Device [Honeywell_Security_Group] [John_Dziadosz] 2012-04-09 Defined TXT keys: MAC=, GW-MAC
acs-ctl-ds udp Access Control Device [Honeywell_Security_Group] [John_Dziadosz] 2012-04-09 Defined TXT keys: MAC=, GW-MAC
acs-ctl-gw tcp Access Control Gateway [Honeywell_Security_Group] [John_Dziadosz] 2012-04-09 Defined TXT keys: MAC=, GW-MAC
acs-ctl-gw udp Access Control Gateway [Honeywell_Security_Group] [John_Dziadosz] 2012-04-09 Defined TXT keys: MAC=, GW-MAC
acsp-server tcp AXIS Camera Station Pro Server [Axis_Communications_2] [Joachim_Ståhl] 2024-04-19 Defined TXT keys: None
activeraid-ssl Encrypted transport of Active Storage Proprietary Device Management Protocol [Skip_Levens] [Skip_Levens] Defined TXT keys: None
adaptive-rn tcp ARN (Adaptive Routing Notification) is a protocol designed to enable dynamic routing adjustments by sharing network status information between nodes in data center networks, improving efficiency and fault tolerance. [Hongyi_Huang] [Hongyi_Huang] 2024-11-22 Defined TXT keys: arn-protocol, adaptive-routing
adaptive-rn udp ARN (Adaptive Routing Notification) is a protocol designed to enable dynamic routing adjustments by sharing network status information between nodes in data center networks, improving efficiency and fault tolerance. [Hongyi_Huang] [Hongyi_Huang] 2024-11-22 Defined TXT keys: arn-protocol, adaptive-routing
addressbook Address-O-Matic [Massimiliano_Ribuoli] [Massimiliano_Ribuoli] Defined TXT keys: None
adobe-shadow tcp Adobe Shadow Server [Adobe_Systems] [Mike_Harris] 2012-04-17 Defined TXT keys: id
adobe-vc Adobe Version Cue Defined TXT keys: txtvers=1, name, version, build
adpro-setup ADPRO Security Device Setup [Patrick_Noffke] [Patrick_Noffke] Defined TXT keys: txtvers, type
aerohive-proxy tcp Aerohive Proxy Configuration Service [Aerohive_Networks] [Matthew_Gast] 2012-05-31 Defined TXT keys: name, port, username
affinity-docs0 tcp Affinity Designer document sharing [Serif_Europe_Ltd] [Tom_Lachecki] 2023-03-30 Defined TXT keys: Proprietary
affinity-docs1 tcp Affinity Photo document sharing [Serif_Europe_Ltd] [Tom_Lachecki] 2023-03-30 Defined TXT keys: Proprietary
affinity-docs2 tcp Affinity Publisher document sharing [Serif_Europe_Ltd] [Tom_Lachecki] 2023-03-30 Defined TXT keys: Proprietary
affinity-cntent tcp Affinity content sharing [Serif_Europe_Ltd] [Tom_Lachecki] 2023-03-30 Defined TXT keys: Proprietary
ai-adp tcp AI Agent Discovery Protocol (ADP) [Harry_Lian] [Harry_Lian] 2026-06-12 [draft-pro-adp-agent-discovery-00] Defined TXT keys: None
airmate tcp Airmate interworking protocol [Myriel_Aviation_-_Airmate] [Daniel_Mavrakis_3] 2020-09-21 Defined TXT keys: proprietary
airmate udp Airmate interworking protocol [Myriel_Aviation_-_Airmate] [Daniel_Mavrakis_3] 2020-09-21 Defined TXT keys: proprietary
alazartech-atn tcp Alazar Technologies ATN Communication Protocol [Alazar_Technologies] [Romain_Deterre] 2016-05-26 Defined TXT keys: None
aloe-gwp tcp Aloe Gateway Protocol [Layered_Logic] [Brooks_Bell] 2012-01-04 Defined TXT keys: Version
aloe-pp tcp Aloe Pairing Protocol [Layered_Logic] [Brooks_Bell] 2012-01-04 Defined TXT keys: Version, DeviceName, DeviceModel, DeviceSystem, DeviceSystemVersion, AppName, AppVersion
amazon-expiscor udp Device discovery for Amazon [ASLLC] [Andy_Jack] 2024-02-22 Defined TXT keys: None
amba-cam udp Ambarella Cameras [Louis_Sun] [Louis_Sun] Defined TXT keys: product=<product model name> description=<string name> version=<firmware version>
amiphd-p2p P2PTapWar Sample Application from "iPhone SDK Development" Book [Chris_Adamson] [Chris_Adamson] Defined TXT keys: None
ams-htm Proprietary protocol for Accu-Med HTM [AccuMed_Services] [Sam_Carleton_2] 2011-10-20 Defined TXT keys: None
apple-ausend Apple Audio Units [James_McCartney] [James_McCartney] Defined TXT keys: None
apple-mobdev tcp Apple Mobile Device Protocol [Apple_2] [Paul_Chinn][Justin_Ko] 2011-10-20 Defined TXT keys: None
apple-midi udp Apple MIDI [Doug_Wyatt] [Doug_Wyatt] Defined TXT keys: None
appletv-itunes Apple TV discovery of iTunes [Amandeep_Jawa_3] [Amandeep_Jawa_3] Defined TXT keys: txtvers
appletv-pair Apple TV Pairing [Amandeep_Jawa_3] [Amandeep_Jawa_3] Defined TXT keys: txtvers
asam-cmp udp ASAM Capture Module Protocol [ASAM_e_V] [Bernd_Wenzel] 2021-09-29 Defined TXT keys: None
aseba tcp protocol for an event-based architecture for distributed control of mobile robots [Mobsya_Association] [S_Magnenat] 2016-08-18 Defined TXT keys: txtvers, type, protovers, ids, pids
astnotify udp Asterisk Caller-ID Notification Service [Sven_Slezak] [Sven_Slezak] Defined TXT keys: prefix=<country code prefix> (numeric, additionally '+')
async address-o-sync [Markus_Brand] [Markus_Brand] Defined TXT keys: None
attero-ad tcp Attero Tech Audio Device [Attero_Tech_LLC] [David_Vaughn] 2015-09-24 Defined TXT keys: txtvers, protovers, CtrlType, Model
attero-ad udp Attero Tech Audio Device [Attero_Tech_LLC] [David_Vaughn] 2015-09-24 Defined TXT keys: txtvers, protovers, CtrlType, Model
audirvana-ap tcp Audirvana Remote Access Protocol [Audirvana_SCS] [Damien_Plisson] 2015-07-21 Defined TXT keys: txtvers, protovers
autotargets-ap tcp Access Point for AutoTargets system [Automated_Target_Solutions_Inc.] [Nathan_Walker] 2015-12-28 Defined TXT keys: none
av-chat-ring-01 tcp TCP SpyChat Stream Message Exchange [Alexios_Vasileiadis] [Alexios_Vasileiadis] 2018-05-03 Defined TXT keys: There are two TXT record keys: 1st key: "txt-vers" associated with an 'int' entry. 2nd key: "conn-stat" associated with an 'int' entry.
avatars-sec tcp Libravatar federated avatar hosting service. [libravatar_org] [Francois_Marier] 2011-10-11 Defined TXT keys: none
axis-nvr tcp Axis Network Video Recorders [Axis_Communications_AB] [Erik_Linge] 2018-05-24 Defined TXT keys: None
axis-nvr udp Axis Network Video Recorders [Axis_Communications_AB] [Erik_Linge] 2018-05-24 Defined TXT keys: None
axis-video Axis Video Cameras [Kristina_Sten] [Kristina_Sten] Defined TXT keys: None
b3d-convince 3M Unitek Digital Orthodontic System [Rajiv_Aaron_Manglani] [Rajiv_Aaron_Manglani] Defined TXT keys: txtvers=1, protovers=<api version>, guid=<32 hex digits>
bandhelper-rc tcp Remote Control for BandHelper app [Arlo_Leach] [Arlo_Leach] 2017-04-21 Defined TXT keys: None
bandhelper-ss tcp Screen sharing for BandHelper app [Arlo_Leach] [Arlo_Leach] 2017-04-21 Defined TXT keys: None
bcloud-server tcp Buddycloud Server Delegation [buddycloud] [Simon_Tennant_2] 2014-06-19 Defined TXT keys: v, host
behnke-cc tcp Behnke doorphones / emergency phones [Telefonbau_Behnke_GmbH] [Thomas_Kraemer] 2020-05-13 Defined TXT keys: None
behnke-station tcp Behnke audio / video intercom systems [Telefonbau_Behnke_GmbH] [Thomas_Kraemer] 2021-03-17 Defined TXT keys: mjpg, jpg, auth, camera, macaddress
behnke-video tcp Behnke doorphones / video intercoms [Telefonbau_Behnke_GmbH] [Thomas_Kraemer] 2021-03-17 Defined TXT keys: mjpg, jpg, auth, camera, macaddress
bidib tcp Model Railway Control via netBiDiB [BiDiB_Tools_e.V.] [Andreas_Bergmaier] 2022-12-26 Defined TXT keys: bidib,node,interface,uid,prod,user - http://bidib.org/transport/bidib_net_e.html
boardgame tcp Two-player board game play [Tianren_Chen] [Tianren_Chen] 2026-08-05 [https://github.com/chentianren0/MiniXiangqi/blob/main/docs/boardgame-protocol.md] Defined TXT keys: None
booked-sync tcp Booked communication protocol - Sharing And Sync Service [Sören_Havemester] [Sören_Havemester] 2013-02-18 Defined TXT keys: Edition, Version, Public Shares, Machine ID, Machine Name
bootstrap tcp Bootstrap service discovery [Pedro_Garcia] [Pedro_Garcia] 2023-03-20 Defined TXT keys: "url": if present, indicates a connection url (i.e. wss://example.com/bootstrap, or https://example.com/bootstrap) to be used by the device for bootstrapping; "namespace": identifies the underlying application-level protocol (should be unique for the application protocol, typically a UUID or a URN)
bootstrap udp Bootstrap service discovery [Pedro_Garcia] [Pedro_Garcia] 2023-03-20 Defined TXT keys: "url": if present, indicates a connection url (i.e. wss://example.com/bootstrap, or https://example.com/bootstrap) to be used by the device for bootstrapping; "namespace": identifies the underlying application-level protocol (should be unique for the application protocol, typically a UUID or a URN)
bq-cromo tcp bq Cromo protocol [MUNDO_READER_SL] [Adan_Munoz] 2014-09-05 Defined TXT keys: None
bq-cromo udp bq Cromo protocol [MUNDO_READER_SL] [Adan_Munoz] 2014-09-05 Defined TXT keys: None
brocoli-concert tcp brocoliconcert telecom [brocoliconcert.corp] [Jang_Hwanhee] 2026-05-26 Defined TXT keys: None
brski-pledge tcp The Bootstrapping Remote Secure Key Infrastructure Pledge [IESG] [IETF_Chair] 2026-05-11 [RFC-ietf-anima-brski-prm-23] Defined TXT keys: None

Contact Information

ID Name Organization Contact URI Last Updated
[AccuMed_Services] AccuMed Services mailto:scarleton&accu-med.com 2011-10-20
[Adan_Munoz] Adan Muñoz MUNDO READER SL mailto:adan.munoz&bq.com 2014-09-05
[Adobe_Systems] Adobe Systems Inc. mailto:mikeharr&adobe.com 2012-04-17
[Aerohive_Networks] Aerohive Networks mailto:iana&aerohive.com 2012-06-04
[Alazar_Technologies] Alazar Technologies mailto:support&alazartech.com 2016-05-26
[Alexios_Vasileiadis] Alexios Vasileiadis mailto:alexvas100&gmail.com 2018-05-03
[Amandeep_Jawa_3] Amandeep Jawa mailto:daap&apple.com
[Andreas_Bergmaier] Andreas Bergmaier mailto:andreas.bergmaier&bidib.org 2022-01-04
[Andy_Jack] Andy Jack Amazon.com Services LLC mailto:jackaj&amazon.co.uk 2024-02-22
[Apple_2] Apple mailto:justin.ko&apple.com 2011-10-20
[Arlo_Leach] Arlo Leach mailto:arlo&arlomedia.com 2017-04-21
[ASAM_e_V] ASAM e.V. mailto:marius.dupuis&asam.net 2022-07-01
[ASLLC] Amazon.com Services LLC mailto:iana-registrations&amazon.com 2024-02-22
[Attero_Tech_LLC] Attero Tech LLC mailto:it.dept&atterotech.com 2015-09-24
[Audirvana_SCS] Audirvana SCS mailto:contact&audirvana.com 2015-07-21
[Automated_Target_Solutions_Inc.] Automated Target Solutions, Inc. mailto:sales&autotargets.com 2015-12-28
[Axis_Communications_2] Axis Communications mailto:contact-iana&axis.com 2024-04-19
[Axis_Communications_AB] Axis Communications AB mailto:erik.linge&axis.com 2018-05-24
[Bernd_Wenzel] Bernd Wenzel ASAM e.V. mailto:bernd.wenzel&asam.net 2022-07-01
[BiDiB_Tools_e.V.] BiDiB & Tools e.V. mailto:info&bidib.org 2022-12-26
[brocoliconcert.corp] brocoliconcert.corp mailto:janghwanhee&brocoliconcert.com 2026-05-26
[Brooks_Bell] Brooks Bell Layered Logic, Inc. mailto:brooks&layeredlogic.com 2012-01-04
[buddycloud] buddycloud mailto:simon&buddycloud.com 2013-05-20
[Carlo_Quiñónez] Carlo Quiñónez ThermoFisher Scientific mailto:carlo.quinonez&thermofisher.com 2021-07-27
[Chris_Adamson] Chris Adamson mailto:invalidname&gmail.com
[Damien_Plisson] Damien Plisson Audirvana SCS mailto:damien78&audirvana.com 2015-07-21
[Daniel_Mavrakis_3] Daniel Mavrakis mailto:mavrakis.daniel&myriel.lu 2020-09-21
[David_Lasker] David Lasker mailto:dave&altosdesign.com
[David_Vaughn] David Vaughn mailto:dvaughn&atterotech.com 2015-09-24
[Doug_Wyatt] Doug Wyatt mailto:dwyatt&apple.com
[Erik_Linge] Erik Linge mailto:contact-iana&axis.com 2018-05-24
[Francois_Marier] Francois Marier libravatar.org mailto:francois&libravatar.org 2011-10-11
[Harry_Lian] Harry Lian mailto:harrylian8766&gmail.com 2026-06-12
[Honeywell_Security_Group] Honeywell Security Group mailto:john.dziadosz&honeywell.com 2012-04-09
[Hongyi_Huang] Hongyi Huang mailto:hhy.hongyi&outlook.com 2024-11-22
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[James_McCartney] James McCartney mailto:jmccartney&apple.com
[Jang_Hwanhee] Jang Hwanhee mailto:janghwanhee&brocoliconcert.com 2026-05-26
[Joachim_Ståhl] Joachim Ståhl Axis Communications mailto:contact-iana&axis.com 2024-04-19
[John_Dziadosz] John Dziadosz Honeywell Security Group mailto:john.dziadosz&honeywell.com 2012-04-09
[Justin_Ko] Justin Ko Apple mailto:justin.ko&apple.com 2011-10-20
[Kristina_Sten] Kristina Sten mailto:kristina.sten&axis.com
[Layered_Logic] Layered Logic, Inc. mailto:brooks&layeredlogic.com 2012-01-04
[libravatar_org] libravatar.org mailto:francois&libravatar.org 2011-10-11
[Louis_Sun] Louis Sun mailto:lysun&ambarella.com
[Markus_Brand] Markus Brand mailto:address-o-sync&slamslash.com
[Massimiliano_Ribuoli] Massimiliano Ribuoli and Marco Stefani mailto:support&address-o-matic.com
[Matthew_Gast] Matthew Gast Aerohive Networks mailto:mgast&aerohive.com 2012-05-31
[Mike_Harris] Mike Harris Adobe Systems Inc. mailto:mikeharr&adobe.com 2012-04-17
[Mobsya_Association] Mobsya Association mailto:stephane.magnenat&mobsya.org 2016-08-18
[MUNDO_READER_SL] MUNDO READER SL mailto:adan.munoz&bq.com 2014-09-05
[Myriel_Aviation_-_Airmate] Myriel Aviation / Airmate mailto:mavrakis.daniel&myriel.lu 2020-09-21
[Nathan_Walker] Nathan Walker Automated Target Solutions, Inc. mailto:n.walker&autotargets.com 2015-12-28
[Patrick_Noffke] Patrick Noffke mailto:patrick.noffke&adpro.com.au
[Paul_Chinn] Paul Chinn Apple mailto:pchinn&apple.com 2011-10-20
[Pedro_Garcia] Pedro Garcia mailto:pedro.garcia&puzzle-star.com 2023-03-20
[Rajiv_Aaron_Manglani] Rajiv Aaron Manglani mailto:rajivmanglani&mmm.com
[Rick_Russell] Rick Russell mailto:rrussell&accessdata.com
[Romain_Deterre] Romain Deterre mailto:romain&alazartech.com 2016-05-26
[Sam_Carleton_2] Sam Carleton AccuMed Services mailto:scarleton&accu-med.com 2011-10-20
[Saso_Ahmed] Saso Ahmed mailto:NotDreamPVP&gmail.com 2026-05-29
[Serif_Europe_Ltd] Serif (Europe) Ltd. mailto:affinity&serif.com 2023-03-30
[Simon_Tennant_2] Simon Tennant buddycloud mailto:simon&buddycloud.com 2014-06-19
[Skip_Levens] Skip Levens mailto:skip&activestoragelabs.com
[Sören_Havemester] Sören Havemester mailto:reshave&gmail.com 2013-02-18
[S_Magnenat] Stéphane Magnenat mailto:stephane.magnenat&mobsya.org 2016-08-18
[Sven_Slezak] Sven Slezak mailto:sunny&mezzo.net
[Telefonbau_Behnke_GmbH] Telefonbau Behnke GmbH mailto:info&behnke-online.de 2021-03-17
[ThermoFisher_Scientific] ThermoFisher Scientific mailto:carlo.quinonez&thermofisher.com 2021-07-27
[Thomas_Kraemer] Thomas Kraemer Telefonbau Behnke GmbH mailto:thomas_kraemer&behnke-online.de 2021-03-17
[Tianren_Chen] Tianren Chen mailto:chentianren0&gmail.com 2026-08-05
[Tom_Lachecki] Tom Lachecki Serif (Europe) Ltd. mailto:tlachecki&serif.com 2023-03-30