Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
apex-edge 913 tcp APEX endpoint-relay service [RFC 3340]
apex-edge 913 udp APEX endpoint-relay service [RFC 3340]
rift-lies 914 udp Routing in Fat Trees Link Information Element [IESG] [IETF_Chair] 2023-02-17 2024-06-07 [RFC 9692]
rift-ties 915 udp Routing in Fat Trees Topology Information Element [IESG] [IETF_Chair] 2023-02-17 2024-06-07 [RFC 9692]
916-952 Unassigned
954-988 Unassigned
ftps-data 989 tcp ftp protocol, data, over TLS/SSL
ftps-data 989 udp ftp protocol, data, over TLS/SSL
1002-1007 Unassigned
1011-1020 Reserved
exp1 1021 tcp RFC3692-style Experiment 1 [IESG] [IETF_Chair] [1][RFC 4727][RFC 6335]
exp1 1021 udp RFC3692-style Experiment 1 [IESG] [IETF_Chair] [1][RFC 4727][RFC 6335]
exp1 1021 sctp RFC3692-style Experiment 1 [IESG] [IETF_Chair] [1][RFC 4727][RFC 6335]
exp1 1021 dccp RFC3692-style Experiment 1 [IESG] [IETF_Chair] [1][RFC 4727][RFC 6335]
exp2 1022 tcp RFC3692-style Experiment 2 [IESG] [IETF_Chair] [1][RFC 4727][RFC 6335]
exp2 1022 udp RFC3692-style Experiment 2 [IESG] [IETF_Chair] [1][RFC 4727][RFC 6335]
exp2 1022 sctp RFC3692-style Experiment 2 [IESG] [IETF_Chair] [1][RFC 4727][RFC 6335]
exp2 1022 dccp RFC3692-style Experiment 2 [IESG] [IETF_Chair] [1][RFC 4727][RFC 6335]
solid-mux 1029 tcp Solid Mux Server [Anders_Borg] [Anders_Borg] 2004-11
solid-mux 1029 udp Solid Mux Server [Anders_Borg] [Anders_Borg] 2004-11
1030 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
1031 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
1032 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
netinfo-local 1033 tcp local netinfo port [Marc_Majka] [Marc_Majka] 2002-08
netinfo-local 1033 udp local netinfo port [Marc_Majka] [Marc_Majka] 2002-08
mxxrlogin 1035 tcp MX-XR RPC [Valassis] [John_Eckert] 2003-04 2015-05-05
mxxrlogin 1035 udp MX-XR RPC [Valassis] [John_Eckert] 2003-04 2015-05-05
danf-ak2 1041 tcp AK2 Product [Karl_Palsson] [Karl_Palsson] 2004-11
danf-ak2 1041 udp AK2 Product [Karl_Palsson] [Karl_Palsson] 2004-11
boinc-client 1043 tcp BOINC Client Control [David_Anderson] [David_Anderson] 2004-11
boinc-client 1043 udp BOINC Client Control [David_Anderson] [David_Anderson] 2004-11
td-postman 1049 tcp Tobit David Postman VPMN [Franz_Josef_Leuders] [Franz_Josef_Leuders]
td-postman 1049 udp Tobit David Postman VPMN [Franz_Josef_Leuders] [Franz_Josef_Leuders]
optima-vnet 1051 tcp Optima VNET [Ralf_Doewich] [Ralf_Doewich]
optima-vnet 1051 udp Optima VNET [Ralf_Doewich] [Ralf_Doewich]
remote-as 1053 tcp Remote Assistant (RA) [Roman_Kriis] [Roman_Kriis] Unauthorized Use Known on port 1053
remote-as 1053 udp Remote Assistant (RA) [Roman_Kriis] [Roman_Kriis]
ansyslmd 1055 tcp ANSYS - License Manager [Suzanne_Lorrin] [Suzanne_Lorrin]
ansyslmd 1055 udp ANSYS - License Manager [Suzanne_Lorrin] [Suzanne_Lorrin]
fpo-fns 1066 tcp FPO-FNS [Jens_Klose] [Jens_Klose]
fpo-fns 1066 udp FPO-FNS [Jens_Klose] [Jens_Klose]
instl-boots 1067 tcp Installation Bootstrap Proto. Serv.

IANA assigned this well-formed service name as a replacement for "instl_boots".
instl_boots 1067 tcp Installation Bootstrap Proto. Serv. This entry is an alias to "instl-boots". This entry is now historic, not usable for use with many common service discovery mechanisms.
instl-boots 1067 udp Installation Bootstrap Proto. Serv.

IANA assigned this well-formed service name as a replacement for "instl_boots".
instl_boots 1067 udp Installation Bootstrap Proto. Serv. This entry is an alias to "instl-boots". This entry is now historic, not usable for use with many common service discovery mechanisms.
instl-bootc 1068 tcp Installation Bootstrap Proto. Cli.

IANA assigned this well-formed service name as a replacement for "instl_bootc".
[David_Arko] [David_Arko]
instl_bootc 1068 tcp Installation Bootstrap Proto. Cli. [David_Arko] [David_Arko] This entry is an alias to "instl-bootc". This entry is now historic, not usable for use with many common service discovery mechanisms.
instl-bootc 1068 udp Installation Bootstrap Proto. Cli.

IANA assigned this well-formed service name as a replacement for "instl_bootc".
[David_Arko] [David_Arko]
instl_bootc 1068 udp Installation Bootstrap Proto. Cli. [David_Arko] [David_Arko] This entry is an alias to "instl-bootc". This entry is now historic, not usable for use with many common service discovery mechanisms.
cognex-insight 1069 tcp COGNEX-INSIGHT [Steve_Olson] [Steve_Olson]
cognex-insight 1069 udp COGNEX-INSIGHT [Steve_Olson] [Steve_Olson]
bsquare-voip 1071 tcp BSQUARE-VOIP [Yen_Lee] [Yen_Lee]
bsquare-voip 1071 udp BSQUARE-VOIP [Yen_Lee] [Yen_Lee]
dab-sti-c 1076 tcp DAB STI-C [World_DAB] [World_DAB]
dab-sti-c 1076 udp DAB STI-C [World_DAB] [World_DAB]
avocent-proxy 1078 tcp Avocent Proxy Protocol [Steven_W_Clark] [Steven_W_Clark]
avocent-proxy 1078 udp Avocent Proxy Protocol [Steven_W_Clark] [Steven_W_Clark]
amt-esd-prot 1082 tcp AMT-ESD-PROT [AMTEC_S_p_A] [AMTEC_S_p_A]
amt-esd-prot 1082 udp AMT-ESD-PROT [AMTEC_S_p_A] [AMTEC_S_p_A]
ansoft-lm-1 1083 tcp Anasoft License Manager
ansoft-lm-1 1083 udp Anasoft License Manager
ansoft-lm-2 1084 tcp Anasoft License Manager
ansoft-lm-2 1084 udp Anasoft License Manager
cplscrambler-lg 1086 tcp CPL Scrambler Logging
cplscrambler-lg 1086 udp CPL Scrambler Logging
cplscrambler-in 1087 tcp CPL Scrambler Internal
cplscrambler-in 1087 udp CPL Scrambler Internal
cplscrambler-al 1088 tcp CPL Scrambler Alarm Log [Richard_Corn] [Richard_Corn]
cplscrambler-al 1088 udp CPL Scrambler Alarm Log [Richard_Corn] [Richard_Corn]
ff-annunc 1089 tcp FF Annunciation
ff-annunc 1089 udp FF Annunciation
ff-fms 1090 tcp FF Fieldbus Message Specification
ff-fms 1090 udp FF Fieldbus Message Specification
ff-sm 1091 tcp FF System Management [Fieldbus_Foundation] [Fieldbus_Foundation]
ff-sm 1091 udp FF System Management [Fieldbus_Foundation] [Fieldbus_Foundation]
pt2-discover 1101 tcp PT2-DISCOVER [Ralph_Kammerlander] [Ralph_Kammerlander]
pt2-discover 1101 udp PT2-DISCOVER [Ralph_Kammerlander] [Ralph_Kammerlander]
adobeserver-1 1102 tcp ADOBE SERVER 1
adobeserver-1 1102 udp ADOBE SERVER 1
adobeserver-2 1103 tcp ADOBE SERVER 2 [Frank_Soetebeer] [Frank_Soetebeer]
adobeserver-2 1103 udp ADOBE SERVER 2 [Frank_Soetebeer] [Frank_Soetebeer]
isoipsigport-1 1106 tcp ISOIPSIGPORT-1
isoipsigport-1 1106 udp ISOIPSIGPORT-1
isoipsigport-2 1107 tcp ISOIPSIGPORT-2 [Peter_Egli] [Peter_Egli]
isoipsigport-2 1107 udp ISOIPSIGPORT-2 [Peter_Egli] [Peter_Egli]
ratio-adp 1108 tcp ratio-adp [Oliver_Thulke] [Oliver_Thulke]
ratio-adp 1108 udp ratio-adp [Oliver_Thulke] [Oliver_Thulke]
1109 Reserved - IANA
nfsd-keepalive 1110 udp Client status info [Beth_Crespo] [Beth_Crespo]
ltp-deepspace 1113 tcp Licklider Transmission Protocol [RFC 5326]
ltp-deepspace 1113 udp Licklider Transmission Protocol 2014-02-21 [RFC 5326][RFC 7122]
ltp-deepspace 1113 dccp Licklider Transmission Protocol 2013-11-12 2014-02-21 [RFC 7122] 7107696
mini-sql 1114 tcp Mini SQL [David_Hughes] [David_Hughes]
mini-sql 1114 udp Mini SQL [David_Hughes] [David_Hughes]
ardus-trns 1115 tcp ARDUS Transfer
ardus-trns 1115 udp ARDUS Transfer
ardus-cntl 1116 tcp ARDUS Control
ardus-cntl 1116 udp ARDUS Control
ardus-mtrns 1117 tcp ARDUS Multicast Transfer [Shinya_Abe] [Shinya_Abe]
ardus-mtrns 1117 udp ARDUS Multicast Transfer [Shinya_Abe] [Shinya_Abe]
availant-mgr 1122 tcp availant-mgr [Steven_Pelletier] [Steven_Pelletier]

Contact Information

ID Name Organization Contact URI Last Updated
[AMTEC_S_p_A] AMTEC S.p.A mailto:sp.amtec&interbusiness.it
[Anders_Borg] Anders Borg mailto:anders.borg&solid.se 2004-11
[Beth_Crespo] Beth Crespo mailto:beth.crespo&hp.com
[David_Anderson] David Anderson mailto:davea&ssl.berkeley.edu 2004-11
[David_Arko] David Arko mailto:darko&hpfcrn.fc.hp.com
[David_Hughes] David Hughes mailto:bambi&hughes.com.au
[Fieldbus_Foundation] Fieldbus Foundation mailto:dave.glanzer&fieldbus.org 2002-10
[Frank_Soetebeer] Frank Soetebeer mailto:frsoeteb&adobe.com 2003-01
[Franz_Josef_Leuders] Franz-Josef Leuders mailto:development&tobit.com
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Jens_Klose] Jens Klose mailto:jklose&intercope.com
[John_Eckert] John Eckert Valassis mailto:eckertj&valassis.com 2015-05-05
[Karl_Palsson] Karl Palsson mailto:karl_p&danfoss.com 2004-11
[Marc_Majka] Marc Majka mailto:majka&apple.com 2002-08
[Oliver_Thulke] Oliver Thulke mailto:oth&ratio.de
[Peter_Egli] Peter Egli mailto:peter.egli&inalp.com
[Ralf_Doewich] Ralf Doewich mailto:ralf.doewich&optimatele.com
[Ralph_Kammerlander] Ralph Kammerlander mailto:ralph.kammerlander&khe.siemens.de
[Richard_Corn] Richard Corn mailto:rac&racc.com
[Roman_Kriis] Roman Kriis mailto:roman&previo.ee
[Shinya_Abe] Shinya Abe mailto:abeabe&pfu.co.jp
[Steve_Olson] Steve Olson mailto:solson&cognex.com
[Steven_Pelletier] Steven Pelletier mailto:stevep&availant.com
[Steven_W_Clark] Steven W. Clark mailto:steven.clark&avocent.com
[Suzanne_Lorrin] Suzanne Lorrin mailto:suzanne.lorrin&ansys.com
[Valassis] Valassis mailto:eckertj&valassis.com 2015-05-05
[World_DAB] World DAB mailto:worlddab_irc&worlddab.org
[Yen_Lee] Yen Lee mailto:YenL&bsquare.com