Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
10130-10159 Unassigned
qb-db-server 10160 tcp QB Database Server Wei Wang Wei Wang 2005-11
qb-db-server 10160 udp QB Database Server Wei Wang Wei Wang 2005-11
snmptls 10161 tcp SNMP-TLS RFC 6353
snmpdtls 10161 udp SNMP-DTLS RFC 6353
snmptls-trap 10162 tcp SNMP-Trap-TLS RFC 6353
snmpdtls-trap 10162 udp SNMP-Trap-DTLS RFC 6353
10163-10199 Unassigned
trisoap 10200 tcp Trigence AE Soap Service Brigitte Gagne Brigitte Gagne 2006-08
trisoap 10200 udp Trigence AE Soap Service Brigitte Gagne Brigitte Gagne 2006-08
rsms 10201 tcp Remote Server Management Service Patrick H. Piper Patrick H. Piper 2009-03-06
rscs 10201 udp Remote Server Control and Test Service Patrick H. Piper Patrick H. Piper 2009-03-06
10202-10251 Unassigned
apollo-relay 10252 tcp Apollo Relay Port Anthony Carrabino Anthony Carrabino 2003-08
apollo-relay 10252 udp Apollo Relay Port Anthony Carrabino Anthony Carrabino 2003-08
eapol-relay 10253 udp Relay of EAPOL frames Wi-SUN Alliance Phil Beecher 2015-06-26
10253 tcp Reserved
10254-10259 Unassigned
axis-wimp-port 10260 tcp Axis WIMP Port Stefan Eriksson Stefan Eriksson
axis-wimp-port 10260 udp Axis WIMP Port Stefan Eriksson Stefan Eriksson
tile-ml 10261 tcp Tile remote machine learning 1026 Labs Rob Earhart 2016-09-27
10261 udp Reserved
10262-10287 Unassigned
blocks 10288 tcp Blocks Carl Malamud Carl Malamud
blocks 10288 udp Blocks Carl Malamud Carl Malamud
10289-10320 Unassigned
10321 tcp Reserved 2023-12-05 De-Assigned on 2023-12-05.
10321 udp Reserved
10322-10438 Unassigned
bngsync 10439 udp BalanceNG session table synchronization protocol Inlab Software GmbH Thomas G. Obermair 2014-05-02
10439 tcp Reserved
10440-10442 Unassigned
cirrossp 10443 tcp CirrosSP Workstation Communication Cirros Document Solutions Ltd Andy Garratt 2020-02-12
10443 udp Reserved
10444-10499 Unassigned
10500 tcp Reserved
hip-nat-t 10500 udp HIP NAT-Traversal IESG IETF Chair 2020-08-12 RFC 5770; RFC 9028
10501-10539 Unassigned
MOS-lower 10540 tcp MOS Media Object Metadata Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-lower 10540 udp MOS Media Object Metadata Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-upper 10541 tcp MOS Running Order Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-upper 10541 udp MOS Running Order Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-aux 10542 tcp MOS Low Priority Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-aux 10542 udp MOS Low Priority Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-soap 10543 tcp MOS SOAP Default Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-soap 10543 udp MOS SOAP Default Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-soap-opt 10544 tcp MOS SOAP Optional Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-soap-opt 10544 udp MOS SOAP Optional Port Eric Thorniley Eric Thorniley 2007-09-17
10545-10547 Unassigned
serverdocs 10548 tcp Apple Document Sharing Service Apple Inc. Jason Thorpe 2015-09-29
10548 udp Reserved
10549-10630 Unassigned
printopia 10631 tcp Printopia Serve Decisive Tactics, Inc. Chris Kent 2011-10-24 2015-04-09
10631 udp Reserved
10632-10799 Unassigned
gap 10800 tcp Gestor de Acaparamiento para Pocket PCs Juan Carlos Olivares Rojas Juan Carlos Olivares Rojas 2006-03
gap 10800 udp Gestor de Acaparamiento para Pocket PCs Juan Carlos Olivares Rojas Juan Carlos Olivares Rojas 2006-03
10801-10804 Unassigned
lpdg 10805 tcp LUCIA Pareja Data Group Alvaro P. Dominguez Alvaro P. Dominguez 2006-02
lpdg 10805 udp LUCIA Pareja Data Group Alvaro P. Dominguez Alvaro P. Dominguez 2006-02
10806-10808 Unassigned
nbd 10809 tcp Network Block Device Wouter Verhelst Wouter Verhelst 2010-08-02 2024-04-30 https://github.com/NetworkBlockDevice/nbd/blob/master/doc/proto.md
10809 udp Reserved
10810 tcp Reserved
nmc-disc 10810 udp Nuance Mobile Care Discovery Gordon Waddell Gordon Waddell 2011-03-21
10811-10859 Unassigned
helix 10860 tcp Helix Client/Server Matthew Strange; Larry Atkin Matthew Strange; Larry Atkin 2009-03-06
helix 10860 udp Helix Client/Server Matthew Strange; Larry Atkin Matthew Strange; Larry Atkin 2009-03-06
10861-10879 Unassigned
bveapi 10880 tcp BVEssentials HTTP API Tri Tech Computers Ltd. James Emerton 2012-11-19
bveapi 10880 udp BVEssentials HTTP API Tri Tech Computers Ltd. James Emerton 2012-11-19
10881-10932 Unassigned
octopustentacle 10933 tcp Listen port used by the Octopus Deploy Tentacle deployment agent Octopus Deploy Pty. Ltd. Paul Stovell 2015-01-28
10933 udp Reserved
10934-10989 Unassigned
rmiaux 10990 tcp Auxiliary RMI Port Eugen Bacic Eugen Bacic
rmiaux 10990 udp Auxiliary RMI Port Eugen Bacic Eugen Bacic
10991-10999 Unassigned
irisa 11000 tcp IRISA V. A. Brauner V. A. Brauner
irisa 11000 udp IRISA V. A. Brauner V. A. Brauner
metasys 11001 tcp Metasys Tobin Schuster Tobin Schuster
metasys 11001 udp Metasys Tobin Schuster Tobin Schuster
11002-11094 Unassigned
weave 11095 tcp Nest device-to-device and device-to-service application protocol Nest Labs, Inc. Grant Erickson 2014-01-16
weave 11095 udp Nest device-to-device and device-to-service application protocol Nest Labs, Inc. Grant Erickson 2014-01-16
11096-11102 Unassigned
origo-sync 11103 tcp OrigoDB Server Sync Interface Devrex Labs Robert Friberg 2013-03-29
11103 udp Reserved
netapp-icmgmt 11104 tcp NetApp Intercluster Management Craig Everhart Craig Everhart 2010-07-06
11104 udp Reserved
netapp-icdata 11105 tcp NetApp Intercluster Data Craig Everhart Craig Everhart 2010-07-06
11105 udp Reserved
sgi-lk 11106 tcp SGI LK Licensing service Michel Bourget Michel Bourget 2009-01-06
sgi-lk 11106 udp SGI LK Licensing service Michel Bourget Michel Bourget 2009-01-06
11107 Unassigned
myq-termlink 11108 udp Hardware Terminals Discovery and Low-Level Communication Protocol JANUS, spol. s r.o. Jakub Ahmadyar 2013-04-23
11108 tcp Reserved
sgi-dmfmgr 11109 tcp Data migration facility Manager (DMF) is a browser based interface to DMF SGI John Sygulla 2013-01-07
11109 udp Reserved
sgi-soap 11110 tcp Data migration facility (DMF) SOAP is a web server protocol to support remote access to DMF SGI John Sygulla 2013-01-07
11110 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
1026 Labs contact&1026labs.com 2016-09-27
Alvaro P. Dominguez alpado&gmail.com 2006-02
Andy Garratt Cirros Document Solutions Ltd admin&cirros.net 2020-02-12
Anthony Carrabino anthonyc&vistasoftware.com 2003-08
Apple Inc. kazu&apple.com 2015-09-29
Brigitte Gagne bgagne&trigence.com 2006-08
Carl Malamud
Chris Kent Decisive Tactics, Inc. ckent&decisivetactics.com 2015-04-09
Cirros Document Solutions Ltd admin&cirros.net 2020-02-12
Craig Everhart Craig.Everhart&netapp.com 2010-07-06
Decisive Tactics, Inc. ckent&decisivetactics.com 2015-04-09
Devrex Labs robert.friberg&devrex.se 2013-03-29
Eric Thorniley eric&etcomms.co.uk 2007-09-17
Eugen Bacic eugen&texar.com
Gordon Waddell gordon.waddell&nuance.com 2011-03-21
Grant Erickson Nest Labs, Inc. grant&nestlabs.com 2014-01-16
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Inlab Software GmbH info&inlab.de 2014-05-02
Jakub Ahmadyar JANUS, spol. s r.o. ahmadyar&myq.cz 2013-04-23
James Emerton Tri Tech Computers Ltd. james&tri-tech.com 2012-11-19
JANUS, spol. s r.o. ahmadyar&myq.cz 2013-04-23
Jason Thorpe thorpej&apple.com 2015-09-29
John Sygulla SGI jsygulla&sgi.com 2013-01-07
Juan Carlos Olivares Rojas jcolivares04c&cenidet.edu.mx 2006-03
Larry Atkin shasta&qsatoolworks.com
Matthew Strange matt&qsatoolworks.com 2009-03-06
Michel Bourget michel&sgi.com 2009-01-06
Nest Labs, Inc. grant&nestlabs.com 2014-01-16
Octopus Deploy Pty. Ltd. paul&octopusdeploy.com 2015-01-28
Patrick H. Piper ppiper&netlinxinc.com 2009-03-06
Paul Stovell Octopus Deploy Pty. Ltd. paul&octopusdeploy.com 2015-01-28
Phil Beecher Wi-SUN Alliance pbeecher&wi-sun.org 2015-06-26
Rob Earhart rob&1026labs.com 2016-09-27
Robert Friberg Devrex Labs robert.friberg&devrex.se 2013-03-29
SGI jsygulla&sgi.com 2013-01-07
Stefan Eriksson contact-iana&axis.com
Thomas G. Obermair Inlab Software GmbH thomas.obermair&inlab.de 2014-05-02
Tobin Schuster tobin.j.schuster&jci.com
Tri Tech Computers Ltd. admins&tri-tech.com 2012-11-19
V. A. Brauner info&datamedia.fr
Wei Wang Wei_Wang&intuit.com 2005-11
Wi-SUN Alliance admin&wi-sun.org 2015-06-26
Wouter Verhelst w&uter.be 2010-08-02