Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
availant-mgr 1122 tcp availant-mgr [Steven_Pelletier] [Steven_Pelletier]
availant-mgr 1122 udp availant-mgr [Steven_Pelletier] [Steven_Pelletier]
kwdb-commn 1127 tcp KWDB Remote Communication [Lal_Samuel_Varghese] [Lal_Samuel_Varghese] 2005-08
kwdb-commn 1127 udp KWDB Remote Communication [Lal_Samuel_Varghese] [Lal_Samuel_Varghese] 2005-08
kvm-via-ip 1132 tcp KVM-via-IP Management Service [Ian_Miller] [Ian_Miller] 2006-03
kvm-via-ip 1132 udp KVM-via-IP Management Service [Ian_Miller] [Ian_Miller] 2006-03
hhb-gateway 1136 tcp HHB Gateway Control [Richard_Harwell] [Richard_Harwell] 2006-02
hhb-gateway 1136 udp HHB Gateway Control [Richard_Harwell] [Richard_Harwell] 2006-02
encrypted-admin 1138 tcp encrypted admin requests

IANA assigned this well-formed service name as a replacement for "encrypted_admin".
[Michael_Elizarov] [Michael_Elizarov] 2007-01
encrypted_admin 1138 tcp encrypted admin requests [Michael_Elizarov] [Michael_Elizarov] 2007-01 This entry is an alias to "encrypted-admin". This entry is now historic, not usable for use with many common service discovery mechanisms.
encrypted-admin 1138 udp encrypted admin requests

IANA assigned this well-formed service name as a replacement for "encrypted_admin".
[Michael_Elizarov] [Michael_Elizarov] 2007-01
encrypted_admin 1138 udp encrypted admin requests [Michael_Elizarov] [Michael_Elizarov] 2007-01 This entry is an alias to "encrypted-admin". This entry is now historic, not usable for use with many common service discovery mechanisms.
x9-icue 1145 tcp X9 iCue Show Control [Brandon_Potter] [Brandon_Potter] 2006-01
x9-icue 1145 udp X9 iCue Show Control [Brandon_Potter] [Brandon_Potter] 2006-01
audit-transfer 1146 tcp audit transfer [Mark_Wahl] [Mark_Wahl] 2005-11
audit-transfer 1146 udp audit transfer [Mark_Wahl] [Mark_Wahl] 2005-11
elfiq-repl 1148 tcp Elfiq Replication Service [Frederick_Parent] [Frederick_Parent] 2005-11
elfiq-repl 1148 udp Elfiq Replication Service [Frederick_Parent] [Frederick_Parent] 2005-11
c1222-acse 1153 tcp ANSI C12.22 Port [RFC 6142]
c1222-acse 1153 udp ANSI C12.22 Port [RFC 6142]
iascontrol-oms 1156 tcp iasControl OMS [Todd_Guay] [Todd_Guay] 2004-11
iascontrol-oms 1156 udp iasControl OMS [Todd_Guay] [Todd_Guay] 2004-11
dbcontrol-oms 1158 tcp dbControl OMS [Todd_Guay] [Todd_Guay] 2004-11
dbcontrol-oms 1158 udp dbControl OMS [Todd_Guay] [Todd_Guay] 2004-11
oracle-oms 1159 tcp Oracle OMS [Todd_Guay] [Todd_Guay] 2004-11
oracle-oms 1159 udp Oracle OMS [Todd_Guay] [Todd_Guay] 2004-11
olsv 1160 tcp DB Lite Mult-User Server [Philip_Stephenson] [Philip_Stephenson] 2005-08
olsv 1160 udp DB Lite Mult-User Server [Philip_Stephenson] [Philip_Stephenson] 2005-08
health-polling 1161 tcp Health Polling
health-polling 1161 udp Health Polling
health-trap 1162 tcp Health Trap
health-trap 1162 udp Health Trap
qsm-proxy 1164 tcp QSM Proxy Service [Norm_Lunde] [Norm_Lunde] 2004-11
qsm-proxy 1164 udp QSM Proxy Service [Norm_Lunde] [Norm_Lunde] 2004-11
qsm-gui 1165 tcp QSM GUI Service [Norm_Lunde] [Norm_Lunde] 2004-11
qsm-gui 1165 udp QSM GUI Service [Norm_Lunde] [Norm_Lunde] 2004-11
qsm-remote 1166 tcp QSM RemoteExec [Norm_Lunde] [Norm_Lunde] 2004-11
qsm-remote 1166 udp QSM RemoteExec [Norm_Lunde] [Norm_Lunde] 2004-11
cisco-ipsla 1167 tcp Cisco IP SLAs Control Protocol [Emmanuel_Tychon] [Emmanuel_Tychon] 2006-03
cisco-ipsla 1167 udp Cisco IP SLAs Control Protocol [Emmanuel_Tychon] [Emmanuel_Tychon] 2006-03
cisco-ipsla 1167 sctp Cisco IP SLAs Control Protocol [Emmanuel_Tychon] [Emmanuel_Tychon] 2006-03
atc-lm 1170 tcp AT+C License Manager [Peter_Schafer] [Peter_Schafer] 2004-02
atc-lm 1170 udp AT+C License Manager [Peter_Schafer] [Peter_Schafer] 2004-02
atc-appserver 1171 tcp AT+C FmiApplicationServer [Peter_Schafer] [Peter_Schafer] 2004-02
atc-appserver 1171 udp AT+C FmiApplicationServer [Peter_Schafer] [Peter_Schafer] 2004-02
d-cinema-rrp 1173 tcp D-Cinema Request-Response [DCI] [DCI] 2004-11 2025-08-26
d-cinema-rrp 1173 udp D-Cinema Request-Response [DCI] [DCI] 2004-11 2025-08-26
fnet-remote-ui 1174 tcp FlashNet Remote Admin [Terry_Smyth] [Terry_Smyth] 2004-11
fnet-remote-ui 1174 udp FlashNet Remote Admin [Terry_Smyth] [Terry_Smyth] 2004-11
indigo-server 1176 tcp Indigo Home Server [Matt_Bendiksen] [Matt_Bendiksen] 2004-11
indigo-server 1176 udp Indigo Home Server [Matt_Bendiksen] [Matt_Bendiksen] 2004-11
sgi-storman 1178 tcp SGI Storage Manager [Greg_Banks] [Greg_Banks] 2004-11
sgi-storman 1178 udp SGI Storage Manager [Greg_Banks] [Greg_Banks] 2004-11
mc-client 1180 tcp Millicent Client Proxy [Steve_Glassman] [Steve_Glassman]
mc-client 1180 udp Millicent Client Proxy [Steve_Glassman] [Steve_Glassman]
accelenet-data 1182 udp AcceleNet Data [Peter_Lepeska] [Peter_Lepeska] 2010-09-10
llsurfup-http 1183 tcp LL Surfup HTTP
llsurfup-http 1183 udp LL Surfup HTTP
llsurfup-https 1184 tcp LL Surfup HTTPS [Katy_Lynn_McCullough] [Katy_Lynn_McCullough]
llsurfup-https 1184 udp LL Surfup HTTPS [Katy_Lynn_McCullough] [Katy_Lynn_McCullough]
mysql-cluster 1186 tcp MySQL Cluster Manager [Arjen_Lentz] [Arjen_Lentz] 2004-11
mysql-cluster 1186 udp MySQL Cluster Manager [Arjen_Lentz] [Arjen_Lentz] 2004-11
hp-webadmin 1188 tcp HP Web Admin [Lance_Kind] [Lance_Kind]
hp-webadmin 1188 udp HP Web Admin [Lance_Kind] [Lance_Kind]
commlinx-avl 1190 tcp CommLinx GPS / AVL System [Peter_Johnson] [Peter_Johnson] 2004-11
commlinx-avl 1190 udp CommLinx GPS / AVL System [Peter_Johnson] [Peter_Johnson] 2004-11
caids-sensor 1192 tcp caids sensors channel [Gregory_Hostettler] [Gregory_Hostettler] 2004-11
caids-sensor 1192 udp caids sensors channel [Gregory_Hostettler] [Gregory_Hostettler] 2004-11
rsf-1 1195 tcp RSF-1 clustering [Dave_Hines] [Dave_Hines] 2004-11
rsf-1 1195 udp RSF-1 clustering [Dave_Hines] [Dave_Hines] 2004-11
carrius-rshell 1197 tcp Carrius Remote Access [Gerry_Dubois] [Gerry_Dubois] 2005-08
carrius-rshell 1197 udp Carrius Remote Access [Gerry_Dubois] [Gerry_Dubois] 2005-08
cajo-discovery 1198 tcp cajo reference discovery [John_Catherino] [John_Catherino] 2005-08
cajo-discovery 1198 udp cajo reference discovery [John_Catherino] [John_Catherino] 2005-08
nucleus-sand 1201 tcp Nucleus Sand Database Server [James_Marsh] [James_Marsh]
nucleus-sand 1201 udp Nucleus Sand Database Server [James_Marsh] [James_Marsh]
ssslic-mgr 1203 tcp License Validation
ssslic-mgr 1203 udp License Validation
ssslog-mgr 1204 tcp Log Request Listener [Eric_Bruno] [Eric_Bruno]
ssslog-mgr 1204 udp Log Request Listener [Eric_Bruno] [Eric_Bruno]
accord-mgc 1205 tcp Accord-MGC [Roni_Even] [Roni_Even]
accord-mgc 1205 udp Accord-MGC [Roni_Even] [Roni_Even]
anthony-data 1206 tcp Anthony Data [Paul_Dollemore] [Paul_Dollemore]
anthony-data 1206 udp Anthony Data [Paul_Dollemore] [Paul_Dollemore]
seagull-ais 1208 tcp SEAGULL AIS [Lee_Breisacher] [Lee_Breisacher]
seagull-ais 1208 udp SEAGULL AIS [Lee_Breisacher] [Lee_Breisacher]
groove-dpp 1211 tcp Groove DPP [Ken_Moore] [Ken_Moore]
groove-dpp 1211 udp Groove DPP [Ken_Moore] [Ken_Moore]
mpc-lifenet 1213 tcp Medtronic/Physio-Control LIFENET [Physio-Control_Inc] [Kevin_Drew] 2014-02-14
mpc-lifenet 1213 udp Medtronic/Physio-Control LIFENET [Physio-Control_Inc] [Kevin_Drew] 2014-02-14
scanstat-1 1215 tcp scanSTAT 1.0 [William_Scheding] [William_Scheding]
scanstat-1 1215 udp scanSTAT 1.0 [William_Scheding] [William_Scheding]
hpss-ndapi 1217 tcp HPSS NonDCE Gateway [Michael_Gleicher] [Michael_Gleicher]
hpss-ndapi 1217 udp HPSS NonDCE Gateway [Michael_Gleicher] [Michael_Gleicher]
aeroflight-ads 1218 tcp AeroFlight-ADs
aeroflight-ads 1218 udp AeroFlight-ADs
aeroflight-ret 1219 tcp AeroFlight-Ret [Eric_Johnson] [Eric_Johnson]
aeroflight-ret 1219 udp AeroFlight-Ret [Eric_Johnson] [Eric_Johnson]
qt-serveradmin 1220 tcp QT SERVER ADMIN [Chris_LeCroy] [Chris_LeCroy]
qt-serveradmin 1220 udp QT SERVER ADMIN [Chris_LeCroy] [Chris_LeCroy]
sweetware-apps 1221 tcp SweetWARE Apps [David_Dunetz] [David_Dunetz]

Contact Information

ID Name Organization Contact URI Last Updated
[Arjen_Lentz] Arjen Lentz mailto:arjen&mysql.com 2004-11
[Brandon_Potter] Brandon Potter mailto:iana&brandonpotter.com 2006-01
[Chris_LeCroy] Chris LeCroy mailto:lecroy&apple.com
[Dave_Hines] Dave Hines mailto:d.hines&high-availability.com 2004-11
[David_Dunetz] David Dunetz mailto:david&sweetware.com
[DCI] Digital Cinema Initiatives, LLC mailto:dci.info&dcimovies.com 2025-08-26
[Emmanuel_Tychon] Emmanuel Tychon mailto:etychon&cisco.com 2006-03
[Eric_Bruno] Eric Bruno mailto:ebruno&solution-soft.com
[Eric_Johnson] Eric Johnson mailto:eric&gruver.net
[Frederick_Parent] Frederick Parent mailto:fparent&elfiq.com 2005-11
[Gerry_Dubois] Gerry Dubois mailto:gdubois&carriustech.com 2005-08
[Greg_Banks] Greg Banks mailto:gnb&sgi.com 2004-11
[Gregory_Hostettler] Gregory Hostettler mailto:ghostettler&caracal.ch 2004-11
[Ian_Miller] Ian Miller mailto:IANA-reg&adder.com 2006-03
[James_Marsh] James Marsh mailto:James_T_Marsh&hotmail.com
[John_Catherino] John Catherino mailto:cajo&dev.java.net 2005-08
[Katy_Lynn_McCullough] Katy Lynn McCullough mailto:KatyM&laplink.com
[Ken_Moore] Ken Moore mailto:kmoore&groove.net
[Kevin_Drew] Kevin Drew Physio-Control, Inc. mailto:kevin.c.drew&physio-control.com 2014-02-14
[Lal_Samuel_Varghese] Lal Samuel Varghese mailto:lalsam&hp.com 2005-08
[Lance_Kind] Lance Kind mailto:lance_kind&hp.com
[Lee_Breisacher] Lee Breisacher mailto:lbreisacher&seagullsw.com
[Mark_Wahl] Mark Wahl mailto:mark.wahl&informed-control.com 2005-11
[Matt_Bendiksen] Matt Bendiksen mailto:matt&perceptiveautomation.com 2004-11
[Michael_Elizarov] Michael Elizarov mailto:Michael.Elizarov&microsoft.com 2007-01
[Michael_Gleicher] Michael Gleicher mailto:mgleicher&comcast.net
[Norm_Lunde] Norm Lunde mailto:norm&commvault.com 2004-11
[Paul_Dollemore] Paul Dollemore mailto:pauld&anthonydata.com
[Peter_Johnson] Peter Johnson mailto:peter&commlinx.com.au 2004-11
[Peter_Lepeska] Peter Lepeska mailto:peter.lepeska&viasat.com 2010-09-10
[Peter_Schafer] Peter Schäfer mailto:p.schaefer&nospam.atc-systeme.de 2004-02
[Philip_Stephenson] Philip Stephenson mailto:Philip.stephenson&oracle.com 2005-08
[Physio-Control_Inc] Physio-Control, Inc. mailto:kevin.c.drew&physio-control.com 2014-02-14
[Richard_Harwell] Richard Harwell mailto:richardcharwell&eaton.com 2006-02
[Roni_Even] Roni Even mailto:roni_e&accord.co.il
[Steve_Glassman] Steve Glassman mailto:steveg&pa.dec.com
[Steven_Pelletier] Steven Pelletier mailto:stevep&availant.com
[Terry_Smyth] Terry Smyth mailto:terry&sgluk.com 2004-11
[Todd_Guay] Todd Guay mailto:todd.guay&oracle.com 2005-08
[William_Scheding] William Scheding mailto:wls&wls.org