Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
proofd 1093 tcp PROOFD
proofd 1093 udp PROOFD
rootd 1094 tcp ROOTD Fons Rademakers Fons Rademakers
rootd 1094 udp ROOTD Fons Rademakers Fons Rademakers
nicelink 1095 tcp NICELink Jordi Lisbona Jordi Lisbona
nicelink 1095 udp NICELink Jordi Lisbona Jordi Lisbona
cnrprotocol 1096 tcp Common Name Resolution Protocol Michael Mealling Michael Mealling
cnrprotocol 1096 udp Common Name Resolution Protocol Michael Mealling Michael Mealling
sunclustermgr 1097 tcp Sun Cluster Manager Ashit Patel Ashit Patel
sunclustermgr 1097 udp Sun Cluster Manager Ashit Patel Ashit Patel
rmiactivation 1098 tcp RMI Activation
rmiactivation 1098 udp RMI Activation
rmiregistry 1099 tcp RMI Registry Mark Hodapp Mark Hodapp
rmiregistry 1099 udp RMI Registry Mark Hodapp Mark Hodapp
mctp 1100 tcp MCTP Vitaly Revsin Vitaly Revsin
mctp 1100 udp MCTP Vitaly Revsin Vitaly Revsin
pt2-discover 1101 tcp PT2-DISCOVER Ralph Kammerlander Ralph Kammerlander
pt2-discover 1101 udp PT2-DISCOVER Ralph Kammerlander Ralph Kammerlander
adobeserver-1 1102 tcp ADOBE SERVER 1
adobeserver-1 1102 udp ADOBE SERVER 1
adobeserver-2 1103 tcp ADOBE SERVER 2 Frank Soetebeer Frank Soetebeer
adobeserver-2 1103 udp ADOBE SERVER 2 Frank Soetebeer Frank Soetebeer
xrl 1104 tcp XRL Patrick Robinson Patrick Robinson
xrl 1104 udp XRL Patrick Robinson Patrick Robinson
ftranhc 1105 tcp FTRANHC Eriko Shimada Eriko Shimada
ftranhc 1105 udp FTRANHC Eriko Shimada Eriko Shimada
isoipsigport-1 1106 tcp ISOIPSIGPORT-1
isoipsigport-1 1106 udp ISOIPSIGPORT-1
isoipsigport-2 1107 tcp ISOIPSIGPORT-2 Peter Egli Peter Egli
isoipsigport-2 1107 udp ISOIPSIGPORT-2 Peter Egli Peter Egli
ratio-adp 1108 tcp ratio-adp Oliver Thulke Oliver Thulke
ratio-adp 1108 udp ratio-adp Oliver Thulke Oliver Thulke
1109 Reserved - IANA
webadmstart 1110 tcp Start web admin server
nfsd-keepalive 1110 udp Client status info Beth Crespo Beth Crespo
lmsocialserver 1111 tcp LM Social Server Ron Lussier Ron Lussier
lmsocialserver 1111 udp LM Social Server Ron Lussier Ron Lussier
icp 1112 tcp Intelligent Communication Protocol Mark H. David Mark H. David
icp 1112 udp Intelligent Communication Protocol Mark H. David Mark H. David
ltp-deepspace 1113 tcp Licklider Transmission Protocol RFC 5326
ltp-deepspace 1113 udp Licklider Transmission Protocol 2014-02-21 RFC 5326; RFC 7122
ltp-deepspace 1113 dccp Licklider Transmission Protocol 2013-11-12 2014-02-21 RFC 7122 7107696
mini-sql 1114 tcp Mini SQL David Hughes David Hughes
mini-sql 1114 udp Mini SQL David Hughes David Hughes
ardus-trns 1115 tcp ARDUS Transfer
ardus-trns 1115 udp ARDUS Transfer
ardus-cntl 1116 tcp ARDUS Control
ardus-cntl 1116 udp ARDUS Control
ardus-mtrns 1117 tcp ARDUS Multicast Transfer Shinya Abe Shinya Abe
ardus-mtrns 1117 udp ARDUS Multicast Transfer Shinya Abe Shinya Abe
sacred 1118 tcp SACRED RFC 3767
sacred 1118 udp SACRED RFC 3767
bnetgame 1119 tcp Battle.net Chat/Game Protocol
bnetgame 1119 udp Battle.net Chat/Game Protocol
bnetfile 1120 tcp Battle.net File Transfer Protocol Domain Tech Domain Tech 2005-04
bnetfile 1120 udp Battle.net File Transfer Protocol Domain Tech Domain Tech 2005-04
rmpp 1121 tcp Datalode RMPP Dave Ruedger Dave Ruedger 2003-11
rmpp 1121 udp Datalode RMPP Dave Ruedger Dave Ruedger 2003-11
availant-mgr 1122 tcp availant-mgr Steven Pelletier Steven Pelletier
availant-mgr 1122 udp availant-mgr Steven Pelletier Steven Pelletier
murray 1123 tcp Murray Stu Mark Stu Mark
murray 1123 udp Murray Stu Mark Stu Mark
hpvmmcontrol 1124 tcp HP VMM Control
hpvmmcontrol 1124 udp HP VMM Control
hpvmmagent 1125 tcp HP VMM Agent
hpvmmagent 1125 udp HP VMM Agent
hpvmmdata 1126 tcp HP VMM Agent John Morton John Morton 2004-11
hpvmmdata 1126 udp HP VMM Agent John Morton John Morton 2004-11
kwdb-commn 1127 tcp KWDB Remote Communication Lal Samuel Varghese Lal Samuel Varghese 2005-08
kwdb-commn 1127 udp KWDB Remote Communication Lal Samuel Varghese Lal Samuel Varghese 2005-08
saphostctrl 1128 tcp SAPHostControl over SOAP/HTTP
saphostctrl 1128 udp SAPHostControl over SOAP/HTTP
saphostctrls 1129 tcp SAPHostControl over SOAP/HTTPS Muscarella Fabrizio Muscarella Fabrizio 2006-04
saphostctrls 1129 udp SAPHostControl over SOAP/HTTPS Muscarella Fabrizio Muscarella Fabrizio 2006-04
casp 1130 tcp CAC App Service Protocol
casp 1130 udp CAC App Service Protocol
caspssl 1131 tcp CAC App Service Protocol Encripted Enrique Corujo Enrique Corujo 2006-02
caspssl 1131 udp CAC App Service Protocol Encripted Enrique Corujo Enrique Corujo 2006-02
kvm-via-ip 1132 tcp KVM-via-IP Management Service Ian Miller Ian Miller 2006-03
kvm-via-ip 1132 udp KVM-via-IP Management Service Ian Miller Ian Miller 2006-03
dfn 1133 tcp Data Flow Network Mikhailov Center Anton Mikhailov 2006-02 2021-03-04
dfn 1133 udp Data Flow Network Mikhailov Center Anton Mikhailov 2006-02 2021-03-04
aplx 1134 tcp MicroAPL APLX Richard Nabavi Richard Nabavi 2006-02
aplx 1134 udp MicroAPL APLX Richard Nabavi Richard Nabavi 2006-02
omnivision 1135 tcp OmniVision Communication Service Serge Vacquier Serge Vacquier 2006-02
omnivision 1135 udp OmniVision Communication Service Serge Vacquier Serge Vacquier 2006-02
hhb-gateway 1136 tcp HHB Gateway Control Richard Harwell Richard Harwell 2006-02
hhb-gateway 1136 udp HHB Gateway Control Richard Harwell Richard Harwell 2006-02
trim 1137 tcp TRIM Workgroup Service Siva Poobalasingam Siva Poobalasingam 2006-03
trim 1137 udp TRIM Workgroup Service Siva Poobalasingam Siva Poobalasingam 2006-03
encrypted-admin 1138 tcp encrypted admin requests

IANA assigned this well-formed service name as a replacement for "encrypted_admin".
Michael Elizarov Michael Elizarov 2007-01
encrypted_admin 1138 tcp encrypted admin requests Michael Elizarov Michael Elizarov 2007-01 This entry is an alias to "encrypted-admin". This entry is now historic, not usable for use with many common service discovery mechanisms.
encrypted-admin 1138 udp encrypted admin requests

IANA assigned this well-formed service name as a replacement for "encrypted_admin".
Michael Elizarov Michael Elizarov 2007-01
encrypted_admin 1138 udp encrypted admin requests Michael Elizarov Michael Elizarov 2007-01 This entry is an alias to "encrypted-admin". This entry is now historic, not usable for use with many common service discovery mechanisms.
evm 1139 tcp Enterprise Virtual Manager Thomas Hennessy Thomas Hennessy 2007-10-04
evm 1139 udp Enterprise Virtual Manager Thomas Hennessy Thomas Hennessy 2007-10-04
autonoc 1140 tcp AutoNOC Network Operations Protocol Kyle Lussier Kyle Lussier 2005-12
autonoc 1140 udp AutoNOC Network Operations Protocol Kyle Lussier Kyle Lussier 2005-12
mxomss 1141 tcp User Message Service Chaoyi Lang Chaoyi Lang 2006-01
mxomss 1141 udp User Message Service Chaoyi Lang Chaoyi Lang 2006-01
edtools 1142 tcp User Discovery Service Lee Dolson Lee Dolson 2006-01

Contact Information

Name Organization Contact URI Last Updated
Anton Mikhailov Mikhailov Center anton&mikhailov.center 2021-03-04
Ashit Patel Ashit.Patel&eng.sun.com
Beth Crespo beth.crespo&hp.com
Chaoyi Lang chao-yi_lang&maxtor.com 2006-01
Dave Ruedger daver&datalode.com 2003-11
David Hughes bambi&hughes.com.au
Domain Tech Domainnametech&blizzard.com 2005-04
Enrique Corujo enrique&caclearing.com 2006-02
Eriko Shimada eriko&kel.fujitsu.co.jp
Fons Rademakers Fons.Rademakers&cern.ch
Frank Soetebeer frsoeteb&adobe.com 2003-01
Ian Miller IANA-reg&adder.com 2006-03
John Morton j.morton&hp.com 2004-11
Jordi Lisbona jlisbona&tango04.net
Kyle Lussier klussier&autonoc.com 2005-12
Lal Samuel Varghese lalsam&hp.com 2005-08
Lee Dolson dolson&f-net.co.kr 2006-01
Mark H. David mhd&gensym.com
Mark Hodapp mark.hodapp&sun.com
Michael Elizarov Michael.Elizarov&microsoft.com 2007-01
Michael Mealling michaelm&netsol.com
Mikhailov Center pulse.cc&mail.ru 2021-03-04
Muscarella Fabrizio fabrizio.muscarella&sap.com 2006-04
Oliver Thulke oth&ratio.de
Patrick Robinson probinson&plosive.com
Peter Egli peter.egli&inalp.com
Ralph Kammerlander ralph.kammerlander&khe.siemens.de
Richard Harwell richardcharwell&eaton.com 2006-02
Richard Nabavi nabavi&microapl.co.uk 2006-02
Ron Lussier coyote&likeminds.com
Serge Vacquier svacquier&axway.com 2019-03-29
Shinya Abe abeabe&pfu.co.jp
Siva Poobalasingam siva&towersoft.com.au 2006-03
Steven Pelletier stevep&availant.com
Stu Mark fordii&j51.com
Thomas Hennessy thennessy&manageiq.com 2007-10-04
Vitaly Revsin vitaly&webmanage.com