Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
11110 udp Reserved
11209-11210 Unassigned
edbsrvr 12010 tcp ElevateDB Server Tim Young Tim Young 2009-05-06
12010 udp Reserved
12014-12108 Unassigned
rets-ssl 12109 tcp RETS over SSL Jeremy Crawford Jeremy Crawford 2003-02
rets-ssl 12109 udp RETS over SSL Jeremy Crawford Jeremy Crawford 2003-02
12110-12120 Unassigned
pduncs 16310 tcp Policy Distribute, Update Notification Diane I. Shannon Diane I. Shannon 2006-08
pduncs 16310 udp Policy Distribute, Update Notification Diane I. Shannon Diane I. Shannon 2006-08
ncpu 17010 tcp Plan 9 cpu port Ronald G. Minnich Ronald G. Minnich 2022-05-13 Defined TXT keys: u=username; k=keypattern; f=fstabFILE; n=namespace; h=hostkey; r=root
17010 udp Reserved
isa100-gci 17223 tcp ISA100 GCI is a service utilizing a common interface between an ISA100 Wireless gateway and a client application ISA100 Wireless Compliance Institute Jay Werb 2015-07-24
18001-18103 Unassigned
radpdf 18104 tcp RAD PDF Service Christopher Truxaw Christopher Truxaw 2010-10-15
18104 udp Reserved
18105-18135 Unassigned
hp-sco 19410 tcp hp-sco Larry Schwartz Larry Schwartz
hp-sco 19410 udp hp-sco Larry Schwartz Larry Schwartz
iec-104-sec 19998 tcp IEC 60870-5-104 process control - secure Grant Gilchrist Grant Gilchrist 2010-10-18
crtech-nlm 20810 tcp CRTech NLM Cullimore And Ring Technologies Dave Wilkins 2021-06-24
20810 udp Reserved
irtrans 21000 tcp IRTrans Control Marcus Mueller Marcus Mueller 2004-11
irtrans 21000 udp IRTrans Control Marcus Mueller Marcus Mueller 2004-11
21001-21009 Unassigned
notezilla-lan 21010 tcp Notezilla.Lan Server Conceptworld Corporation Gautam Jain 2013-08-20
21010 udp Reserved
21011-21211 Unassigned
s102 23272 udp S102 application Kimmo Kymalainen Kimmo Kymalainen 2009-08-26
icl-twobase10 25009 tcp icl-twobase10 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase10 25009 udp icl-twobase10 J. A. (Tony) Sever J. A. (Tony) Sever
25010-25099 Unassigned
db2c-tls 25100 tcp IBM Db2 Client Interface - Encrypted IBM Matthew Emmerton 2024-03-05
25100 udp Reserved
25101-25470 Unassigned
flex-lm 27000-27009 FLEX LM (1-10) Flexera Software Paul Bland 2018-02-15
flex-lmadmin 27010 tcp A protocol for managing license services Flexera Paul Bland 2018-08-22
27010 udp Reserved
gruber-cashreg 28010 tcp Gruber cash registry protocol Gruber Schanksysteme Clemens Gruber 2019-12-31
28010 udp Reserved
rwp 30100 tcp Remote Window Protocol Maxim Baklanovsky Maxim Baklanovsky 2015-05-20
30100 udp Reserved
rwp 30100 sctp Remote Window Protocol Maxim Baklanovsky Maxim Baklanovsky 2015-05-20
30101-30259 Unassigned
31000-31015 Unassigned
ka-sddp 31016 tcp Kollective Agent Secure Distributed Delivery Protocol Kollective Technology Inc. John Wainwright 2016-12-11
ka-kdp 31016 udp Kollective Agent Kollective Delivery Protocol Kollective Technology Inc. John Wainwright 2016-12-11
31017-31019 Unassigned
autotrac-acp 31020 tcp Autotrac ACP 245 Roberto Jorge Dino Roberto Jorge Dino
31020 udp Reserved
31021-31028 Unassigned
31029 tcp Reserved
yawn 31029 udp YaWN - Yet Another Windows Notifier David Spivey David Spivey 2010-08-30
31030-31336 Unassigned
32802-32810 Unassigned
axio-disc 35100 tcp Axiomatic discovery protocol Axiomatic Technologies Corporation Oleksandr_Bogush 2016-12-09
axio-disc 35100 udp Axiomatic discovery protocol Axiomatic Technologies Corporation Oleksandr_Bogush 2016-12-09
35101-35353 Unassigned
36002-36410 Unassigned
40854-41110 Unassigned
caerpc 42510 tcp CA eTrust RPC Jon Press Jon Press 2005-08
caerpc 42510 udp CA eTrust RPC Jon Press Jon Press 2005-08
shaperai 43210 tcp Shaper Automation Server Management Shaper Automation Inc. Yohann Sulaiman 2012-06-22
shaperai-disc 43210 udp Shaper Automation Server Management Discovery Shaper Automation Inc. Yohann Sulaiman 2012-06-22
jvl-mactalk 47100 udp Configuration of motors connected to Industrial Ethernet JVL Industri Elektronik Kim Berthelsen 2012-12-21
47100 tcp Reserved
47101-47556 Unassigned
47810-47999 Unassigned
help HELP command RFC 1078 TCP Port Service Multiplexer (TCPMUX)
hpr-bldlnx HP Remote Build System for Linux-based Systems Jeffrey J. Walls Jeffrey J. Walls Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102
hpr-toollnx HP Remote System that houses compilers and tools for Linux-based Systems Jeffrey J. Walls Jeffrey J. Walls Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102
hpr-tstlnx HP Remote Test System for Linux-based Systems Jeffrey J. Walls Jeffrey J. Walls Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102
presence Peer-to-peer messaging / Link-Local Messaging XMPP Registrar XMPP Registrar Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html Note: Registration updated May 2007. Was formerly listed as "iChat AV" (Apple's IM client for Mac OS X) with TXT keys: txtvers, port.p2pj, phsh, vc, 1st, AIM, msg, status, last When first shipped in Mac OS X 10.2, iChat's peer-to-peer messaging protocol was created to solve the problem of serverless messaging between peers on the same link. However, there is nothing inherent in the protocol that limits it to being only link-local; it was simply an artifact of iChat in Mac OS X 10.2 using link-local Multicast DNS to discover peers. With the advent of Wide-Area DNS-SD, it is also possible to use iChat's peer-to-peer messaging between machines on different links.
recipe-sharing tcp Recipe Sharing Protocol Daniel G. Taylor Daniel G. Taylor 2007-11 Defined TXT keys: http://www.recipemanager.org/rsp/rsp10draft.html#dnssd
spx-hmp tcp SpinetiX HMP SpinetiX S.A. Diego Santa Cruz 2011-10-18 Defined TXT keys: txtvers=1 cport= the port for the content HTTP server (secondary HTTP server used for content publishing) mode= the mode in which the HMP device is currently operating, one of "normal", "safe" or "recovery" serial= serial number of the HMP device firmware= firmware version string (e.g., 2.1.0-0.1.7844) model= model string (e.g., HMP100)
x510 tcp Security service to protocols ITU-T Study Group 17 Erik Andersen 2019-08-13 Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Axiomatic Technologies Corporation obogush&axiomatic.com 2016-12-09
Christopher Truxaw ctruxaw&redsoftware.com 2010-10-15
Clemens Gruber iana&pqgruber.com 2019-12-31
Conceptworld Corporation admin&conceptworld.com 2013-08-20
Cullimore And Ring Technologies dave.wilkins&crtech.com 2021-06-24
Daniel G. Taylor dan&programmer-art.org 2007-11
Dave Wilkins dave.wilkins&crtech.com 2021-06-24
David Spivey DavidTSpivey&gmail.com 2010-08-30
Diane I. Shannon shannond&us.ibm.com 2007-04
Diego Santa Cruz SpinetiX S.A. Diego.SantaCruz&spinetix.com 2011-10-18
Erik Andersen era&x500.eu 2019-08-13
Flexera pbland&flexera.com 2018-08-22
Flexera Software security&flexerasoftware.com 2016-07-19
Gautam Jain Conceptworld Corporation admin&conceptworld.com 2013-08-20
Grant Gilchrist grant&enernex.com 2010-10-18
Gruber Schanksysteme iana&pqgruber.com 2019-12-31
IBM memmerto&ca.ibm.com 2024-03-05
ISA100 Wireless Compliance Institute jay&jwerb.com 2015-07-24
ITU-T Study Group 17 era&x500.eu 2019-08-13
J. A. (Tony) Sever J.A.Sever&bra0119.wins.icl.co.uk
Jay Werb ISA100 Wireless Compliance Institute jay&jwerb.com 2015-07-24
Jeffrey J. Walls jeff.walls&hp.com
Jeremy Crawford jeremy&reso.org 2015-09-07
John Wainwright jwainwright&kollective.com 2016-12-11
Jon Press IANA.Registions&ca.com 2005-09
JVL Industri Elektronik jvl&jvl.dk 2012-12-21
Kim Berthelsen JVL Industri Elektronik kb&jvl.dk 2012-12-21
Kimmo Kymalainen kimmo.kymalainen&etsi.org 2017-05-08
Kollective Technology Inc. info&kollective.com 2016-12-11
Larry Schwartz lrs&cup.hp.com
Marcus Mueller marcus&irtrans.de 2004-11
Matthew Emmerton IBM memmerto&ca.ibm.com 2024-03-05
Maxim Baklanovsky m.baklanovsky&spbu.ru 2015-05-20
Oleksandr_Bogush obogush&axiomatic.com 2016-12-09
Paul Bland pbland&flexera.com 2018-08-22
Roberto Jorge Dino roberto.dino&autotrac.com.br
Ronald G. Minnich rminnich&gmail.com 2022-05-13
Shaper Automation Inc. ports&shaperai.com 2012-06-22
SpinetiX S.A. Diego.SantaCruz&spinetix.com 2011-10-18
Tim Young timyoung&elevatesoft.com 2009-05-06
XMPP Registrar registrar&xmpp.org
Yohann Sulaiman ports&shaperai.com 2012-06-22