Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
capfast-lmd 1756 tcp capfast-lmd Chuck Neal Chuck Neal
capfast-lmd 1756 udp capfast-lmd Chuck Neal Chuck Neal
cnhrp 1757 tcp cnhrp William Stoye William Stoye
cnhrp 1757 udp cnhrp William Stoye William Stoye
tftp-mcast 1758 tcp tftp-mcast Tom Emberson Tom Emberson
tftp-mcast 1758 udp tftp-mcast Tom Emberson Tom Emberson
spss-lm 1759 tcp SPSS License Manager Tex Hull Tex Hull
spss-lm 1759 udp SPSS License Manager Tex Hull Tex Hull
www-ldap-gw 1760 tcp www-ldap-gw Nick Emery Nick Emery
www-ldap-gw 1760 udp www-ldap-gw Nick Emery Nick Emery
cft-0 1761 tcp cft-0 Martine Marchand Martine Marchand
cft-0 1761 udp cft-0 Martine Marchand Martine Marchand
cft-1 1762 tcp cft-1 Martine Marchand Martine Marchand
cft-1 1762 udp cft-1 Martine Marchand Martine Marchand
cft-2 1763 tcp cft-2 Martine Marchand Martine Marchand
cft-2 1763 udp cft-2 Martine Marchand Martine Marchand
cft-3 1764 tcp cft-3 Martine Marchand Martine Marchand
cft-3 1764 udp cft-3 Martine Marchand Martine Marchand
cft-4 1765 tcp cft-4 Martine Marchand Martine Marchand
cft-4 1765 udp cft-4 Martine Marchand Martine Marchand
cft-5 1766 tcp cft-5 Martine Marchand Martine Marchand
cft-5 1766 udp cft-5 Martine Marchand Martine Marchand
cft-6 1767 tcp cft-6 Martine Marchand Martine Marchand
cft-6 1767 udp cft-6 Martine Marchand Martine Marchand
cft-7 1768 tcp cft-7 Martine Marchand Martine Marchand
cft-7 1768 udp cft-7 Martine Marchand Martine Marchand
bmc-net-adm 1769 tcp bmc-net-adm Portnoy Boxman Portnoy Boxman
bmc-net-adm 1769 udp bmc-net-adm Portnoy Boxman Portnoy Boxman
bmc-net-svc 1770 tcp bmc-net-svc Portnoy Boxman Portnoy Boxman
bmc-net-svc 1770 udp bmc-net-svc Portnoy Boxman Portnoy Boxman
vaultbase 1771 tcp vaultbase Jose A. Sesin Jose A. Sesin
vaultbase 1771 udp vaultbase Jose A. Sesin Jose A. Sesin
essweb-gw 1772 tcp EssWeb Gateway Bob Nattenberg Bob Nattenberg
essweb-gw 1772 udp EssWeb Gateway Bob Nattenberg Bob Nattenberg
kmscontrol 1773 tcp KMSControl Roy Chastain Roy Chastain
kmscontrol 1773 udp KMSControl Roy Chastain Roy Chastain
global-dtserv 1774 tcp global-dtserv Nicholas Davies Nicholas Davies
global-dtserv 1774 udp global-dtserv Nicholas Davies Nicholas Davies
vdab 1775 tcp data interchange between visual processing containers MJA Technology LLC Mark J. App 2014-04-23
1775 udp Reserved
femis 1776 tcp Federal Emergency Management Information System Larry Gerhardstein Larry Gerhardstein
femis 1776 udp Federal Emergency Management Information System Larry Gerhardstein Larry Gerhardstein
powerguardian 1777 tcp powerguardian Charles Bennett Charles Bennett 2008-08-29
powerguardian 1777 udp powerguardian Charles Bennett Charles Bennett 2008-08-29
prodigy-intrnet 1778 tcp prodigy-internet Bob Dedrick Bob Dedrick
prodigy-intrnet 1778 udp prodigy-internet Bob Dedrick Bob Dedrick
pharmasoft 1779 tcp pharmasoft Ola Strandberg Ola Strandberg
pharmasoft 1779 udp pharmasoft Ola Strandberg Ola Strandberg
dpkeyserv 1780 tcp dpkeyserv Yasunari Gon Yamasita Yasunari Gon Yamasita
dpkeyserv 1780 udp dpkeyserv Yasunari Gon Yamasita Yasunari Gon Yamasita
answersoft-lm 1781 tcp answersoft-lm James A. Brewster James A. Brewster
answersoft-lm 1781 udp answersoft-lm James A. Brewster James A. Brewster
hp-hcip 1782 tcp hp-hcip Allen Baker Allen Baker
hp-hcip 1782 udp hp-hcip Allen Baker Allen Baker
1783 Decomissioned Port 04/14/00, ms naonao naonao
finle-lm 1784 tcp Finle License Manager Dongling Wang Dongling Wang
finle-lm 1784 udp Finle License Manager Dongling Wang Dongling Wang
windlm 1785 tcp Wind River Systems License Manager Will Dere Will Dere
windlm 1785 udp Wind River Systems License Manager Will Dere Will Dere
funk-logger 1786 tcp funk-logger
funk-logger 1786 udp funk-logger
funk-license 1787 tcp funk-license Cimarron Boozer; Eric Wilde Cimarron Boozer; Eric Wilde
funk-license 1787 udp funk-license Cimarron Boozer; Eric Wilde Cimarron Boozer; Eric Wilde
psmond 1788 tcp psmond Will Golson Will Golson
psmond 1788 udp psmond Will Golson Will Golson
hello 1789 tcp hello D. J. Bernstein D. J. Bernstein 2018-04-05
hello 1789 udp hello D. J. Bernstein D. J. Bernstein 2018-04-05
nmsp 1790 tcp Narrative Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
nmsp 1790 udp Narrative Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
ea1 1791 tcp EA1 Kirk MacLean Kirk MacLean
ea1 1791 udp EA1 Kirk MacLean Kirk MacLean
ibm-dt-2 1792 tcp ibm-dt-2 Sam Borman Sam Borman
ibm-dt-2 1792 udp ibm-dt-2 Sam Borman Sam Borman
rsc-robot 1793 tcp rsc-robot Andrew Jay Schneider Andrew Jay Schneider
rsc-robot 1793 udp rsc-robot Andrew Jay Schneider Andrew Jay Schneider
cera-bcm 1794 tcp cera-bcm Leo Moesgaard Leo Moesgaard
cera-bcm 1794 udp cera-bcm Leo Moesgaard Leo Moesgaard
dpi-proxy 1795 tcp dpi-proxy Charles Gordon Charles Gordon
dpi-proxy 1795 udp dpi-proxy Charles Gordon Charles Gordon
vocaltec-admin 1796 tcp Vocaltec Server Administration Scott Petrack Scott Petrack
vocaltec-admin 1796 udp Vocaltec Server Administration Scott Petrack Scott Petrack
uma 1797 tcp UMA Martin Kirk Martin Kirk
uma 1797 udp UMA Martin Kirk Martin Kirk
etp 1798 tcp Event Transfer Protocol Mike Wray Mike Wray
etp 1798 udp Event Transfer Protocol Mike Wray Mike Wray
netrisk 1799 tcp NETRISK Kevin Green Kevin Green
netrisk 1799 udp NETRISK Kevin Green Kevin Green
fhsp 1807 tcp Fujitsu Hot Standby Protocol Eiki Iwata Eiki Iwata
fhsp 1807 udp Fujitsu Hot Standby Protocol Eiki Iwata Eiki Iwata
rkb-oscs 1817 tcp RKB-OSCS Robert Kevin Breton Robert Kevin Breton
rkb-oscs 1817 udp RKB-OSCS Robert Kevin Breton Robert Kevin Breton
asi 1827 tcp ASI Bob Tournoux Bob Tournoux
asi 1827 udp ASI Bob Tournoux Bob Tournoux
csoft1 1837 tcp csoft1 John Coll John Coll
csoft1 1837 udp csoft1 John Coll John Coll
slp-notify 1847 tcp SLP Notification RFC 3082
slp-notify 1847 udp SLP Notification RFC 3082
datacaptor 1857 tcp DataCaptor Steven M. Forrester Steven M. Forrester
datacaptor 1857 udp DataCaptor Steven M. Forrester Steven M. Forrester
udrive 1867 tcp UDRIVE Robby Walker Robby Walker
udrive 1867 udp UDRIVE Robby Walker Robby Walker

Contact Information

Name Organization Contact URI Last Updated
Allen Baker abaker&boi.hp.com
Andrew Jay Schneider ajs&relsoft.com
Bob Dedrick bob&staff.prodigy.com
Bob Nattenberg bnattenberg&arborsoft.com
Bob Tournoux bob.tournoux&usiny.mail.abb.com
Charles Bennett bennettc&ohio.edu 2008-08-29
Charles Gordon cgordon&digprod.com
Chuck Neal chuck&phase3.com
Cimarron Boozer cboozer&funk.com
D. J. Bernstein ports&box.cr.yp.to 2018-04-05
Dongling Wang dongling&finle.com
Eiki Iwata eiki&nd.net.fujitsu.co.jp
Eric Wilde eric&funk.com
James A. Brewster jimbrew&answersoft.com
John Coll john&csoft.co.uk
Jose A. Sesin sesin&vaultbase.com
Kevin Green Kevin_Green&tds.com
Kirk MacLean kmaclean&ea.com
Larry Gerhardstein lh_gerhardstein&pnl.gov
Leo Moesgaard leo_moesgaard&dk.ibm.com
Mark J. App MJA_Technology_LLC mapp&vdabtec.com 2020-02-03
Martin Kirk m.kirk&opengroup.org
Martine Marchand tel:+16-1-46-59-24-84
Mike Wray mjw&hplb.hpl.hp.com
MJA Technology LLC mapp&vdabtec.com 2020-02-03
Nicholas Davies N.Davies&globalcomm.co.uk
Nick Emery Nick.Emery&altavista.digital.com
Ola Strandberg Ola.Strandberg&pharmasoft.se
Paul Santinelli Jr. psantinelli&narrative.com
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Robby Walker webmaster&cd-lab.com
Robert Kevin Breton BOBBRETON&hotmail.com
Roy Chastain roy&kmsys.com
Sam Borman sam_borman&uk.ibm.com
Scott Petrack Scott_Petrack&vocaltec.com
Steven M. Forrester StevenF&capsuletech.com
Tex Hull tex&spss.com
Tom Emberson tom&lanworks.com
Will Dere will&wrs.com
Will Golson golson&fc.hp.com
William Stoye wstoye&atml.co.uk
Yasunari Gon Yamasita yamasita&omronsoft.co.jp
naonao&kikaku.mmp.fujitsu.co.jp