Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
2 tcp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by [Bernie_Volz]
2 udp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by [Bernie_Volz]
3 tcp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by [Bernie_Volz]
3 udp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by [Bernie_Volz]
ftp-data 20 tcp File Transfer [Default Data] [Jon_Postel] [Jon_Postel]
ftp-data 20 udp File Transfer [Default Data] [Jon_Postel] [Jon_Postel]
ftp-data 20 sctp FTP [Randall_Stewart] [Randall_Stewart] 2022-02-07 [RFC 9260]
smtp 25 tcp Simple Mail Transfer [IESG] [IETF_Chair] 2017-06-05 [RFC-ietf-emailcore-rfc5321bis-43]
smtp 25 udp Simple Mail Transfer [IESG] [IETF_Chair] 2017-06-05 [RFC-ietf-emailcore-rfc5321bis-43]
nsw-fe 27 tcp NSW User System FE [Robert_Thomas] [Robert_Thomas]
nsw-fe 27 udp NSW User System FE [Robert_Thomas] [Robert_Thomas]
msg-icp 29 tcp MSG ICP [Robert_Thomas] [Robert_Thomas]
msg-icp 29 udp MSG ICP [Robert_Thomas] [Robert_Thomas]
msg-auth 31 tcp MSG Authentication [Robert_Thomas] [Robert_Thomas]
msg-auth 31 udp MSG Authentication [Robert_Thomas] [Robert_Thomas]
mpm-flags 44 tcp MPM FLAGS Protocol
mpm-flags 44 udp MPM FLAGS Protocol
mpm-snd 46 tcp MPM [default send] [Jon_Postel] [Jon_Postel]
mpm-snd 46 udp MPM [default send] [Jon_Postel] [Jon_Postel]
47 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
47 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
re-mail-ck 50 tcp Remote Mail Checking Protocol [Steve_Dorner] [Steve_Dorner]
re-mail-ck 50 udp Remote Mail Checking Protocol [Steve_Dorner] [Steve_Dorner]
51 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
xns-time 52 tcp XNS Time Protocol [Susie_Armstrong] [Susie_Armstrong]
xns-time 52 udp XNS Time Protocol [Susie_Armstrong] [Susie_Armstrong]
xns-ch 54 tcp XNS Clearinghouse [Susie_Armstrong] [Susie_Armstrong]
xns-ch 54 udp XNS Clearinghouse [Susie_Armstrong] [Susie_Armstrong]
isi-gl 55 tcp ISI Graphics Language
isi-gl 55 udp ISI Graphics Language
xns-auth 56 tcp XNS Authentication [Susie_Armstrong] [Susie_Armstrong]
xns-auth 56 udp XNS Authentication [Susie_Armstrong] [Susie_Armstrong]
xns-mail 58 tcp XNS Mail [Susie_Armstrong] [Susie_Armstrong]
xns-mail 58 udp XNS Mail [Susie_Armstrong] [Susie_Armstrong]
61 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
61 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
tacacs-ds 65 tcp TACACS-Database Service [Kathy_Huber] [Kathy_Huber]
tacacs-ds 65 udp TACACS-Database Service [Kathy_Huber] [Kathy_Huber]
sql-net 66 tcp Oracle SQL*NET

IANA assigned this well-formed service name as a replacement for "sql*net".
[Jack_Haverty] [Jack_Haverty]
sql*net 66 tcp Oracle SQL*NET [Jack_Haverty] [Jack_Haverty] This entry is an alias to "sql-net". This entry is now historic, not usable for use with many common service discovery mechanisms.
sql-net 66 udp Oracle SQL*NET

IANA assigned this well-formed service name as a replacement for "sql*net".
[Jack_Haverty] [Jack_Haverty]
sql*net 66 udp Oracle SQL*NET [Jack_Haverty] [Jack_Haverty] This entry is an alias to "sql-net". This entry is now historic, not usable for use with many common service discovery mechanisms.
netrjs-1 71 tcp Remote Job Service
netrjs-1 71 udp Remote Job Service
netrjs-2 72 tcp Remote Job Service
netrjs-2 72 udp Remote Job Service
netrjs-3 73 tcp Remote Job Service
netrjs-3 73 udp Remote Job Service
netrjs-4 74 tcp Remote Job Service [Bob_Braden] [Bob_Braden]
netrjs-4 74 udp Remote Job Service [Bob_Braden] [Bob_Braden]
www-http 80 tcp World Wide Web HTTP [Tim_Berners_Lee] [Tim_Berners_Lee] This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http".
www-http 80 udp World Wide Web HTTP [Tim_Berners_Lee] [Tim_Berners_Lee] This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http".
mit-ml-dev 83 tcp MIT ML Device [David_Reed] [David_Reed]
mit-ml-dev 83 udp MIT ML Device [David_Reed] [David_Reed]
mit-ml-dev 85 tcp MIT ML Device [David_Reed] [David_Reed]
mit-ml-dev 85 udp MIT ML Device [David_Reed] [David_Reed]
su-mit-tg 89 tcp SU/MIT Telnet Gateway [Mark_Crispin] [Mark_Crispin]
su-mit-tg 89 udp SU/MIT Telnet Gateway [Mark_Crispin] [Mark_Crispin]
mit-dov 91 tcp MIT Dover Spooler [Eliot_Moss] [Eliot_Moss]
mit-dov 91 udp MIT Dover Spooler [Eliot_Moss] [Eliot_Moss]
swift-rvf 97 tcp Swift Remote Virtural File Protocol [Maurice_R_Turcotte] [Maurice_R_Turcotte]
swift-rvf 97 udp Swift Remote Virtural File Protocol [Maurice_R_Turcotte] [Maurice_R_Turcotte]
iso-tsap 102 tcp ISO-TSAP Class 0 [Marshall_Rose] [Marshall_Rose]
iso-tsap 102 udp ISO-TSAP Class 0 [Marshall_Rose] [Marshall_Rose]
gppitnp 103 tcp Genesis Point-to-Point Trans Net
gppitnp 103 udp Genesis Point-to-Point Trans Net
acr-nema 104 tcp ACR-NEMA Digital Imag. & Comm. 300 [Patrick_McNamee] [Patrick_McNamee]
acr-nema 104 udp ACR-NEMA Digital Imag. & Comm. 300 [Patrick_McNamee] [Patrick_McNamee]
csnet-ns 105 tcp Mailbox Name Nameserver [Marvin_Solomon] [Marvin_Solomon]
csnet-ns 105 udp Mailbox Name Nameserver [Marvin_Solomon] [Marvin_Solomon]
3com-tsmux 106 tcp 3COM-TSMUX [Jeremy_Siegel] [Jeremy_Siegel] Known Unauthorized Use on 106
3com-tsmux 106 udp 3COM-TSMUX [Jeremy_Siegel] [Jeremy_Siegel] Known Unauthorized Use on 106
pop2 109 tcp Post Office Protocol - Version 2 [Joyce_K_Reynolds] [Joyce_K_Reynolds]
pop2 109 udp Post Office Protocol - Version 2 [Joyce_K_Reynolds] [Joyce_K_Reynolds]
pop3 110 tcp Post Office Protocol - Version 3 [Marshall_Rose] [Marshall_Rose]
pop3 110 udp Post Office Protocol - Version 3 [Marshall_Rose] [Marshall_Rose]
uucp-path 117 tcp UUCP Path Service
uucp-path 117 udp UUCP Path Service
locus-map 125 tcp Locus PC-Interface Net Map Ser [Eric_Peterson] [Eric_Peterson]
locus-map 125 udp Locus PC-Interface Net Map Ser [Eric_Peterson] [Eric_Peterson]
locus-con 127 tcp Locus PC-Interface Conn Server [Eric_Peterson] [Eric_Peterson]
locus-con 127 udp Locus PC-Interface Conn Server [Eric_Peterson] [Eric_Peterson]
gss-xlicen 128 tcp GSS X License Verification [John_Light] [John_Light]
gss-xlicen 128 udp GSS X License Verification [John_Light] [John_Light]
cisco-fna 130 tcp cisco FNATIVE
cisco-fna 130 udp cisco FNATIVE
cisco-tna 131 tcp cisco TNATIVE
cisco-tna 131 udp cisco TNATIVE
cisco-sys 132 tcp cisco SYSMAINT
cisco-sys 132 udp cisco SYSMAINT
ingres-net 134 tcp INGRES-NET Service [Mike_Berrow] [Mike_Berrow]
ingres-net 134 udp INGRES-NET Service [Mike_Berrow] [Mike_Berrow]
netbios-ns 137 tcp NETBIOS Name Service
netbios-ns 137 udp NETBIOS Name Service
netbios-dgm 138 tcp NETBIOS Datagram Service
netbios-dgm 138 udp NETBIOS Datagram Service
netbios-ssn 139 tcp NETBIOS Session Service [Jon_Postel] [Jon_Postel]
netbios-ssn 139 udp NETBIOS Session Service [Jon_Postel] [Jon_Postel]
emfis-data 140 tcp EMFIS Data Service
emfis-data 140 udp EMFIS Data Service

Contact Information

ID Name Organization Contact URI Last Updated
[Bernie_Volz] Bernie Volz mailto:volz&cisco.com
[Bob_Braden] Bob Braden mailto:Braden&isi.edu
[David_Reed] David Reed
[Eliot_Moss] Eliot Moss mailto:EBM&xx.lcs.mit.edu
[Eric_Peterson] Eric Peterson mailto:lcc.eric&seas.ucla.edu
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Jack_Haverty] Jack Haverty mailto:jhaverty&oracle.com
[Jeremy_Siegel] Jeremy Siegel mailto:jzs&nsd.3com.com
[John_Light] John Light mailto:johnl&gssc.gss.com
[Jon_Postel] Jon Postel mailto:postel&isi.edu
[Joyce_K_Reynolds] Joyce K. Reynolds mailto:jkrey&isi.edu
[Kathy_Huber] Kathy Huber mailto:khuber&bbn.com
[Mark_Crispin] Mark Crispin mailto:MRC&panda.com
[Marshall_Rose] Marshall Rose mailto:mrose17&gmail.com 2024-07-29
[Marvin_Solomon] Marvin Solomon mailto:solomon&cs.wisc.edu
[Maurice_R_Turcotte] Maurice R. Turcotte mailto:mailrus!uflorida!rm1!dnmrt%25rmatl@uunet.uu.net
[Mike_Berrow] Mike Berrow
[Patrick_McNamee] Patrick McNamee
[Randall_Stewart] Randall Stewart IETF TSVWG mailto:rrs&lakerest.net
[Robert_Thomas] Robert Thomas mailto:BThomas&f.bbn.com
[Steve_Dorner] Steve Dorner mailto:s-dorner&uiuc.edu
[Susie_Armstrong] Susie Armstrong mailto:Armstrong.wbst128@xerox
[Tim_Berners_Lee] Tim Berners-Lee mailto:timbl&w3.org