Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
10 tcp Unassigned
10 udp Unassigned
http 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
http 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
www 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
100 Unassigned 2012-03-21 Known Unauthorized Use on 100
hostname 101 tcp NIC Host Name Server Jon Postel Jon Postel
hostname 101 udp NIC Host Name Server Jon Postel Jon Postel
iso-tsap 102 tcp ISO-TSAP Class 0 Marshall Rose Marshall Rose
iso-tsap 102 udp ISO-TSAP Class 0 Marshall Rose Marshall Rose
gppitnp 103 tcp Genesis Point-to-Point Trans Net
gppitnp 103 udp Genesis Point-to-Point Trans Net
acr-nema 104 tcp ACR-NEMA Digital Imag. & Comm. 300 Patrick McNamee Patrick McNamee
acr-nema 104 udp ACR-NEMA Digital Imag. & Comm. 300 Patrick McNamee Patrick McNamee
cso 105 tcp CCSO name server protocol Martin Hamilton Martin Hamilton
cso 105 udp CCSO name server protocol Martin Hamilton Martin Hamilton
csnet-ns 105 tcp Mailbox Name Nameserver Marvin Solomon Marvin Solomon
csnet-ns 105 udp Mailbox Name Nameserver Marvin Solomon Marvin Solomon
3com-tsmux 106 tcp 3COM-TSMUX Jeremy Siegel Jeremy Siegel Known Unauthorized Use on 106
3com-tsmux 106 udp 3COM-TSMUX Jeremy Siegel Jeremy Siegel Known Unauthorized Use on 106
rtelnet 107 tcp Remote Telnet Service Jon Postel Jon Postel
rtelnet 107 udp Remote Telnet Service Jon Postel Jon Postel
snagas 108 tcp SNA Gateway Access Server Kevin Murphy Kevin Murphy
snagas 108 udp SNA Gateway Access Server Kevin Murphy Kevin Murphy
pop2 109 tcp Post Office Protocol - Version 2 Joyce K. Reynolds Joyce K. Reynolds
pop2 109 udp Post Office Protocol - Version 2 Joyce K. Reynolds Joyce K. Reynolds
pop3 110 tcp Post Office Protocol - Version 3 Marshall Rose Marshall Rose
pop3 110 udp Post Office Protocol - Version 3 Marshall Rose Marshall Rose
z39-50 210 tcp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 tcp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
z39-50 210 udp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 udp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
225-241 Reserved 2024-12-20 RFC 1060
249-255 Reserved 2024-12-20 RFC 1060
bhmds 310 tcp bhmds John Kelly John Kelly
bhmds 310 udp bhmds John Kelly John Kelly
rpki-rtr 323 tcp Resource PKI to Router Protocol IESG IETF Chair RFC 6810
rpki-rtr-tls 324 tcp Resource PKI to Router Protocol over TLS IESG IETF Chair RFC 6810
decladebug 410 tcp DECLadebug Remote Debug Protocol Hewlett Packard Hewlett Packard
decladebug 410 udp DECLadebug Remote Debug Protocol Hewlett Packard Hewlett Packard
https 443 tcp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 udp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
fcp 510 tcp FirstClass Protocol Mike Marshburn Mike Marshburn
fcp 510 udp FirstClass Protocol Mike Marshburn Mike Marshburn
npmp-local 610 tcp npmp-local
npmp-local 610 udp npmp-local
entrust-ash 710 tcp Entrust Administration Service Handler Peter Whittaker Peter Whittaker
entrust-ash 710 udp Entrust Administration Service Handler Peter Whittaker Peter Whittaker
fcp-udp 810 tcp FCP Paul Whittemore Paul Whittemore
fcp-udp 810 udp FCP Datagram Paul Whittemore Paul Whittemore
kink 910 tcp Kerberized Internet Negotiation of Keys (KINK) RFC 4430
kink 910 udp Kerberized Internet Negotiation of Keys (KINK) RFC 4430
cadlock2 1000 tcp
cadlock2 1000 udp
webpush 1001 tcp HTTP Web Push IESG IETF Chair 2016-11-01 RFC 8030
1001 udp Reserved
1002-1007 Unassigned
1008 udp Possibly used by Sun Solaris????
1009 Unassigned
surf 1010 tcp surf Joseph Geer Joseph Geer
surf 1010 udp surf Joseph Geer Joseph Geer
1011-1020 Reserved
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
1023 tcp Reserved 2024-12-20 RFC 6335
1023 udp Reserved 2024-12-20 RFC 6335
1024 tcp Reserved 2024-12-20 RFC 6335
1024 udp Reserved 2024-12-20 RFC 6335
blackjack 1025 tcp network blackjack
blackjack 1025 udp network blackjack
cap 1026 tcp Calendar Access Protocol Doug Royer Doug Royer 2010-12-09
cap 1026 udp Calendar Access Protocol Doug Royer Doug Royer 2010-12-09
6a44 1027 udp IPv6 Behind NAT44 CPEs IESG IETF Chair 2012-08-02 RFC 6751
1027 tcp Reserved
1028 Deprecated 2004-02
solid-mux 1029 tcp Solid Mux Server Anders Borg Anders Borg 2004-11
solid-mux 1029 udp Solid Mux Server Anders Borg Anders Borg 2004-11
1030 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
1031 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
1032 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
netinfo-local 1033 tcp local netinfo port Marc Majka Marc Majka 2002-08
netinfo-local 1033 udp local netinfo port Marc Majka Marc Majka 2002-08
activesync 1034 tcp ActiveSync Notifications Sandra Vargas Sandra Vargas 2003-03
activesync 1034 udp ActiveSync Notifications Sandra Vargas Sandra Vargas 2003-03
mxxrlogin 1035 tcp MX-XR RPC Valassis John Eckert 2003-04 2015-05-05
mxxrlogin 1035 udp MX-XR RPC Valassis John Eckert 2003-04 2015-05-05
nsstp 1036 tcp Nebula Secure Segment Transfer Protocol Steve Ravida Steve Ravida
nsstp 1036 udp Nebula Secure Segment Transfer Protocol Steve Ravida Steve Ravida
ams 1037 tcp AMS Ronald R. Ohmer Ronald R. Ohmer 2004-02
ams 1037 udp AMS Ronald R. Ohmer Ronald R. Ohmer 2004-02
mtqp 1038 tcp Message Tracking Query Protocol RFC 3887
mtqp 1038 udp Message Tracking Query Protocol RFC 3887
sbl 1039 tcp Streamlined Blackhole Jonathan A. Zdziaraski Jonathan A. Zdziaraski 2004-11

Contact Information

Name Organization Contact URI Last Updated
Anders Borg anders.borg&solid.se 2004-11
Doug Royer DouglasRoyer&gmail.com 2010-12-09
Hewlett Packard
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jeremy Siegel jzs&nsd.3com.com
John Eckert Valassis eckertj&valassis.com 2015-05-05
John Kelly johnk&bellhow.com
Jon Postel postel&isi.edu
Jonathan A. Zdziaraski jonathan&nuclearelephant.com 2004-11
Joseph Geer jgeer&peapod.com
Joyce K. Reynolds jkrey&isi.edu
Kevin Murphy murphy&sevens.lkg.dec.com
Marc Majka majka&apple.com 2002-08
Mark H. Needleman markn&sirsi.com
Marshall Rose mrose17&gmail.com 2024-07-29
Martin Hamilton martin&mrrl.lut.as.uk
Marvin Solomon solomon&cs.wisc.edu
Mike Marshburn paul&softarc.com
Patrick McNamee
Paul Whittemore paul&softarc.com
Peter Whittaker pww&entrust.com
Ronald R. Ohmer rohmer&aisconsulting.net 2004-02
Sandra Vargas Sandrama&microsoft.com 2003-03
Steve Ravida steve.ravida&nebulaholdings.com
Valassis eckertj&valassis.com 2015-05-05