Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
http 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
http 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
www 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
pop3 110 tcp Post Office Protocol - Version 3 Marshall Rose Marshall Rose
pop3 110 udp Post Office Protocol - Version 3 Marshall Rose Marshall Rose
https 443 tcp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 udp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
mctp 1100 tcp MCTP Vitaly Revsin Vitaly Revsin
mctp 1100 udp MCTP Vitaly Revsin Vitaly Revsin
pt2-discover 1101 tcp PT2-DISCOVER Ralph Kammerlander Ralph Kammerlander
pt2-discover 1101 udp PT2-DISCOVER Ralph Kammerlander Ralph Kammerlander
adobeserver-1 1102 tcp ADOBE SERVER 1
adobeserver-1 1102 udp ADOBE SERVER 1
adobeserver-2 1103 tcp ADOBE SERVER 2 Frank Soetebeer Frank Soetebeer
adobeserver-2 1103 udp ADOBE SERVER 2 Frank Soetebeer Frank Soetebeer
xrl 1104 tcp XRL Patrick Robinson Patrick Robinson
xrl 1104 udp XRL Patrick Robinson Patrick Robinson
ftranhc 1105 tcp FTRANHC Eriko Shimada Eriko Shimada
ftranhc 1105 udp FTRANHC Eriko Shimada Eriko Shimada
isoipsigport-1 1106 tcp ISOIPSIGPORT-1
isoipsigport-1 1106 udp ISOIPSIGPORT-1
isoipsigport-2 1107 tcp ISOIPSIGPORT-2 Peter Egli Peter Egli
isoipsigport-2 1107 udp ISOIPSIGPORT-2 Peter Egli Peter Egli
ratio-adp 1108 tcp ratio-adp Oliver Thulke Oliver Thulke
ratio-adp 1108 udp ratio-adp Oliver Thulke Oliver Thulke
1109 Reserved - IANA
webadmstart 1110 tcp Start web admin server
nfsd-keepalive 1110 udp Client status info Beth Crespo Beth Crespo
umsp 2110 tcp UMSP Alexander Bogdanov Alexander Bogdanov
umsp 2110 udp UMSP Alexander Bogdanov Alexander Bogdanov
sim-control 3110 tcp simulator control port Ian Bell Ian Bell
sim-control 3110 udp simulator control port Ian Bell Ian Bell
g2tag 4110 tcp G2 RFID Tag Telemetry Data David Goodall David Goodall 2007-02
g2tag 4110 udp G2 RFID Tag Telemetry Data David Goodall David Goodall 2007-02
5108-5110 Unassigned
softcm 6110 tcp HP SoftBench CM Scott A. Kramer Scott A. Kramer
softcm 6110 udp HP SoftBench CM Scott A. Kramer Scott A. Kramer
ieee11073-20701 6464 tcp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
ieee11073-20701 6464 udp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
8103-8110 Unassigned
9108-9110 Unassigned
nmea-0183 10110 tcp NMEA-0183 Navigational Data Meindert Sprang Meindert Sprang 2009-02-18
nmea-0183 10110 udp NMEA-0183 Navigational Data Meindert Sprang Meindert Sprang 2009-02-18
irisa 11000 tcp IRISA V. A. Brauner V. A. Brauner
irisa 11000 udp IRISA V. A. Brauner V. A. Brauner
metasys 11001 tcp Metasys Tobin Schuster Tobin Schuster
metasys 11001 udp Metasys Tobin Schuster Tobin Schuster
11002-11094 Unassigned
weave 11095 tcp Nest device-to-device and device-to-service application protocol Nest Labs, Inc. Grant Erickson 2014-01-16
weave 11095 udp Nest device-to-device and device-to-service application protocol Nest Labs, Inc. Grant Erickson 2014-01-16
11096-11102 Unassigned
origo-sync 11103 tcp OrigoDB Server Sync Interface Devrex Labs Robert Friberg 2013-03-29
11103 udp Reserved
netapp-icmgmt 11104 tcp NetApp Intercluster Management Craig Everhart Craig Everhart 2010-07-06
11104 udp Reserved
netapp-icdata 11105 tcp NetApp Intercluster Data Craig Everhart Craig Everhart 2010-07-06
11105 udp Reserved
sgi-lk 11106 tcp SGI LK Licensing service Michel Bourget Michel Bourget 2009-01-06
sgi-lk 11106 udp SGI LK Licensing service Michel Bourget Michel Bourget 2009-01-06
11107 Unassigned
myq-termlink 11108 udp Hardware Terminals Discovery and Low-Level Communication Protocol JANUS, spol. s r.o. Jakub Ahmadyar 2013-04-23
11108 tcp Reserved
sgi-dmfmgr 11109 tcp Data migration facility Manager (DMF) is a browser based interface to DMF SGI John Sygulla 2013-01-07
11109 udp Reserved
sgi-soap 11110 tcp Data migration facility (DMF) SOAP is a web server protocol to support remote access to DMF SGI John Sygulla 2013-01-07
11110 udp Reserved
12110-12120 Unassigned
40854-41110 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alexander Bogdanov alexander_bgd&softhome.net
Beth Crespo beth.crespo&hp.com
Craig Everhart Craig.Everhart&netapp.com 2010-07-06
David Goodall david.goodall&g2microsystems.com 2007-02
David Gregorczyk david.gregorczyk&draeger.com 2017-03-02
Devrex Labs robert.friberg&devrex.se 2013-03-29
Eriko Shimada eriko&kel.fujitsu.co.jp
Frank Soetebeer frsoeteb&adobe.com 2003-01
Grant Erickson Nest Labs, Inc. grant&nestlabs.com 2014-01-16
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ian Bell ianb&arca-technologies.com
Jakub Ahmadyar JANUS, spol. s r.o. ahmadyar&myq.cz 2013-04-23
JANUS, spol. s r.o. ahmadyar&myq.cz 2013-04-23
John Sygulla SGI jsygulla&sgi.com 2013-01-07
Marshall Rose mrose17&gmail.com 2024-07-29
Meindert Sprang ms&customware.nl 2009-02-18
Michel Bourget michel&sgi.com 2009-01-06
Nest Labs, Inc. grant&nestlabs.com 2014-01-16
Oliver Thulke oth&ratio.de
Patrick Robinson probinson&plosive.com
Peter Egli peter.egli&inalp.com
Ralph Kammerlander ralph.kammerlander&khe.siemens.de
Robert Friberg Devrex Labs robert.friberg&devrex.se 2013-03-29
SGI jsygulla&sgi.com 2013-01-07
Scott A. Kramer sk&tleilaxu.sde.hp.com
Tobin Schuster tobin.j.schuster&jci.com
V. A. Brauner info&datamedia.fr
Vitaly Revsin vitaly&webmanage.com