Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ntp | 123 | tcp | Network Time Protocol | Dave Mills | Dave Mills | RFC 5905 | |||||
| ntp | 123 | udp | Network Time Protocol | Dave Mills | Dave Mills | RFC 5905 | |||||
| murray | 1123 | tcp | Murray | Stu Mark | Stu Mark | ||||||
| murray | 1123 | udp | Murray | Stu Mark | Stu Mark | ||||||
| periscope | 1230 | tcp | Periscope | Kevin Madden | Kevin Madden | ||||||
| periscope | 1230 | udp | Periscope | Kevin Madden | Kevin Madden | ||||||
| menandmice-lpm | 1231 | tcp | menandmice-lpm | Sigfus Magnusson | Sigfus Magnusson | ||||||
| menandmice-lpm | 1231 | udp | menandmice-lpm | Sigfus Magnusson | Sigfus Magnusson | ||||||
| first-defense | 1232 | tcp | Remote systems monitoring | Nexum, Inc. | Michael Fread | 2012-09-21 | Microsoft (unoffically) using 1232 | ||||
| first-defense | 1232 | udp | Remote systems monitoring | Nexum, Inc. | Michael Fread | 2012-09-21 | Microsoft (unoffically) using 1232 | ||||
| univ-appserver | 1233 | tcp | Universal App Server | Tim Sent | Tim Sent | ||||||
| univ-appserver | 1233 | udp | Universal App Server | Tim Sent | Tim Sent | ||||||
| search-agent | 1234 | tcp | Infoseek Search Agent | Jackie Wu | Jackie Wu | ||||||
| search-agent | 1234 | udp | Infoseek Search Agent | Jackie Wu | Jackie Wu | ||||||
| mosaicsyssvc1 | 1235 | tcp | mosaicsyssvc1 | Brian Matthews | Brian Matthews | ||||||
| mosaicsyssvc1 | 1235 | udp | mosaicsyssvc1 | Brian Matthews | Brian Matthews | ||||||
| bvcontrol | 1236 | tcp | bvcontrol | Daniel J Walsh | Daniel J Walsh | ||||||
| bvcontrol | 1236 | udp | bvcontrol | Daniel J Walsh | Daniel J Walsh | ||||||
| tsdos390 | 1237 | tcp | tsdos390 | Ben Pracht | Ben Pracht | ||||||
| tsdos390 | 1237 | udp | tsdos390 | Ben Pracht | Ben Pracht | ||||||
| hacl-qs | 1238 | tcp | hacl-qs | Farid Faez | Farid Faez | ||||||
| hacl-qs | 1238 | udp | hacl-qs | Farid Faez | Farid Faez | ||||||
| nmsd | 1239 | tcp | NMSD | Yuri Machkasov | Yuri Machkasov | ||||||
| nmsd | 1239 | udp | NMSD | Yuri Machkasov | Yuri Machkasov | ||||||
| gtp-control | 2123 | tcp | GTP-Control Plane (3GPP) | Alessio Casati | Alessio Casati | ||||||
| gtp-control | 2123 | udp | GTP-Control Plane (3GPP) | Alessio Casati | Alessio Casati | ||||||
| edix | 3123 | tcp | EDI Translation Protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| edix | 3123 | udp | EDI Translation Protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| z-wave | 4123 | tcp | Z-Wave Protocol | Sigma Designs, Inc. | Anders Brandt; Mary Miller | 2007-02 | 2012-11-08 | ||||
| z-wave | 4123 | udp | Z-Wave Protocol | Sigma Designs, Inc. | Anders Brandt; Mary Miller | 2007-02 | 2012-11-08 | ||||
| backup-express | 6123 | tcp | Backup Express | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| backup-express | 6123 | udp | Backup Express | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| snif | 7123 | tcp | SNIF End-to-End TLS Relay Control Connection | VESvault Corp | Jim Zubov | 2021-12-24 | 2026-07-22 | draft-zubov-snif-05, Section 4.3 | |||
| snif | 7123 | udp | SNIF End-to-End TLS Relay over QUIC | VESvault Corp | Jim Zubov | 2026-07-22 | 2026-07-22 | draft-zubov-snif-05, Section 4.4 | |||
| 8123-8127 | Unassigned | ||||||||||
| grcp | 9123 | tcp | Global Relay compliant instant messaging protocol | Global Relay Communications Inc | Lu Vo | 2012-11-28 | 2025-06-12 | ||||
| 9123 | udp | Reserved | |||||||||
| 11212-11234 | Unassigned | ||||||||||
| xcompute | 11235 | tcp | numerical systems messaging | Xplicit Computing Inc | Graham J. Orr | 2020-10-16 | |||||
| 11235 | udp | Reserved | |||||||||
| xcompute | 11235 | sctp | numerical systems messaging | Xplicit Computing Inc | Graham J. Orr | 2020-10-16 | |||||
| 11236-11318 | Unassigned | ||||||||||
| linogridengine | 12300 | tcp | LinoGrid Engine | Frans Lundberg | Frans Lundberg | 2004-11 | |||||
| linogridengine | 12300 | udp | LinoGrid Engine | Frans Lundberg | Frans Lundberg | 2004-11 | |||||
| 12301 | Unassigned | ||||||||||
| rads | 12302 | tcp | Remote Administration Daemon (RAD) is a system service that offers secure, remote, programmatic access to Solaris system configuration and run-time state | Oracle Corporation | Devjani Ray | 2012-04-20 | |||||
| 12302 | udp | Reserved | |||||||||
| 12303-12320 | Unassigned | ||||||||||
| warehouse-sss | 12321 | tcp | Warehouse Monitoring Syst SSS | Craig Steffen | Craig Steffen | 2005-08 | |||||
| warehouse-sss | 12321 | udp | Warehouse Monitoring Syst SSS | Craig Steffen | Craig Steffen | 2005-08 | |||||
| warehouse | 12322 | tcp | Warehouse Monitoring Syst | Craig Steffen | Craig Steffen | 2005-08 | |||||
| warehouse | 12322 | udp | Warehouse Monitoring Syst | Craig Steffen | Craig Steffen | 2005-08 | |||||
| 12323-12344 | Unassigned | ||||||||||
| italk | 12345 | tcp | Italk Chat System | Takayuki Ito | Takayuki Ito | ||||||
| italk | 12345 | udp | Italk Chat System | Takayuki Ito | Takayuki Ito | ||||||
| 12346-12545 | Unassigned | ||||||||||
| aurora-balaena | 33123 | tcp | Aurora (Balaena Ltd) | Andrew Mather | Andrew Mather | 2008-02-14 | |||||
| aurora-balaena | 33123 | udp | Aurora (Balaena Ltd) | Andrew Mather | Andrew Mather | 2008-02-14 | |||||
| z-wave-s | 41230 | tcp | Z-Wave Protocol over SSL/TLS | Sigma Designs | Anders Brandt | 2015-06-26 | |||||
| z-wave-s | 41230 | udp | Z-Wave Protocol over DTLS | Sigma Designs | Anders Brandt | 2015-06-26 | |||||
| 41231-41793 | Unassigned | ||||||||||
| z-wave-tunnel | 44123 | tcp | Z-Wave Secure Tunnel | Sigma Designs, Inc. | Anders Brandt | 2012-10-12 | 2015-06-26 | ||||
| 44123 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alessio Casati | a.casati&computer.org | ||
| Anders Brandt | Sigma Designs, Inc. | Anders_Brandt&sigmadesigns.com | 2012-11-08 |
| Anders Brandt | Sigma Designs | anders_brandt&sigmadesigns.com | 2012-10-12 |
| Anders Brandt | Sigma Designs | anders_brandt&sigmadesigns.com | 2015-06-26 |
| Andrew Mather | info&balaena.com | 2008-02-14 | |
| Ben Pracht | ben.pracht&tivoli.com | ||
| Brian Matthews | bmatthews&mosaicsystems.com | ||
| Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 | |
| Chi Shih Chang | Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 |
| Craig Steffen | csteffen&ncsa.uiuc.edu | 2005-08 | |
| Daniel J Walsh | dwalsh&bindview.com | ||
| Dave Mills | mills&udel.edu | 2022-06-03 | |
| Devjani Ray | Oracle Corporation | Devjani.Ray&oracle.com | 2012-04-20 |
| Farid Faez | farid_faez&hp.com | ||
| Frans Lundberg | frans&linova.com | 2004-11 | |
| Global Relay Communications Inc | info&globalrelay.net | 2025-06-12 | |
| Graham J. Orr | graham&xplicitcomputing.com | 2020-10-16 | |
| Jackie Wu | jackiew&infoseek.com | ||
| Jim Zubov | VESvault Corp | jz&vesvault.com | 2021-12-29 |
| Kevin Madden | Kevin&emailxtras.com | ||
| Lu Vo | Global Relay Communications Inc | lu.vo&globalrelay.net | 2025-06-12 |
| Mary Miller | Sigma Designs, Inc. | Mary_Miller&sigmadesigns.com | 2012-11-08 |
| Michael Fread | Nexum, Inc. | mfread&nexuminc.com | 2012-09-21 |
| Nexum, Inc. | mfread&nexuminc.com | 2012-09-21 | |
| Oracle Corporation | Devjani.Ray&oracle.com | 2012-04-20 | |
| Sigfus Magnusson | sigfusm&menandmice.com | ||
| Sigma Designs, Inc. | anders_brandt&sigmadesigns.com | 2011-10-03 | |
| Sigma Designs, Inc. | pr&sdesigns.com | 2012-11-08 | |
| Sigma Designs | anders_brandt&sigmadesigns.com | 2015-06-26 | |
| Stu Mark | fordii&j51.com | ||
| Takayuki Ito | yuki&euc.jp | ||
| Tim Sent | tim.sent&systemsarchitects.com | ||
| VESvault Corp | info&vesvault.com | 2021-12-29 | |
| William Randolph Royere III | william&royere.net | ||
| Xplicit Computing Inc | info&xplicitcomputing.com | 2020-10-16 | |
| Yuri Machkasov | yuri&ptc.com |