Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-09

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER REGISTERED OR NOT.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
14 tcp Unassigned
14 udp Unassigned
finger 79 tcp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
finger 79 udp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
114 unassigned Deprecated June 2004
emfis-data 140 tcp EMFIS Data Service
emfis-data 140 udp EMFIS Data Service
emfis-cntl 141 tcp EMFIS Control Service Gerd Beling Gerd Beling
emfis-cntl 141 udp EMFIS Control Service Gerd Beling Gerd Beling
bl-idm 142 tcp Britton-Lee IDM Susie Snitzer Susie Snitzer
bl-idm 142 udp Britton-Lee IDM Susie Snitzer Susie Snitzer
imap 143 tcp Internet Message Access Protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 9051
143 udp Reserved 2021-02-22 RFC 9051
uma 144 tcp Universal Management Architecture Jay Whitney Jay Whitney
uma 144 udp Universal Management Architecture Jay Whitney Jay Whitney
uaac 145 tcp UAAC Protocol David A. Gomberg David A. Gomberg
uaac 145 udp UAAC Protocol David A. Gomberg David A. Gomberg
iso-tp0 146 tcp ISO-IP0
iso-tp0 146 udp ISO-IP0
iso-ip 147 tcp ISO-IP Marshall Rose Marshall Rose
iso-ip 147 udp ISO-IP Marshall Rose Marshall Rose
jargon 148 tcp Jargon Bill Weinman Bill Weinman
jargon 148 udp Jargon Bill Weinman Bill Weinman
aed-512 149 tcp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
aed-512 149 udp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
914c-g 211 tcp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 tcp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
914c-g 211 udp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 udp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
vmpwscs 214 tcp VM PWSCS Dan Shia Dan Shia
vmpwscs 214 udp VM PWSCS Dan Shia Dan Shia
opalis-robot 314 tcp Opalis Robot Laurent Domenech Laurent Domenech
opalis-robot 314 udp Opalis Robot Laurent Domenech Laurent Domenech
infoseek 414 tcp InfoSeek Steve Kirsch Steve Kirsch
infoseek 414 udp InfoSeek Steve Kirsch Steve Kirsch
submissions 465 tcp Message Submission over TLS protocol IESG IETF Chair 2017-12-12 RFC 8314
shell 514 tcp cmd like exec, but automatic authentication is performed as for login server
syslog 514 udp 2020-06-01 RFC 5426
sshell 614 tcp SSLshell Simon J. Gerraty Simon J. Gerraty
sshell 614 udp SSLshell Simon J. Gerraty Simon J. Gerraty
iris-xpcs 714 tcp IRIS over XPCS RFC 4992
iris-xpcs 714 udp IRIS over XPCS RFC 4992
iscsi 860 tcp iSCSI IESG IETF Chair 2013-08-27 RFC 7143
iscsi 860 udp iSCSI IESG IETF Chair 2013-08-27 RFC 7143
914 tcp Reserved
rift-lies 914 udp Routing in Fat Trees Link Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
imaps 993 tcp IMAP over TLS protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 8314; RFC 9051
pop3s 995 tcp POP3 over TLS protocol IESG IETF Chair 2017-12-12 RFC 8314
mini-sql 1114 tcp Mini SQL David Hughes David Hughes
mini-sql 1114 udp Mini SQL David Hughes David Hughes
autonoc 1140 tcp AutoNOC Network Operations Protocol Kyle Lussier Kyle Lussier 2005-12
autonoc 1140 udp AutoNOC Network Operations Protocol Kyle Lussier Kyle Lussier 2005-12
mxomss 1141 tcp User Message Service Chaoyi Lang Chaoyi Lang 2006-01
mxomss 1141 udp User Message Service Chaoyi Lang Chaoyi Lang 2006-01
edtools 1142 tcp User Discovery Service Lee Dolson Lee Dolson 2006-01
edtools 1142 udp User Discovery Service Lee Dolson Lee Dolson 2006-01
imyx 1143 tcp Infomatryx Exchange David Walling David Walling 2006-03
imyx 1143 udp Infomatryx Exchange David Walling David Walling 2006-03
fuscript 1144 tcp Fusion Script Peter Loveday Peter Loveday 2006-01
fuscript 1144 udp Fusion Script Peter Loveday Peter Loveday 2006-01
x9-icue 1145 tcp X9 iCue Show Control Brandon Potter Brandon Potter 2006-01
x9-icue 1145 udp X9 iCue Show Control Brandon Potter Brandon Potter 2006-01
audit-transfer 1146 tcp audit transfer Mark Wahl Mark Wahl 2005-11
audit-transfer 1146 udp audit transfer Mark Wahl Mark Wahl 2005-11
capioverlan 1147 tcp CAPIoverLAN Diego Friedel Diego Friedel 2005-11
capioverlan 1147 udp CAPIoverLAN Diego Friedel Diego Friedel 2005-11
elfiq-repl 1148 tcp Elfiq Replication Service Frederick Parent Frederick Parent 2005-11
elfiq-repl 1148 udp Elfiq Replication Service Frederick Parent Frederick Parent 2005-11
bvtsonar 1149 tcp BlueView Sonar Service Teledyne BlueView, Inc. Cat Zimmermann 2005-11 2012-09-19
bvtsonar 1149 udp BlueView Sonar Service Teledyne BlueView, Inc. Cat Zimmermann 2005-11 2012-09-19
c1222-acse 1153 tcp ANSI C12.22 Port RFC 6142
c1222-acse 1153 udp ANSI C12.22 Port RFC 6142
kazaa 1214 tcp KAZAA Ahti Heinla Ahti Heinla
kazaa 1214 udp KAZAA Ahti Heinla Ahti Heinla
1276 tcp Reserved 2014-05-23 This entry has been removed on 2014-05-23.
1276 udp Reserved 2014-05-23 This entry has been removed on 2014-05-23.
pdps 1314 tcp Photoscript Distributed Printing System Les Klein Les Klein
pdps 1314 udp Photoscript Distributed Printing System Les Klein Les Klein
cadkey-tablet 1400 tcp Cadkey Tablet Daemon Joe McCollough Joe McCollough
cadkey-tablet 1400 udp Cadkey Tablet Daemon Joe McCollough Joe McCollough
goldleaf-licman 1401 tcp Goldleaf License Manager John Fox John Fox
goldleaf-licman 1401 udp Goldleaf License Manager John Fox John Fox
prm-sm-np 1402 tcp Prospero Resource Manager
prm-sm-np 1402 udp Prospero Resource Manager
prm-nm-np 1403 tcp Prospero Resource Manager B. Clifford Neuman B. Clifford Neuman
prm-nm-np 1403 udp Prospero Resource Manager B. Clifford Neuman B. Clifford Neuman
igi-lm 1404 tcp Infinite Graphics License Manager
igi-lm 1404 udp Infinite Graphics License Manager
ibm-res 1405 tcp IBM Remote Execution Starter
ibm-res 1405 udp IBM Remote Execution Starter
netlabs-lm 1406 tcp NetLabs License Manager
netlabs-lm 1406 udp NetLabs License Manager
tibet-server 1407 tcp TIBET Data Server Technical Pursuit Inc. Scott Shattuck 2015-06-16 This port has been retasked on 2015-06-16.
1407 udp Reserved This port has been removed on 2015-06-16.
sophia-lm 1408 tcp Sophia License Manager Eric Brown Eric Brown
sophia-lm 1408 udp Sophia License Manager Eric Brown Eric Brown
here-lm 1409 tcp Here License Manager David Ison David Ison
here-lm 1409 udp Here License Manager David Ison David Ison
hiq 1410 tcp HiQ License Manager Rick Pugh Rick Pugh

Contact Information

Name Organization Contact URI Last Updated
Ahti Heinla ahti&ahti.bluemoon.ee 2002-06
Albert G. Broscius broscius&dsl.cis.upenn.edu
B. Clifford Neuman bcn&isi.edu 2022-02-18
Bill Harrell
Bill Weinman wew&bearnet.com
Brandon Potter iana&brandonpotter.com 2006-01
Cat Zimmermann Teledyne BlueView, Inc. czimmermann&teledyne.com 2012-09-19
Chaoyi Lang chao-yi_lang&maxtor.com 2006-01
Dan Shia dset!shia&uunet.uu.net
David A. Gomberg gomberg&gateway.mitre.org
David Hughes bambi&hughes.com.au
David Ison here&dialup.oar.net
David Walling sylvanhollow&yahoo.com 2006-03
David Zimmerman dpz&rutgers.edu
Diego Friedel d.friedel&avm.de 2006-03
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Eric Brown sst!emerald!eric&uunet.uu.net
Frederick Parent fparent&elfiq.com 2005-11
Gerd Beling GBELING&isi.edu
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jay Whitney jw&powercenter.com
Joe McCollough joe&cadkey.com
John Fox
Kyle Lussier klussier&autonoc.com 2005-12
Laurent Domenech Opalis ldomenech&opalis.com
Lee Dolson dolson&f-net.co.kr 2006-01
Les Klein sgy&cix.compulink.co.uk
Mark Wahl mark.wahl&informed-control.com 2005-11
Marshall Rose mrose17&gmail.com 2024-07-29
Peter Loveday peter&eyeonline.com 2006-01
Rick Pugh rick&bilmillennium.com
Scott Shattuck Technical Pursuit Inc. ss&technicalpursuit.com 2015-06-16
Simon J. Gerraty sjg&quick.com.au
Steve Kirsch stk&infoseek.com
Susie Snitzer
Technical Pursuit Inc. ss&technicalpursuit.com 2015-06-16
Teledyne BlueView, Inc. czimmermann&teledyne.com 2012-09-19