Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
jargon 148 tcp Jargon Bill Weinman Bill Weinman
jargon 148 udp Jargon Bill Weinman Bill Weinman
elfiq-repl 1148 tcp Elfiq Replication Service Frederick Parent Frederick Parent 2005-11
elfiq-repl 1148 udp Elfiq Replication Service Frederick Parent Frederick Parent 2005-11
pacerforum 1480 tcp PacerForum Peter Caswell Peter Caswell
pacerforum 1480 udp PacerForum Peter Caswell Peter Caswell
airs 1481 tcp AIRS Bruce Wilson Bruce Wilson
airs 1481 udp AIRS Bruce Wilson Bruce Wilson
miteksys-lm 1482 tcp Miteksys License Manager Shane McRoberts Shane McRoberts
miteksys-lm 1482 udp Miteksys License Manager Shane McRoberts Shane McRoberts
afs 1483 tcp AFS License Manager Michael R. Pizolato Michael R. Pizolato
afs 1483 udp AFS License Manager Michael R. Pizolato Michael R. Pizolato
confluent 1484 tcp Confluent License Manager James Greenfiel James Greenfiel
confluent 1484 udp Confluent License Manager James Greenfiel James Greenfiel
lansource 1485 tcp LANSource Christopher Wells Christopher Wells
lansource 1485 udp LANSource Christopher Wells Christopher Wells
nms-topo-serv 1486 tcp nms_topo_serv

IANA assigned this well-formed service name as a replacement for "nms_topo_serv".
Sylvia Siu Sylvia Siu
nms_topo_serv 1486 tcp nms_topo_serv Sylvia Siu Sylvia Siu This entry is an alias to "nms-topo-serv". This entry is now historic, not usable for use with many common service discovery mechanisms.
nms-topo-serv 1486 udp nms_topo_serv

IANA assigned this well-formed service name as a replacement for "nms_topo_serv".
Sylvia Siu Sylvia Siu
nms_topo_serv 1486 udp nms_topo_serv Sylvia Siu Sylvia Siu This entry is an alias to "nms-topo-serv". This entry is now historic, not usable for use with many common service discovery mechanisms.
localinfosrvr 1487 tcp LocalInfoSrvr Brian Matthews Brian Matthews
localinfosrvr 1487 udp LocalInfoSrvr Brian Matthews Brian Matthews
docstor 1488 tcp DocStor Brian Spears Brian Spears
docstor 1488 udp DocStor Brian Spears Brian Spears
dmdocbroker 1489 tcp dmdocbroker Razmik Abnous Razmik Abnous
dmdocbroker 1489 udp dmdocbroker Razmik Abnous Razmik Abnous
veritas-ucl 2148 tcp VERITAS UNIVERSAL COMMUNICATION LAYER Songlin Ren Songlin Ren
veritas-ucl 2148 udp VERITAS UNIVERSAL COMMUNICATION LAYER Songlin Ren Songlin Ren
nm-game-admin 3148 tcp NetMike Game Administrator
nm-game-admin 3148 udp NetMike Game Administrator
hhb-handheld 4148 tcp HHB Handheld Client Steven G. Loughner Steven G. Loughner 2007-03
hhb-handheld 4148 udp HHB Handheld Client Steven G. Loughner Steven G. Loughner 2007-03
ricardo-lm 6148 tcp Ricardo North America License Manager M Flemming M Flemming
ricardo-lm 6148 udp Ricardo North America License Manager M Flemming M Flemming
isdd 8148 tcp i-SDD file transfer Frank Waarsenburg Frank Waarsenburg 2004-11
isdd 8148 udp i-SDD file transfer Frank Waarsenburg Frank Waarsenburg 2004-11
11435-11488 Unassigned Known UNAUTHORIZED USE: port 11488
asgcypresstcps 11489 tcp ASG Cypress Secure Only David Luxford David Luxford 2010-07-01
11489 udp Reserved
14146-14148 Unassigned
est-coaps udp EST over secure CoAP (EST-coaps) Toerless Eckert Toerless Eckert 2022-05-03 2022-05-04 RFC 9148. Defined TXT keys: None

Contact Information

Name Contact URI Last Updated
Bill Weinman wew&bearnet.com
Brian Matthews brian_matthews&ibist.ibis.com
Brian Spears bspears&salix.com
Bruce Wilson tel:+1-905-771-6161
Christopher Wells Christopher_Wells&3com.com
David Luxford david.luxford&asg.com 2010-07-01
Frank Waarsenburg frank&eye-display.nl 2004-11
Frederick Parent fparent&elfiq.com 2005-11
James Greenfiel jim&pa.confluent.com
M Flemming mflemming&aol.com
Michael R. Pizolato michael&afs.com
Peter Caswell pfc&pacvax.pacersoft.com
Razmik Abnous abnous&documentum.com
Shane McRoberts mcroberts&miteksys.com
Songlin Ren ren&veritas.com
Steven G. Loughner stevengloughner&eaton.com 2007-03
Sylvia Siu Sylvia_Siu&novell.co
Toerless Eckert tte&cs.fau.de 2022-05-03