Service Name and Transport Protocol Port Number Registry

Last Updated
2026-09-30
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
15 tcp Unassigned [was netstat]
15 udp Unassigned
sftp 115 tcp Simple File Transfer Protocol [Mark_Lottor] [Mark_Lottor]
sftp 115 udp Simple File Transfer Protocol [Mark_Lottor] [Mark_Lottor]
sql-net 150 tcp SQL-NET [Martin_Picard] [Martin_Picard]
sql-net 150 udp SQL-NET [Martin_Picard] [Martin_Picard]
hems 151 tcp HEMS
hems 151 udp HEMS
bftp 152 tcp Background File Transfer Program [Annette_DeSchon] [Annette_DeSchon]
bftp 152 udp Background File Transfer Program [Annette_DeSchon] [Annette_DeSchon]
sgmp 153 tcp SGMP [Marty_Schoffstahl] [Marty_Schoffstahl]
sgmp 153 udp SGMP [Marty_Schoffstahl] [Marty_Schoffstahl]
netsc-prod 154 tcp NETSC
netsc-prod 154 udp NETSC
netsc-dev 155 tcp NETSC [Sergio_Heker] [Sergio_Heker]
netsc-dev 155 udp NETSC [Sergio_Heker] [Sergio_Heker]
sqlsrv 156 tcp SQL Service [Craig_Rogers] [Craig_Rogers]
sqlsrv 156 udp SQL Service [Craig_Rogers] [Craig_Rogers]
knet-cmp 157 tcp KNET/VM Command/Message Protocol [Gary_S_Malkin] [Gary_S_Malkin]
knet-cmp 157 udp KNET/VM Command/Message Protocol [Gary_S_Malkin] [Gary_S_Malkin]
pcmail-srv 158 tcp PCMail Server [Mark_L_Lambert] [Mark_L_Lambert]
pcmail-srv 158 udp PCMail Server [Mark_L_Lambert] [Mark_L_Lambert]
nss-routing 159 tcp NSS-Routing [Yakov_Rekhter] [Yakov_Rekhter]
nss-routing 159 udp NSS-Routing [Yakov_Rekhter] [Yakov_Rekhter]
softpc 215 tcp Insignia Solutions [Martyn_Thomas] [Martyn_Thomas]
softpc 215 udp Insignia Solutions [Martyn_Thomas] [Martyn_Thomas]
dpsi 315 tcp DPSI [Tony_Scamurra] [Tony_Scamurra]
dpsi 315 udp DPSI [Tony_Scamurra] [Tony_Scamurra]
bnet 415 tcp BNet [Jim_Mertz] [Jim_Mertz]
bnet 415 udp BNet [Jim_Mertz] [Jim_Mertz]
snpp 444 tcp Simple Network Paging Protocol [RFC 1568]
snpp 444 udp Simple Network Paging Protocol [RFC 1568]
printer 515 tcp spooler
printer 515 udp spooler
dhcpv6-client 546 udp DHCPv6 Client [IESG] [IETF_Chair] 2018-05-21 [RFC 9915]
dhcpv6-server 547 udp DHCPv6 Server [IESG] [IETF_Chair] 2018-05-21 [RFC 9915]
sco-inetmgr 615 tcp Internet Configuration Manager
sco-inetmgr 615 udp Internet Configuration Manager
dhcp-failover 647 tcp DHCP Failover [IESG] [IETF_Chair] 2018-05-21 [RFC 8156]
iris-lwz 715 tcp IRIS-LWZ [RFC 4993]
iris-lwz 715 udp IRIS-LWZ [RFC 4993]
915 tcp Reserved
rift-ties 915 udp Routing in Fat Trees Topology Information Element [IESG] [IETF_Chair] 2023-02-17 2024-06-07 [RFC 9692]
ardus-trns 1115 tcp ARDUS Transfer
ardus-trns 1115 udp ARDUS Transfer
blaze 1150 tcp Blaze File Server [Curt_Schimmel] [Curt_Schimmel] 2005-11
blaze 1150 udp Blaze File Server [Curt_Schimmel] [Curt_Schimmel] 2005-11
unizensus 1151 tcp Unizensus Login Server [Dirk_Materlik] [Dirk_Materlik] 2005-11
unizensus 1151 udp Unizensus Login Server [Dirk_Materlik] [Dirk_Materlik] 2005-11
winpoplanmess 1152 tcp Winpopup LAN Messenger [Vitali_Fomine] [Vitali_Fomine] 2005-11
winpoplanmess 1152 udp Winpopup LAN Messenger [Vitali_Fomine] [Vitali_Fomine] 2005-11
c1222-acse 1153 tcp ANSI C12.22 Port [RFC 6142]
c1222-acse 1153 udp ANSI C12.22 Port [RFC 6142]
resacommunity 1154 tcp Community Service [Stephane_MONS] [Stephane_MONS] 2005-09
resacommunity 1154 udp Community Service [Stephane_MONS] [Stephane_MONS] 2005-09
nfa 1155 tcp Network File Access [James_Powell] [James_Powell]
nfa 1155 udp Network File Access [James_Powell] [James_Powell]
iascontrol-oms 1156 tcp iasControl OMS [Todd_Guay] [Todd_Guay] 2004-11
iascontrol-oms 1156 udp iasControl OMS [Todd_Guay] [Todd_Guay] 2004-11
iascontrol 1157 tcp Oracle iASControl [Todd_Guay] [Todd_Guay] 2004-11
iascontrol 1157 udp Oracle iASControl [Todd_Guay] [Todd_Guay] 2004-11
dbcontrol-oms 1158 tcp dbControl OMS [Todd_Guay] [Todd_Guay] 2004-11
dbcontrol-oms 1158 udp dbControl OMS [Todd_Guay] [Todd_Guay] 2004-11
oracle-oms 1159 tcp Oracle OMS [Todd_Guay] [Todd_Guay] 2004-11
oracle-oms 1159 udp Oracle OMS [Todd_Guay] [Todd_Guay] 2004-11
scanstat-1 1215 tcp scanSTAT 1.0 [William_Scheding] [William_Scheding]
scanstat-1 1215 udp scanSTAT 1.0 [William_Scheding] [William_Scheding]
els 1315 tcp E.L.S., Event Listener Service [Jim_Cleppe] [Jim_Cleppe]
els 1315 udp E.L.S., Event Listener Service [Jim_Cleppe] [Jim_Cleppe]
tibet-server 1407 tcp TIBET Data Server [Technical_Pursuit_Inc] [Scott_Shattuck] 2015-06-16 This port has been retasked on 2015-06-16.
1407 udp Reserved This port has been removed on 2015-06-16.
dbstar 1415 tcp DBStar [Jeffrey_Millman] [Jeffrey_Millman]
dbstar 1415 udp DBStar [Jeffrey_Millman] [Jeffrey_Millman]
vlsi-lm 1500 tcp VLSI License Manager [Shue_Lin_Kuo] [Shue_Lin_Kuo]
vlsi-lm 1500 udp VLSI License Manager [Shue_Lin_Kuo] [Shue_Lin_Kuo]
saiscm 1501 tcp Satellite-data Acquisition System 3 [Bill_Taylor] [Bill_Taylor]
saiscm 1501 udp Satellite-data Acquisition System 3 [Bill_Taylor] [Bill_Taylor]
shivadiscovery 1502 tcp Shiva [Jonathan_Wenocur] [Jonathan_Wenocur]
shivadiscovery 1502 udp Shiva [Jonathan_Wenocur] [Jonathan_Wenocur]
imtc-mcs 1503 tcp Databeam [Jim_Johnston] [Jim_Johnston]
imtc-mcs 1503 udp Databeam [Jim_Johnston] [Jim_Johnston]
evb-elm 1504 tcp EVB Software Engineering License Manager [B_G_Mahesh] [B_G_Mahesh]
evb-elm 1504 udp EVB Software Engineering License Manager [B_G_Mahesh] [B_G_Mahesh]
funkproxy 1505 tcp Funk Software, Inc. [Robert_D_Vincent] [Robert_D_Vincent]
funkproxy 1505 udp Funk Software, Inc. [Robert_D_Vincent] [Robert_D_Vincent]
utcd 1506 tcp Universal Time daemon (utcd) [Walter_Poxon] [Walter_Poxon]
utcd 1506 udp Universal Time daemon (utcd) [Walter_Poxon] [Walter_Poxon]
symplex 1507 tcp symplex [Mike_Turley] [Mike_Turley]
symplex 1507 udp symplex [Mike_Turley] [Mike_Turley]
diagmond 1508 tcp diagmond [Pete_Moscatelli] [Pete_Moscatelli]
diagmond 1508 udp diagmond [Pete_Moscatelli] [Pete_Moscatelli]
robcad-lm 1509 tcp Robcad, Ltd. License Manager [Hindin_Joseph] [Hindin_Joseph]
robcad-lm 1509 udp Robcad, Ltd. License Manager [Hindin_Joseph] [Hindin_Joseph]
mvx-lm 1510 tcp Midland Valley Exploration Ltd. Lic. Man. [Neil_Salter] [Neil_Salter]
mvx-lm 1510 udp Midland Valley Exploration Ltd. Lic. Man. [Neil_Salter] [Neil_Salter]
3l-l1 1511 tcp 3l-l1 [Ian_A_Young] [Ian_A_Young]
3l-l1 1511 udp 3l-l1 [Ian_A_Young] [Ian_A_Young]
wins 1512 tcp Microsoft's Windows Internet Name Service [Pradeep_Bahl] [Pradeep_Bahl]
wins 1512 udp Microsoft's Windows Internet Name Service [Pradeep_Bahl] [Pradeep_Bahl]
fujitsu-dtc 1513 tcp Fujitsu Systems Business of America, Inc

Contact Information

ID Name Organization Contact URI Last Updated
[Annette_DeSchon] Annette DeSchon mailto:DESCHON&isi.edu
[B_G_Mahesh] B.G. Mahesh mailto:mahesh&sett.com
[Bill_Taylor] Bill Taylor mailto:sais&ssec.wisc.edu
[Craig_Rogers] Craig Rogers mailto:Rogers&isi.edu
[Curt_Schimmel] Curt Schimmel mailto:curt&small-tree.com 2005-11
[Dirk_Materlik] Dirk Materlik mailto:materlik&blubbsoft.de 2005-11
[Gary_S_Malkin] Gary S. Malkin mailto:GMALKIN&xylogics.com
[Hindin_Joseph] Hindin Joseph mailto:hindin%25robcad@uunet.uu.net
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Ian_A_Young] Ian A. Young mailto:iay&threel.co.uk
[James_Powell] James Powell mailto:james&mailhost.unidata.com
[Jeffrey_Millman] Jeffrey Millman mailto:jcm&dbstar.com
[Jim_Cleppe] Jim Cleppe mailto:clep13&hotmail.com
[Jim_Johnston] Jim Johnston mailto:jjohnston&databeam.com
[Jim_Mertz] Jim Mertz mailto:JMertz+RV09&rvdc.unisys.com
[Jonathan_Wenocur] Jonathan Wenocur mailto:jhw&shiva.com
[Mark_L_Lambert] Mark L. Lambert mailto:markl&ptt.lcs.mit.edu
[Mark_Lottor] Mark Lottor mailto:MKL&nisc.sri.com
[Martin_Picard] Martin Picard
[Marty_Schoffstahl] Marty Schoffstahl mailto:schoff&nisc.nyser.net
[Martyn_Thomas] Martyn Thomas
[Mike_Turley] Mike Turley mailto:turley&symplex.com
[Neil_Salter] Neil Salter mailto:neil&indigo2.mvel.demon.co.uk
[Pete_Moscatelli] Pete Moscatelli mailto:moscat&hprdstl0.rose.hp.com
[Pradeep_Bahl] Pradeep Bahl mailto:pradeepb&microsoft.com
[Robert_D_Vincent] Robert D. Vincent mailto:bert&willowpond.com
[Scott_Shattuck] Scott Shattuck Technical Pursuit Inc. mailto:ss&technicalpursuit.com 2015-06-16
[Sergio_Heker] Sergio Heker mailto:heker&jvncc.csc.org
[Shue_Lin_Kuo] Shue-Lin Kuo mailto:shuelin&mdk.sanjose.vlsi.com
[Stephane_MONS] Stéphane MONS mailto:stephane.mons&free.fr 2005-09
[Technical_Pursuit_Inc] Technical Pursuit Inc. mailto:ss&technicalpursuit.com 2015-06-16
[Todd_Guay] Todd Guay mailto:todd.guay&oracle.com 2005-08
[Tony_Scamurra] Tony Scamurra mailto:Tony&desktoppaging.com
[Vitali_Fomine] Vitali Fomine mailto:info&winpopup-lan-messenger.com 2005-11
[Walter_Poxon] Walter Poxon mailto:wdp&ironwood.cray.com
[William_Scheding] William Scheding mailto:wls&wls.org
[Yakov_Rekhter] Yakov Rekhter mailto:Yakov&ibm.com