Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
16 tcp Unassigned
16 udp Unassigned
ansanotify 116 tcp ANSA REX Notify Nicola J. Howarth Nicola J. Howarth
ansanotify 116 udp ANSA REX Notify Nicola J. Howarth Nicola J. Howarth
sgmp-traps 160 tcp SGMP-TRAPS Marty Schoffstahl Marty Schoffstahl
sgmp-traps 160 udp SGMP-TRAPS Marty Schoffstahl Marty Schoffstahl
snmp 161 tcp SNMP
snmp 161 udp SNMP
snmptrap 162 tcp SNMPTRAP Marshall Rose Marshall Rose
snmptrap 162 udp SNMPTRAP Marshall Rose Marshall Rose
cmip-man 163 tcp CMIP/TCP Manager
cmip-man 163 udp CMIP/TCP Manager
cmip-agent 164 tcp CMIP/TCP Agent Amatzia Ben-Artzi Amatzia Ben-Artzi
cmip-agent 164 udp CMIP/TCP Agent Amatzia Ben-Artzi Amatzia Ben-Artzi
xns-courier 165 tcp Xerox Susie Armstrong Susie Armstrong
xns-courier 165 udp Xerox Susie Armstrong Susie Armstrong
s-net 166 tcp Sirius Systems Brian Lloyd Brian Lloyd
s-net 166 udp Sirius Systems Brian Lloyd Brian Lloyd
namp 167 tcp NAMP Marty Schoffstahl Marty Schoffstahl
namp 167 udp NAMP Marty Schoffstahl Marty Schoffstahl
rsvd 168 tcp RSVD Alan Sandell Alan Sandell 2008-05-01
rsvd 168 udp RSVD Alan Sandell Alan Sandell 2008-05-01
send 169 tcp SEND William Oldwin William Oldwin 2019-04-22
send 169 udp SEND William Oldwin William Oldwin 2019-04-22
CAIlic 216 tcp Computer Associates Int'l License Server Chuck Spitz Chuck Spitz
CAIlic 216 udp Computer Associates Int'l License Server Chuck Spitz Chuck Spitz
decauth 316 tcp decAuth Michael Agishtein Michael Agishtein
decauth 316 udp decAuth Michael Agishtein Michael Agishtein
359 tcp Reserved 2023-11-16 De-Assigned on 2023-11-16.
359 udp Reserved 2023-11-16 De-Assigned on 2023-11-16.
silverplatter 416 tcp Silverplatter Peter Ciuffetti Peter Ciuffetti
silverplatter 416 udp Silverplatter Peter Ciuffetti Peter Ciuffetti
videotex 516 tcp videotex Daniel Mavrakis Daniel Mavrakis
videotex 516 udp videotex Daniel Mavrakis Daniel Mavrakis
sco-sysmgr 616 tcp SCO System Administration Server
sco-sysmgr 616 udp SCO System Administration Server
pana 716 udp PANA Messages RFC 5191
916-952 Unassigned
ardus-cntl 1116 tcp ARDUS Control
ardus-cntl 1116 udp ARDUS Control
olsv 1160 tcp DB Lite Mult-User Server Philip Stephenson Philip Stephenson 2005-08
olsv 1160 udp DB Lite Mult-User Server Philip Stephenson Philip Stephenson 2005-08
health-polling 1161 tcp Health Polling
health-polling 1161 udp Health Polling
health-trap 1162 tcp Health Trap
health-trap 1162 udp Health Trap
sddp 1163 tcp SmartDialer Data Protocol Lee Griffiths Lee Griffiths 2004-11
sddp 1163 udp SmartDialer Data Protocol Lee Griffiths Lee Griffiths 2004-11
qsm-proxy 1164 tcp QSM Proxy Service Norm Lunde Norm Lunde 2004-11
qsm-proxy 1164 udp QSM Proxy Service Norm Lunde Norm Lunde 2004-11
qsm-gui 1165 tcp QSM GUI Service Norm Lunde Norm Lunde 2004-11
qsm-gui 1165 udp QSM GUI Service Norm Lunde Norm Lunde 2004-11
qsm-remote 1166 tcp QSM RemoteExec Norm Lunde Norm Lunde 2004-11
qsm-remote 1166 udp QSM RemoteExec Norm Lunde Norm Lunde 2004-11
cisco-ipsla 1167 tcp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
cisco-ipsla 1167 udp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
cisco-ipsla 1167 sctp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
vchat 1168 tcp VChat Conference Service Andreas Wetzel Andreas Wetzel 2002-09
vchat 1168 udp VChat Conference Service Andreas Wetzel Andreas Wetzel 2002-09
tripwire 1169 tcp TRIPWIRE Ed Metcalf; Albert Holt Ed Metcalf; Albert Holt
tripwire 1169 udp TRIPWIRE Ed Metcalf; Albert Holt Ed Metcalf; Albert Holt
etebac5 1216 tcp ETEBAC 5 Jean-Louis Barbut Jean-Louis Barbut
etebac5 1216 udp ETEBAC 5 Jean-Louis Barbut Jean-Louis Barbut
exbit-escp 1316 tcp Exbit-ESCP Morten Christensen Morten Christensen
exbit-escp 1316 udp Exbit-ESCP Morten Christensen Morten Christensen
tibet-server 1407 tcp TIBET Data Server Technical Pursuit Inc. Scott Shattuck 2015-06-16 This port has been retasked on 2015-06-16.
1407 udp Reserved This port has been removed on 2015-06-16.
novell-lu6-2 1416 tcp Novell LU6.2

IANA assigned this well-formed service name as a replacement for "novell-lu6.2".
Peter Liu Peter Liu
novell-lu6.2 1416 tcp Novell LU6.2 Peter Liu Peter Liu This entry is an alias to "novell-lu6-2". This entry is now historic, not usable for use with many common service discovery mechanisms.
novell-lu6-2 1416 udp Novell LU6.2

IANA assigned this well-formed service name as a replacement for "novell-lu6.2".
Peter Liu Peter Liu
novell-lu6.2 1416 udp Novell LU6.2 Peter Liu Peter Liu This entry is an alias to "novell-lu6-2". This entry is now historic, not usable for use with many common service discovery mechanisms.
vpad 1516 tcp Virtual Places Audio data
vpad 1516 udp Virtual Places Audio data
issd 1600 tcp issd
issd 1600 udp issd
aas 1601 tcp aas Bob Beard Bob Beard
aas 1601 udp aas Bob Beard Bob Beard
inspect 1602 tcp inspect Frank O'Neill Frank O'Neill
inspect 1602 udp inspect Frank O'Neill Frank O'Neill
picodbc 1603 tcp pickodbc John Lombardo John Lombardo
picodbc 1603 udp pickodbc John Lombardo John Lombardo
icabrowser 1604 tcp icabrowser Brad Pedersen Brad Pedersen
icabrowser 1604 udp icabrowser Brad Pedersen Brad Pedersen
slp 1605 tcp Salutation Manager (Salutation Protocol)
slp 1605 udp Salutation Manager (Salutation Protocol)
slm-api 1606 tcp Salutation Manager (SLM-API) Tohru Mori Tohru Mori
slm-api 1606 udp Salutation Manager (SLM-API) Tohru Mori Tohru Mori
stt 1607 tcp stt Ryan Bolz Ryan Bolz
stt 1607 udp stt Ryan Bolz Ryan Bolz
smart-lm 1608 tcp Smart Corp. License Manager Connie Qiu Connie Qiu
smart-lm 1608 udp Smart Corp. License Manager Connie Qiu Connie Qiu
isysg-lm 1609 tcp isysg-lm Adam Curtin Adam Curtin
isysg-lm 1609 udp isysg-lm Adam Curtin Adam Curtin
taurus-wh 1610 tcp taurus-wh Jeff Moffatt Jeff Moffatt
taurus-wh 1610 udp taurus-wh Jeff Moffatt Jeff Moffatt
ill 1611 tcp Inter Library Loan Niall Murphy Niall Murphy
ill 1611 udp Inter Library Loan Niall Murphy Niall Murphy
netbill-trans 1612 tcp NetBill Transaction Server
netbill-trans 1612 udp NetBill Transaction Server
netbill-keyrep 1613 tcp NetBill Key Repository

Contact Information

Name Organization Contact URI Last Updated
Adam Curtin adam.curtin&isysg.com
Alan Sandell alan.sandell&ist.co.uk 2008-05-01
Albert Holt alberth&triosoftware.com
Amatzia Ben-Artzi
Andreas Wetzel mickey&enforcer.cc 2002-09
Bob Beard bobb&lachman.com
Brad Pedersen bradp&citrix.com
Brian Lloyd brian&lloyd.com
Chuck Spitz spich04&cai.com
Connie Qiu connie&scdb.com
Daniel Mavrakis system&venus.mctel.fr
Ed Metcalf emetcalf&tripwiresecurity.com
Emmanuel Tychon etychon&cisco.com 2006-03
Frank O'Neill frank&morse.ilo.dec.com
Jean-Louis Barbut etebac5&gsit.fr
Jeff Moffatt jeff&taurus.com
John Lombardo johnl&picksys.com
Lee Griffiths lg&dataconnection.com 2004-11
Marshall Rose mrose17&gmail.com 2024-07-29
Marty Schoffstahl schoff&nisc.nyser.net
Michael Agishtein misha&unx.dec.com
Morten Christensen mjc&exbit.dk
Niall Murphy niallm&orca.ucd.ie
Nicola J. Howarth njh&ansa.co.uk
Norm Lunde norm&commvault.com 2004-11
Peter Ciuffetti petec&silverplatter.com
Peter Liu
Philip Stephenson Philip.stephenson&oracle.com 2005-08
Ryan Bolz ryanbo&microsoft.com
Scott Shattuck Technical Pursuit Inc. ss&technicalpursuit.com 2015-06-16
Susie Armstrong Armstrong.wbst128&xerox.com
Technical Pursuit Inc. ss&technicalpursuit.com 2015-06-16
Tohru Mori tmori&vnet.ibm.com
William Oldwin william&bitsome.ie 2022-01-28