Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
xns-courier 165 tcp Xerox Susie Armstrong Susie Armstrong
xns-courier 165 udp Xerox Susie Armstrong Susie Armstrong
qsm-gui 1165 tcp QSM GUI Service Norm Lunde Norm Lunde 2004-11
qsm-gui 1165 udp QSM GUI Service Norm Lunde Norm Lunde 2004-11
nkd 1650 tcp nkdn
nkd 1650 udp nkd
shiva-confsrvr 1651 tcp shiva_confsrvr

IANA assigned this well-formed service name as a replacement for "shiva_confsrvr".
Mike Horowitz Mike Horowitz
shiva_confsrvr 1651 tcp shiva_confsrvr Mike Horowitz Mike Horowitz This entry is an alias to "shiva-confsrvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
shiva-confsrvr 1651 udp shiva_confsrvr

IANA assigned this well-formed service name as a replacement for "shiva_confsrvr".
Mike Horowitz Mike Horowitz
shiva_confsrvr 1651 udp shiva_confsrvr Mike Horowitz Mike Horowitz This entry is an alias to "shiva-confsrvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
xnmp 1652 tcp xnmp Ali Saleh Ali Saleh
xnmp 1652 udp xnmp Ali Saleh Ali Saleh
alphatech-lm 1653 tcp alphatech-lm Joseph Hauk Joseph Hauk
alphatech-lm 1653 udp alphatech-lm Joseph Hauk Joseph Hauk
stargatealerts 1654 tcp stargatealerts Tim Coppernoll Tim Coppernoll
stargatealerts 1654 udp stargatealerts Tim Coppernoll Tim Coppernoll
dec-mbadmin 1655 tcp dec-mbadmin
dec-mbadmin 1655 udp dec-mbadmin
dec-mbadmin-h 1656 tcp dec-mbadmin-h Nick Shipman Nick Shipman
dec-mbadmin-h 1656 udp dec-mbadmin-h Nick Shipman Nick Shipman
fujitsu-mmpdc 1657 tcp fujitsu-mmpdc Katsumi Oomuro Katsumi Oomuro
fujitsu-mmpdc 1657 udp fujitsu-mmpdc Katsumi Oomuro Katsumi Oomuro
sixnetudr 1658 tcp sixnetudr Red Lion Controls Denis Aull 2014-05-21
sixnetudr 1658 udp sixnetudr Red Lion Controls Denis Aull 2014-05-21
sg-lm 1659 tcp Silicon Grail License Manager William R Bishop William R Bishop
sg-lm 1659 udp Silicon Grail License Manager William R Bishop William R Bishop
x-bone-api 2165 tcp X-Bone API Joe Touch Joe Touch
x-bone-api 2165 udp X-Bone API Joe Touch Joe Touch
newgenpay 3165 tcp Newgenpay Engine Service Ilan Zisser Ilan Zisser
newgenpay 3165 udp Newgenpay Engine Service Ilan Zisser Ilan Zisser
m2pa 3565 tcp M2PA RFC 4165
m2pa 3565 sctp M2PA RFC 4165
altcp 4165 tcp ArcLink over Ethernet Dmitry Brant Dmitry Brant 2007-03
altcp 4165 udp ArcLink over Ethernet Dmitry Brant Dmitry Brant 2007-03
ife-icorp 5165 tcp ife_1corp

IANA assigned this well-formed service name as a replacement for "ife_icorp".
Paul Annala Paul Annala
ife_icorp 5165 tcp ife_1corp Paul Annala Paul Annala This entry is an alias to "ife-icorp". This entry is now historic, not usable for use with many common service discovery mechanisms.
ife-icorp 5165 udp ife_1corp

IANA assigned this well-formed service name as a replacement for "ife_icorp".
Paul Annala Paul Annala
ife_icorp 5165 udp ife_1corp Paul Annala Paul Annala This entry is an alias to "ife-icorp". This entry is now historic, not usable for use with many common service discovery mechanisms.
doc-server 7165 tcp Document WCF Server Micha Ben-Efraim Micha Ben-Efraim 2008-01-07
doc-server 7165 udp Document WCF Server Micha Ben-Efraim Micha Ben-Efraim 2008-01-07
9165-9182 Unassigned
suncacao-websvc 11165 tcp sun cacao web service access point Nick Stephen Nick Stephen 2005-08
suncacao-websvc 11165 udp sun cacao web service access point Nick Stephen Nick Stephen 2005-08

Contact Information

Name Organization Contact URI Last Updated
Ali Saleh scomm&cerf.net
Denis Aull Red Lion Controls Engineering&RedLion.net 2014-05-21
Dmitry Brant dmitry_brant&lincolnelectric.com 2007-03
Ilan Zisser ilan&newgenpay.com
Joe Touch touch&strayalpha.com 2020-02-07
Joseph Hauk joseph.hauk&alphatech.com
Katsumi Oomuro NAE01421&niftyserve.or.jp
Micha Ben-Efraim benmi07&ca.com 2008-01-07
Mike Horowitz mah&shiva.com
Nick Shipman Nick.Shipman&mrmog.reo.dec.com
Nick Stephen nick.stephen&sun.com 2005-08
Norm Lunde norm&commvault.com 2004-11
Paul Annala paa&bull.se
Red Lion Controls Engineering&RedLion.net 2014-05-21
Susie Armstrong Armstrong.wbst128&xerox.com
Tim Coppernoll Tim_Coppernoll&ccm.jf.intel.com
William R Bishop wrb&world.std.com