Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
qotd 17 tcp Quote of the Day Jon Postel Jon Postel
qotd 17 udp Quote of the Day Jon Postel Jon Postel
47 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
47 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
61 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
61 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
uucp-path 117 tcp UUCP Path Service
uucp-path 117 udp UUCP Path Service
print-srv 170 tcp Network PostScript Brian Reid Brian Reid
print-srv 170 udp Network PostScript Brian Reid Brian Reid
multiplex 171 tcp Network Innovations Multiplex
multiplex 171 udp Network Innovations Multiplex
cl-1 172 tcp Network Innovations CL/1

IANA assigned this well-formed service name as a replacement for "cl/1".
Kevin DeVault Kevin DeVault
cl/1 172 tcp Network Innovations CL/1 Kevin DeVault Kevin DeVault This entry is an alias to "cl-1". This entry is now historic, not usable for use with many common service discovery mechanisms.
cl-1 172 udp Network Innovations CL/1

IANA assigned this well-formed service name as a replacement for "cl/1".
Kevin DeVault Kevin DeVault
cl/1 172 udp Network Innovations CL/1 Kevin DeVault Kevin DeVault This entry is an alias to "cl-1". This entry is now historic, not usable for use with many common service discovery mechanisms.
xyplex-mux 173 tcp Xyplex Bob Stewart Bob Stewart
xyplex-mux 173 udp Xyplex Bob Stewart Bob Stewart
mailq 174 tcp MAILQ Rayan Zachariassen Rayan Zachariassen
mailq 174 udp MAILQ Rayan Zachariassen Rayan Zachariassen
vmnet 175 tcp VMNET Christopher Tengi Christopher Tengi
vmnet 175 udp VMNET Christopher Tengi Christopher Tengi
genrad-mux 176 tcp GENRAD-MUX Ron Thornton Ron Thornton
genrad-mux 176 udp GENRAD-MUX Ron Thornton Ron Thornton
xdmcp 177 tcp X Display Manager Control Protocol Robert W. Scheifler Robert W. Scheifler
xdmcp 177 udp X Display Manager Control Protocol Robert W. Scheifler Robert W. Scheifler
nextstep 178 tcp NextStep Window Server Leo Hourvitz Leo Hourvitz
nextstep 178 udp NextStep Window Server Leo Hourvitz Leo Hourvitz
bgp 179 tcp Border Gateway Protocol Kirk Lougheed Kirk Lougheed
bgp 179 udp Border Gateway Protocol Kirk Lougheed Kirk Lougheed
bgp 179 sctp BGP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
dbase 217 tcp dBASE Unix Don Gibson Don Gibson
dbase 217 udp dBASE Unix Don Gibson Don Gibson
zannet 317 tcp Zannet Zan Oliphant Zan Oliphant
zannet 317 udp Zannet Zan Oliphant Zan Oliphant
onmux 417 tcp Onmux Stephen Hanna Stephen Hanna
onmux 417 udp Onmux Stephen Hanna Stephen Hanna
talk 517 tcp like tenex link, but across machine - unfortunately, doesn't use link protocol (this is actually just a rendezvous port from which a tcp connection is established)
talk 517 udp like tenex link, but across machine - unfortunately, doesn't use link protocol (this is actually just a rendezvous port from which a tcp connection is established)
sco-dtmgr 617 tcp SCO Desktop Administration Server Christopher Durham Christopher Durham
sco-dtmgr 617 udp SCO Desktop Administration Server Christopher Durham Christopher Durham
717-728 Unassigned
dlep 854 tcp Dynamic Link Exchange Protocol (DLEP) IESG IETF Chair 2017-04-03 RFC 8175
dlep 854 udp Dynamic Link Exchange Protocol (DLEP) IESG IETF Chair 2017-04-03 RFC 8175
ardus-mtrns 1117 tcp ARDUS Multicast Transfer Shinya Abe Shinya Abe
ardus-mtrns 1117 udp ARDUS Multicast Transfer Shinya Abe Shinya Abe
atc-lm 1170 tcp AT+C License Manager Peter Schäfer Peter Schäfer 2004-02
atc-lm 1170 udp AT+C License Manager Peter Schäfer Peter Schäfer 2004-02
atc-appserver 1171 tcp AT+C FmiApplicationServer Peter Schäfer Peter Schäfer 2004-02
atc-appserver 1171 udp AT+C FmiApplicationServer Peter Schäfer Peter Schäfer 2004-02
dnap 1172 tcp DNA Protocol David McLaughlin David McLaughlin 2004-11
dnap 1172 udp DNA Protocol David McLaughlin David McLaughlin 2004-11
d-cinema-rrp 1173 tcp D-Cinema Request-Response Digital Cinema Initiatives, LLC Digital Cinema Initiatives, LLC 2004-11 2025-08-26
d-cinema-rrp 1173 udp D-Cinema Request-Response Digital Cinema Initiatives, LLC Digital Cinema Initiatives, LLC 2004-11 2025-08-26
fnet-remote-ui 1174 tcp FlashNet Remote Admin Terry Smyth Terry Smyth 2004-11
fnet-remote-ui 1174 udp FlashNet Remote Admin Terry Smyth Terry Smyth 2004-11
dossier 1175 tcp Dossier Server Rob Minerick Rob Minerick 2004-11
dossier 1175 udp Dossier Server Rob Minerick Rob Minerick 2004-11
indigo-server 1176 tcp Indigo Home Server Matt Bendiksen Matt Bendiksen 2004-11
indigo-server 1176 udp Indigo Home Server Matt Bendiksen Matt Bendiksen 2004-11
dkmessenger 1177 tcp DKMessenger Protocol Douglas Kadlecek Douglas Kadlecek 2004-11
dkmessenger 1177 udp DKMessenger Protocol Douglas Kadlecek Douglas Kadlecek 2004-11
sgi-storman 1178 tcp SGI Storage Manager Greg Banks Greg Banks 2004-11
sgi-storman 1178 udp SGI Storage Manager Greg Banks Greg Banks 2004-11
b2n 1179 tcp Backup To Neighbor Thomas Fok Thomas Fok 2004-11
b2n 1179 udp Backup To Neighbor Thomas Fok Thomas Fok 2004-11
hpss-ndapi 1217 tcp HPSS NonDCE Gateway Michael Gleicher Michael Gleicher
hpss-ndapi 1217 udp HPSS NonDCE Gateway Michael Gleicher Michael Gleicher
vrts-ipcserver 1317 tcp vrts-ipcserver Bruce Hestand Bruce Hestand
vrts-ipcserver 1317 udp vrts-ipcserver Bruce Hestand Bruce Hestand
timbuktu-srv1 1417 tcp Timbuktu Service 1 Port
timbuktu-srv1 1417 udp Timbuktu Service 1 Port
vpac 1517 tcp Virtual Places Audio control
vpac 1517 udp Virtual Places Audio control
nimrod-agent 1617 tcp Nimrod Inter-Agent Communication Charles Lynn Charles Lynn
nimrod-agent 1617 udp Nimrod Inter-Agent Communication Charles Lynn Charles Lynn
mps-raft 1700 tcp mps-raft Jason Leupen Jason Leupen
mps-raft 1700 udp mps-raft Jason Leupen Jason Leupen
l2f 1701 tcp l2f
l2f 1701 udp l2f
l2tp 1701 tcp l2tp Andy Valencia Andy Valencia
l2tp 1701 udp l2tp Andy Valencia Andy Valencia
deskshare 1702 tcp deskshare Sarah Thompson Sarah Thompson
deskshare 1702 udp deskshare Sarah Thompson Sarah Thompson
hb-engine 1703 tcp hb-engine Charles C.L. Chou Charles C.L. Chou
hb-engine 1703 udp hb-engine Charles C.L. Chou Charles C.L. Chou
bcs-broker 1704 tcp bcs-broker Andy Warner Andy Warner
bcs-broker 1704 udp bcs-broker Andy Warner Andy Warner
slingshot 1705 tcp slingshot Paul Groarke Paul Groarke
slingshot 1705 udp slingshot Paul Groarke Paul Groarke
jetform 1706 tcp jetform gdeinsta gdeinsta
jetform 1706 udp jetform gdeinsta gdeinsta
vdmplay 1707 tcp vdmplay David Thielen David Thielen
vdmplay 1707 udp vdmplay David Thielen David Thielen
gat-lmd 1708 tcp gat-lmd Igor Zaoutine Igor Zaoutine
gat-lmd 1708 udp gat-lmd Igor Zaoutine Igor Zaoutine
centra 1709 tcp centra Drew Wolff Drew Wolff
centra 1709 udp centra Drew Wolff Drew Wolff
impera 1710 tcp impera Stepehen Campbell Stepehen Campbell
impera 1710 udp impera Stepehen Campbell Stepehen Campbell

Contact Information

Name Organization Contact URI Last Updated
Andy Valencia vandys&vandys-lap.cisco.com
Andy Warner andyw&knoware.nl
Bob Stewart STEWART&xyplex.com
Brian Reid reid&decwrl.dec.com
Bruce Hestand Bruce.Hestand&veritas.com
Charles C.L. Chou cchou&zoom.com
Charles Lynn clynn&bbn.com
Christopher Durham chrisdu&sco.com
Christopher Tengi tengi&princeton.edu
David McLaughlin davidmclaughlin&accessdata.com 2004-11
David Thielen support&windward.net
Digital Cinema Initiatives, LLC dci.info&dcimovies.com 2025-08-26
Don Gibson sequent!aero!twinsun!ashtate.A-T.COM!dong&uunet.UU.NET
Douglas Kadlecek doug&dkware.com 2004-11
Drew Wolff dwolff&centra.net
Greg Banks gnb&sgi.com 2004-11
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Igor Zaoutine igor&global-tech.com
Jason Leupen Jleupen&aol.com
Jon Postel postel&isi.edu
Kevin DeVault
Kirk Lougheed LOUGHEED&mathom.cisco.com
Leo Hourvitz leo&next.com
Matt Bendiksen matt&perceptiveautomation.com 2004-11
Michael Gleicher mgleicher&comcast.net
Paul Groarke paulg&quay.ie
Peter Schäfer p.schaefer&nospam.atc-systeme.de 2004-02
Randall Stewart IETF TSVWG rrs&lakerest.net
Rayan Zachariassen rayan&ai.toronto.edu
Rob Minerick rob&vortimac.com 2004-11
Robert W. Scheifler RWS&xx.lcs.mit.edu
Ron Thornton thornton&aerostation.org 2020-09-01
Sarah Thompson sarah&telergy.com
Shinya Abe abeabe&pfu.co.jp
Stepehen Campbell campbell&uniprise.com
Stephen Hanna hanna&world.std.com
Terry Smyth terry&sgluk.com 2004-11
Thomas Fok thomas&melody-soft.com 2004-11
Zan Oliphant zan&accessone.com
gdeinsta gdeinsta&jetform.com