Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
mailq 174 tcp MAILQ Rayan Zachariassen Rayan Zachariassen
mailq 174 udp MAILQ Rayan Zachariassen Rayan Zachariassen
fnet-remote-ui 1174 tcp FlashNet Remote Admin Terry Smyth Terry Smyth 2004-11
fnet-remote-ui 1174 udp FlashNet Remote Admin Terry Smyth Terry Smyth 2004-11
encore 1740 tcp encore Stuart Button Stuart Button
encore 1740 udp encore Stuart Button Stuart Button
cisco-net-mgmt 1741 tcp cisco-net-mgmt John McCormack John McCormack
cisco-net-mgmt 1741 udp cisco-net-mgmt John McCormack John McCormack
3Com-nsd 1742 tcp 3Com-nsd Nitza Steinberg Nitza Steinberg
3Com-nsd 1742 udp 3Com-nsd Nitza Steinberg Nitza Steinberg
cinegrfx-lm 1743 tcp Cinema Graphics License Manager Rodney Iwashina Rodney Iwashina
cinegrfx-lm 1743 udp Cinema Graphics License Manager Rodney Iwashina Rodney Iwashina
ncpm-ft 1744 tcp ncpm-ft Ken Hearn Ken Hearn
ncpm-ft 1744 udp ncpm-ft Ken Hearn Ken Hearn
remote-winsock 1745 tcp remote-winsock Avi Nathan Avi Nathan
remote-winsock 1745 udp remote-winsock Avi Nathan Avi Nathan
ftrapid-1 1746 tcp ftrapid-1
ftrapid-1 1746 udp ftrapid-1
ftrapid-2 1747 tcp ftrapid-2 Richard J. Williams Richard J. Williams
ftrapid-2 1747 udp ftrapid-2 Richard J. Williams Richard J. Williams
oracle-em1 1748 tcp oracle-em1 Bob Purvy Bob Purvy
oracle-em1 1748 udp oracle-em1 Bob Purvy Bob Purvy
aspen-services 1749 tcp aspen-services Mark B. Hurst Mark B. Hurst
aspen-services 1749 udp aspen-services Mark B. Hurst Mark B. Hurst
msfw-array 2174 tcp MS Firewall Intra Array Itai Greenberg Itai Greenberg 2004-11
msfw-array 2174 udp MS Firewall Intra Array Itai Greenberg Itai Greenberg 2004-11
armi-server 3174 tcp ARMI Server Bobby Martin Bobby Martin
armi-server 3174 udp ARMI Server Bobby Martin Bobby Martin
smcluster 4174 tcp StorMagic Cluster Services Chris Farey Chris Farey 2011-03-09
sm-disc 4174 udp StorMagic Discovery StorMagic Ltd Chris Farey 2011-12-16
dtn-bundle 4556 tcp DTN Bundle TCP CL Protocol IESG IETF Chair 2021-02-22 RFC 9174
clutild 7174 tcp Clutild Cheryl Stoutenburg Cheryl Stoutenburg
clutild 7174 udp Clutild Cheryl Stoutenburg Cheryl Stoutenburg
oemcacao-rmi 11174 tcp OEM cacao rmi registry access point David Sechrest David Sechrest 2010-09-22
11174 udp Reserved
17236-17499 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Avi Nathan avin&microsoft.com
Bob Purvy bpurvy&us.oracle.com
Bobby Martin bobbymartin&hotmail.com
Cheryl Stoutenburg cstoutenburg&vnet.ibm.com
Chris Farey StorMagic Ltd chris_farey&stormagic.com 2011-12-16
David Sechrest david.sechrest&oracle.com 2010-09-22
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Itai Greenberg itaig&microsoft.com 2004-11
John McCormack jmac&cisco.com
Ken Hearn hearn&hpindacx.cup.hp.com
Mark B. Hurst mhurst&aspenres.com
Nitza Steinberg nitza&isd.3com.com
Rayan Zachariassen rayan&ai.toronto.edu
Richard J. Williams RJW1&trpo4.tr.unisys.com
Rodney Iwashina rodney&cyclone.rfx.com
StorMagic Ltd chris_farey&stormagic.com 2011-12-16
Stuart Button button&promis.com
Terry Smyth terry&sgluk.com 2004-11