Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
gacp 190 tcp Gateway Access Control Protocol C. Philip Wood C. Philip Wood
gacp 190 udp Gateway Access Control Protocol C. Philip Wood C. Philip Wood
commlinx-avl 1190 tcp CommLinx GPS / AVL System Peter Johnson Peter Johnson 2004-11
commlinx-avl 1190 udp CommLinx GPS / AVL System Peter Johnson Peter Johnson 2004-11
ssdp 1900 tcp SSDP UPnP Forum UPnP Forum
ssdp 1900 udp SSDP UPnP Forum UPnP Forum
fjicl-tep-a 1901 tcp Fujitsu ICL Terminal Emulator Program A Bob Lyon Bob Lyon
fjicl-tep-a 1901 udp Fujitsu ICL Terminal Emulator Program A Bob Lyon Bob Lyon
fjicl-tep-b 1902 tcp Fujitsu ICL Terminal Emulator Program B Bob Lyon Bob Lyon
fjicl-tep-b 1902 udp Fujitsu ICL Terminal Emulator Program B Bob Lyon Bob Lyon
linkname 1903 tcp Local Link Name Resolution Dan Harrington Dan Harrington
linkname 1903 udp Local Link Name Resolution Dan Harrington Dan Harrington
fjicl-tep-c 1904 tcp Fujitsu ICL Terminal Emulator Program C Bob Lyon Bob Lyon
fjicl-tep-c 1904 udp Fujitsu ICL Terminal Emulator Program C Bob Lyon Bob Lyon
sugp 1905 tcp Secure UP.Link Gateway Protocol Peter King Peter King
sugp 1905 udp Secure UP.Link Gateway Protocol Peter King Peter King
tpmd 1906 tcp TPortMapperReq Sheila Devins Sheila Devins
tpmd 1906 udp TPortMapperReq Sheila Devins Sheila Devins
intrastar 1907 tcp IntraSTAR Peter Schoenberger Peter Schoenberger
intrastar 1907 udp IntraSTAR Peter Schoenberger Peter Schoenberger
dawn 1908 tcp Dawn Michael Crawford Michael Crawford
dawn 1908 udp Dawn Michael Crawford Michael Crawford
global-wlink 1909 tcp Global World Link Nicholas Davies Nicholas Davies
global-wlink 1909 udp Global World Link Nicholas Davies Nicholas Davies
tivoconnect 2190 tcp TiVoConnect Beacon Jeffrey J. Peters Jeffrey J. Peters 2002-08
tivoconnect 2190 udp TiVoConnect Beacon Jeffrey J. Peters Jeffrey J. Peters 2002-08
itu-bicc-stc 3097 sctp ITU-T Q.1902.1/Q.2150.3 Greg Sidebottom Greg Sidebottom
csvr-proxy 3190 tcp ConServR Proxy
csvr-proxy 3190 udp ConServR Proxy
sieve 4190 tcp ManageSieve Protocol
4190 udp Reserved RFC 5804
aol 5190 tcp America-Online Marty Lyons Marty Lyons
aol 5190 udp America-Online Marty Lyons Marty Lyons
gcp-rphy 8190 tcp Generic control plane for RPHY CableLabs Karthik Sundaresan 2015-11-24
8190 udp Reserved
9184-9190 Unassigned
igrid 19000 tcp iGrid Server Massimo Cafaro Massimo Cafaro 2004-11
igrid 19000 udp iGrid Server Massimo Cafaro Massimo Cafaro 2004-11
19001-19006 Unassigned
scintilla 19007 tcp Scintilla protocol for device services Veejansh Inc Chirag Patel 2014-03-04
scintilla 19007 udp Scintilla protocol for device services Veejansh Inc Chirag Patel 2014-03-04
19008-19019 Unassigned
j-link 19020 tcp J-Link TCP/IP Protocol SEGGER Microcontroller GmbH & Co. KG SEGGER Microcontroller GmbH & Co. KG
19020 udp Reserved
19021-19190 Unassigned
ip-provision 43190 tcp IP-PROVISION Roman Kriis Roman Kriis
ip-provision 43190 udp IP-PROVISION Roman Kriis Roman Kriis

Contact Information

Name Organization Contact URI Last Updated
Bob Lyon bl&oasis.icl.co.uk
C. Philip Wood cpw&lanl.gov
CableLabs info&cablelabs.com 2015-11-24
Chirag Patel Veejansh Inc cpatel&veejansh.com 2014-03-04
Dan Harrington dth&lucent.com
Greg Sidebottom gregside&home.com
Jeffrey J. Peters jpeters&tivo.com 2002-08
Karthik Sundaresan k.sundaresan&cablelabs.com 2015-11-24
Marty Lyons marty&aol.com
Massimo Cafaro massimo.cafaro&unile.it 2004-11
Michael Crawford michaelc&travsoft.com
Nicholas Davies N.Davies&globalcomm.co.uk
Peter Johnson peter&commlinx.com.au 2004-11
Peter King king&uplanet.com
Peter Schoenberger ps&teles.de
Roman Kriis roman&previo.ee
SEGGER Microcontroller GmbH & Co. KG info&segger.com 2009-01-16
Sheila Devins sheila_devins&vnet.ibm.com
UPnP Forum upnpadmin&forum.upnp.org
Veejansh Inc admin&veejansh.com 2014-03-04