Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| irc | 194 | tcp | Internet Relay Chat Protocol | Jarkko Oikarinen | Jarkko Oikarinen | ||||||
| irc | 194 | udp | Internet Relay Chat Protocol | Jarkko Oikarinen | Jarkko Oikarinen | ||||||
| openvpn | 1194 | tcp | OpenVPN | James Yonan | James Yonan | 2004-11 | |||||
| openvpn | 1194 | udp | OpenVPN | James Yonan | James Yonan | 2004-11 | |||||
| jvclient | 1940 | tcp | JetVision Client Port | Stephen Tsun | Stephen Tsun | ||||||
| jvclient | 1940 | udp | JetVision Client Port | Stephen Tsun | Stephen Tsun | ||||||
| dic-aida | 1941 | tcp | DIC-Aida | Frans S.C. Witte | Frans S.C. Witte | ||||||
| dic-aida | 1941 | udp | DIC-Aida | Frans S.C. Witte | Frans S.C. Witte | ||||||
| res | 1942 | tcp | Real Enterprise Service | Bob Janssen | Bob Janssen | ||||||
| res | 1942 | udp | Real Enterprise Service | Bob Janssen | Bob Janssen | ||||||
| beeyond-media | 1943 | tcp | Beeyond Media | Bob Deblier | Bob Deblier | ||||||
| beeyond-media | 1943 | udp | Beeyond Media | Bob Deblier | Bob Deblier | ||||||
| close-combat | 1944 | tcp | close-combat | David Hua | David Hua | ||||||
| close-combat | 1944 | udp | close-combat | David Hua | David Hua | ||||||
| dialogic-elmd | 1945 | tcp | dialogic-elmd | Roger Kay | Roger Kay | ||||||
| dialogic-elmd | 1945 | udp | dialogic-elmd | Roger Kay | Roger Kay | ||||||
| tekpls | 1946 | tcp | tekpls | Brian Abramson | Brian Abramson | ||||||
| tekpls | 1946 | udp | tekpls | Brian Abramson | Brian Abramson | ||||||
| sentinelsrm | 1947 | tcp | SentinelSRM | Michael Zunke | Michael Zunke | 2010-07-23 | Unauthorized Use Known on port 1947 | ||||
| sentinelsrm | 1947 | udp | SentinelSRM | Michael Zunke | Michael Zunke | 2010-07-23 | Unauthorized Use Known on port 1947 | ||||
| eye2eye | 1948 | tcp | eye2eye | Trevor Bell | Trevor Bell | ||||||
| eye2eye | 1948 | udp | eye2eye | Trevor Bell | Trevor Bell | ||||||
| ismaeasdaqlive | 1949 | tcp | ISMA Easdaq Live | Stephen Dunne | Stephen Dunne | ||||||
| ismaeasdaqlive | 1949 | udp | ISMA Easdaq Live | Stephen Dunne | Stephen Dunne | ||||||
| 2194-2196 | Unassigned | Unauthorized Use Known on ports 2194-2196 | |||||||||
| magbind | 3194 | tcp | Rockstorm MAG protocol | Jens Nilsson | Jens Nilsson | ||||||
| magbind | 3194 | udp | Rockstorm MAG protocol | Jens Nilsson | Jens Nilsson | ||||||
| spdm | 4194 | tcp | Security Protocol and Data Model | DMTF Administration | Robert Keyes | 2022-01-10 | 2025-05-30 | ||||
| 4194 | udp | Reserved | |||||||||
| cpscomm | 5194 | tcp | CipherPoint Config Service | CipherPoint Software, inc. | CipherPoint Software, inc. | 2010-03-03 | |||||
| 5194 | udp | Reserved | |||||||||
| ircs-u | 6697 | tcp | Internet Relay Chat via TLS/SSL | 2014-02-11 | RFC 7194 | ||||||
| blp1 | 8194 | tcp | Bloomberg data API | Albert Hou | Albert Hou | 2006-05 | |||||
| blp1 | 8194 | udp | Bloomberg data API | Albert Hou | Albert Hou | 2006-05 | |||||
| ua-secureagent | 19194 | tcp | UserAuthority SecureAgent | Reuven Harrison | Reuven Harrison | 2003-01 | |||||
| ua-secureagent | 19194 | udp | UserAuthority SecureAgent | Reuven Harrison | Reuven Harrison | 2003-01 | |||||
| 19399-19409 | Unassigned | ||||||||||
| hp-sco | 19410 | tcp | hp-sco | Larry Schwartz | Larry Schwartz | ||||||
| hp-sco | 19410 | udp | hp-sco | Larry Schwartz | Larry Schwartz | ||||||
| hp-sca | 19411 | tcp | hp-sca | Larry Schwartz | Larry Schwartz | ||||||
| hp-sca | 19411 | udp | hp-sca | Larry Schwartz | Larry Schwartz | ||||||
| hp-sessmon | 19412 | tcp | HP-SESSMON | Gita Murthy | Gita Murthy | ||||||
| hp-sessmon | 19412 | udp | HP-SESSMON | Gita Murthy | Gita Murthy | ||||||
| 19413-19538 | Unassigned | ||||||||||
| 31766-31947 | Unassigned | ||||||||||
| iceedcp-tx | 31948 | tcp | Embedded Device Configuration Protocol TX IANA assigned this well-formed service name as a replacement for "iceedcp_tx". |
Oliver Lewis | Oliver Lewis | 2006-08 | |||||
| iceedcp_tx | 31948 | tcp | Embedded Device Configuration Protocol TX | Oliver Lewis | Oliver Lewis | 2006-08 | This entry is an alias to "iceedcp-tx". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| iceedcp-tx | 31948 | udp | Embedded Device Configuration Protocol TX IANA assigned this well-formed service name as a replacement for "iceedcp_tx". |
Oliver Lewis | Oliver Lewis | 2006-08 | |||||
| iceedcp_tx | 31948 | udp | Embedded Device Configuration Protocol TX | Oliver Lewis | Oliver Lewis | 2006-08 | This entry is an alias to "iceedcp-tx". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| iceedcp-rx | 31949 | tcp | Embedded Device Configuration Protocol RX IANA assigned this well-formed service name as a replacement for "iceedcp_rx". |
Oliver Lewis | Oliver Lewis | 2006-08 | |||||
| iceedcp_rx | 31949 | tcp | Embedded Device Configuration Protocol RX | Oliver Lewis | Oliver Lewis | 2006-08 | This entry is an alias to "iceedcp-rx". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| iceedcp-rx | 31949 | udp | Embedded Device Configuration Protocol RX IANA assigned this well-formed service name as a replacement for "iceedcp_rx". |
Oliver Lewis | Oliver Lewis | 2006-08 | |||||
| iceedcp_rx | 31949 | udp | Embedded Device Configuration Protocol RX | Oliver Lewis | Oliver Lewis | 2006-08 | This entry is an alias to "iceedcp-rx". This entry is now historic, not usable for use with many common service discovery mechanisms. |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Albert Hou | ahou1&bloomberg.com | 2006-05 | |
| Bob Deblier | bob&virtualunlimited.com | ||
| Bob Janssen | bob&res.nl | ||
| Brian Abramson | brianab&vnd.tek.com | ||
| CipherPoint Software, inc. | wshea&cipherpointsoftware.com | 2010-03-03 | |
| David Hua | davhuaµsoft.com | ||
| DMTF Administration | admin&dmtf.org | 2025-05-30 | |
| Frans S.C. Witte | fscwitte&dicgroep.nl | ||
| Gita Murthy | gita&cup.hp.com | ||
| James Yonan | jim&yonan.net | 2004-11 | |
| Jarkko Oikarinen | jto&tolsun.oulu.fi | ||
| Jens Nilsson | jens&rockstorm.se | ||
| Larry Schwartz | lrs&cup.hp.com | ||
| Michael Zunke | Michael.Zunke&ealaddin.com | 2010-07-23 | |
| Oliver Lewis | o.lewis&icerobotics.co.uk | 2006-08 | |
| Reuven Harrison | rharrison&checkpoint.com | 2003-01 | |
| Robert Keyes | robert&woldconsulting.com | 2025-05-30 | |
| Roger Kay | r.kay&nz.dialogic.com | ||
| Stephen Dunne | sdun&isma.co.uk | ||
| Stephen Tsun | stsun&jetstream.com | ||
| Trevor Bell | Trevor&iguana.iosoftware.com |