Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ftp 21 tcp File Transfer Protocol [Control] Jon Postel Jon Postel RFC 959 Defined TXT keys: u=<username> p=<password> path=<path>
ftp 21 udp File Transfer Protocol [Control] Jon Postel Jon Postel RFC 959 Defined TXT keys: u=<username> p=<password> path=<path>
ftp 21 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path>
smtp 25 tcp Simple Mail Transfer IESG IETF Chair 2017-06-05 RFC-ietf-emailcore-rfc5321bis-43
smtp 25 udp Simple Mail Transfer IESG IETF Chair 2017-06-05 RFC-ietf-emailcore-rfc5321bis-43
erpc 121 tcp Encore Expedited Remote Pro.Call Jack O'Neil Jack O'Neil
erpc 121 udp Encore Expedited Remote Pro.Call Jack O'Neil Jack O'Neil
z39-50 210 tcp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 tcp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
z39-50 210 udp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 udp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
914c-g 211 tcp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 tcp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
914c-g 211 udp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 udp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
anet 212 tcp ATEXSSTR Jim Taylor Jim Taylor
anet 212 udp ATEXSSTR Jim Taylor Jim Taylor
ipx 213 tcp IPX Don Provan Don Provan
ipx 213 udp IPX Don Provan Don Provan
vmpwscs 214 tcp VM PWSCS Dan Shia Dan Shia
vmpwscs 214 udp VM PWSCS Dan Shia Dan Shia
softpc 215 tcp Insignia Solutions Martyn Thomas Martyn Thomas
softpc 215 udp Insignia Solutions Martyn Thomas Martyn Thomas
CAIlic 216 tcp Computer Associates Int'l License Server Chuck Spitz Chuck Spitz
CAIlic 216 udp Computer Associates Int'l License Server Chuck Spitz Chuck Spitz
dbase 217 tcp dBASE Unix Don Gibson Don Gibson
dbase 217 udp dBASE Unix Don Gibson Don Gibson
mpp 218 tcp Netix Message Posting Protocol Shannon Yeh Shannon Yeh
mpp 218 udp Netix Message Posting Protocol Shannon Yeh Shannon Yeh
uarps 219 tcp Unisys ARPs Ashok Marwaha Ashok Marwaha
uarps 219 udp Unisys ARPs Ashok Marwaha Ashok Marwaha
fln-spx 221 tcp Berkeley rlogind with SPX auth
fln-spx 221 udp Berkeley rlogind with SPX auth
pip 321 tcp PIP Gordon Mohr Gordon Mohr
pip 321 udp PIP Gordon Mohr Gordon Mohr
bhoetty 351 tcp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoetty 351 udp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 tcp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 udp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
ariel2 421 tcp Ariel 2
ariel2 421 udp Ariel 2
ripng 521 tcp ripng Robert E. Minnear Robert E. Minnear
ripng 521 udp ripng Robert E. Minnear Robert E. Minnear
escp-ip 621 tcp ESCP Lai Zit Seng Lai Zit Seng
escp-ip 621 udp ESCP Lai Zit Seng Lai Zit Seng
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
rmpp 1121 tcp Datalode RMPP Dave Ruedger Dave Ruedger 2003-11
rmpp 1121 udp Datalode RMPP Dave Ruedger Dave Ruedger 2003-11
eoss 1210 tcp EOSS Robert Armes Robert Armes
eoss 1210 udp EOSS Robert Armes Robert Armes
groove-dpp 1211 tcp Groove DPP Ken Moore Ken Moore
groove-dpp 1211 udp Groove DPP Ken Moore Ken Moore
lupa 1212 tcp lupa Barney Wolff Barney Wolff
lupa 1212 udp lupa Barney Wolff Barney Wolff
mpc-lifenet 1213 tcp Medtronic/Physio-Control LIFENET Physio-Control, Inc. Kevin Drew 2014-02-14
mpc-lifenet 1213 udp Medtronic/Physio-Control LIFENET Physio-Control, Inc. Kevin Drew 2014-02-14
kazaa 1214 tcp KAZAA Ahti Heinla Ahti Heinla
kazaa 1214 udp KAZAA Ahti Heinla Ahti Heinla
scanstat-1 1215 tcp scanSTAT 1.0 William Scheding William Scheding
scanstat-1 1215 udp scanSTAT 1.0 William Scheding William Scheding
etebac5 1216 tcp ETEBAC 5 Jean-Louis Barbut Jean-Louis Barbut
etebac5 1216 udp ETEBAC 5 Jean-Louis Barbut Jean-Louis Barbut
hpss-ndapi 1217 tcp HPSS NonDCE Gateway Michael Gleicher Michael Gleicher
hpss-ndapi 1217 udp HPSS NonDCE Gateway Michael Gleicher Michael Gleicher
aeroflight-ads 1218 tcp AeroFlight-ADs
aeroflight-ads 1218 udp AeroFlight-ADs
aeroflight-ret 1219 tcp AeroFlight-Ret Eric Johnson Eric Johnson
aeroflight-ret 1219 udp AeroFlight-Ret Eric Johnson Eric Johnson
sweetware-apps 1221 tcp SweetWARE Apps David Dunetz David Dunetz
sweetware-apps 1221 udp SweetWARE Apps David Dunetz David Dunetz
pip 1321 tcp PIP Gordon Mohr Gordon Mohr
pip 1321 udp PIP Gordon Mohr Gordon Mohr
gandalf-lm 1421 tcp Gandalf License Manager gilmer gilmer
gandalf-lm 1421 udp Gandalf License Manager gilmer gilmer
ncube-lm 1521 tcp nCube License Manager Maxine Yuen Maxine Yuen 2022-02-14 Unauthorized Use Known on port 1521
ncube-lm 1521 udp nCube License Manager Maxine Yuen Maxine Yuen 2022-02-14 Unauthorized Use Known on port 1521
softdataphone 1621 tcp softdataphone Dror Gill Dror Gill
softdataphone 1621 udp softdataphone Dror Gill Dror Gill
caicci 1721 tcp caicci Sylvia Scheuren Sylvia Scheuren
caicci 1721 udp caicci Sylvia Scheuren Sylvia Scheuren
donnyworld 1821 tcp donnyworld Don Oliver Don Oliver
donnyworld 1821 udp donnyworld Don Oliver Don Oliver
noadmin 1921 tcp NoAdmin Martin Bestmann Martin Bestmann
noadmin 1921 udp NoAdmin Martin Bestmann Martin Bestmann
servexec 2021 tcp
xinuexpansion1 2021 udp
amiganetfs 2100 tcp Amiga Network Filesystem Rudi Chiarito Rudi Chiarito
amiganetfs 2100 udp Amiga Network Filesystem Rudi Chiarito Rudi Chiarito
rtcm-sc104 2101 tcp rtcm-sc104 Wolfgang Rupprecht Wolfgang Rupprecht
rtcm-sc104 2101 udp rtcm-sc104 Wolfgang Rupprecht Wolfgang Rupprecht
zephyr-srv 2102 tcp Zephyr server
zephyr-srv 2102 udp Zephyr server
zephyr-clt 2103 tcp Zephyr serv-hm connection
zephyr-clt 2103 udp Zephyr serv-hm connection
zephyr-hm 2104 tcp Zephyr hostmanager Greg Hudson Greg Hudson
zephyr-hm 2104 udp Zephyr hostmanager Greg Hudson Greg Hudson
minipay 2105 tcp MiniPay Amir Herzberg Amir Herzberg

Contact Information

Name Organization Contact URI Last Updated
Ahti Heinla ahti&ahti.bluemoon.ee 2002-06
Amir Herzberg amirh&vnet.ibm.com
Ashok Marwaha
Barney Wolff barney&databus.com
Bill Harrell
Chuck Spitz spich04&cai.com
Dan Shia dset!shia&uunet.uu.net
Dave Ruedger daver&datalode.com 2003-11
David Dunetz david&sweetware.com
Don Gibson sequent!aero!twinsun!ashtate.A-T.COM!dong&uunet.UU.NET
Don Oliver don&donnyworld.com
Don Provan donp&xlnvax.novell.com
Dror Gill drorgi&vnet.ibm.com
Eric Johnson eric&gruver.net
Gordon Mohr gojomo&usa.net
Greg Hudson zephyr-bugs&mit.edu
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jack O'Neil
Jean-Louis Barbut etebac5&gsit.fr
Jim Taylor taylor&heart.epps.kodak.com
John Kelly johnk&bellhow.com
Jon Postel postel&isi.edu
Ken Moore kmoore&groove.net
Kevin Drew Physio-Control, Inc. kevin.c.drew&physio-control.com 2014-02-14
Lai Zit Seng lzs&pobox.com
Mark H. Needleman markn&sirsi.com
Martin Bestmann martin&datawatch.de
Martyn Thomas
Maxine Yuen maxine&hq.ncube.com
Michael Gleicher mgleicher&comcast.net
Physio-Control, Inc. kevin.c.drew&physio-control.com 2014-02-14
Randall Stewart IETF TSVWG rrs&lakerest.net
Robert Armes rarmes&axarte.com
Robert E. Minnear minnear&ipsilon.com
Rudi Chiarito nutello&sweetness.com
Shannon Yeh yeh&netix.com
Sylvia Scheuren schsy02&cai.com
William Scheding wls&wls.org
Wolfgang Rupprecht wolfgang&wsrcc.com
gilmer&gandalf.ca