Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-10
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| td-replica | 268 | tcp | Tobit David Replica | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| td-replica | 268 | udp | Tobit David Replica | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| propel-msgsys | 1268 | tcp | PROPEL-MSGSYS | Bert Van der Linden | Bert Van der Linden | ||||||
| propel-msgsys | 1268 | udp | PROPEL-MSGSYS | Bert Van der Linden | Bert Van der Linden | ||||||
| amt | 2268 | tcp | AMT | IESG | IETF Chair | 2004-12 | 2014-12-17 | RFC 7450 | |||
| amt | 2268 | udp | AMT | IESG | IETF Chair | 2004-12 | 2014-12-17 | RFC 7450 | |||
| pxc-sapxom | 2680 | tcp | pxc-sapxom | Hideki Kiriyama | Hideki Kiriyama | ||||||
| pxc-sapxom | 2680 | udp | pxc-sapxom | Hideki Kiriyama | Hideki Kiriyama | ||||||
| mpnjsomb | 2681 | tcp | mpnjsomb | Takenori Miyahara | Takenori Miyahara | ||||||
| mpnjsomb | 2681 | udp | mpnjsomb | Takenori Miyahara | Takenori Miyahara | ||||||
| 2682 | Removed | 2002-04-30 | |||||||||
| ncdloadbalance | 2683 | tcp | NCDLoadBalance | Tim Stevenson | Tim Stevenson | ||||||
| ncdloadbalance | 2683 | udp | NCDLoadBalance | Tim Stevenson | Tim Stevenson | ||||||
| mpnjsosv | 2684 | tcp | mpnjsosv | ||||||||
| mpnjsosv | 2684 | udp | mpnjsosv | ||||||||
| mpnjsocl | 2685 | tcp | mpnjsocl | ||||||||
| mpnjsocl | 2685 | udp | mpnjsocl | ||||||||
| mpnjsomg | 2686 | tcp | mpnjsomg | Takenori Miyahara | Takenori Miyahara | ||||||
| mpnjsomg | 2686 | udp | mpnjsomg | Takenori Miyahara | Takenori Miyahara | ||||||
| pq-lic-mgmt | 2687 | tcp | pq-lic-mgmt | Bob Sledge | Bob Sledge | ||||||
| pq-lic-mgmt | 2687 | udp | pq-lic-mgmt | Bob Sledge | Bob Sledge | ||||||
| md-cg-http | 2688 | tcp | md-cf-http | Lyndon Nerenberg | Lyndon Nerenberg | ||||||
| md-cg-http | 2688 | udp | md-cf-http | Lyndon Nerenberg | Lyndon Nerenberg | ||||||
| fastlynx | 2689 | tcp | FastLynx | Dave Sewell | Dave Sewell | ||||||
| fastlynx | 2689 | udp | FastLynx | Dave Sewell | Dave Sewell | ||||||
| msft-gc | 3268 | tcp | Microsoft Global Catalog | ||||||||
| msft-gc | 3268 | udp | Microsoft Global Catalog | ||||||||
| 5266-5268 | Unassigned | ||||||||||
| grid | 6268 | tcp | Grid Authentication | Jason Hamilton | Jason Hamilton | 2006-06 | |||||
| grid | 6268 | udp | Grid Authentication | Jason Hamilton | Jason Hamilton | 2006-06 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Bert Van der Linden | bert&propel.com | ||
| Bob Sledge | bob&pqsystems.com | ||
| Dave Sewell | dave&sewelldev.com | ||
| Franz-Josef Leuders | development&tobit.com | ||
| Hideki Kiriyama | kiriyama&cp10.es.xerox.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jason Hamilton | JHamilton&griddatasecurity.com | 2006-06 | |
| Lyndon Nerenberg | lyndon&execmail.ca | ||
| Takenori Miyahara | miyahara&pfu.co.jp | ||
| Tim Stevenson | tes&ncd.com |