Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dsp3270 246 tcp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
dsp3270 246 udp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
270 tcp Reserved
gist 270 udp Q-mode encapsulation for GIST messages RFC 5971
opsmgr 1270 tcp Microsoft Operations Manager Ashvin Sanghvi Ashvin Sanghvi
opsmgr 1270 udp Microsoft Operations Manager Ashvin Sanghvi Ashvin Sanghvi
starschool 2270 tcp starSchool Adam Ernst Adam Ernst 2004-12
starschool 2270 udp starSchool Adam Ernst Adam Ernst 2004-12
tqdata 2700 tcp tqdata Al Guetzlaff Al Guetzlaff
tqdata 2700 udp tqdata Al Guetzlaff Al Guetzlaff
sms-rcinfo 2701 tcp SMS RCINFO
sms-rcinfo 2701 udp SMS RCINFO
sms-xfer 2702 tcp SMS XFER
sms-xfer 2702 udp SMS XFER
sms-chat 2703 tcp SMS CHAT
sms-chat 2703 udp SMS CHAT
sms-remctrl 2704 tcp SMS REMCTRL Tom Friend Tom Friend
sms-remctrl 2704 udp SMS REMCTRL Tom Friend Tom Friend
sds-admin 2705 tcp SDS Admin Don Traub Don Traub
sds-admin 2705 udp SDS Admin Don Traub Don Traub
ncdmirroring 2706 tcp NCD Mirroring Tim Stevenson Tim Stevenson
ncdmirroring 2706 udp NCD Mirroring Tim Stevenson Tim Stevenson
emcsymapiport 2707 tcp EMCSYMAPIPORT Bruce Ferjulian Bruce Ferjulian
emcsymapiport 2707 udp EMCSYMAPIPORT Bruce Ferjulian Bruce Ferjulian
banyan-net 2708 tcp Banyan-Net R. Thirumurthy R. Thirumurthy
banyan-net 2708 udp Banyan-Net R. Thirumurthy R. Thirumurthy
supermon 2709 tcp Supermon Ron Minnich Ron Minnich
supermon 2709 udp Supermon Ron Minnich Ron Minnich
verismart 3270 tcp Verismart Jay Weber Jay Weber
verismart 3270 udp Verismart Jay Weber Jay Weber
cartographerxmp 5270 tcp Cartographer XMP Bobby Krupczak Bobby Krupczak 2008-04-03 2011-08-31
cartographerxmp 5270 udp Cartographer XMP Bobby Krupczak Bobby Krupczak 2008-04-03 2011-08-31
6270-6299 Unassigned
robot-remote 8270 tcp Robot Framework Remote Library Interface Robot Framework Foundation Chris Newman 2017-01-26
8270 udp Reserved
flex-lm 27000-27009 FLEX LM (1-10) Flexera Software Paul Bland 2018-02-15
flex-lmadmin 27010 tcp A protocol for managing license services Flexera Paul Bland 2018-08-22
27010 udp Reserved
27011-27015 Unassigned
chlenix 27016 tcp Cloud hosting environment network Vlad Bondarenko Vlad Bondarenko 2024-09-23
27016 udp Reserved
mongodb 27017 tcp Mongo database system MongoDB, Inc. Akshay Kumar 2019-02-21
27017 udp Reserved
27018-27344 Unassigned Unauthorized Use Known on ports 27018 and 27019

Contact Information

Name Organization Contact URI Last Updated
Adam Ernst cosmicsoft&cosmicsoft.net 2004-12
Akshay Kumar MongoDB, Inc. akshay&mongodb.com 2019-02-21
Al Guetzlaff aeg&teamquest.com
Ashvin Sanghvi AshvinS&microsoft.com
Bobby Krupczak rdk&krupczak.org 2008-04-03
Bruce Ferjulian ferjulian_bruce&emc.com
Chris Newman chris.newman&oracle.com 2017-01-26
Don Traub don.traub&sun.com
Flexera pbland&flexera.com 2018-08-22
Flexera Software security&flexerasoftware.com 2016-07-19
Jay Weber weber&vfi.com
MongoDB, Inc. akshay&mongodb.com 2019-02-21
Paul Bland pbland&flexera.com 2018-08-22
R. Thirumurthy rtm&banyannetworks.com
Robot Framework Foundation robotframework-foundation&googlegroups.com 2017-01-26
Ron Minnich rminnich&acl.lanl.gov
Tim Stevenson tes&ncd.com
Tom Friend tomfr&microsoft.com
Vlad Bondarenko bondarenko.vlad.univ&gmail.com 2024-09-23
Weldon J. Showalter Gamma&mintaka.dca.mil