Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
acr-nema 104 tcp ACR-NEMA Digital Imag. & Comm. 300 Patrick McNamee Patrick McNamee
acr-nema 104 udp ACR-NEMA Digital Imag. & Comm. 300 Patrick McNamee Patrick McNamee
tacacss 300 tcp TLS Secure Login Host Protocol (TACACSS) IESG IETF Chair 2025-07-15 RFC 9887
300 udp Reserved
h323hostcallsc 1300 tcp H.323 Secure Call Control Signalling ITU-T ITU-T TSB 2013-01-31
h323hostcallsc 1300 udp H.323 Secure Call Control Signalling ITU-T ITU-T TSB 2013-01-31
cvmmon 2300 tcp CVMMON Roger Kumpf Roger Kumpf
cvmmon 2300 udp CVMMON Roger Kumpf Roger Kumpf
hp-3000-telnet 2564 tcp HP 3000 NS/VT block mode telnet
hp-3000-telnet 2564 udp HP 3000 NS/VT block mode telnet
hbci 3000 tcp HBCI Kurt Haubner Kurt Haubner
hbci 3000 udp HBCI Kurt Haubner Kurt Haubner
remoteware-cl 3000 tcp RemoteWare Client Tim Farley Tim Farley This entry records an unassigned but widespread use
remoteware-cl 3000 udp RemoteWare Client Tim Farley Tim Farley This entry records an unassigned but widespread use
origo-native 3001 tcp OrigoDB Server Native Interface Devrex Labs Robert Friberg 2013-03-29 port 3001 previously "Removed on 2006-05-25"
3001 udp Reserved 2013-03-29 port 3001 previously "Removed on 2006-05-25"
exlm-agent 3002 tcp EXLM Agent Randy Martin Randy Martin
exlm-agent 3002 udp EXLM Agent Randy Martin Randy Martin
remoteware-srv 3002 tcp RemoteWare Server Tim Farley Tim Farley This entry records an unassigned but widespread use
remoteware-srv 3002 udp RemoteWare Server Tim Farley Tim Farley This entry records an unassigned but widespread use
cgms 3003 tcp CGMS Corey Clinton Corey Clinton 2011-02-02
cgms 3003 udp CGMS Corey Clinton Corey Clinton 2011-02-02
csoftragent 3004 tcp Csoft Agent Nedelcho Stanev Nedelcho Stanev
csoftragent 3004 udp Csoft Agent Nedelcho Stanev Nedelcho Stanev
geniuslm 3005 tcp Genius License Manager Jakob Spies Jakob Spies
geniuslm 3005 udp Genius License Manager Jakob Spies Jakob Spies
ii-admin 3006 tcp Instant Internet Admin PerfTech, Inc. Lewis Donzis 2019-12-19
ii-admin 3006 udp Instant Internet Admin PerfTech, Inc. Lewis Donzis 2019-12-19
lotusmtap 3007 tcp Lotus Mail Tracking Agent Protocol Ken Lin Ken Lin
lotusmtap 3007 udp Lotus Mail Tracking Agent Protocol Ken Lin Ken Lin
midnight-tech 3008 tcp Midnight Technologies Kyle Unice Kyle Unice
midnight-tech 3008 udp Midnight Technologies Kyle Unice Kyle Unice
pxc-ntfy 3009 tcp PXC-NTFY Takeshi Nishizawa Takeshi Nishizawa
pxc-ntfy 3009 udp PXC-NTFY Takeshi Nishizawa Takeshi Nishizawa
ceph 3300 tcp Ceph monitor Sage Weil Sage Weil 2015-06-29 Known Unauthorized Use on port 3300
3300 udp Reserved
corelccam 4300 tcp Corel CCam Jason Aiken Jason Aiken
corelccam 4300 udp Corel CCam Jason Aiken Jason Aiken
lisp-data 4341 udp LISP Data Packets IESG IETF Chair 2007-11-12 2021-02-17 RFC 9300
hacl-hb 5300 tcp HA cluster heartbeat Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-hb 5300 udp HA cluster heartbeat Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
bmc-grx 6300 tcp BMC GRX Portnoy Boxman Portnoy Boxman
bmc-grx 6300 udp BMC GRX Portnoy Boxman Portnoy Boxman
swx 7300-7359 The Swiss Exchange Edgar Blum Edgar Blum
tmi 8300 tcp Transport Management Interface Steve Kneizys Steve Kneizys 2006-11
tmi 8300 udp Transport Management Interface Steve Kneizys Steve Kneizys 2006-11
vrace 9300 tcp Virtual Racing Service Pete Loeffen Pete Loeffen 2006-10
vrace 9300 udp Virtual Racing Service Pete Loeffen Pete Loeffen 2006-10
linogridengine 12300 tcp LinoGrid Engine Frans Lundberg Frans Lundberg 2004-11
linogridengine 12300 udp LinoGrid Engine Frans Lundberg Frans Lundberg 2004-11
inovaport1 23000 tcp Inova LightLink Server Type 1 Chris Koeritz Chris Koeritz 2006-10
inovaport1 23000 udp Inova LightLink Server Type 1 Chris Koeritz Chris Koeritz 2006-10
inovaport2 23001 tcp Inova LightLink Server Type 2 Chris Koeritz Chris Koeritz 2006-10
inovaport2 23001 udp Inova LightLink Server Type 2 Chris Koeritz Chris Koeritz 2006-10
inovaport3 23002 tcp Inova LightLink Server Type 3 Chris Koeritz Chris Koeritz 2006-10
inovaport3 23002 udp Inova LightLink Server Type 3 Chris Koeritz Chris Koeritz 2006-10
inovaport4 23003 tcp Inova LightLink Server Type 4 Chris Koeritz Chris Koeritz 2006-10
inovaport4 23003 udp Inova LightLink Server Type 4 Chris Koeritz Chris Koeritz 2006-10
inovaport5 23004 tcp Inova LightLink Server Type 5 Chris Koeritz Chris Koeritz 2006-10
inovaport5 23004 udp Inova LightLink Server Type 5 Chris Koeritz Chris Koeritz 2006-10
inovaport6 23005 tcp Inova LightLink Server Type 6 Chris Koeritz Chris Koeritz 2006-10
inovaport6 23005 udp Inova LightLink Server Type 6 Chris Koeritz Chris Koeritz 2006-10
23006-23052 Unassigned
ndmps 30000 tcp Secure Network Data Management Protocol Alioune Thiam Alioune Thiam 2013-02-05
30000 udp Reserved
pago-services1 30001 tcp Pago Services 1 Balduin Mueller-Platz Balduin Mueller-Platz 2002-03
pago-services1 30001 udp Pago Services 1 Balduin Mueller-Platz Balduin Mueller-Platz 2002-03
pago-services2 30002 tcp Pago Services 2 Balduin Mueller-Platz Balduin Mueller-Platz 2002-03
pago-services2 30002 udp Pago Services 2 Balduin Mueller-Platz Balduin Mueller-Platz 2002-03
amicon-fpsu-ra 30003 tcp Amicon FPSU-IP Remote Administration Amicon OOO Alexey Novotorzhin 2013-04-25
amicon-fpsu-ra 30003 udp Amicon FPSU-IP Remote Administration Amicon OOO Alexey Novotorzhin 2013-04-25
amicon-fpsu-s 30004 udp Amicon FPSU-IP VPN Amicon OOO Alexey Novotorzhin 2013-04-25
30004 tcp Reserved
30005-30099 Unassigned
wg-endpt-comms 33000 tcp WatchGuard Endpoint Communications WatchGuard Technologies, Inc. Anunoy Ghosh 2020-01-16
33000 udp Reserved
33001-33059 Unassigned
recvr-rc 43000 tcp Receiver Remote Control Research Electronics International Ross Binkley 2012-12-20
recvr-rc-disc 43000 udp Receiver Remote Control Discovery Research Electronics International Ross Binkley 2012-12-20
43001-43187 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alexey Novotorzhin Amicon OOO nav&amicon.ru 2013-04-25
Alioune Thiam alioune_thiam&symantec.com 2013-02-05
Amicon OOO info&amicon.ru 2013-04-25
Anunoy Ghosh anunoy.ghosh&watchguard.com 2020-01-16
Balduin Mueller-Platz balduin.mueller-platz&pago.de 2002-03
Chris Koeritz portmanager&inovasolutions.com 2006-10
Corey Clinton ccclinton&travisassoc.com 2011-02-02
Devrex Labs robert.friberg&devrex.se 2013-03-29
Edgar Blum edgar.blum&swx.ch
Edward Yim eyim&hpmfas4.cup.hp.com
Eric Soderberg seric&hposl102.cup.hp
Frans Lundberg frans&linova.com 2004-11
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU-T tsbsg16&itu.int 2013-01-31
ITU-T TSB ITU-T tsbsg16&itu.int 2013-01-31
Jakob Spies Jakob.Spies&genius.de
Jason Aiken jasona&corelcomputer.com
Ken Lin klin&us.ibm.com
Kurt Haubner haubner&ibm.net
Kyle Unice kyle&midnighttech.com
Lewis Donzis lew&perftech.com 2019-12-19
Nedelcho Stanev decho&csoft.bg
Patrick McNamee
PerfTech, Inc. contact&perftech.com 2019-12-19
Pete Loeffen President at Digital Rowing Inc. peterl&digitalrowing.com 2006-10
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Randy Martin exlmoc&clemson.edu
Research Electronics International software&reiusa.net 2012-12-20
Robert Friberg Devrex Labs robert.friberg&devrex.se 2013-03-29
Roger Kumpf kumpf&cup.hp.com
Ross Binkley Research Electronics International software&reiusa.net 2012-12-20
Sage Weil sage&newdream.net 2015-06-29
Steve Kneizys skneizys&erpdata.com 2006-11
Takeshi Nishizawa takeshi&cp10.es.xerox.com
Tim Farley Tim.Farley&xcellenet.com
WatchGuard Technologies, Inc. vendoraccount&watchguard.com 2020-01-16