Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
pkix-timestamp 318 tcp PKIX TimeStamp Robert Zuccherato Robert Zuccherato
pkix-timestamp 318 udp PKIX TimeStamp Robert Zuccherato Robert Zuccherato
krb5gatekeeper 1318 tcp krb5gatekeeper Patrick Moore Patrick Moore
krb5gatekeeper 1318 udp krb5gatekeeper Patrick Moore Patrick Moore
cadencecontrol 2318 tcp Cadence Control Buck Caldwell Buck Caldwell
cadencecontrol 2318 udp Cadence Control Buck Caldwell Buck Caldwell
mc-brk-srv 3180 tcp Millicent Broker Server Steve Glassman Steve Glassman
mc-brk-srv 3180 udp Millicent Broker Server Steve Glassman Steve Glassman
bmcpatrolagent 3181 tcp BMC Patrol Agent
bmcpatrolagent 3181 udp BMC Patrol Agent
bmcpatrolrnvu 3182 tcp BMC Patrol Rendezvous Portnoy Boxman Portnoy Boxman
bmcpatrolrnvu 3182 udp BMC Patrol Rendezvous Portnoy Boxman Portnoy Boxman
cops-tls 3183 tcp COPS/TLS Mark Stevens Mark Stevens
cops-tls 3183 udp COPS/TLS Mark Stevens Mark Stevens
apogeex-port 3184 tcp ApogeeX Port Tom Nys Tom Nys
apogeex-port 3184 udp ApogeeX Port Tom Nys Tom Nys
smpppd 3185 tcp SuSE Meta PPPD Arvin Schnell Arvin Schnell
smpppd 3185 udp SuSE Meta PPPD Arvin Schnell Arvin Schnell
iiw-port 3186 tcp IIW Monitor User Port Corey Burnett Corey Burnett
iiw-port 3186 udp IIW Monitor User Port Corey Burnett Corey Burnett
odi-port 3187 tcp Open Design Listen Port Phivos Aristides Phivos Aristides
odi-port 3187 udp Open Design Listen Port Phivos Aristides Phivos Aristides
brcm-comm-port 3188 tcp Broadcom Port Thomas L. Johnson Thomas L. Johnson
brcm-comm-port 3188 udp Broadcom Port Thomas L. Johnson Thomas L. Johnson
pcle-infex 3189 tcp Pinnacle Sys InfEx Port Anthon van der Neut Anthon van der Neut
pcle-infex 3189 udp Pinnacle Sys InfEx Port Anthon van der Neut Anthon van der Neut
ssrip 3318 tcp Swith to Swith Routing Information Protocol Baba Hidekazu Baba Hidekazu
ssrip 3318 udp Swith to Swith Routing Information Protocol Baba Hidekazu Baba Hidekazu
4318 Unassigned
pkix-cmc 5318 tcp PKIX Certificate Management using CMS (CMC) IESG IETF Chair 2026-02-13 RFC 10003
5318 udp Reserved
iona-data 6318 tcp IONA Measurement and control data Insphere Ltd Guy Avery 2024-07-01
6318 udp Reserved
secure-ts 9318 tcp PKIX TimeStamp over TLS Niklas Weiss Niklas Weiss 2004-11
secure-ts 9318 udp PKIX TimeStamp over TLS Niklas Weiss Niklas Weiss 2004-11
11236-11318 Unassigned
43001-43187 Unassigned
reachout 43188 tcp REACHOUT Roman Kriis Roman Kriis
reachout 43188 udp REACHOUT Roman Kriis Roman Kriis
ndm-agent-port 43189 tcp NDM-AGENT-PORT Roman Kriis Roman Kriis
ndm-agent-port 43189 udp NDM-AGENT-PORT Roman Kriis Roman Kriis

Contact Information

Name Organization Contact URI Last Updated
Anthon van der Neut anthon&mnt.org
Arvin Schnell arvin&suse.de
Baba Hidekazu baba&flare.nd.net.fujitsu.co.jp
Buck Caldwell buck_c&polygon.com
Corey Burnett corey.burnett&biopop.com
Guy Avery Insphere Ltd guy&insphereltd.com 2013-02-20
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Insphere Ltd guy&insphereltd.com 2024-07-01
Mark Stevens mstevens&ellacoya.com
Niklas Weiss n.weiss&d-trust.net 2004-11
Patrick Moore pcmoore&sandia.gov
Phivos Aristides phivos&opendesign.com
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Robert Zuccherato robert.zuccherato&entrust.com
Roman Kriis roman&previo.ee
Steve Glassman steveg&pa.dec.com
Thomas L. Johnson tjohnson&broadcom.com
Tom Nys tom.nys.tn&belgium.agfa.com