Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ptp-event 319 tcp PTP Event Kang Lee Kang Lee 2010-07-27
ptp-event 319 udp PTP Event Kang Lee Kang Lee 2010-07-27
syslog-conn 601 tcp Reliable Syslog Service RFC 3195
syslog-conn 601 udp Reliable Syslog Service RFC 3195
amx-icsp 1319 tcp AMX-ICSP Jeff Burch Jeff Burch
amx-icsp 1319 udp AMX-ICSP Jeff Burch Jeff Burch
infolibria 2319 tcp InfoLibria Chris Chiotasso Chris Chiotasso
infolibria 2319 udp InfoLibria Chris Chiotasso Chris Chiotasso
csvr-proxy 3190 tcp ConServR Proxy
csvr-proxy 3190 udp ConServR Proxy
csvr-sslproxy 3191 tcp ConServR SSL Proxy Mikhail Kruk Mikhail Kruk
csvr-sslproxy 3191 udp ConServR SSL Proxy Mikhail Kruk Mikhail Kruk
firemonrcc 3192 tcp FireMon Revision Control Michael Bishop Michael Bishop
firemonrcc 3192 udp FireMon Revision Control Michael Bishop Michael Bishop
spandataport 3193 tcp SpanDataPort Jesse McKay Jesse McKay
spandataport 3193 udp SpanDataPort Jesse McKay Jesse McKay
magbind 3194 tcp Rockstorm MAG protocol Jens Nilsson Jens Nilsson
magbind 3194 udp Rockstorm MAG protocol Jens Nilsson Jens Nilsson
ncu-1 3195 tcp Network Control Unit
ncu-1 3195 udp Network Control Unit
ncu-2 3196 tcp Network Control Unit Charlie Hundre Charlie Hundre
ncu-2 3196 udp Network Control Unit Charlie Hundre Charlie Hundre
embrace-dp-s 3197 tcp Embrace Device Protocol Server
embrace-dp-s 3197 udp Embrace Device Protocol Server
embrace-dp-c 3198 tcp Embrace Device Protocol Client Elliot Schwartz Elliot Schwartz
embrace-dp-c 3198 udp Embrace Device Protocol Client Elliot Schwartz Elliot Schwartz
dmod-workspace 3199 tcp DMOD WorkSpace Nick Plante Nick Plante
dmod-workspace 3199 udp DMOD WorkSpace Nick Plante Nick Plante
sdt-lmd 3319 tcp SDT License Manager Salvo Nassisi Salvo Nassisi
sdt-lmd 3319 udp SDT License Manager Salvo Nassisi Salvo Nassisi
skytale 4319 tcp Sentyron SkyTale encrypted communication Sentyron B.V. Mark Revier 2022-01-20 2025-10-30
skytale 4319 udp Sentyron SkyTale encrypted communication Sentyron B.V. Mark Revier 2022-01-20 2025-10-30
roughtime 5319 tcp Roughtime time synchronization IESG IETF Chair 2026-03-27 RFC 10049
roughtime 5319 udp Roughtime time synchronization IESG IETF Chair 2026-03-27 RFC 10049
6319 Unassigned
8314-8319 Unassigned
9319-9320 Unassigned
imip 11319 tcp IMIP Len Zuvela Len Zuvela
imip 11319 udp IMIP Len Zuvela Len Zuvela
31766-31947 Unassigned
iceedcp-tx 31948 tcp Embedded Device Configuration Protocol TX

IANA assigned this well-formed service name as a replacement for "iceedcp_tx".
Oliver Lewis Oliver Lewis 2006-08
iceedcp_tx 31948 tcp Embedded Device Configuration Protocol TX Oliver Lewis Oliver Lewis 2006-08 This entry is an alias to "iceedcp-tx". This entry is now historic, not usable for use with many common service discovery mechanisms.
iceedcp-tx 31948 udp Embedded Device Configuration Protocol TX

IANA assigned this well-formed service name as a replacement for "iceedcp_tx".
Oliver Lewis Oliver Lewis 2006-08
iceedcp_tx 31948 udp Embedded Device Configuration Protocol TX Oliver Lewis Oliver Lewis 2006-08 This entry is an alias to "iceedcp-tx". This entry is now historic, not usable for use with many common service discovery mechanisms.
iceedcp-rx 31949 tcp Embedded Device Configuration Protocol RX

IANA assigned this well-formed service name as a replacement for "iceedcp_rx".
Oliver Lewis Oliver Lewis 2006-08
iceedcp_rx 31949 tcp Embedded Device Configuration Protocol RX Oliver Lewis Oliver Lewis 2006-08 This entry is an alias to "iceedcp-rx". This entry is now historic, not usable for use with many common service discovery mechanisms.
iceedcp-rx 31949 udp Embedded Device Configuration Protocol RX

IANA assigned this well-formed service name as a replacement for "iceedcp_rx".
Oliver Lewis Oliver Lewis 2006-08
iceedcp_rx 31949 udp Embedded Device Configuration Protocol RX Oliver Lewis Oliver Lewis 2006-08 This entry is an alias to "iceedcp-rx". This entry is now historic, not usable for use with many common service discovery mechanisms.
31950-32033 Unassigned
ip-provision 43190 tcp IP-PROVISION Roman Kriis Roman Kriis
ip-provision 43190 udp IP-PROVISION Roman Kriis Roman Kriis
noit-transport 43191 tcp Reconnoiter Agent Data Transport Theo Schlossnagle Theo Schlossnagle 2009-05-19
43191 udp Reserved
43192-43209 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Charlie Hundre charlie&rdsrv.reco.com.tw
Chris Chiotasso cchiotasso&infolibria.com
Elliot Schwartz elliot&mit.edu
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jeff Burch jeff.burch&amx.com
Jens Nilsson jens&rockstorm.se
Jesse McKay jesse&spandata.com
Kang Lee I&M Society TC-9 kang.lee&nist.gov 2010-07-27
Len Zuvela IM Unified Coalition imu-comments&egroups.com
Mark Revier Sentyron B.V. iana&sentyron.com 2025-10-30
Michael Bishop mbishop&fishnetsecurity.com
Mikhail Kruk mkruk&biscom.com
Nick Plante nplante&dmod.com
Oliver Lewis o.lewis&icerobotics.co.uk 2006-08
Roman Kriis roman&previo.ee
Salvo Nassisi sdtech&tin.it
Sentyron B.V. iana&sentyron.com 2025-10-30
Theo Schlossnagle jesus&omniti.com 2009-05-19