Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-10
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| rtsps | 322 | tcp | RTSPS | Anders Klemets | Anders Klemets | ||||||
| rtsps | 322 | udp | RTSPS | Anders Klemets | Anders Klemets | ||||||
| novation | 1322 | tcp | Novation | Alan Dano | Alan Dano | ||||||
| novation | 1322 | udp | Novation | Alan Dano | Alan Dano | ||||||
| ofsd | 2322 | tcp | ofsd | ||||||||
| ofsd | 2322 | udp | ofsd | ||||||||
| xnm-ssl | 3220 | tcp | XML NM over SSL | ||||||||
| xnm-ssl | 3220 | udp | XML NM over SSL | ||||||||
| xnm-clear-text | 3221 | tcp | XML NM over TCP | Mark Trostler | Mark Trostler | ||||||
| xnm-clear-text | 3221 | udp | XML NM over TCP | Mark Trostler | Mark Trostler | ||||||
| glbp | 3222 | tcp | Gateway Load Balancing Pr | Douglas McLaggan | Douglas McLaggan | ||||||
| glbp | 3222 | udp | Gateway Load Balancing Pr | Douglas McLaggan | Douglas McLaggan | ||||||
| digivote | 3223 | tcp | DIGIVOTE (R) Vote-Server | Christian Treczoks | Christian Treczoks | ||||||
| digivote | 3223 | udp | DIGIVOTE (R) Vote-Server | Christian Treczoks | Christian Treczoks | ||||||
| aes-discovery | 3224 | tcp | AES Discovery Port | Ken Richard | Ken Richard | ||||||
| aes-discovery | 3224 | udp | AES Discovery Port | Ken Richard | Ken Richard | ||||||
| fcip-port | 3225 | tcp | FCIP | RFC 3821 | |||||||
| fcip-port | 3225 | udp | FCIP | RFC 3821 | |||||||
| isi-irp | 3226 | tcp | ISI Industry Software IRP | Peter Sandstrom | Peter Sandstrom | ||||||
| isi-irp | 3226 | udp | ISI Industry Software IRP | Peter Sandstrom | Peter Sandstrom | ||||||
| dwnmshttp | 3227 | tcp | DiamondWave NMS Server | ||||||||
| dwnmshttp | 3227 | udp | DiamondWave NMS Server | ||||||||
| dwmsgserver | 3228 | tcp | DiamondWave MSG Server | Varma Bhupatiraju | Varma Bhupatiraju | ||||||
| dwmsgserver | 3228 | udp | DiamondWave MSG Server | Varma Bhupatiraju | Varma Bhupatiraju | ||||||
| global-cd-port | 3229 | tcp | Global CD Port | Vitaly Revsin | Vitaly Revsin | ||||||
| global-cd-port | 3229 | udp | Global CD Port | Vitaly Revsin | Vitaly Revsin | ||||||
| active-net | 3322-3325 | Active Networks | Bob Braden | Bob Braden | |||||||
| trim-event | 4322 | tcp | TRIM Event Service | ||||||||
| trim-event | 4322 | udp | TRIM Event Service | ||||||||
| 5322-5342 | Unassigned | ||||||||||
| emp-server2 | 6322 | tcp | Empress Software Connectivity Server 2 | Srdjan Holovac | Srdjan Holovac | ||||||
| emp-server2 | 6322 | udp | Empress Software Connectivity Server 2 | Srdjan Holovac | Srdjan Holovac | ||||||
| garmin-marine | 8322 | tcp | Garmin Marine | Garmin International, Inc." | Nathan Karstens | 2015-07-23 | |||||
| garmin-marine | 8322 | udp | Garmin Marine | Garmin International, Inc." | Nathan Karstens | 2015-07-23 | |||||
| 9322-9338 | Unassigned | ||||||||||
| 10322-10438 | Unassigned | ||||||||||
| 11322-11366 | Unassigned | ||||||||||
| warehouse | 12322 | tcp | Warehouse Monitoring Syst | Craig Steffen | Craig Steffen | 2005-08 | |||||
| warehouse | 12322 | udp | Warehouse Monitoring Syst | Craig Steffen | Craig Steffen | 2005-08 | |||||
| 13219-13222 | Unassigned | ||||||||||
| powwow-client | 13223 | tcp | PowWow Client | Paul K. Peterson | Paul K. Peterson | ||||||
| powwow-client | 13223 | udp | PowWow Client | Paul K. Peterson | Paul K. Peterson | ||||||
| powwow-server | 13224 | tcp | PowWow Server | Paul K. Peterson | Paul K. Peterson | ||||||
| powwow-server | 13224 | udp | PowWow Server | Paul K. Peterson | Paul K. Peterson | ||||||
| 13225-13399 | Unassigned | ||||||||||
| hid | 24322 | udp | Transport of Human Interface Device data streams | Freebox SAS | Nicolas Pouillon | 2012-12-14 | |||||
| 24322 | tcp | Reserved | |||||||||
| 32035-32248 | Unassigned | ||||||||||
| t1distproc60 | 32249 | tcp | T1 Distributed Processor | Peter Beahan | Peter Beahan | 2004-11 | |||||
| t1distproc60 | 32249 | udp | T1 Distributed Processor | Peter Beahan | Peter Beahan | 2004-11 | |||||
| 32250-32399 | Unassigned | ||||||||||
| pmproxy | 44322 | tcp | PCP proxy (pmproxy) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2003-07 | 2025-09-26 | ||||
| pmproxy | 44322 | udp | PCP proxy (pmproxy) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2003-07 | 2025-09-26 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alan Dano | wiseobject&yahoo.com | ||
| Anders Klemets | andersklµsoft.com | ||
| Bob Braden | braden&isi.edu | ||
| Christian Treczoks | ct&braehler.com | ||
| Craig Steffen | csteffen&ncsa.uiuc.edu | 2005-08 | |
| Douglas McLaggan | glbp-info&cisco.com | ||
| Freebox SAS | npouillon&freebox.fr | 2012-12-14 | |
| Garmin International, Inc." | nettel&garmin.com | 2015-07-23 | |
| Ken McDonell | kenj&kenj.id.au | 2025-09-26 | |
| Ken Richard | kenr&aeseducation.com | ||
| Mark Trostler | trostler&juniper.net | ||
| Nathan Karstens | Garmin International, Inc. | nettel&garmin.com | 2015-07-23 |
| Nicolas Pouillon | Freebox SAS | npouillon&freebox.fr | 2012-12-14 |
| Paul K. Peterson | paul&tribal.com | ||
| Performance Co-Pilot (PCP) Project | pcp-maintainers&groups.io | 2025-09-26 | |
| Peter Beahan | peter_beahan&technologyonecorp.com | 2004-11 | |
| Peter Sandstrom | peter.sandstrom&tassen.fi | ||
| Srdjan Holovac | srdjan&empress.com | ||
| Varma Bhupatiraju | varma&calient.net | ||
| Vitaly Revsin | vitaly&netapp.com |