Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-06

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
apex-edge 913 tcp APEX endpoint-relay service RFC 3340
apex-edge 913 udp APEX endpoint-relay service RFC 3340
naap 1340 tcp NAAP Henry Haverinen Henry Haverinen
naap 1340 udp NAAP Henry Haverinen Henry Haverinen
wrs-registry 2340 tcp WRS Registry

IANA assigned this well-formed service name as a replacement for "wrs_registry".
Christophe Cleraux Christophe Cleraux
wrs_registry 2340 tcp WRS Registry Christophe Cleraux Christophe Cleraux This entry is an alias to "wrs-registry". This entry is now historic, not usable for use with many common service discovery mechanisms.
wrs-registry 2340 udp WRS Registry

IANA assigned this well-formed service name as a replacement for "wrs_registry".
Christophe Cleraux Christophe Cleraux
wrs_registry 2340 udp WRS Registry Christophe Cleraux Christophe Cleraux This entry is an alias to "wrs-registry". This entry is now historic, not usable for use with many common service discovery mechanisms.
anet-m 3340 tcp OMF data m
anet-m 3340 udp OMF data m
csms2 3400 tcp CSMS2 Markus Michels Markus Michels
csms2 3400 udp CSMS2 Markus Michels Markus Michels
filecast 3401 tcp filecast Eden Sherry Eden Sherry
filecast 3401 udp filecast Eden Sherry Eden Sherry
fxaengine-net 3402 tcp FXa Engine Network Port Lucas Alonso Lucas Alonso 2002-02
fxaengine-net 3402 udp FXa Engine Network Port Lucas Alonso Lucas Alonso 2002-02
3403 De-registered 2006-10-27
3404 Removed 2002-05-01
nokia-ann-ch1 3405 tcp Nokia Announcement ch 1
nokia-ann-ch1 3405 udp Nokia Announcement ch 1
nokia-ann-ch2 3406 tcp Nokia Announcement ch 2 Morteza Kalhour Morteza Kalhour 2002-02
nokia-ann-ch2 3406 udp Nokia Announcement ch 2 Morteza Kalhour Morteza Kalhour 2002-02
ldap-admin 3407 tcp LDAP admin server port Stephen Tsun Stephen Tsun 2002-02
ldap-admin 3407 udp LDAP admin server port Stephen Tsun Stephen Tsun 2002-02
BESApi 3408 tcp BES Api Port Colin Griffiths Colin Griffiths 2002-02
BESApi 3408 udp BES Api Port Colin Griffiths Colin Griffiths 2002-02
networklens 3409 tcp NetworkLens Event Port
networklens 3409 udp NetworkLens Event Port
gaia 4340 tcp Gaia Connector Protocol Philippe Detournay Philippe Detournay 2007-11-12
gaia 4340 udp Gaia Connector Protocol Philippe Detournay Philippe Detournay 2007-11-12
gribi 9340 tcp gRPC Routing Information Base Interface Google Networking Rob Shakir 2022-03-29
9340 udp Reserved
doip-data 13400 tcp DoIP Data Joerg Schneider Joerg Schneider 2011-01-26
doip-disc 13400 udp DoIP Discovery Joerg Schneider Joerg Schneider 2011-01-26
13401-13719 Unassigned
novar-dbase 23400 tcp Novar Data Keith Kilroy Keith Kilroy 2006-02
novar-dbase 23400 udp Novar Data Keith Kilroy Keith Kilroy 2006-02
novar-alarm 23401 tcp Novar Alarm Keith Kilroy Keith Kilroy 2006-02
novar-alarm 23401 udp Novar Alarm Keith Kilroy Keith Kilroy 2006-02
novar-global 23402 tcp Novar Global Keith Kilroy Keith Kilroy 2006-02
novar-global 23402 udp Novar Global Keith Kilroy Keith Kilroy 2006-02
23403-23455 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Christophe Cleraux chrisc&wrs.com
Colin Griffiths colin.griffiths&interlinksoftware.com 2002-02
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Eden Sherry eden&pair.com
Google Networking gribi-maintainers&google.com 2022-03-29
Henry Haverinen henry.haverinen&nokia.com
Joerg Schneider joerg.s.schneider&daimler.com 2011-01-26
Keith Kilroy Keith.Kilroy&novarcontrols.com 2006-02
Lucas Alonso luke&demiurgestudios.com 2002-02
Markus Michels mmi&cedros.com
Morteza Kalhour Morteza.Kalhour&nokia.com 2002-02
Philippe Detournay philippe.detournay&acrosoft.be 2007-11-12
Rob Shakir Google Networking robjs&google.com 2022-03-29
Stephen Tsun stsun&calient.net 2002-02