Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| is99s | 380 | tcp | TIA/EIA/IS-99 modem server | Frank Quick | Frank Quick | ||||||
| is99s | 380 | udp | TIA/EIA/IS-99 modem server | Frank Quick | Frank Quick | ||||||
| telesis-licman | 1380 | tcp | Telesis Network License Manager | Karl Schendel, Jr. | Karl Schendel, Jr. | ||||||
| telesis-licman | 1380 | udp | Telesis Network License Manager | Karl Schendel, Jr. | Karl Schendel, Jr. | ||||||
| etcd-server | 2380 | tcp | etcd server to server communication | CoreOS | Brian Harrington | 2014-07-09 | |||||
| 2380 | udp | Reserved | |||||||||
| sns-channels | 3380 | tcp | SNS Channels | Shekar Pasumarthi | Shekar Pasumarthi | ||||||
| sns-channels | 3380 | udp | SNS Channels | Shekar Pasumarthi | Shekar Pasumarthi | ||||||
| teredo | 3544 | tcp | Teredo Port | RFC 4380 | |||||||
| teredo | 3544 | udp | Teredo Port | RFC 4380 | |||||||
| pwgpsi | 3800 | tcp | Print Services Interface | Harry Lewis | Harry Lewis | 2003-05 | |||||
| pwgpsi | 3800 | udp | Print Services Interface | Harry Lewis | Harry Lewis | 2003-05 | |||||
| ibm-mgr | 3801 | tcp | ibm manager service | Tim Hahn | Tim Hahn | 2006-03 | |||||
| ibm-mgr | 3801 | udp | ibm manager service | Tim Hahn | Tim Hahn | 2006-03 | |||||
| vhd | 3802 | tcp | VHD | Chris Duncombe | Chris Duncombe | ||||||
| vhd | 3802 | udp | VHD | Chris Duncombe | Chris Duncombe | ||||||
| soniqsync | 3803 | tcp | SoniqSync | Ryan Melville | Ryan Melville | 2004-01 | |||||
| soniqsync | 3803 | udp | SoniqSync | Ryan Melville | Ryan Melville | 2004-01 | |||||
| iqnet-port | 3804 | tcp | Harman IQNet Port | Bruce Vander Werf | Bruce Vander Werf | 2004-02 | |||||
| iqnet-port | 3804 | udp | Harman IQNet Port | Bruce Vander Werf | Bruce Vander Werf | 2004-02 | |||||
| tcpdataserver | 3805 | tcp | ThorGuard Server Port | Joel E. Steiger | Joel E. Steiger | 2004-02 | |||||
| tcpdataserver | 3805 | udp | ThorGuard Server Port | Joel E. Steiger | Joel E. Steiger | 2004-02 | |||||
| wsmlb | 3806 | tcp | Remote System Manager | Thomas Fiege | Thomas Fiege | 2004-02 | |||||
| wsmlb | 3806 | udp | Remote System Manager | Thomas Fiege | Thomas Fiege | 2004-02 | |||||
| spugna | 3807 | tcp | SpuGNA Communication Port | Samuele Sequi | Samuele Sequi | 2004-02 | |||||
| spugna | 3807 | udp | SpuGNA Communication Port | Samuele Sequi | Samuele Sequi | 2004-02 | |||||
| sun-as-iiops-ca | 3808 | tcp | Sun App Svr-IIOPClntAuth | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| sun-as-iiops-ca | 3808 | udp | Sun App Svr-IIOPClntAuth | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| apocd | 3809 | tcp | Java Desktop System Configuration Agent | Geoff Higgins | Geoff Higgins | 2006-03 | |||||
| apocd | 3809 | udp | Java Desktop System Configuration Agent | Geoff Higgins | Geoff Higgins | 2006-03 | |||||
| 4380-4388 | Unassigned | ||||||||||
| v5ua | 5675 | tcp | V5UA application port | RFC 3807 | |||||||
| v5ua | 5675 | udp | V5UA application port | RFC 3807 | |||||||
| v5ua | 5675 | sctp | V5UA application port | RFC 3807 | |||||||
| 6380-6381 | Unassigned | ||||||||||
| cruise-update | 8380 | tcp | Cruise UPDATE | Steve Husak | Steve Husak | ||||||
| cruise-update | 8380 | udp | Cruise UPDATE | Steve Husak | Steve Husak | ||||||
| boxp | 9380 | tcp | Brivs! Open Extensible Protocol | Danko Alexeyev | Danko Alexeyev | 2007-08-08 | |||||
| boxp | 9380 | udp | Brivs! Open Extensible Protocol | Danko Alexeyev | Danko Alexeyev | 2007-08-08 | |||||
| 34380-34566 | Unassigned | ||||||||||
| ivs-database | 38000 | tcp | InfoVista Server Database | InfoVista | Sébastien Bouchex Bellomié | 2014-05-23 | |||||
| 38000 | udp | Reserved | |||||||||
| ivs-insertion | 38001 | tcp | InfoVista Server Insertion | InfoVista | Sébastien Bouchex Bellomié | 2014-05-23 | |||||
| 38001 | udp | Reserved | |||||||||
| cresco-control | 38002 | tcp | Cresco Controller | University of Kentucky | Cody Bumgardner | 2014-11-21 | |||||
| crescoctrl-disc | 38002 | udp | Cresco Controller Discovery | University of Kentucky | Cody Bumgardner | 2014-11-21 | |||||
| 38003-38200 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Abhijit Kumar | as-iana-ports&sun.com | 2005-11 | |
| Brian Harrington | CoreOS | brian.harrington&coreos.com | 2014-07-09 |
| Bruce Vander Werf | bvanderwerf&crownintl.com | 2004-02 | |
| Chris Duncombe | cduncombe&atpeng.com | 2022-03-25 | |
| Cody Bumgardner | University of Kentucky | cody&uky.edu | 2014-11-21 |
| CoreOS | brian.harrington&coreos.com | 2014-07-09 | |
| Danko Alexeyev | virtuall&virtuall.info | 2007-08-08 | |
| Frank Quick | fquick&qualcomm.com | ||
| Geoff Higgins | geoff.higgins&sun.com | 2006-03 | |
| Harry Lewis | harryl&us.ibm.com | 2003-05 | |
| InfoVista | sbouchex&infovista.com | 2014-05-23 | |
| Joel E. Steiger | jsteiger&eic-us.com | 2004-02 | |
| Karl Schendel, Jr. | wiz&telesis.com | ||
| Ryan Melville | ryan_melville&soniqcast.com | 2004-01 | |
| Samuele Sequi | samuelesequi&defcom.it | 2004-02 | |
| Sébastien Bouchex Bellomié | InfoVista | sbouchex&infovista.com | 2014-05-23 |
| Shekar Pasumarthi | shekarp&firstfloor.com | ||
| Steve Husak | portmaster&cruisetech.com | ||
| Thomas Fiege | tfiege&us.ibm.com | 2004-02 | |
| Tim Hahn | hahnt&us.ibm.com | 2006-03 | |
| University of Kentucky | cody&uky.edu | 2014-11-21 |