Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| hp-alarm-mgr | 383 | tcp | hp performance data alarm manager | Frank Blakely | Frank Blakely | ||||||
| hp-alarm-mgr | 383 | udp | hp performance data alarm manager | Frank Blakely | Frank Blakely | ||||||
| gwha | 1383 | tcp | GW Hannaway Network License Manager | J. Gabriel Foster | J. Gabriel Foster | ||||||
| gwha | 1383 | udp | GW Hannaway Network License Manager | J. Gabriel Foster | J. Gabriel Foster | ||||||
| ms-olap4 | 2383 | tcp | Microsoft OLAP | Mosha Pasumansky | Mosha Pasumansky | ||||||
| ms-olap4 | 2383 | udp | Microsoft OLAP | Mosha Pasumansky | Mosha Pasumansky | ||||||
| esp-lm | 3383 | tcp | Enterprise Software Products License Manager | George Rudy | George Rudy | ||||||
| esp-lm | 3383 | udp | Enterprise Software Products License Manager | George Rudy | George Rudy | ||||||
| cernsysmgmtagt | 3830 | tcp | Cerner System Management Agent | Mike Craft | Mike Craft | 2008-01-29 | |||||
| cernsysmgmtagt | 3830 | udp | Cerner System Management Agent | Mike Craft | Mike Craft | 2008-01-29 | |||||
| dvapps | 3831 | tcp | Docsvault Application Service | Ketul Patel | Ketul Patel | 2006-10 | |||||
| dvapps | 3831 | udp | Docsvault Application Service | Ketul Patel | Ketul Patel | 2006-10 | |||||
| xxnetserver | 3832 | tcp | xxNETserver | XXT LLC | Matt Ferrari | 2006-10 | 2012-07-12 | ||||
| xxnetserver | 3832 | udp | xxNETserver | XXT LLC | Matt Ferrari | 2006-10 | 2012-07-12 | ||||
| aipn-auth | 3833 | tcp | AIPN LS Authentication | Qiang Zhang | Qiang Zhang | 2006-10 | |||||
| aipn-auth | 3833 | udp | AIPN LS Authentication | Qiang Zhang | Qiang Zhang | 2006-10 | |||||
| spectardata | 3834 | tcp | Spectar Data Stream Service | ||||||||
| spectardata | 3834 | udp | Spectar Data Stream Service | ||||||||
| spectardb | 3835 | tcp | Spectar Database Rights Service | Jan Rutger Voorhorst | Jan Rutger Voorhorst | 2006-10 | |||||
| spectardb | 3835 | udp | Spectar Database Rights Service | Jan Rutger Voorhorst | Jan Rutger Voorhorst | 2006-10 | |||||
| markem-dcp | 3836 | tcp | MARKEM NEXTGEN DCP | ||||||||
| markem-dcp | 3836 | udp | MARKEM NEXTGEN DCP | ||||||||
| mkm-discovery | 3837 | tcp | MARKEM Auto-Discovery | Vadym Kargin | Vadym Kargin | 2005-08 | |||||
| mkm-discovery | 3837 | udp | MARKEM Auto-Discovery | Vadym Kargin | Vadym Kargin | 2005-08 | |||||
| sos | 3838 | tcp | Scito Object Server | Arno Klaassen | Arno Klaassen | 2003-11 | |||||
| sos | 3838 | udp | Scito Object Server | Arno Klaassen | Arno Klaassen | 2003-11 | |||||
| amx-rms | 3839 | tcp | AMX Resource Management Suite | Ron Barber | Ron Barber | 2003-11 | |||||
| amx-rms | 3839 | udp | AMX Resource Management Suite | Ron Barber | Ron Barber | 2003-11 | |||||
| 6383-6388 | Unassigned | ||||||||||
| m2mservices | 8383 | tcp | M2m Services | Carlos Arteaga | Carlos Arteaga | 2004-11 | |||||
| m2mservices | 8383 | udp | M2m Services | Carlos Arteaga | Carlos Arteaga | 2004-11 | |||||
| 13824-13831 | Unassigned | ||||||||||
| a-trust-rpc | 13832 | tcp | Certificate Management and Issuing | A-Trust GmbH | Patrick Hagelkruys | 2023-06-05 | |||||
| 13832 | udp | Reserved | |||||||||
| 13833-13893 | Unassigned | ||||||||||
| 16369-16383 | Unassigned | ||||||||||
| slpda | tcp | Remote Service Discovery in the Service Location | RFC 3832 | ||||||||
| slpda | udp | Remote Service Discovery in the Service Location | RFC 3832 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| A-Trust GmbH | technik&a-trust.at | 2023-08-03 | |
| Arno Klaassen | arno&ccr.jussieu.fr | 2003-11 | |
| Carlos Arteaga | carteaga&adelphia.net | 2004-11 | |
| Frank Blakely | frankb&hpptc16.rose.hp.com | ||
| George Rudy | george&entsoft.com | ||
| J. Gabriel Foster | fop&gwha.com | ||
| Jan Rutger Voorhorst | janrutger&roadware.nl | 2006-10 | |
| Ketul Patel | ketulp76&yahoo.com | 2006-10 | |
| Matt Ferrari | XXT LLC | xxt.matt&sbcglobal.net | 2012-07-12 |
| Mike Craft | mcraft&cerner.com | 2008-01-29 | |
| Mosha Pasumansky | moshapµsoft.com | ||
| Patrick Hagelkruys | hagelkruys&a-trust.at | 2023-06-05 | |
| Qiang Zhang | qzhang&iwncomm.com | 2006-10 | |
| Ron Barber | ron.barber&amx.com | 2003-11 | |
| Vadym Kargin | vkargin&markem.com | 2005-08 | |
| XXT LLC | xxt.matt&sbcglobal.net | 2012-07-12 |