Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
avanti-cdp 4065 tcp Avanti Common Data

IANA assigned this well-formed service name as a replacement for "avanti_cdp".
Steve Meyer Sr. Steve Meyer Sr. 2007-02
avanti_cdp 4065 tcp Avanti Common Data Steve Meyer Sr. Steve Meyer Sr. 2007-02 This entry is an alias to "avanti-cdp". This entry is now historic, not usable for use with many common service discovery mechanisms.
avanti-cdp 4065 udp Avanti Common Data

IANA assigned this well-formed service name as a replacement for "avanti_cdp".
Steve Meyer Sr. Steve Meyer Sr. 2007-02
avanti_cdp 4065 udp Avanti Common Data Steve Meyer Sr. Steve Meyer Sr. 2007-02 This entry is an alias to "avanti-cdp". This entry is now historic, not usable for use with many common service discovery mechanisms.
cxtp 5091 sctp Context Transfer Protocol 2005-07 RFC 4065

Contact Information

Name Contact URI Last Updated
Steve Meyer Sr. stevem&avanti-tech.com 2007-02