Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
graphics 41 tcp Graphics
graphics 41 udp Graphics
finger 79 tcp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
finger 79 udp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
kerberos 88 tcp Kerberos B. Clifford Neuman B. Clifford Neuman 2022-02-18 RFC 4120
kerberos 88 udp Kerberos B. Clifford Neuman B. Clifford Neuman 2022-02-18 RFC 4120
emfis-cntl 141 tcp EMFIS Control Service Gerd Beling Gerd Beling
emfis-cntl 141 udp EMFIS Control Service Gerd Beling Gerd Beling
225-241 Reserved 2024-12-20 RFC 1060
decladebug 410 tcp DECLadebug Remote Debug Protocol Hewlett Packard Hewlett Packard
decladebug 410 udp DECLadebug Remote Debug Protocol Hewlett Packard Hewlett Packard
rmt 411 tcp Remote MT Protocol Peter Eriksson Peter Eriksson
rmt 411 udp Remote MT Protocol Peter Eriksson Peter Eriksson
synoptics-trap 412 tcp Trap Convention Port Illan Raab Illan Raab
synoptics-trap 412 udp Trap Convention Port Illan Raab Illan Raab
smsp 413 tcp Storage Management Services Protocol Murthy Srinivas Murthy Srinivas
smsp 413 udp Storage Management Services Protocol Murthy Srinivas Murthy Srinivas
infoseek 414 tcp InfoSeek Steve Kirsch Steve Kirsch
infoseek 414 udp InfoSeek Steve Kirsch Steve Kirsch
bnet 415 tcp BNet Jim Mertz Jim Mertz
bnet 415 udp BNet Jim Mertz Jim Mertz
silverplatter 416 tcp Silverplatter Peter Ciuffetti Peter Ciuffetti
silverplatter 416 udp Silverplatter Peter Ciuffetti Peter Ciuffetti
onmux 417 tcp Onmux Stephen Hanna Stephen Hanna
onmux 417 udp Onmux Stephen Hanna Stephen Hanna
hyper-g 418 tcp Hyper-G Frank Kappe Frank Kappe
hyper-g 418 udp Hyper-G Frank Kappe Frank Kappe
ariel1 419 tcp Ariel 1 Joel Karafin Joel Karafin
ariel1 419 udp Ariel 1 Joel Karafin Joel Karafin
decvms-sysmgt 441 tcp decvms-sysmgt Lee Barton Lee Barton
decvms-sysmgt 441 udp decvms-sysmgt Lee Barton Lee Barton
uucp-rlogin 541 tcp uucp-rlogin Stuart Lynne Stuart Lynne
uucp-rlogin 541 udp uucp-rlogin Stuart Lynne Stuart Lynne
repcmd 641 tcp repcmd Scott Dale Scott Dale
repcmd 641 udp repcmd Scott Dale Scott Dale
netgw 741 tcp netGW Oliver Korfmacher Oliver Korfmacher
netgw 741 udp netGW Oliver Korfmacher Oliver Korfmacher
danf-ak2 1041 tcp AK2 Product Karl Palsson Karl Palsson 2004-11
danf-ak2 1041 udp AK2 Product Karl Palsson Karl Palsson 2004-11
mxomss 1141 tcp User Message Service Chaoyi Lang Chaoyi Lang 2006-01
mxomss 1141 udp User Message Service Chaoyi Lang Chaoyi Lang 2006-01
nessus 1241 tcp nessus Jordan Hrycaj Jordan Hrycaj
nessus 1241 udp nessus Jordan Hrycaj Jordan Hrycaj
qubes 1341 tcp QuBES Eric Grange Eric Grange
qubes 1341 udp QuBES Eric Grange Eric Grange
hiq 1410 tcp HiQ License Manager Rick Pugh Rick Pugh
hiq 1410 udp HiQ License Manager Rick Pugh Rick Pugh
af 1411 tcp AudioFile Jim Gettys Jim Gettys
af 1411 udp AudioFile Jim Gettys Jim Gettys
innosys 1412 tcp InnoSys
innosys 1412 udp InnoSys
innosys-acl 1413 tcp Innosys-ACL Eric Welch Eric Welch
innosys-acl 1413 udp Innosys-ACL Eric Welch Eric Welch
ibm-mqseries 1414 tcp IBM MQSeries Roger Meli Roger Meli
ibm-mqseries 1414 udp IBM MQSeries Roger Meli Roger Meli
dbstar 1415 tcp DBStar Jeffrey Millman Jeffrey Millman
dbstar 1415 udp DBStar Jeffrey Millman Jeffrey Millman
novell-lu6-2 1416 tcp Novell LU6.2

IANA assigned this well-formed service name as a replacement for "novell-lu6.2".
Peter Liu Peter Liu
novell-lu6.2 1416 tcp Novell LU6.2 Peter Liu Peter Liu This entry is an alias to "novell-lu6-2". This entry is now historic, not usable for use with many common service discovery mechanisms.
novell-lu6-2 1416 udp Novell LU6.2

IANA assigned this well-formed service name as a replacement for "novell-lu6.2".
Peter Liu Peter Liu
novell-lu6.2 1416 udp Novell LU6.2 Peter Liu Peter Liu This entry is an alias to "novell-lu6-2". This entry is now historic, not usable for use with many common service discovery mechanisms.
timbuktu-srv1 1417 tcp Timbuktu Service 1 Port
timbuktu-srv1 1417 udp Timbuktu Service 1 Port
timbuktu-srv2 1418 tcp Timbuktu Service 2 Port
timbuktu-srv2 1418 udp Timbuktu Service 2 Port
timbuktu-srv3 1419 tcp Timbuktu Service 3 Port
timbuktu-srv3 1419 udp Timbuktu Service 3 Port
cadis-1 1441 tcp Cadis License Management
cadis-1 1441 udp Cadis License Management
rds2 1541 tcp rds2 Sudhakar Rajamannar Sudhakar Rajamannar
rds2 1541 udp rds2 Sudhakar Rajamannar Sudhakar Rajamannar
invision 1641 tcp InVision Christopher Davey Christopher Davey
invision 1641 udp InVision Christopher Davey Christopher Davey
cisco-net-mgmt 1741 tcp cisco-net-mgmt John McCormack John McCormack
cisco-net-mgmt 1741 udp cisco-net-mgmt John McCormack John McCormack
netopia-vo3 1841 tcp netopia-vo3
netopia-vo3 1841 udp netopia-vo3
dic-aida 1941 tcp DIC-Aida Frans S.C. Witte Frans S.C. Witte
dic-aida 1941 udp DIC-Aida Frans S.C. Witte Frans S.C. Witte
interbase 2041 tcp
interbase 2041 udp
ias-admind 2141 tcp IAS-ADMIND Baiju V. Patel Baiju V. Patel
ias-admind 2141 udp IAS-ADMIND Baiju V. Patel Baiju V. Patel
ivsd 2241 tcp IVS Daemon Thierry Turletti Thierry Turletti
ivsd 2241 udp IVS Daemon Thierry Turletti Thierry Turletti
xiostatus 2341 tcp XIO Status Randy Maas Randy Maas
xiostatus 2341 udp XIO Status Randy Maas Randy Maas
vrts-registry 2410 tcp VRTS Registry Pranay Varma Pranay Varma
vrts-registry 2410 udp VRTS Registry Pranay Varma Pranay Varma
netwave-ap-mgmt 2411 tcp Netwave AP Management Johnny Zweig Johnny Zweig
netwave-ap-mgmt 2411 udp Netwave AP Management Johnny Zweig Johnny Zweig
cdn 2412 tcp CDN Alan Noble Alan Noble
cdn 2412 udp CDN Alan Noble Alan Noble
orion-rmi-reg 2413 tcp orion-rmi-reg J.S. Greenfield J.S. Greenfield
orion-rmi-reg 2413 udp orion-rmi-reg J.S. Greenfield J.S. Greenfield
beeyond 2414 tcp Beeyond Bob Deblier Bob Deblier
beeyond 2414 udp Beeyond Bob Deblier Bob Deblier
codima-rtp 2415 tcp Codima Remote Transaction Protocol Sylvia Ross Sylvia Ross
codima-rtp 2415 udp Codima Remote Transaction Protocol Sylvia Ross Sylvia Ross
rmtserver 2416 tcp RMT Server Yvon Marineau Yvon Marineau

Contact Information

Name Organization Contact URI Last Updated
Alan Noble noble&netmind.com
B. Clifford Neuman bcn&isi.edu 2022-02-18
Baiju V. Patel Baiju.v.patel&intel.com
Bob Deblier bob&virtualunlimited.com
Chaoyi Lang chao-yi_lang&maxtor.com 2006-01
Christopher Davey niallocl&quay.ie
David Zimmerman dpz&rutgers.edu
Eric Grange egrange&creative-it.net 2002-08
Eric Welch
Frank Kappe fkappe&iicm.tu-graz.ac.at
Frans S.C. Witte fscwitte&dicgroep.nl
Gerd Beling GBELING&isi.edu
Hewlett Packard
Illan Raab iraab&synoptics.com
J.S. Greenfield greeny&us.ibm.com
Jeffrey Millman jcm&dbstar.com
Jim Gettys jg&crl.dec.com
Jim Mertz JMertz+RV09&rvdc.unisys.com
Joel Karafin jkarafin&infotrieve.com
John McCormack jmac&cisco.com
Johnny Zweig zweig&netwave-wireless.com
Jordan Hrycaj jordan&mjh.teddy-net.com
Karl Palsson karl_p&danfoss.com 2004-11
Lee Barton barton&star.enet.dec.com
Murthy Srinivas murthy&novell.com
Oliver Korfmacher okorf&netcs.com
Peter Ciuffetti petec&silverplatter.com
Peter Eriksson pen&lysator.liu.se
Peter Liu
Pranay Varma pran&veritas.com
Randy Maas randym&xiotech.com
Rick Pugh rick&bilmillennium.com
Roger Meli rmmeli%25winvmd@vnet.ibm.com
Scott Dale scott&replicase.com
Stephen Hanna hanna&world.std.com
Steve Kirsch stk&infoseek.com
Stuart Lynne sl&wimsey.com
Sudhakar Rajamannar mobius1&cerfnet.com
Sylvia Ross sross&codimatech.com
Thierry Turletti Thierry.Turletti&sophia.inria.fr
Yvon Marineau yvon&simware.com