Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| finger | 79 | tcp | Finger | David Zimmerman | David Zimmerman | Unauthorized use by some mail users (see [RFC4146] for details) | |||||
| finger | 79 | udp | Finger | David Zimmerman | David Zimmerman | Unauthorized use by some mail users (see [RFC4146] for details) | |||||
| infoseek | 414 | tcp | InfoSeek | Steve Kirsch | Steve Kirsch | ||||||
| infoseek | 414 | udp | InfoSeek | Steve Kirsch | Steve Kirsch | ||||||
| ibm-mqseries | 1414 | tcp | IBM MQSeries | Roger Meli | Roger Meli | ||||||
| ibm-mqseries | 1414 | udp | IBM MQSeries | Roger Meli | Roger Meli | ||||||
| beeyond | 2414 | tcp | Beeyond | Bob Deblier | Bob Deblier | ||||||
| beeyond | 2414 | udp | Beeyond | Bob Deblier | Bob Deblier | ||||||
| wip-port | 3414 | tcp | BroadCloud WIP Port | ||||||||
| wip-port | 3414 | udp | BroadCloud WIP Port | ||||||||
| cedros-fds | 4140 | tcp | Cedros Fraud Detection System IANA assigned this well-formed service name as a replacement for "cedros_fds". |
Markus Michels | Markus Michels | 2006-10 | |||||
| cedros_fds | 4140 | tcp | Cedros Fraud Detection System | Markus Michels | Markus Michels | 2006-10 | This entry is an alias to "cedros-fds". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| cedros-fds | 4140 | udp | Cedros Fraud Detection System IANA assigned this well-formed service name as a replacement for "cedros_fds". |
Markus Michels | Markus Michels | 2006-10 | |||||
| cedros_fds | 4140 | udp | Cedros Fraud Detection System | Markus Michels | Markus Michels | 2006-10 | This entry is an alias to "cedros-fds". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| oirtgsvc | 4141 | tcp | Workflow Server | ||||||||
| oirtgsvc | 4141 | udp | Workflow Server | ||||||||
| oidocsvc | 4142 | tcp | Document Server | ||||||||
| oidocsvc | 4142 | udp | Document Server | ||||||||
| oidsr | 4143 | tcp | Document Replication | Norman Brie | Norman Brie | ||||||
| oidsr | 4143 | udp | Document Replication | Norman Brie | Norman Brie | ||||||
| 4144 | Unassigned | Compuserve (unoffically) is using port 4144 | |||||||||
| vvr-control | 4145 | tcp | VVR Control | Ming Xu | Ming Xu | ||||||
| vvr-control | 4145 | udp | VVR Control | Ming Xu | Ming Xu | ||||||
| tgcconnect | 4146 | tcp | TGCConnect Beacon | Brian Becker | Brian Becker | 2006-10 | |||||
| tgcconnect | 4146 | udp | TGCConnect Beacon | Brian Becker | Brian Becker | 2006-10 | |||||
| vrxpservman | 4147 | tcp | Multum Service Manager | Scott Mager | Scott Mager | 2006-10 | |||||
| vrxpservman | 4147 | udp | Multum Service Manager | Scott Mager | Scott Mager | 2006-10 | |||||
| hhb-handheld | 4148 | tcp | HHB Handheld Client | Steven G. Loughner | Steven G. Loughner | 2007-03 | |||||
| hhb-handheld | 4148 | udp | HHB Handheld Client | Steven G. Loughner | Steven G. Loughner | 2007-03 | |||||
| agslb | 4149 | tcp | A10 GSLB Service | John Chiong | John Chiong | 2007-07-02 | |||||
| agslb | 4149 | udp | A10 GSLB Service | John Chiong | John Chiong | 2007-07-02 | |||||
| updog | 4414 | tcp | Updog Monitoring and Status Framework | Egon Technologies, LLC | James Downs | 2015-10-05 | |||||
| 4414 | udp | Reserved | |||||||||
| statusd | 5414 | tcp | StatusD | Stephen Misel | Stephen Misel | ||||||
| statusd | 5414 | udp | StatusD | Stephen Misel | Stephen Misel | ||||||
| 8406-8414 | Unassigned | ||||||||||
| 14035-14140 | Unassigned | ||||||||||
| vcs-app | 14141 | tcp | VCS Application | Ming Xu | Ming Xu | ||||||
| vcs-app | 14141 | udp | VCS Application | Ming Xu | Ming Xu | ||||||
| icpp | 14142 | tcp | IceWall Cert Protocol | Tsutomu Fujinami | Tsutomu Fujinami | 2005-08 | |||||
| icpp | 14142 | udp | IceWall Cert Protocol | Tsutomu Fujinami | Tsutomu Fujinami | 2005-08 | |||||
| icpps | 14143 | tcp | IceWall Cert Protocol over TLS | Kenta Kambara | Kenta Kambara | 2016-05-24 | |||||
| 14143 | udp | Reserved | |||||||||
| 14144 | Unassigned | ||||||||||
| gcm-app | 14145 | tcp | GCM Application | Ming Xu | Ming Xu | ||||||
| gcm-app | 14145 | udp | GCM Application | Ming Xu | Ming Xu | ||||||
| 14146-14148 | Unassigned | ||||||||||
| vrts-tdd | 14149 | tcp | Veritas Traffic Director | Sameer Deokule | Sameer Deokule | 2002-03 | |||||
| vrts-tdd | 14149 | udp | Veritas Traffic Director | Sameer Deokule | Sameer Deokule | 2002-03 | |||||
| ca-web-update | 14414 | tcp | CA eTrust Web Update Service | Robert Ciochon | Robert Ciochon | 2006-08 | |||||
| ca-web-update | 14414 | udp | CA eTrust Web Update Service | Robert Ciochon | Robert Ciochon | 2006-08 |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Bob Deblier | bob&virtualunlimited.com | |
| Brian Becker | bbecker&tgc-usa.com | 2006-10 |
| David Zimmerman | dpz&rutgers.edu | |
| Egon Technologies, LLC | james.downs&egontech.com | 2015-10-05 |
| James Downs | james.downs&egontech.com | 2015-10-05 |
| John Chiong | jchiong&a10networks.com | 2007-07-02 |
| Kenta Kambara | kenta.kambara&hpe.com | 2016-05-24 |
| Markus Michels | markus.michels&cedros.com | 2006-10 |
| Ming Xu | ming&veritas.com | |
| Norman Brie | norm_brie&sns.ca | |
| Robert Ciochon | robert.ciochon&ca.com | 2006-08 |
| Roger Meli | rmmeli%25winvmd@vnet.ibm.com | |
| Sameer Deokule | sameer.deokule&veritas.com | 2002-03 |
| Scott Mager | Scott.Mager&cerner.com | 2006-10 |
| Stephen Misel | steve&satelnet.org | |
| Steve Kirsch | stk&infoseek.com | |
| Steven G. Loughner | stevengloughner&eaton.com | 2007-03 |
| Tsutomu Fujinami | tsutomu.fujinami&hp.com | 2005-08 |