Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| nnsp | 433 | tcp | NNTP for transit servers (NNSP) | IESG | IETF Chair | 2018-07-06 | RFC 3977 | ||||
| nnsp | 433 | udp | NNTP for transit servers (NNSP) | IESG | IETF Chair | 2018-07-06 | RFC 3977 | ||||
| ms-sql-s | 1433 | tcp | Microsoft-SQL-Server | ||||||||
| ms-sql-s | 1433 | udp | Microsoft-SQL-Server | ||||||||
| codasrv-se | 2433 | tcp | codasrv-se | Robert Watson | Robert Watson | ||||||
| codasrv-se | 2433 | udp | codasrv-se | Robert Watson | Robert Watson | ||||||
| opnet-smp | 3433 | tcp | OPNET Service Management Platform | OPNET Technologies Inc | Edward Macomber | 2002-03 | 2011-09-21 | ||||
| opnet-smp | 3433 | udp | OPNET Service Management Platform | OPNET Technologies Inc | Edward Macomber | 2002-03 | 2011-09-21 | ||||
| dey-sapi | 4330 | tcp | DEY Storage Administration REST API | DEY Storage Systems, Inc. | Garrett D'Amore | 2013-03-01 | |||||
| 4330 | udp | Reserved | |||||||||
| ktickets-rest | 4331 | tcp | ktickets REST API for event management and ticketing systems (embedded POS devices) | KeyTicket Solutions | MANG Ioan-Alexandru | 2014-04-04 | |||||
| 4331 | udp | Reserved | |||||||||
| getty-focus | 4332 | tcp | Getty Images FOCUS service | Matthew Margolis | Bryan Ramirez | 2019-04-18 | |||||
| 4332 | udp | Reserved | |||||||||
| ahsp | 4333 | tcp | ArrowHead Service Protocol (AHSP) | QuantuMatriX Technologies | Matthew Schultz | 2014-04-10 | |||||
| ahsp | 4333 | udp | ArrowHead Service Protocol (AHSP) | QuantuMatriX Technologies | Matthew Schultz | 2014-04-10 | |||||
| ahsp | 4333 | sctp | ArrowHead Service Protocol (AHSP) | QuantuMatriX Technologies | Matthew Schultz | 2014-04-10 | |||||
| netconf-ch-ssh | 4334 | tcp | NETCONF Call Home (SSH) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4334 | udp | Reserved | |||||||||
| netconf-ch-tls | 4335 | tcp | NETCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4335 | udp | Reserved | |||||||||
| restconf-ch-tls | 4336 | tcp | RESTCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4336 | udp | Reserved | |||||||||
| 4337-4339 | Unassigned | ||||||||||
| vop | 4433 | tcp | Versile Object Protocol | Versile AS | Tore Skaug | 2012-02-01 | |||||
| 4433 | udp | Reserved | |||||||||
| pyrrho | 5433 | tcp | Pyrrho DBMS | Malcolm Crowe | Malcolm Crowe | 2005-11 | |||||
| pyrrho | 5433 | udp | Pyrrho DBMS | Malcolm Crowe | Malcolm Crowe | 2005-11 | |||||
| 6433-6439 | Unassigned | ||||||||||
| 8433 | tcp | Reserved | |||||||||
| aws-as2 | 8433 | udp | Non Persistent Desktop and Application Streaming | Amazon.com Services LLC | Ivan O'Mahony | 2022-11-07 | |||||
| 11431-11433 | Unassigned | ||||||||||
| 33335-33433 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Amazon.com Services LLC | aws-iana&amazon.com | 2022-11-07 | |
| Bryan Ramirez | bryan.ramirez&gettyimages.com | 2019-04-18 | |
| DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 | |
| Edward Macomber | OPNET Technologies Inc | tmacomber&opnet.com | 2011-09-21 |
| Garrett D'Amore | DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ivan O'Mahony | Amazon.com Services LLC | iomahony&amazon.com | 2022-11-07 |
| KeyTicket Solutions | amang&keyticket.eu | 2014-04-04 | |
| Malcolm Crowe | malcolm.crowe&paisley.ac.uk | 2005-11 | |
| MANG Ioan-Alexandru | KeyTicket Solutions | amang&keyticket.eu | 2014-04-04 |
| Matthew Margolis | matthew.margolis&gettyimages.com | 2019-04-18 | |
| Matthew Schultz | QuantuMatriX Technologies | matt&qmxtech.com | 2014-04-10 |
| OPNET Technologies Inc | tmacomber&opnet.com | 2011-09-21 | |
| QuantuMatriX Technologies | admin&qmxtech.com | 2014-04-10 | |
| Robert Watson | robert&cyrus.watson.org | ||
| Tore Skaug | Versile AS | tore.skaug&versile.com | 2012-02-01 |
| Versile AS | contact&versile.com | 2012-02-01 |