Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dna-cml 436 tcp DNA-CML Dan Flowers Dan Flowers
dna-cml 436 udp DNA-CML Dan Flowers Dan Flowers
saism 1436 tcp Satellite-data Acquisition System 2 Bill Taylor Bill Taylor
saism 1436 udp Satellite-data Acquisition System 2 Bill Taylor Bill Taylor
topx 2436 tcp TOP/X Dragos Pop Dragos Pop
topx 2436 udp TOP/X Dragos Pop Dragos Pop
gc-config 3436 tcp GuardControl Exchange Protocol Andreas Schwarz Andreas Schwarz 2002-03
gc-config 3436 udp GuardControl Exchange Protocol Andreas Schwarz Andreas Schwarz 2002-03
matrix-vnet 4360 tcp Matrix VNet Communication Protocol

IANA assigned this well-formed service name as a replacement for "matrix_vnet".
Rehan Mahmood Rehan Mahmood 2009-03-18
matrix_vnet 4360 tcp Matrix VNet Communication Protocol Rehan Mahmood Rehan Mahmood 2009-03-18 This entry is an alias to "matrix-vnet". This entry is now historic, not usable for use with many common service discovery mechanisms.
4360 udp Reserved
4361 tcp Reserved
nacnl 4361 udp NavCom Discovery and Control Port Yilei Jia Yilei Jia 2009-03-18
4362 tcp Reserved
afore-vdp-disc 4362 udp AFORE vNode Discovery protocol Michael Richardson Michael Richardson 2011-02-08
4363-4365 Unassigned
shadowstream 4366 udp ShadowStream System StorageCraft Technology Corporation David McConkie 2014-12-17
4366 tcp Reserved
4367 Unassigned
wxbrief 4368 tcp WeatherBrief Direct Kim Alan Waggoner Kim Alan Waggoner 2006-11
wxbrief 4368 udp WeatherBrief Direct Kim Alan Waggoner Kim Alan Waggoner 2006-11
epmd 4369 tcp Erlang Port Mapper Daemon Erlang/OTP support Erlang/OTP support
epmd 4369 udp Erlang Port Mapper Daemon Erlang/OTP support Erlang/OTP support
5436 tcp Reserved
pmip6-cntl 5436 udp pmip6-cntl RFC 5844
7432-7436 Unassigned
33436-33655 Unassigned Known Unauthorized Use on ports 33436-33534

Contact Information

Name Organization Contact URI Last Updated
Andreas Schwarz andi&trancefield.de 2002-03
Bill Taylor sais&ssec.wisc.edu
Dan Flowers flowers&smaug.lkg.dec.com
David McConkie StorageCraft Technology Corporation dave.mcconkie&storagecraft.com 2014-12-17
Dragos Pop dragos&cs.ubbcluj.ro
Erlang/OTP support epmd&erix.ericsson.se 2004-12
Kim Alan Waggoner kimw&weatherbank.com 2006-11
Michael Richardson mcr&sandelman.ca 2011-02-08
Rehan Mahmood rehan&matrixmultimedia.co.uk 2009-03-18
StorageCraft Technology Corporation dave.mcconkie&storagecraft.com 2014-12-17
Yilei Jia yjia&navcomtech.com 2009-03-18