Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
creativeserver 453 tcp CreativeServer
creativeserver 453 udp CreativeServer
genie-lm 1453 tcp Genie License Manager Paul Applegate Paul Applegate
genie-lm 1453 udp Genie License Manager Paul Applegate Paul Applegate
madge-ltd 2453 tcp madge ltd Mark Lyall Mark Lyall
madge-ltd 2453 udp madge ltd Mark Lyall Mark Lyall
pscupd 3453 tcp PSC Update Datalogic ADC, Inc Reid B. Ligon 2001-11-10 2014-07-31
pscupd 3453 udp PSC Update Datalogic ADC, Inc Reid B. Ligon 2001-11-10 2014-07-31
gsakmp 3761 tcp gsakmp port RFC 4535
gsakmp 3761 udp gsakmp port RFC 4535
nssalertmgr 4453 tcp NSS Alert Manager
nssalertmgr 4453 udp NSS Alert Manager
4504-4533 Unassigned
4534 tcp Reserved
armagetronad 4534 udp Armagetron Advanced Game Server Manuel Moos Yann Kaiser 2012-11-02
ehs 4535 tcp Event Heap Server
ehs 4535 udp Event Heap Server
ehs-ssl 4536 tcp Event Heap Server SSL Brad Johanson Brad Johanson 2005-08
ehs-ssl 4536 udp Event Heap Server SSL Brad Johanson Brad Johanson 2005-08
wssauthsvc 4537 tcp WSS Security Service Mark Tirschwell Mark Tirschwell 2006-01
wssauthsvc 4537 udp WSS Security Service Mark Tirschwell Mark Tirschwell 2006-01
swx-gate 4538 tcp Software Data Exchange Gateway Julien VALIENTE Julien VALIENTE 2006-05
swx-gate 4538 udp Software Data Exchange Gateway Julien VALIENTE Julien VALIENTE 2006-05
4539-4544 Unassigned
surebox 5453 tcp SureBox Emin BORU Emin BORU 2004-11
surebox 5453 udp SureBox Emin BORU Emin BORU 2004-11

Contact Information

Name Organization Contact URI Last Updated
Brad Johanson bradj&tidebreak.com 2005-08
Datalogic ADC, Inc ReceptionBLQ&datalogic.com 2014-07-31
Emin BORU emin&danismanlik.net 2004-11
Julien VALIENTE j.valiente&objectif-software.com 2006-05
Manuel Moos z-man&users.sf.net 2012-11-02
Mark Lyall mark.lyall&madge.com
Mark Tirschwell mark.tirschwell&wallstreetsystems.com 2006-01
Paul Applegate p.applegate2&genie.geis.com
Reid B. Ligon Reid.Ligon&datalogic.com 2014-07-31
Yann Kaiser kaiser.yann&gmail.com 2012-11-02